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Before you begin the BENCHMAN XT installation, read through the fol-
lowing list to be sure all the requirements have been met.

�������� �  �8����'����

The work place should be clean and uncluttered, with enough room to
open and assemble the machining center and its components.

You should have a sturdy bench to put the machine and computer on.

�,7���2
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Keep in mind that when troubleshooting, you may need to check the cir-
cuit breakers on the rear panel of the machine.

Place the computer in an area where it will not be exposed to metal chips
or cutting fluid.

Place the machining center within 6 feet of an appropriate electrical supply.

Finally, be sure you have met all of the required operating conditions.

�"',����� #&���'�  �8����'����

The Control Program runs on a 586/ 120MHz personal computer. The
computer must have:

� Windows 95 or Windows NT 4.0 or higher

� 16MB RAM minimum for Windows 95 (32MB for best performance)

� 32MB RAM minimum for Windows NT

� A 3.5 in floppy drive

� A hard drive with at least 5MB of available space

� A full length ISA bus slot to install the Motion Control card

� A VGA graphics controller and monitor

� A Windows-compatible mouse
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Before you connect and run your new BENCHMAN XT, you should:

�9 Check the shipment to make sure you received everything you need.

�9 Register the BENCHMAN XT so it is covered by warranty.

:9 Prepare a workspace for the BENCHMAN XT.

�9 Unpack and set up the BENCHMAN XT.

;9 Install the Motion Control Card into your computer.

When all of these procedures are complete, you can connect the BENCH-
MAN XT to your computer and install the Control Program.

����)� 6"��� #��,'���

The first thing you should do after receiving the BENCHMAN XT is inspect
the packaging for any visible signs of damage. If there is damage to the out-
side of the packaging, contact the shipping company as well as Light Ma-
chines Customer Service Department at 800-221-2763 or 603-625-8600

 �������� �������������	


You’ll find a registration card in the small box with the documentation and
software disks. Clearly print all the requested information and return this
card to Light Machines Corporation.
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Make sure you have all the items on hand necessary to perform the instal-
lation. To install the BENCHMAN XT, you must have ready:

� A sturdy bench on which you’ll place the BENCHMAN XT and your
computer. Placing the bench against a wall provides more stability.
Make sure the wall has a 230 VAC, 20 amp polarized outlet.

� A personal computer running Windows 95 or Windows NT version 4.0 or
greater. See page A-2  for a complete list of the necessary computer equip-
ment.

� Your PC Owner’s Manual or equivalent documentation.

��,��)� ���� ��������� 	


�9 Position the pallet near the bench on which you’ll set the BENCHMAN
XT. The bench should be located against a wall for maximum support.

�9 Remove the staples attaching the bottom of the cardboard container to
the pallet.

:9 Lift the cardboard container off of the pallet.

�9 Inspect the BENCHMAN XT chassis for signs of visual damage.

If any damage is noted, or if you find any discrepancies between the
packing slip and the items received, call Light Machines’ Customer
Service Department (800-221-2763 or 603-625-8600).
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The base of the machine is designed so that a forklift can be used to lift it
off of the pallet and place it on the benchtop.

�9 Remove the lag bolts holding the 2x4 cross member to the pallet, and
remove the cross member.

�9 Using the forklift, carefully guide the forks of the lift under the ma-
chining center, raise the machine off the pallet, and move the ma-
chine to the desired location.

:9 Carefully lower the BENCHMAN XT to the benchtop.
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If you are required to move the BENCHMAN XT through a narrow area
such as a doorway, it will be necessary to remove the X axis
cover. The following is the removal and reinstallation proce-
dure. Please read through all the steps before removing the
cover.

�9 Reach under the outside of the cover and
remove the 2 hex nuts from the PEM studs that
attach the X axis cover to the Y axis cover.

�9 Remove the 13 button head cap screws
and 3 hex nuts on the inside of the enclosure that
screw into the X axis cover. Be careful when re-
moving these screws, they are the last item at-

taching the cover to the enclosure.

:9 If the X axis cover does not come off after all the
fasteners are removed, push down on the cover to break the

original silicone seal applied at the factory.

 ������%%���"��"-� ����	��5����"/��

�9 Remove all remaining silicone from the X axis cover and the enclo-
sure left over from the original seal.

�9 Reseal the X axis cover to the enclosure with DOW Corning 732 sili-
con or equivalent.

:9 Mount the front of the X axis cover onto the PEM studs coming out of
the Y axis cover. Attach the X axis cover to the enclosure from the in-
side using the 13 button head cap screws and 3 hex nuts that were re-
moved earlier.

�9 Replace the 2 hex nuts on the PEM studs on the inside of the cover.

;9 Allow 24 hours for the silicone to cure before using coolant.

.�,4�
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The following paragraphs review the procedures for installing all the hardware
components of the BENCHMAN XT. Be sure that your computer system
meets all of the requirements outlined on page A-2. It should also be set up ac-
cording to the instructions in your PC owners manual.

The first step is to install the Motion Control Card in your personal computer.
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The following paragraphs describe the procedure for installing the Motion
Control Card in the chassis of your PC. You should have already set up your
PC according to the instructions in your owner’s manual. The Motion
Control Card can be installed in any full-size ISA slot designated for ex-
pansion card use. Refer to your computer owner’s manual to determine
particular expansion card restrictions.
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To install the Motion Control Card, you must remove the cover of the PC.
Refer to the instructions supplied with your PC for details on removing the
cover. Generally, the cover is secured by four screws through the rear
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panel; however, some PC's may have push latches, or screws in different
locations.
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Set the cover aside and locate the slot where the card is to be mounted.
Remove the blank slot cover (if any). This requires removing a screw at
the top rail of the rear panel. You may choose to discard the cover, but
save the screw for installing the Motion Control Card.
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The card is shipped inside an anti-static envelope. Handle the card by the
edges, being careful not to create any static discharge. Grounding yourself
with a static discharge wrist strap or working on a grounded surface is
suggested. Slide the card out of the envelope and inspect it for signs of
damage, such as bent or broken components or a warped circuit card. If
damage is noted, contact Light Machines Corporation immediately.
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Before installing the card into the computer, verify that the following
jumpers are installed or removed. Use the following graphic to verify the
location of the jumpers on the card.



��
#����#��� ,
�

�9 Grasp the Motion Control Card at the front and back.

�9 Position the card above the bus connector at the chosen slot. The in-
terface connector on the end of the card should face the rear panel of
the computer chassis.

:9 Slide the card into the bus slot. The connector on the card should protrude
from the rear panel of the computer. Carefully wiggle the card back and
forth to assure its tightness in the bus slot. Components on the Motion
Control Card should not touch adjacent cards or other components.

�9 Secure the card to the top rail of the rear panel with the screw you
saved when removing the blank slot cover.

;9 Make note of which slot the Motion Control Card is plugged into.
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The following procedure describes how to insert and secure the Motion
Control Card in the computer.
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If you are having problems getting the software to recognize the
NextMove motion card, you may have an address conflict. Address con-
flicts result when there is additional hardware using the same (default) I/O
address as the NextMove Motion Card. The factory I/O address setting is
0320-0322. The following procedure should be used to reconfigure the
hardware address.

�9 Power off the Computer and remove the NextMove motion card. It is
necessary to remove the card in order to reset DIP switch settings.
You may also be unable to reserve system resources while the card is
still in the system.

�9 Power on your computer and allow Windows 95 to start up.

:9 Click on the Start button. The Windows 95 Start Menu appears.

�9 Click on the Settings option. The Settings sub-menu appears.

;9 Click on the Control Panel option listed in the Settings sub-menu. The
Control Panel window will appear on the desktop.

���
!1�

/"��$�#����&��#����&�����
�"�!"��

��
�#����#��
#�#�%*�)
��#"����%��
��
��#�

#�#�%�	��
#�
#��'�����#"��

#�#�%�
�3�#��'��%��#���
�	"��
"������!�#"��%���*



��
#����#��� ,
��

=9 Click on System to open the System Properties window. Select the
Device Manager tab. Your screen will look similar to this.

>9 To reserve system resources, double click on Computer to open the
Computer Properties dialog box. Select the Reserve Properties tab,
then select the Input/Output (I/O) radio button.
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?9 Select the Add... button to define a reserved system resource. The Edit
Resource Setting dialog box appears. Enter the Start Value and the
End Value for the Input/Output Range you wish to reserve for the
Motion Control Card. The Start and End values can be determined by
using the following table.

+!*� #(����� #������� #����� @�%�� ���� @�%��

1�A�1��A�1�A�1� ��� ��0

1�A�1�A�1�A�1.. ��� ��>

1�A�1�A�1..A�1� ��� ��,

1�A�1�A�1..A�1.. ��& ��8

1�A�1..A�1�A�1� ��� ��0

1�A�1..A�1�A�1.. ��� ��>

1�A�1..A�1..A�1� ��� ��,

1�A�1..A�1..A�1.. ��& ��8

1..A�1�A�1�A�1� �0� �00

1..A�1�A�1�A�1.. �0� �0>

1..A�1�A�1..A�1� �0� �0,

1..A�1�A�1..A�1.. �0& �08

1..A�1..A�1�A�1� ��� ��0

1..A�1..A�1�A�1.. ��� ��>

1..A�1..A�1..A�1� ��� ��,

1..A�1..A�1..A�1.. ��& ��8

B9 In the above example, the address range from 033C to 033E is be-
ing reserved for the NextMove card. Select OK to close the Edit Re-
source Setting Dialog box. This range has now been reserved by the
system.  Note that if the range you have selected is already in use, an
error will be posted, and you will have to select a different range.
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9 Select OK to close the Computer Properties dialog box. A prompt will
appear verifying that the system resources have been modified.

��9 Select No. The computer will have to be powered down before in-
stalling the NextMove card. If you select Yes, the computer will auto-
matically restart and you will have to power down again before insert-
ing the card. Select OK to close the System Properties dialog box.

��9 Manually power down the system by selecting the Start button, and
then selecting Shut Down.... When Windows has shut down, you may
power off the system.
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Once you have chosen a valid address in the software, the address on the
card must be set to match. Be sure to observe all static discharge  proce-
dures when handling the motion control card in order to prevent static
damage.

�9 Locate the S1 DIP switch block which is located just above the HIJK
jumper pins. Using the list on page A-12, set the DIP switches to
match the settings for the address that you have reserved for the card.

�9 Insert the card into the computer, making sure that the card is fully
seated in the expansion bus. Because this is a full-length card, you
should double check to ensure that the card is seated.

:9 Replace all covers and power up the computer.

#��� �"���"%� *�"���'� #"-�(���� �"� ���� ��(� �������

Once the card has been set to a free address, the Control Program software
must be set to recognize the new address.

�9 Select Set up from the BENCHMAN folder. The Setup utility appears.



��
#����#��� ,
�=

�9 Select the Interface Card tab and use the up/down arrow keys to scroll
to the interface card address settings. Note that the DIP switch settings
on the screen will be updated as well.

:9 Once the Interface Address is set in the software, select OK to close
the  Setup utility. You may now run the BENCHMAN software.
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After installing the Motion Control and optional Rotary Motion Control
cards in the computer and verifying their operation, the BENCHMAN XT
connections can be made. The following cables and lines must be con-
nected:

� 100 pin interface cable between the computer and machining center

� Serial port cable from the computer to the machining center

� ATC air supply

� BENCHMAN XT power cord

� Computer power cord

� For optional rotational axis on 5K and 7.5K machines:

Interface cable from the computer to the machining center

The connection diagram on the following page is provided as a visual aid.
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After installing the Motion Control Card in the computer and verifying its
operation, the BENCHMAN XT connections can be made. The following
cables and lines must be connected:

� 100 pin interface cable between the computer and machining center

� Serial port cable from the computer to the machining center

� ATC air supply

� BENCHMAN XT power cord

� Computer power cord

� Chiller cooling line connections and power cord

The connection diagram on the following page is provided as a visual aid.

Set the chiller temperature to 70 °F (21 °C).  Refer to the chiller's user
guide.
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There is a single 100-pin cable that connects the machining center to the
computer. Carefully plug this cable into the Motion Control Card that you in-
stalled in your computer. Be sure the cable is installed correctly. It is pos-
sible to make this connection backwards! Tighten the finger screws on
the cable to be sure that it is firmly attached. A loose or marginal connec-
tion can cause problems operating the machining center.

�"��������� ���� ���� #�,,%&

The BENCHMAN XT is equipped with an Automatic Tool Changer. The
ATC requires an air supply of 75 to 90 psi, and should be connected to the
regulator at the left rear corner of the machine.

���������	

��������	

ATC Air Supply connection (Rear and Side View)
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After securing the connections between the BENCHMAN XT and the
computer, plug in the main power cords for each. The BENCHMAN XT
must be plugged into a 230 VAC, 60Hz, 20A outlet (220V, 50Hz for inter-
national customers), and the computer must be plugged into a grounded
120 VAC, 60Hz, 15A, polarized outlet. See the diagrams on the previous
pages.

ATC Air Supply 75-90 psi (520-620kPa)
1/4" NPT female connection provided
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There are only a few differences between the Benchman BXT-4021 and
BXT-4521 models:

� To achieve a spindle speed of 45,000 RPM, the BXT-4521 uses a 2.7
horsepower high frequency induction motor.   It is important to warm
the spindle bearings by running the spindle at 15,000 RPM for a few
minutes prior to running the spindle at its maximum speed.

� You may be asked to specify the Benchman model and maximum
spindle speed during software installation.

� The BXT-4021 includes a 20-tool carousel.  The BXT-4521 includes
a 12-tool carousel.
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The Control Program is shipped on 3.5", 1.4MB disks. The Control
Program must be installed on a hard drive running either Windows
95, or Windows NT version 4.0 (or higher). You must have at least 5 MB
of free space on your hard drive to perform this installation. See page A-2
for a complete list of computer requirements.

!����%%���� ���� �"���"%� *�"���'

The Control Program must be installed on the hard drive on your computer.
The following instructions assume that your hard drive is drive C, and
your floppy drive is drive A.

�9 Turn on the computer. Wait for it to go through its internal checks and
for it to complete the start up process.

�9 When your Windows desktop appears, insert the disk in the computer
floppy drive.

:9 Using the Windows Explorer, (Start Menu>Programs>Windows
Explorer) open the floppy drive.

Note: If you are installing on Windows NT, use either the File Manager to
access the floppy drive, or select Run from the Program Manager.

�9 Double click on Install to start the installation.

;9 The Welcome screen appears warning you to exit all other running
programs. If no other programs are running, click Next.

=9 The next screen is the destination directory for the Control Program. If
you would like to install the control program in an alternate directory,
click on Browse. Otherwise, click Next.

>9 A window showing the progress of the installation will appear, and
when ready, will prompt you to install the second disk. After the
installation is complete, a message will appear asking if you would
like to view the Readme file. It is suggested that you read this file. It
contains important information about the software and the machine
that may not be included in the manual.

?9 After reading the Readme file, remove the disk from the floppy drive.
Power on the machine, and then launch the Control Program by double
clicking the BENCHMAN icon. You have the option of dragging the
shortcut icon onto your desktop from the open BENCHMAN folder, or
selecting the Start Menu> Programs> Benchman> BENCHMAN.
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In the event you need to remove the Control Program from your hard
drive, there is an uninstall program included on the software disks. This
uninstall program is part of  the Control Program and was copied onto
your hard drive during the installation.

To uninstall the Control Program software, select Start Menu> Programs>
BENCHMAN> Remove BENCHMAN. A message appears asking if you
are sure you want to remove the program and all its files. Click on Yes to
uninstall, or No to exit the uninstall program.


��� #���,� *�"���'

The Setup Program allows you to select a number of  program and hard-
ware defaults, as well as configure the options installed on the machine.
To access the Setup Program, you must exit the Control Program. Then
select the Start Menu> Programs> BENCHMAN> Setup. The program
will start and you will see the Welcome screen. You may choose from the
file tabs to view the defaults for each category.

The Setup Program provides defaults under the following categories:

� Welcome

� General

� Options

� Interface Card

During the software installation, the Setup window opens automatically so
that you can select the options installed on your machine. You may need
to access the Setup Program again to remove options or to reset other de-
faults. See Section E: Setup Program for detailed information about the
program.
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Should you require technical assistance, you should contact your local
Light Machines dealer. If you are unable to resolve your problem through
your local dealer, free technical support is available by phone, fax, or
email from 8:15 A.M. to 5:00 P.M. EST.

��-"��� ��%%���

Make sure you have the following information gathered before contacting
our Technical Support group.

� The product serial number.
� The name of the owner of the product.
� The specifications of your computer (e.g. hard drive size, clock speed,

etc.).
� Notes on any Control Program error messages.

When you call, make sure you have access to both your BENCHMAN XT
and your computer. This will allow our technical support representatives
to walk through the problem with you. Our technical support numbers are:

U. S. (800) 221-2763
Canada (800) 637-4829

Fax (603) 625-2137
email support@lmcorp.com

�������&

Light Machines' products (excluding software) carry a one-year limited
warranty from date of purchase, as outlined in the Terms and Conditions
of Sale. If you need to return a product, call Light Machines and a Techni-
cal Support representative will issue you a Return Materials Authorization
number (RMA). You must write the RMA and your return address on the
outside of the product carton or crate. Failure to do so can result in a delay
in the return of your product.
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The BENCHMAN XT is designed to be the ultimate benchtop manufac-
turing solution. It is run directly from your personal computer, and by uti-
lizing the optional Light Machines’ spectraCAM software, you can design
and machine parts in plastics, aluminum, steel, and graphite all from one
operator station.

The BXT-4021 comes with a 5000 RPM or optional 7500 RPM spindle.
The BXT-4521 includes an optional 45,000 RPM spindle.

The BENCHMAN XT Machining Center is shipped fully assembled, and
is easy to install. Complete instructions for installing the machining cen-
ter, as well as software installation instructions, are included in Section A
of this User's Guide.

.�������

Some of the BENCHMAN XT features include:

� A 2 horsepower AC Servo spindle motor in the BXT-4021, and a 2.7
horsepower high frequency induction motor for the BXT-4521

� An R8 industry-standard spindle taper for the BXT-4021, and an ISO
10 spindle taper collet for the BXT-4521

� Computer controlled spindle speeds up to 5000 RPM (7500 optional)
for the BXT-4021, and 45,000 RPM for the BXT-4521

� Rapid traverse rates up to 200 ipm

� EIA RS-274D standard G&M code programming

� Multiple tool programming

� Feed rate and spindle speed override functions

� A built-in full-screen NC program editor

� An on-line help utility

� Simultaneous or simulated, solid or centerline graphic tool path verifi-
cation



+�
#���(���	��� -
�

��������� 	
� �"',"�����
There are, of course, more components on the BENCHMAN XT than
those shown here, but to begin, you need only be concerned with the ma-
jor components.
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The Safety Shield and access door encloses the milling area to help protect
the operator from flying chips. An electro-mechanical Safety Interlock
Switch prevents the machine from operating with the door open.

The X, Y, and Z motion of the machine is performed by DC servo drive mo-
tors on each axis. There are also Limit Switches (beneath the covers, next
to the drive motor on each axis) to prevent the machine from traveling be-
yond its limits on each axis.

The Spindle Head supports a 2 horsepower AC Servo Spindle Motor.
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The Front Panel provides the operating controls shown here.

You can’t miss the most important control on the machine; the Emer-
gency Stop button. When pressed, this bright red palm button halts ma-
chine operation immediately. To resume operation, twist and pull the but-
ton back out. It’s important that this button be pressed before performing

any manual operations, like changing the stock or the tooling.

The Power Switch turns the machine on and off.

The Cycle Start and Cycle Stop buttons start and stop the
program. Cycle Stop differs from the Emergency Stop; the pro-
gram will not stop immediately.

The Feed Rate Override knob allows the operator to adjust
the feed rate without entering the Control Program. The feed
rate can be increased to 200% of the programmed feed rate.

The Spindle Speed Override knob performs the same function for the
spindle speed, but only allows speeds of up to 150% of the programmed
speed.

The Platter Up/Down lighted pushbutton raises or lowers the tool platter.
The pushbutton lights during platter activation.

The Index Platter lighted pushbutton rotates the tool platter one tool position
clockwise each time the button is depressed. The pushbutton lights when in-
dexing the platter.

The Drawbar Clamp/Unclamp lighted pushbutton toggles the tool drawbar
clamped or unclamped each time the button is depressed.  The pushbutton
lights during drawbar activation.

 ���� *���%� �"',"�����

The key lock, power indicators, and circuit breakers for the machine are
located on the rear panel of the BENCHMAN XT.

The Key Lock Switch keeps unauthorized persons from turning on the
machine. When the Key Lock is in the unlocked position, you can turn on
power to the machine using the power button on the front of the machine.

Power Switch Emergency Stop

Cycle Start

Cycle Stop

Feed Rate
Override

Spindle Speed
Override

Platter Up/Down Index Platter Drawbar Clamp/
Unclamp



+�
#���(���	��� -
=

The Main Power Light illuminates when machine power is on. The Drive
Power Light illuminates when the servo amplifiers are powered on.

The machine has five sets of circuit breakers for Main Power, the Con-
trol, the Servo Motors, Auxiliary Outputs, and the Spindle. If a circuit
breaker blows, the circuit breaker switch pops out, revealing white at the
top of the switch. To reset the circuit breaker, push the switch up and back
into the circuit breaker until it locks in place.

!������������ "-� �������������� ������
The intended use of the BENCHMAN XT Machining Center is as a con-
ventional computer numerical controlled (CNC) vertical mill used in
industrial environments.
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A trained operator affixes a workpiece to the machine’s table and a cutting
tool into the machine’s spindle. The cutting tool rotates as a computer
controls the machine’s table and spindle movements. These motions result
in the cutting tool being brought into contact with the workpiece and the
cutting tool removing material from the workpiece.

The operator specifies appropriate feeds, speeds, and cutting depths for
the type of tooling and workpiece material being used so as to not over-
load the tool or the machine.

�������� 
""%�� ���� .�5�����

The cutting tool may be any off-the-shelf tool designed for vertical milling
operations. The tool’s shank is restricted to 1/2" diameter to fit a standard
XT tool holder.  The BXT-4521 uses an ER-16 collet, which restricts tool
shank diameter to 3/8".

You can use standard off-the-shelf fixtures to mount a workpiece to the
machine’s table.

�"�),����� �������%�

The workpiece may be ferrous or nonferrous, including, but not limited to
steel, aluminum, graphite, plastic, and wax.
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Do NOT use the machine for tasks it was not designed to perform. Im-
proper use or modification of the machine may damage the machine and
may result in serious injury.

Misuse of the machine may result from:

� Improperly affixing a nonstandard or oversized cutting tool to the ma-
chine.

� Improperly affixing the cutting tool to the machine.

� Manually holding or feeding the workpiece into the machine.

� Improperly affixing the workpiece to the machine.

� Improperly defining feeds, speeds, and depth of cut while machining.

� Introducing hazardous materials when machining.

� Removing the safety door or making any other unauthorized modifica-
tions to the machine.

� Cutting unacceptable materials.

� Using damaged or dull tooling.

�� �!��

,����3�#"�
����
�
�
�%�������
��#����#"��%�##��!�#�����	��5'��%��
����3�4#���
�����!��9�%#���3����#"����%"���*



+�
#���(���	��� -
�

1,�������� �"�����"��
You must meet all work area, power, grounding, and environmental condi-
tions before using the machine.

�"�)� ����

You must allow at least 12.5 square feet (1.16 square meters) of work area
to operate the machine.

��������*"(��� #�,,%&

AC power input must satisfy the following requirements:

@"%����

230 VAC +10% -15%

.��8����&

47-63 Hz single phase, 3 wire

*"(���  �����

4.6 KVA

20 Amps

��"������

A positive earth grounding system for the machine and the computer is re-
quired for proper and safe operation. The ground path must have a DC resis-
tance of 3.5 ohms or less to a true earth ground.

Ground the machining center in compliance with all applicable electrical
codes.
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The machining center is designed to operate within the following environ-
mental limits:


�',�������

Operating: 60o to 80o F (15o  to 27o C)

Storage: 0o to 130o F (0o  to 54o C)

Transition: 10o C/hr

��'����&

5% to 80% without condensation

�%������

Operating: 0 to 10,000 feet (3,048 meters)

Non-operating: 0 to 40,000 feet (12,192 meters)

#�"�)

Non-operating: 10g in 11 milliseconds

@�4����"�

Operating: 5Hz to 500Hz, 0.5G acceleration

Non-operating: 10Hz to 500Hz, 1.0G acceleration

�"���

70 db at 8ft.
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Performing preventive maintenance on your BENCHMAN XT Machining
Center ensures a longer, trouble-free life for the machine. We provide instruc-
tions for preventative maintenance in the following paragraphs.

��%%����(�

The BENCHMAN XT uses pre-loaded ballscrews on all three axes. The
screws are lubricated at the factory with a special long-life, waterproof
ballscrew lubricant. This lubricant should last for at least 200-250 hours
of machine use. After 200 hours, apply more lubricant to the screws in a
thin film over the length of the screw. The ballscrew lubricant (part num-
ber 39-0000-0007) is available from Light Machines Corporation.

To gain access to the ballscrews, jog the cross slide and spindle to the ex-
treme negative end of travel on all axes just before the limits are tripped.
Lift the bellows cover and use a small brush to apply grease sparingly but
evenly along the entire length of the ballscrew.
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It is important to clean off the Y and Z axis bellows covers. The chips can
get caught in the folds of the bellows limiting travel, and also puncture
and tear the material. Brush the chips off of the covers after each job to
prevent this from happening.

3������ �"��"�� #&���'� 3�4������"�

The spindle head is moved along a precision linear rail system by pre-
loaded ballscrews.  The spindle is mounted to a carriage that is guided on
the rail system by recirculating ball bearings.  The table is also moved on
a linear rail system that includes recirculating ball bearings.

Four slide carriages and two track rails are used to facilitate movement on
each axis.  The slide carriages should be lubricated witha a Lithium soap
based grease such as Shell Alvania EP2 after each 1000 hours of opera-
tion.

Bellows Spindle

Front tray Rear trayTable
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F� �5��� 3�4������"�

To lubricate the Z axis bearings:

The grease fittings for the Z axis are secured to the Z-axis chip deflectors
which are fastened to each side of the spindle head mounting plate.  Ap-
ply grease to the fittings and clean off the excess grease with a clean
cloth.

	� ���� 6� �5��� 3�4������"�

To lubricate the X and Y axis bearings:

Move the XY table to the extreme right.  The X-axis grease fittings are
secured to the left Y chip deflector which is fastened to the left side of
the XY intermediate plate.  The Y-axis grease fittings are located at the
bottom of the left and right Y-axis chip deflectors.  Apply grease to the
fittings and clean off the excess grease with a clean cloth.

	A6A� ���� F� �5��� ��G���'����

No adjustments are necessary.
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Light Machines ships the BENCHMAN XT with a factory-aligned Spindle
Head. You should not attempt to align the Spindle Head without first con-
tacting your local dealer, or Light Machines.

�����%�
""%� !������"������ �'"/�%

Occasionally it might become necessary to insert or remove a tool manu-
ally during program development, maintenance, or troubleshooting.

�� �!��

-��%���3���#��������'��%"���9����
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1. Unclamp the spindle drawbar by pressing the Drawbar Clamp/
Unclamp pushbutton on the control panel.

2. Insert the toolholder into
the spindle and rotate the
toolholder  until the slot-
ted hole in the toolholder
flange seats on the
spindle's alignment pin.

3. Clamp the spindle draw-
bar by pressing the
Drawbar Clamp/Unclamp
pushbutton.

�����%�
""%� �'"/�%

1. Unclamp the drawbar by
pressing the Drawbar
Clamp/Unclamp pushbutton.  Rotate the toolholder until it can be
pulled out of the spindle.

Alignment pin

/���'���#��#"��,/&����������
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The spindle motor on the BENCHMAN XT Machining Center is a 2
horsepower AC Servo motor. The  only wearing parts on the motor are the
ball bearings on the motor shaft. The ball bearings are sealed, lifetime-lu-
bricated bearings and do not require special maintenance.

The BXT-4521 uses a 2.7 horsepower high frequency induction motor. The
motorized spindle is a sealed unit, and utilizes a pressurized air curtain to en-
sure that no dirt or moisture contaminates the motor shaft or bearings. You
should not attempt to lubricate these bearings at any time.

���"'����� 
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1. Insert the tools into toolholders.

2. Home the platter to position tool fork # 1 across from the
spindle.

3. Insert the tool # 1
toolholder into tool fork
# 1 so that the semicircu-
lar hole in the toolholder
flange engages the fork
alignment pin.

4. Index the platter one tool
position and insert the
tool # 2 toolholder into
tool fork # 2.

5. Repeat steps 3 and 4 un-
til all the tools are loaded
into the platter.

#������� ���� #,���%�� �"'�� 1--���

The spindle home offset must be reestablished if a tool fork of the carou-
sel is unable to fully engage a toolholder clamped in the spindle drawbar.
The procedure for setting the offset is performed by manually finding the
correct rotational spindle position for tool engagement, and storing this
position in the system's computer.  The procedure requires the use of the
ATC Control screen, and the Emergency Stop pushbutton.

+���%��%�����"���

/����3��5,��!����#�'��



)
��:
�2����L�+�%#����--
��

�� �!��

�������'���#��#"��%����
���	"���������"���
��������#���
��%��
���*��-��%���3���#��������'��%"���9����
*

1. Tool # 1 must be clamped in the
spindle drawbar.  Insert and clamp
tool # 1 into the drawbar if necessary.

The toolholder must be inserted into the
spindle with the head of the capscrew cen-

tered in the clearance cut-
out of the toolholder.

2. Make sure the platter is retracted away from the
spindle (in), lowered (down), and in the Home posi-
tion.

3. Raise tool # 1 fork.

4. Press the Emergency Stop pushbutton so that the spindle can be ro-
tated freely.

�� �!��
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5. Rotate the spindle until the semicircu-
lar hole in the toolholder flange is
aligned directly across from tool fork
#1.

6. Remove your hands from the tool enclosure
and move the carousel (out) to the spindle.
If tool fork #1 completely engages the
toolholder in the spindle proceed to step 7.

If the tool fork doesn't completely engage
the toolholder,  move the carousel (in) away from the spindle and re-
peat steps 5 and 6 until the spindle rotation is properly adjusted.

+���%��%�����"���
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7. While the tool fork is engaged,
draw a thin straight line across the
bottom of the spindle and spindle
housing so the rotational position
of the spindle can be found again
later.  Use a felt-tipped marker,
and do not scratch the surfaces
with a scribe or other sharp tool.

8. Move the carousel (in) away from
the spindle, pull the Emergency
Stop pushbutton out, and Home
the spindle.

9. Push the Emergency Stop pushbutton  in.

10. Rotate the spindle until the line segment drawn on the bottom of the
spindle is aligned with the line segment on the housing.

11. Click on the Set Spindle Offset button on the Automatic Tool
Changer Control screen to store the new spindle alignment position.

12. Click on the Test button of the Spindle Setup group. The spindle
should make one complete rotation to the aligned position.  If it does
not, repeat this entire procedure and retest.  If the system fails to re-
turn to the aligned position a second time, contact Light Machines
Corporation for assistance.

3�4��������� ���� ���"'����� 
""%� �������

The ATC motion system rollers should be lubricated with 10W engine oil
on a weekly basis.

 �����%��
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The spindle drive belt is located within the spindle assembly. Normally, it
should not need adjustment. If you suspect that there may be a problem
with the spindle drive belt, please contact your local dealer or Light Ma-
chines Technical Support.

�� �!��
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The axis drive belts are located between the motors and ballscrews on
each axis. Normally, they should not need adjustment. If you suspect that
there may be a problem with the axis drive belts, please contact your local
dealer or Light Machines Technical Support.
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There are a few general guidelines for maintaining your personal com-
puter and software in a shop environment. See your owner’s manual for
maintenance procedures that are specific to your computer.

������� -"�� ���� �"',����

Follow these general rules for computer care.

� Keep the computer and peripherals (mouse, keyboard, external drive,
printer) out of direct sunlight and away from sources of heat and in a
relatively clean environment (i.e., not right next to the foundry room).

� Cover the computer and keyboard with a dust cover when not in use.

� Keep liquids (soda, coffee, cutting fluid, grease) away from the com-
puter and peripherals.

� Keep oil, grease, metal chips and excess dust away from the com-
puter, keyboard and floppy disks.

� Use grounded, three-prong outlets for the computer and peripherals. Take
precautions against current overload. A line-surge suppression unit can be
purchased at your local computer store to help alleviate this problem.

� Don’t block the vent holes in the computer or drives; they are required
for air circulation.

������� -"�� .%",,&�+��)�

Floppy disks are simple to use but require a few precautions to maintain
their integrity.

� Don’t touch the magnetic disk part of the disk (the shiny, record-like
part inside the disk jacket). Dust or grease from your hand can ruin any
part of the disk that you touch and can possibly destroy the entire disk.

� Keep disks in a disk box or special disk container instead of spreading
them out on your work space.

� Handle disks gently, don’t bend them.

� Don’t write on disk labels with a ball point pen. If you must write on
the label, always write very lightly with a felt tip pen.

� Keep disks in a clean, cool environment away from excess amounts of
dust, heat, or sun.
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� Avoid getting machining fluids on the disks. If you spill a liquid or
cutting fluid on a disk, it is 99 percent certain that the disk and all the
data on it can never be used again. Do not attempt to use the disk; flu-
ids transferred from the disk to the disk drive might damage the drive.

� Keep disks away from all magnetic sources including telephones,
high-voltage power sources and mill motors.

� Make back-up copies of all NC program disks each time you update them.

� Print copies of all NC programs in case of disk failure or lost disks.

No matter how cautious you are, disks will go bad; they develop bad blocks
(unreadable surfaces). If this happens while you are editing a program, the
program will be lost. This disaster can be avoided by making back-up copies.
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BENCHMAN XT is available with a number of factory installed options.
This section includes information about each one.

>A;

�  *�� #,���%�

The 7,500 RPM Spindle (ACC-5107) allows you to machine materials at
speeds up to 7,500 RPM.

�;A


�  *�� #,���%�

The 45,000 RPM Spindle provided with the BENCHMAN BXT-4521 al-
lows you to machine materials at speeds up to 45,000 RPM.

+�����H���� *��)���

The ACC-5262 Digitizing Package includes a digitizing probe and soft-
ware that lets you digitize existing parts and models to capture 3-D sur-
face data. The easy-to-use PC-driven package provides reverse engineer-
ing capabilities with BENCHMAN. It can generate files in three different
formats; an NC part program, an ASCII text file with XYZ data points,
and a DXF 3-D mesh file.

The Digitizing Package includes a touch signal probe, a probe interface
cable, a 20mm long stylus with 3mm diameter head, a 20mm stylus exten-
sion, the Digitizing Package User’s Guide, the Digitizing Package soft-
ware on 3.5" diskettes, and an 8 mm Collet.

���� @���

The Air Vise (PNU-4114) has jaws that open to a maximum of 3.0 inches.
The vise comes with a solenoid valve and all the tubing required to inter-
face with the Pneumatic Control option (PNU-4111) if so equipped.



)
��:
�2����L�+�%#����--
0�

���,����� +���� �"%%����"�� #&���'

The Graphite Dust Collection System (PNU-4116) uses a high volume
vacuum system to remove fine graphite dust from the enclosure during ma-
chining. A filter is fitted to one of the enclosure windows, while a duct is
fitted to the other. The duct runs into a separate vacuum module, which
houses the vacuum motor and dust collector. Refer to the documentation
provided with the system for more information.

 "���&� �5��� �"���"%

This option allows for machining on the X, Y, Z, and Rotary axes. The Rotary
Axis Control (ACC-5407) provides the software to program machining on all
four axes. The 5C Rotary Positioner (ACC-5224) is available as a separate op-
tion.

*���'����� �"���"%

The Pneumatic Control option (PNU-4111) allows programmed control of
Light Machines-installed pneumatic options, such as the Air Vise and
Pneumatic Door Opener. It can also provide control for up to two (2) user
installed pneumatic devices operating at a minimum pressure of 75psi.

.%""�� �""%���

The BENCHMAN XT is available with Flood Coolant (ACC-5205). A
pump provides coolant to the workpiece resulting in reduced tool wear,
and evacuation of chips. The coolant pump and plumbing are installed at
the factory; the operator is required to fill the coolant sump.

Flood Coolant is not available on the BXT-4521.

.�%%���� ���� #�',

Benchman requires a minimum of seven (7) gallons of coolant, and holds
a maximum of nine (9) gallons. Light Machines recommends the use of
Valcool Coolant. Using any other brand of coolant may cause corrosion of
any parts that come in contact with the coolant. The coolant sump is
shipped dry, and must be filled before using the flood coolant system.

To fill the sump:
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�9 Make sure the coolant is thoroughly mixed before filling the sump.
The coolant concentrate should be diluted with water according to the
following formula: 1:17 (6%) to 1:25 (4%).

�9 Press the Emergency Stop button on the front panel.

:9 Open the safety shield of the machining center.

�9 Carefully add at least seven (7), and not more than nine (9) gallons of
the coolant mixture to the sump.

;9 Close the safety shield, and return power to the machine.

Because of evaporation of water in the coolant and other minor losses, coolant
levels should be checked weekly, along with other maintenance. The cool-
ant also becomes dirty, and should be replaced periodically.

.%""�� �""%���� #���,� ���� 1,�����"�

Flood Coolant is a factory installed option. The BENCHMAN XT comes
flood coolant ready.

�""%���� .%"(

The pump draws coolant from the sump in the bottom of the enclosure,
and cycles it through the adjustable nozzle directly onto the workpiece.
The coolant pump is located beneath a cover in the right rear corner of the en-
closure. It can be turned on and off either through the user interface, or by
M codes in the NC program (M08/on, M09/off). The nozzle tube is adjust-
able, and has a petcock built into it to control the flow of coolant.

The coolant runs off the workpiece, taking the chips with it, and back into
the sump area. There are screens over the sump to separate the chips from the
coolant. These screens should be cleaned periodically. If the chips are not
removed from the screens, they will block the flow of coolant back into the
sump.

Important! Do not drill or make holes of any sort in the enclosure, espe-
cially on the back panel. If holes are drilled to mount an aftermarket ac-
cessory or other device, coolant is likely to leak out and could be hazard-
ous  to other components of the machine.

�����������

Flood coolant machines require only a little more maintenance than non
coolant machines. It is important to perform the following maintenance.

� Keep sump screens clean to maintain the flow of coolant through the sys-
tem.

� Check and refill coolant levels as necessary.
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�9 Open operator door.

�9 Remove one of the sump screens.

:9 Make sure the coolant is within an inch of the screen.

�9 Refill if necessary.

� Coolant should be replaced once a month, depending on machine usage.

�9 Press the Emergency Stop Button on the controller and remove
power from the machining center.

�9 Place an approved ten (10) gallon container below the drain plug
at the rear of the machining center.

:9 Remove the drain plug.

�9 When the coolant has drained into the container, replace the plug
and properly dispose of the used coolant.

;9 Open the safety shield and refill the sump with fresh coolant. Be
sure the coolant is mixed thoroughly before filling the sump. Do
not try to mix coolant in the sump.
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To start the Control Program:

From Windows 95 or Windows NT 4.0 select the Start menu, and then
Programs> Benchman> BENCHMAN. You can also create a shortcut by
opening the Benchman directory and dragging BENCHMAN.EXE onto
your desktop.

From Windows NT double-click the BENCHMAN XT icon in the
BENCHMAN XT group.

#�������� ���� �"���"%� *�"���'� ��� #�'�%���� �"��

If this dialog box appears when you start the Control Program, the Motion
Control Card that came with your machining center has not been properly
installed (see Section A).

If you do not have the Motion Control Card installed you can still edit and
verify NC part programs without the machining center by running the
Control Program in Simulate Mode.

To start the Control Program in Simulate Mode, select Cancel. When the
next dialog box appears, select Simulate.

BENCHMAN
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You can access on-line help by using the commands under the Help Menu,
or by pressing F1.

For information on the functions and screens in the Control Program software,
refer to Section E, Control Program Reference.
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You should become familiar with the main parts of the Control Program
screen before you begin using the Control Program to run NC part pro-
grams. The following are the default components that make up the screen.

����� ���

The Menu Bar carries all of the menu commands for the Control Program. For
a full explanation of each menu and its relative commands, see Section E,
Control Program Reference.

#�������� 
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The Standard Tool Bar provides easy access to the most often used Con-
trol Program commands.
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The ATC Tool Bar provides easy access to the functions of the Automatic
Tool Changer. It allows the user to insert tools from each of the tool sta-
tions into the spindle, clamp and unclamp the draw bar, and configure the
ATC.
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The Outputs Tool Bar is an active tool bar. It provides switches activate or
deactivate the named output. The feature is on when the buttons are de-
pressed. If you hold the mouse over the button, a message will be dis-
played on the Status bar stating whether the output is on or off.
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The Inputs Tool Bar is an informational tool bar. It provides information
on the state of the input. An input is active (on) when the button is de-
pressed.
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Whenever you open an NC part program file, it appears in its own edit
window. These windows have the same characteristics as other Windows
95 windows (scroll bars, minimize/maximize buttons, etc.). You can have
multiple edit windows open at a time, the number of which depends on
available memory.

By default, each new window is locked; you can not edit a locked
window. To unlock the window, use the Lock command under the Edit
Menu.
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The Status Bars display information about the XT and the computer. The
top of the bar shows information about the machine itself, while  the bot-
tom displays NC program information, and the time. The top left side of
the Status Bar displays any current machine error conditions. The bottom
left side of the Status Bar is reserved for operator messages such as the
one displayed here. If any of the areas are grayed-out, the feature is con-
sidered off. See page E-11 for more information about the Status Bar.

� Machine Error Conditions: Displays current machine errors, if any.

� FR: Current machine Feed Rate.

� SS: Current Spindle Speed.

� SL: Spindle Load; current load on the spindle.

� AP: Relative ATC air pressure

� QS: Queue Status, or percentage of queue currently in use.

� The Machine Homed state: Black if the machine is currently homed.

� The Caps Lock key state: Black if the Caps Lock feature is on. Some
NC programmers prefer to type their programs in capital letters. When
the Caps Lock feature is on anything you type will be displayed in
capital letters. Press the Shift key to type lower case letters.

� The Num Lock key state: Black if the Num Lock feature is on. Some
NC programmers prefer to use the numeric keypad on the keyboard  to
enter figures. The Num Lock feature must be on to do this.

� Current Line : Total Lines: Displays the line the cursor is currently
on, and the total number of lines in the NC program.

� The file locking state: Black if the NC program file is locked.

� The file modified state: Black if the NC program has been modified
since being opened.

� The current time (according to your computer).
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The Position Readout provides information on the current X, Y and Z co-
ordinates of the tool position. The units of measure in the Position Read-
out are determined by the Units command under the Setup Menu.
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The Machine Info Panel provides information on the current tool, tool
diameter, feed rate, spindle speed, number of  passes made, coordinate
system in use, as well as the current block and total number of blocks
in the program.
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The Verify Window displays a simulation of your part program when you
select the Verify command from the Program Menu, or when you click the
Verify Program button on the Standard Tool Bar.

Tool path verification can be performed in centerline view or solid view.
Centerline view is based on the centerline of the tool. Solid view is a solid
representation of the tool and workpiece.
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Like any other power tool, the BENCHMAN XT is a potentially dangerous
machine if operated in a careless manner. The importance of safely operat-
ing the BENCHMAN XT, including the need for protection against per-
sonal injury and the prevention of damage to the equipment, can not be
stressed enough. You will find more information on safe machining in the
Reference Guide: Section J.

#�-��&�  �%��

The following safety rules should be practiced by all operators of the
BENCHMAN XT Machining Center.

 �'"/�� ��G������� 2�&�� ���� ��������
Make a habit of checking that keys and adjusting wrenches are removed
from the machining center before operating the machine.

+"��"�� ."���� �� 
""%
Select the feed rate and depth of cut best suited to the design, construction
and purpose of the cutting tool. It is always better to take too light a cut
than too heavy a cut.

���� ����  ����� 
""%
Select the type of cutting tool best suited to the milling operation. Don’t
force a tool or attachment to do a job it wasn’t designed to do.

#������ ���� �"�),����
Be certain that you have firmly secured the workpiece on the cross slide
and the cutting tool in the spindle before turning on the spindle motor.


���� ���� #,���%�� �&� ����� ��-"��� #�������
Manually turning the spindle allows you to safely determine that the tool
will not hit the machining center bed, cross slide, or stock on start up.


������� �%%� �"%����A� 3"�)���� ���� +��/���� +�/����
Tighten the work holders and tool holders. Do not over-tighten these devices.
Over-tightening may damage threads or warp parts, thereby reducing ac-
curacy and effectiveness.
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Before you run the BENCHMAN XT for the first time, you should know
how to stop the machine should an emergency situation arise. There are a
number of ways an emergency stop can be initiated on the Machining
Center: By pressing the Emergency Stop button, by simultaneously pressing
the Control and Space Bar keys on the computer keyboard, by activating one
of the limit switches, or by activating the safety door interlock switch.

#�",,���� (���� ���� �'������&� #�",� ����"�

There is an Emergency Stop button located on the front panel of the ma-
chining center; it has an oversized red cap. Before power can be applied to
the machining center, the Emergency Stop button must be pulled fully out
from the front panel. Rotate the cap clockwise to release it. The Emer-
gency Stop button works on the spindle even if the computer is turned off.

In the event of some machine or operator emergency, you can immediately
kill power to the machining center by pushing in the Emergency Stop but-
ton. Pushing in the Emergency Stop button terminates the part program.
Wait until the machining center has completely stopped moving before
opening the safety shield.

When the error has been corrected, and the Emergency Stop button is reset
(rotated and released), press Enter on the keyboard to close the error dialog
box that appeared when the Emergency Stop button was pressed. Take the
necessary steps to ensure that the problem is fixed, (i.e., edit the part program
to remove the tool crash, check the position of the workpiece, etc.) before run-
ning the program again. You may need to reinitialize (reset the point of origin
for all axes) the machining center using the Set Position command from the
Setup Menu, and you may need to home the machine again.

The Emergency Stop button should be your first target when a critical error
occurs. You do not need to use it in situations where safety or reaction time is
not an issue. For example, if you start to run a program but notice that the tool
is moving towards the wrong corner of the workpiece, use a software stop to
halt the program and reset the origin of the workpiece.

#�",,���� (���� ���� �"',����� 2�&4"���

The execution of the part program can be interrupted by pressing keys on
the computer keyboard. To stop the part program with the keyboard, press
the Control key and Space Bar simultaneously. The cutting stops immedi-
ately and the cutting tool remains in position.
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The reason for stopping the program will determine the method used to re-
start the program. If it the problem was not a critical error, and you want
to continue from the same position, select the Run/Continue command
from the Program Menu. In the Start At Line box, enter the number of the
last line executed, then click on the Run Program button. (The last line ex-
ecuted is displayed on the Machine Info Panel.)

#�",,���� (���� �� 3�'��� #(����

The BENCHMAN XT is equipped with limit switches to sense the end of
travel on each axis. If the table travel exceeds the end of travel on any
axis, a limit switch is activated and shuts down machine operation.

Once a limit switch is activated, the tool must be jogged away from it us-
ing the Jog Control keypad (selected from the View Menuor the Standard
Toolbar).

To move the cross slide away from the limit switch, you must jog it in the
opposite direction. Each axis has a positive and a negative limit. If a posi-
tive limit is hit, you must jog away from it in a negative direction. If a nega-
tive limit is hit, you must jog away from it in a positive direction. If both a
positive and a negative limit are hit, you must jog off the negative limits first.

If the cross slide comes close enough to the end of travel on any axis
to activate a limit switch, the following procedure must be followed to
restore normal operation.

�9 Select Jog Control from the View Menu or the Standard Tool Bar.

�9 Press the appropriate jog key on the jog keypad to move the cross
slide away from the triggered limit switch.

:9 Check your initial machine set up to make sure it was performed cor-
rectly.
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When you installed the Control Program, an NC part program file named
MILLONE.NC was copied into the BENCHMAN XT directory along
with the other files. This program is designed to machine a 3" x 2" x 1.5"
piece of machinable wax. You will be using this file to create your first
workpiece on the machining center.
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�9 Select the Open command from the File Menu, or click on the Open
button on the Standard Tool Bar. The Open dialog box appears.

�9 Double-click on MILLONE.NC, or click on the filename and then
click on the Open button. The edit window for MILLONE.NC
appears.
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After loading the NC program, you need to adjust the Verify Settings specifi-
cally for the part you are about to machine. To view the Verify Setup dia-
log box, double click on the Verify window. You may also select Verify
from the Program Menu, or select Verify from the Standard Toolbar then
click on the Verify Settings button.

The Verify Setup dialog box appears.

��G���� ���� @��(

�9 Select the View tab.

�9 Select either Solid (for a solid representation),  or Centerline (for a
centerline representation of the tool and workpiece) from the Style
area.

:9 Select Isometric from the Preset View area for a three dimensional
view of the part.
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�9 Select the Stock tab.

�9 Enter the stock Dimensions for the MILLONE.NC program. The
stock dimensions are X=3", Y=2" and Z=1.5".

:9 Set the Initial Tool Position to X=0, Y=0 and Z=0.5.

�9 Set the point of Origin to zero on all three axes.

;9 Select OK. The dialog box closes, and the shape of the workpiece in
the Verify Window changes.
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To machine this part, you will use an 1/8" HSS end mill. You will use the
parameters for this particular end mill for the tool path verification as well.
To define the tool parameters, first add the tool to the tool library, then
select the tool for verification.

���� ���� 
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�9 Select Setup Library from the Tools Menu. The Setup Tools dialog
box appears. There is a 1/8" end mill already defined. However, our pur-
pose is to learn to use the system, so we will create another 1/8" end mill.

�9 In the Tool Library scroll box, scroll down to tool 11, which is undefined
at this point. Highlight Tool 11 by clicking on it with your mouse.

:9 In the Tool Type pull-down list, select End Mill.

�9 Enter "End Mill" in the Description box.

;9 Enter 0.125 in the Diameter box.
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�9 Select Tool from the Tools Menu. The Select Tool for Use dialog
box appears.

�9 Select Tool 11 from the pull-down list.

:9 Click on the Select Tool button.
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=9 Click on the Apply button. You have just defined a new tool in the
library. From now on, whenever you need an 1/8" HSS end mill it
will be there.

>9 Click on OK to exit the Tool Library.
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Tool path verification allows you to check for programming errors before
actually running the part program on the Machining Center.

�9 Select Verify from the Program Menu. The Verify Program dialog
box appears. The default starting line for the program is Line 1.
When verifying a program for the first time, you should begin at the
first block.

�9 Click on the Verify Program button, then watch the Verify Window.
You will see MILLONE.NC executed on the graphic workpiece.
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Before you run your part program for the first time, you should perform a
dry run (run the program with no stock mounted) to make sure that all the
movements of the machining center make sense and that the tool is in no
danger of striking any fixtures or crashing into the cross slide. Although
the program should be run with no stock mounted, you should set the
point of origin using the workpiece, and then remove it.

Begin with the Emergency Stop button pressed in, and the spindle speed
turned all the way down. The vise or other work holding device should be
mounted to the cross slide and the tool should be mounted in the spindle.

�9 Mount the workpiece in the vise.

�9 Close the Safety Shield and pull out the Emergency Stop button.

:9 Select Jog Control from the View Menu (or the Standard Toolbar).
The Jog Keypad appears.

�9 Use the Jog Keypad to jog the spindle to the top of the left front cor-
ner of the workpiece.

;9 Select Set Position from the Setup Menu. The Set Position dialog box ap-
pears.

=9 Enter zero in the X, Y and Z boxes.
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>9 Click on OK. The values in the Position Readout all change to zero.

?9 Jog the tool up and away from the workpiece.

B9 Press the Emergency Stop button, open the safety shield and remove
the workpiece.

�
9 Return the Safety Shield to the closed position and pull out the Emer-
gency Stop button.

��9 Put on a pair of safety glasses and complete the Safety Checklist (re-
fer to Reference Guide: Section J.)

��9 Select Run/Continue from the Program Menu. The Run Program dialog
box appears.

�:9 Click on the Run Program button.

��9 As the part program runs, observe the tool motion in relation to the
vise (and eventually the workpiece). Look for signs of a possible tool
crash and be prepared to press the Emergency Stop switch on the ma-
chining center. Edit and re-verify the program as required. When you
are satisfied that the tool motions are correct, you can mount the
workpiece.
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�9 Using the Jog Keypad, jog the spindle up and out of the way.

�9 Before mounting the workpiece, push the Emergency Stop button in.

:9 Mount the workpiece in the vise leaving at least 1/8" of the stock
above the jaws of the vise. Take care to position the workpiece paral-
lel to the tool bed. To assure that the piece is flat, place parallel bars
underneath to space it upwards within the vise before clamping.

�9 Pull the Emergency Stop button out.

;9 Select the Operator Panel and check that the spindle speed is set to
100%.

The workpiece is now correctly mounted.

 ��� ���� *�"���'

Before executing the MILLONE.NC program, make certain that all safety
precautions have been taken. The machining center safety shield should be
closed, and you should be wearing safety glasses.

If anything goes wrong, immediately press the Emergency Stop button on the
machining center to stop the operation. A safety checklist has been provided
in the Reference Guide: Section J of this guide. Post a copy of this check-
list near the machining center and review it before you run any NC pro-
gram.

To run the program:

�9 After reviewing the Safety Checklist, select the Run/Continue com-
mand from the Program Menu. The Run Program dialog box appears.

�9 Make sure that the Start Line box is set to line 1 of the program.
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:9 Click on the Run Settings button. The Run Settings dialog box appears.

�9 Make any changes desired in the Run Settings dialog box, then select OK.

;9 Click on the Run Program button in the Run Program dialog box to
begin running your program.

=9 After the part is machined, press the Emergency Stop button before
opening the safety shield and removing the finished part.
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The BENCHMAN XT interface (the screen) is composed of several components
that allow you to create NC part programs and interact with the machining
center. The interface is easily configured and optimized by opening, closing,
resizing and repositioning the screen components.
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The Message Bar is located directly beneath the Menu Bar. When an NC
program is running or being verified, the Message Bar displays the opera-
tion and the name of the program being run or verified, or the most recent
operator message. When the program pauses for any reason (i.e. a pro-
grammed stop or an operator requested pause), the Message Bar displays a
message (Operator Requested Stop; Change Tool; etc.), a green Continue
Program and a red Stop Program button. When there is no program run-
ning, the Message Bar displays the Control Program copyright notice.

������ ����"(�
Windows are used to display information. Windows can be docked or they can
be floating windows. They are activated or hidden using the commands under
the View Menu. Windows can be interactive, or for information display only.

The following windows are available:

� Program Edit Windows

� Verify Window

� Machine Info Window

� Position Window

*�"���'� ����� ����"(�

When you open an existing NC part program file, or create a new one, the
program appears in a program edit window. Program Edit Windows have
all of the features common to other windows, including a title bar which dis-
plays the program file name, and controls for minimizing, maximizing, and
closing the window.

Program Edit Windows appear in the Edit Area (the large central area) of
the screen. The Edit Area is fixed in position; you cannot close it or move
it, and  can contain multiple Program Edit Windows. The Windows Menu
has several commands for managing Program Edit Windows. It also allows
you to select a particular window from a list of all current program win-
dows, identified by file names.

When other windows, panels, and toolbars are closed, the space that their
docking areas occupy is given to the Edit Area.

When other windows, panels, and toolbars are open, the space that their
docking areas occupy is taken from the Edit Area.
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The Verify Window can be opened
and closed by selecting the Verify
Window command from the View
Menu.

The Verify Window displays a simula-
tion of your part program (tool path
verification) when you select the
Verify command from the Program
Menu, or when you click the Verify
Program button on the Standard Toolbar.

Tool path verification can be performed in centerline view or solid view.
Centerline view is based on the centerline of the tool. Solid view is a solid
representation of the tool and workpiece.


����������� !�-"�����"(

The information displayed in the Machine Info Window varies with the
particular operation being performed:

When the machine is idle, the Machine Info Window displays the fol-
lowing information:

� Current tool number and diameter

� Feed rate and spindle speed

� Number of passes made for the current program

� Coordinate system being used

� Current block number and the number of blocks in the current pro-
gram.

The passes, current block, and total number of blocks refer to the last pro-
gram verified or run.
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When a program is running, the Machine Info Window becomes a dy-
namic display. In addition to updating the previously mentioned informa-
tion, each line of code is displayed as it is executed, along with the previ-
ous and next lines of code. Also, a clock provides the elapsed run time for the
program.

When a program is being verified, the Machine Info Window displays
the current line of code, plus the previous and next lines. The elapsed time
is not indicated.


��� *"����"�� ����"(

This is a dynamic display. When a program is running or being verified,
the current position of the tool is indicated here.

If you double-click on this window, the Goto Position dialog box appears,
allowing you to move the tool to specific coordinates.
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Toolbars carry buttons that correspond to frequently used menu com-
mands. You can click on these buttons to quickly select the associated
menu command. Toolbars also generate Outputs and display the state of In-
puts. Toolbars can be placed anywhere on your screen, and can be hidden
if you do not use them often or want the additional space for program win-
dows. Toolbars are revealed and hidden using the Toolbars command un-
der the View Menu.

The toolbars include:

� Standard Toolbar

� Outputs Toolbar

� Inputs Toolbar

� ATC Control Toolbar


��� #�������� 
""%4��

The Standard Toolbar provides quick-access buttons for the following:

�"''���$ ����� �"$

New File Create a new program edit window

Open File Open an existing NC program file

Save File Save an NC program file

Cut Cut text from a program

Copy Copy text from a program

Paste Paste text into a program

Print Print an NC program

Help Access Help

Context Help This button can help you instantly find informa-
tion on the objects you see on the screen. For in-
stance, click on the Context Help button, then
click on a menu item, toolbar button, window or
other screen element. The Help file for that particu-
lar item appears.

Jog Control Panel Show or hide the Jog Control Panel

�"���5��#������/�
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Operator Panel Show or hide the Operator Panel

Verify Verify the current NC part program

Run Run the current NC part program

Pause Pause the currently running NC part program

Stop Immediately halt the currently running NC program


����
�� �"���"%� 
""%4��

The Automatic Tool Changer Toolbar provides quick-access buttons for
automatically changing tools. The toolbar provides four buttons that:
clamp and unclamp the drawbar, open the Configure ATC dialog box,
open the Operate ATC dialog box, and select one tool from a drop down
menu of twenty tools for insertion into the spindle.


��� !�,���� 
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The Inputs Toolbar isn’t really a toolbar in the sense that it is not used to
interact with the various Control Program inputs. It is a monitoring device
that keeps track of the state of the various system inputs.

The state of each input is indicated by the position of its button. If a button is
depressed, the input is “on” or “high.” If a button is not depressed, the in-
put is “off” or “low.” You can also check the condition of an input by
clicking on it, or by holding the mouse over the input button. The state of
the input is displayed on the Status Bar at the bottom of the screen.

The inputs on the Inputs Toolbar include:

� The Emergency Stop condition. This input is in the “on” condition
(depressed) if the Emergency Stop button on the machining center is
pushed in.

� The Safety Shield condition. This input is in the “on” condition
(depressed) if the Safety Shield on the machining center is open.

� The Cycle Start condition. This input is in the “on” condition (pro-
gram has begun) when the button is depressed.

� The Cycle Stop condition. This input is in the “on” condition (pro-
gram is being stopped) when the button is depressed.
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� The Positive Limit condition. This input is in the “on” condition
(depressed) if one of the positive axis limits has been hit.

� The Negative Limit condition. This input is in the “on” condition
(depressed) if one of the negative axis limits has been hit.

� The Door Lock condition. This input is in the “on” condition (de-
pressed) if the door is locked.

� The Machine Keylock condition. This input is in the “on” condition
(depressed) if the machine key lock is in the locked position.


��� 1��,���� 
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The Outputs Toolbar provides quick-access buttons for controlling the
system outputs. Depending on the options configuration of your ma-
chine, the Outputs toolbar may have more buttons on it than the one
shown here.

The state of each output is indicated by the position of its button. If a button is
depressed, the output is “on” or “high.” If a button is not depressed, the
output is “off” or “low.” You can also check the condition of an output by
holding the cursor over the button. Clicking on the button will change the
state of the output. The state of the output is displayed on the Status Bar at
the bottom of the screen.

The output controls on the Outputs Toolbar include:

� The Spindle control. This button turns the spindle on and off.

� The Spindle Direction control. This button reverses spindle direction.

� The Coolant control. This button turns  the flow of coolant to the
workpiece on and off.

� The Light control. This button turns the light on and off.

� The Door Lock control. This button latches and unlatches the door lock.

� The Air Vise control. This button activates and deactivates the op-
tional air vise.

� The pneumatic Door Opener control. Selecting this button allows you
to activate the optional pneumatic door opener.

� The General Pneumatic Device control (not shown). This button
controls any other pneumatic device you have installed on the ma-
chine.
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The Jog Control Panel and the Operator Panel are used to control machine
operation.


��� 0"���"���"%�*���%

The Jog Control Panel is accessed by selecting the Jog Control command
under the View Menu, or by clicking on the Jog Control button on the
Standard Toolbar. The Jog Control Panel allows you to manually move
(jog) the tool on the machining center. Selecting the Keypad button allows
you to use the numeric keypad on the keyboard to jog the machine.

Each axis on the machine is represented by buttons. The X and Y axes are
represented by the crosspad. The crosspad follows the Cartesian coordi-
nate system standard; -X to +X is left to right, while -Y to +Y is front to
back. The Z axis is represented by two buttons, one for positive motion
(up) and one for negative motion (down). Pressing any of the axis buttons
moves the tool in the indicated direction.

Jogging occurs in specific increments of speed and distance. The speed
and distance values are selected on this panel as well. You can alter the
speed and distance parameters for jogging by selecting the Jog Settings
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command under the Setup Menu, or by double clicking on the Jog Control
Panel.

To jog a tool:

�9 Define the Speeds and Steps (distances) for jogging by selecting the
Jog Settings command under the Setup Menu.

�9 Click on the Axis button on the Jog Keypad to move the tool in the
desired direction. The tool moves at the speed and distance indicated
by the Speed and Step buttons.
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The Operator Panel controls include:

����� Optional Skip: Allows you to execute or ignore any optional skips (
/ codes) you have embedded in the NC program.

����� Optional Stop: Allows you to execute or ignore any optional stops
(M01 codes) you have embedded in the NC program.

����� Single Step: Causes the NC program to pause after each block is ex-
ecuted. This allows you to check each step of the cutting operation.
Single Step is particularly useful after changing the workpiece size.

����� Stop: Immediately halts the currently running NC program. This button
works the same as the Ctrl + Space Bar combination.

����� Cycle Start: Begins running the current NC program from the begin-
ning or from a paused condition.

����� Feedhold: Pauses the currently running NC program. To continue
running the program from a Feedhold, press the Feedhold button again
or press the Cycle Start button.

����� Feed Rate Override: Overrides the programmed feed rate.

����� Spindle Speed Override: Overrides the programmed spindle speed.
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The Operator Panel provides controls that are used while running an NC
program on the machining center.
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The Status Bar display various information about the machining center and
the computer. The top of the bar shows information about the machine while
the bottom displays NC program information, and the time. The top left
side of the Status Bar displays any current machine error conditions. The
bottom left side of the Status Bar is displays operator messages such as the
one shown here. If any of the areas are grayed-out, the feature is consid-
ered off.

� Machine Error Conditions: When an error is generated, the message
area flashes red, and displays a letter designating the error. Click on
the message area for the error details.

� FR: Current Machine Feed Rate. This displays the actual feed rate,
taking into consideration the programmed feed rate, and any overrides
set on the front panel or the Operator Panel on the screen.

� SS: Current Spindle Speed. This displays the actual spindle speed,
taking into consideration the programmed spindle speed, and any
overrides set on the front panel or the Operator Panel on the screen.

� SL: Spindle Load; current load on the spindle.

� AP: Relative ATC air pressure. If the pressure drops below the safe
operating  level (75 psi), the display will turn red.

� QS: Queue Status, or percentage of queue (buffer space on the Motion
Control Card) currently in use.

� Operator Messages: Displays general machine messages.

� The Machine Homed state: Black if the machine is currently homed.

� The Caps Lock key state: Black if the Caps Lock feature is on. Some
NC programmers prefer to type their programs in capital letters. When
the Caps Lock feature is on anything you type will be displayed in
capital letters. Press the Shift key to type lower case letters.

� The Num Lock key state: Black if the Num Lock feature is on. Some
NC programmers prefer to use the numeric keypad on the keyboard to
enter figures. The Num Lock feature must be on to do this.

� Current Line: Total Lines: Displays the line the cursor is currently
on, and the total number of lines in the NC program.

� The File Locking state: Black if the NC program file is locked.

� The File Modified state: Black if the NC program has been modified
since being opened.

� The current time (according to your computer).
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The Menu Bar is located at the very top of the screen. It lists the catego-
ries of commands into which the Control Program operations are grouped.

The available menus are:

� The File Menu

� The Edit Menu

� The View Menu

� The Program Menu

� The Tools Menu

� The Setup Menu

� The Window Menu

� The Help Menu

.�%�� ����

The File Menu provides typical file management commands and the Exit
command.

�"''���$ ����� �"$

New Create a new program window.

Open Open an existing file.

Close Close an open program window.

Save Save a program.

Save As Save a program under a different filename or loca-
tion.

Print Print an open NC program.

Print Setup Set up your printer for printing.

Recent files Open one of the eight most recently used files.

Exit Exit the Control Program.

��(� �"''���

Use the New command under the File Menu to create a new program edit window.

You can create a new program edit window at any time. The number of
program edit windows that you have open at one time is limited by the
amount of memory on your computer.



8
��&��#�������!����7�3����%�

To create a new program window, select New from the File Menu, or press
Ctrl+N.

A new program window is created. The filename on the Title Bar is “Un-
titled,” indicating that this is a new program. The program will remain untitled
until you save it. You should save your new programs before they are run or veri-
fied.

1,��� �"''���

Use the Open command under the File Menu to open an existing NC program.
The number of program edit windows that you have open at one time is limited
by the amount of memory on your computer.

To open an existing NC program:

�9 Select Open from the File Menu, or press Ctrl+O. The Open dialog box appears.

�9 In the dialog box, locate and highlight the desired NC file.

:9 Click the Open button or press Enter. The selected NC program file is
opened. The Title Bar displays the name of the file.

To select a file that is already open:

� If the open file has changed since it was opened, you are prompted to re-
load the original version of the file or to cancel the opening procedure.

� If the open file has not changed since it was opened, it becomes the active
Program Edit Window.

�%"��� �"''���

You can close a program window that is not running, at any time. Unless you
have already done so, you will be prompted to save any changes made to the
program file.

To close a program window:

�9 Make sure the program window you want to close is selected.

�9 Select one of several ways to close the open window:

� Select the Close command from the File Menu.

� Single-click the icon on the far left of the Title Bar, and select Close
from the drop-down menu. (If the edit window is maximized, this
icon will be in the far left of the Menu Bar.)

� Double-click the icon on the far left of the Title Bar. (If the edit window
is maximized, this icon will be in the far left of the Menu Bar.)

� Click on the Close button on the far right of the Title Bar. (If the edit window
is maximized, this icon will be in the far right of the Menu Bar.)

� Press Ctrl+F4.
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:9 If there are unsaved changes to the current program, the File Save dia-
log box appears, prompting you to save the changes. Click one of the
buttons in the dialog box:

� Click Yes to save the changes.

� Click No to discard the changes.

� Click Cancel to exit the dialog box without saving the changes or
closing the program window.

#�/�� �"''���

Use the Save command under the File Menu to save the current program
as an NC file.

If the current NC program was previously saved, selecting Save saves the
changes to the same file. If the current program is new (and still has the
name “Untitled”), selecting Save brings up the Save As dialog box, in
which you name, choose a location for, and save the new program.

To save a program, select Save from the File Menu, or press Ctrl+S.

The current program is saved to a file. If this is a new program, the Save
File As dialog box appears. Choose a name and location for the new file.

#�/�� ��� 999� �"''���

Use the Save As command under the File Menu to save the current pro-
gram to an NC file using a new name or location.

#�/�����+��%"���"5

The Save As dialog box is the same in the Control Program as in other
Windows applications.

To use the Save As dialog box:

�9 Select a destination for the file using the Save in:, Up one level and Cre-
ate new folder buttons.

�9 Enter a filename in the File Name: field.

:9 Select a file type in the Save as type: field.

�9 Click OK or press Enter to save the file.

;9 Click Cancel or press Esc to cancel and exit the dialog box.
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Use the Print command under the File menu to print the current NC program.

To print the program:

�9 Select one of the following ways to open the Print dialog box:

� Click the Print button on the toolbar.

� Select the Print command from the File Menu.

� Press Ctrl+P.

The Print dialog box appears.

�9 Choose the desired print options in the dialog box. Clicking Setup
opens the Print Setup dialog box.

:9 Click OK to print, or click Cancel to exit the Print dialog box without
printing the NC program.

You can print to any printer that is supported by Windows 95. See your
printer manual or Windows documentation for more information on install-
ing and using printers with Windows.

*����� #���,� �"''���

Use the Print Setup command under the File Menu to select a printer. The
Print Setup dialog box allows you to establish parameters for printing your
NC part programs.

To choose print settings:

�9 Select Print Setup from the File Menu. The Print Setup dialog box ap-
pears.

�9 Select the desired print settings, including:

� The destination printer.

� The size of the paper.

� The paper tray.

� The orientation of the paper.

:9 Click OK to print, or click Cancel to exit the Print dialog box without
setting the printing parameters.
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You can use the numeric (1, 2, 3, … 8) commands under the File Menu to
open any of the eight most recently opened files.

The names and paths of the eight most recent files appear as file 1 (the file
last opened) through file 8 (the eighth most recent).

To open one of the eight most recently opened programs:

Select 1, 2, 3, 4, 5, 6, 7 or 8 from the File menu.

The recent program you selected is opened. The Title Bar displays the
name of the program file.

�5��� �"''���

Use the Exit command under the File Menu to exit the Control Program.
You should always exit the Control Program before you exit Windows.

Use one of the following options to exit the Control Program:

� Select the Exit command from the File Menu.

� Single-click the icon on the far left of the Control Program Title Bar. Se-
lect Close from the drop-down menu.

� Double-click the icon on the far left of the Control Program Title Bar.

� Click on the Close button on the far right of the Title Bar.

� Press Alt+F4.

If there are unsaved changes to any program window, a dialog box appears
for each unsaved program window, prompting you to save the changes.

� Click Yes to save the changes and exit.

� Click No to ignore the changes and exit.

� Click Cancel or press Esc to cancel the Exit command and return to
the Control Program.
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The Edit Menu provides typical text editing commands.

�"''���$ ����� �"$

Undo Undo the most recent editing command.

Redo Redo the last undo command.

Cut Cut selected text to the Windows clipboard.

Copy Copy selected text to the Windows clipboard.

Paste Paste text from the Windows clipboard into the
current NC program.

Clear Delete selected text.

Delete Line Delete the line the cursor is currently on.

Find Locate a sequence of characters in an NC pro-
gram.

Replace Replace one sequence of characters with another,
one or more times.

Goto Line Jump to a particular line in the NC program.

Renumber Modify or insert N codes in an NC program .

Lock Lock or unlock the Program Edit Window to pre-
vent or allow modification to the NC program.

Select Font Change the font currently being used.

���"� �"''���

The Undo command reverses the most recent editing action taken. It is useful
for recovering from accidental deletion or inclusion of a block of text.

To undo the last change, select Undo from the Edit menu, or press
Ctrl+Z.

� If your last editing action was to delete selected text, the text is re-
stored.

� If your last editing action was to delete a character, the character is re-
stored.

� If your last editing action was to paste text, the text is removed.

� If your last editing action was to type a character, the character is re-
moved.

� If Undo is grayed-out in the Edit menu, no changes can be undone.
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The Redo command reverses the action of the undo command. If you de-
leted a part of the text, and then decided to undo that deletion, the Redo
command will perform the original delete again.

���� �"''���

Use the Cut command under the Edit Menu to remove text from the NC
program (the text is copied to the Windows clipboard). The text can then
be pasted anywhere in the current program, into another program, or into an-
other application such as Notepad. The text remains in the Windows clip-
board until it is replaced by another Cut or Copy operation.

To cut text to the Clipboard:

�9 Select the text you wish to cut.

�9 Select Cut from the Edit Menu, or press Ctrl+X.

�",&� �"''���

Use the Copy command under the Edit Menu to duplicate selected text in
an NC program.

To copy text to the Clipboard:

�9 Select the text you wish to copy.

�9 Select Copy from the Edit Menu, or press Ctrl+C. The selected text
is copied to the Clipboard.

*����� �"''���

Use the Paste command to insert text from the Windows clipboard into
your NC program.

To paste text from the Clipboard:

�9 Place the cursor at the point in the NC program where you wish to insert
text that has been previously cut or copied to the Windows clipboard.

�9 Select Paste from the Edit menu, or press Ctrl+V. The contents of the
clipboard are inserted into the program. If this menu command is
grayed-out, there is no text on the clipboard to paste.
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Use the Clear command under the Edit Menu to delete selected text from
your NC program. The text is not copied to the Windows clipboard. You
can also use the Delete key on your keyboard to achieve the same effect.

To delete text using the Clear command:

�9 Select the text you wish to delete.

�9 Select the Clear command from the Edit Menu. The selected text is de-
leted.

+�%���� 3���� �"''���

Use the Delete Line command under the Edit Menu to delete an entire line
of NC code from a program without selecting it first.

To delete a program line using the Delete Line command:

�9 Place the cursor anywhere on the line of code you wish to delete.

�9 Select the Delete Line command from the Edit Menu, or press F2.
The line of code is deleted.

.���� �"''���

Use the Find command under the Edit Menu to locate a particular se-
quence of characters within an NC program.

To use the Find command:

�9 Select Find from the Edit Menu, or press Ctrl+F.

�9 Enter the character sequence you are looking for in the Find: box.

:9 Select the Match Case box to restrict the search to finding only those text
strings that match the case (upper or lower) of the text that you en-
tered.

�9 Select Up or Down from the Direction box to search through the text
before or after the cursor position, respectively.

;9 Click Find Next or press Alt+S to begin the search. Click Cancel or
press ESC to exit the Find dialog box without performing the search.

To find the same character string again, use the Find Next button.
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Use the Replace command under the Edit Menu to replace an existing
character string with a new character string.

To use the Replace command:

�9 Select Replace from the Edit Menu.

�9 Enter the existing character string in the Find What: box.

:9 Enter the new character string in the Replace With: box.

�9 If you select Match whole word only the program will only find and
replace text that matches your entry. When you select Match case, it
will find and replace those text strings that match the case (upper or
lower) of the text you entered.

;9 Select one of the buttons depending on how you wish to replace text.

� Find Next will find the next occurrence of the text.

� Replace will replace the selected text with the new text.

� Replace All will replace all occurrences of the text with the new
text.

� Close will close the dialog box.

�"�"� 3���� �"''���

Use the Goto Line command under the Edit Menu to move the cursor to a
specific line in the NC program. This
command is also available using the
Program Edit Window Pop-up Menu.

To use the Goto Line command:

�9 Select Goto Line from the Edit
Menu, or press Ctrl+G. The
Goto Line dialog box appears.

�9 Enter a line number in the Jump To Line box. The cursor moves to the
specified line. If the line number entered is larger than the number of
lines in the program, the cursor is moved to the end of the program.
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Use the Renumber command under the Edit Menu to alter the N codes in
your NC program.

The Renumber command can be
used to:

� Insert N codes in a program
that doesn’t have any.

� Remove N codes from a pro-
gram.

� Renumber the N codes in a pro-
gram.

� Insert, remove or ignore spaces between NC commands.

� Remove comments from the program.

!���������"���

To insert or renumber the N codes in your program:

�9 Select Renumber from the Edit Menu. The Renumber/Format Pro-
gram dialog box appears.

�9 Select Renumber N Codes or press Alt+N.

:9 Click on the Start N Code box (or press Alt+T), then enter the num-
ber of the first N code. The default starting block number is N1.

�9 Click on the Increment box (or press Alt+I), then enter the incre-
ment you wish to use.

For instance, if you wish to have each N code numbered in incre-
ments of 5, enter 5 in the Start N Code box and enter 5 in the Incre-
ment box. The N code sequence will then be: N5, N10, N15,
N20…and so on.

This option is useful if you are renumbering a portion of the program to
be inserted into another program. Using increments greater than 1 al-
lows you to insert additional numbered lines without having to re-
number the whole program.

;9 Select Do It, or press Alt+O, to execute the Renumbering options
you selected. Select Cancel, press Alt+C, or press Esc, to exit the
Renumber/Format Program dialog box without altering the NC pro-
gram.
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Although the Renumber command automatically changes P codes used
with (M99) codes, it does not renumber P codes used with M98 codes, nor
does it renumber O codes. Although O codes are not altered, the lines
which they occupy are counted. So, the very next N code is numbered as
though the O code has been renumbered, too.

For instance, N41X...
N42X…
O25G…
N44…

In this example, although the O code has not been renumbered, the line it
resides on has been counted. The N code on the following line reflects the
next number in the sequence.

!������"�� �'"/��#,����

To insert or remove spaces between the NC words in your program:

�9 Select Renumber from the Edit Menu. The Renumber/Format Pro-
gram dialog box appears.

�9 Choose a Spaces option.

����� Insert Spaces inserts a space between each NC word (to the left
of the comment code).

����� Remove Spaces removes any spaces between NC words (to the
left of the comment code).

����� Ignore Spaces ignores any spaces in the NC program.

:9 Select Do It, or press Alt+O, to execute the Spaces options you se-
lected. Select Cancel, press Alt+C, or press Esc, to exit the Renum-
ber/Format Program dialog box without altering the NC program.
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To remove comments from your program:

�9 Select Renumber from the Edit Menu. The Renumber/Format Pro-
gram dialog box appears.

�9 Select Remove Comments.

:9 Select Do It, or press Alt+O, to execute the Remove Comments com-
mand. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.

 �'"/�����"���

To remove the N codes from your program:

�9 Select Renumber from the Edit Menu. The Renumber/Format Pro-
gram dialog box appears.

�9 Select Remove N Codes or press Alt+R.

:9 Select Do It, or press Alt+O, to execute the Remove N Codes com-
mand. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.

3"�)� �"''���

Use the Lock command under the Edit Menu to prevent or allow changes to
your NC programs. If a check mark appears next to this command, the current
NC program is locked.

When an NC program is unlocked, it can be modified by the commands on
the Edit Menu. When an NC program is locked, the program cannot be
changed by any commands. By default, when you open a file it is auto-
matically locked to prevent accidental changes. You can change this de-
fault in the preferences dialog box.

If you have Multiple Program Edit windows open, each is individually locked
or unlocked. The state of the currently selected NC program, locked or un-
locked, can be easily checked by looking at the Lock Indicator on the Status
Bar.

To use the Lock command to lock or unlock your NC program, select
Lock from the Edit Menu, press Ctrl+L, or double-click the Lock Indica-
tor on the Status Bar.
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Use the Select Font command under the Edit Menu to change the font settings
for open NC programs. Font Settings are intended for viewing and printing
purposes only. They do not affect the NC program in any way and are not
stored within the program file. All open program windows use the same font
settings.

To use the Select Font command:

�9 Select the Select Font command from the Edit Menu.

�9 Select a font from the Font list.

:9 Select a font size from the Size list.

�9 Click OK to change the font, or click Cancel or press Esc to exit the
Font dialog box without changing the fonts.

@��(� ����

The View Menu commands control the display of windows and toolbars.

�"''���$ ����� �"$

Position Open or close the Machine Position Window.

Machine Info Open or close the Machine Info Window.

Jog Control Open or close the Jog Control Panel.

Operator Panel Open or close the Operator Panel.

Verify Window Open or close the Verify Window.

Toolbars Open or close the toolbars.

*"����"�� �"''���

Use the Position command on the View Menu to open or close the Posi-
tion Window.

To open or close the Position window, select Position from the View
Menu. A check mark appears next to the Position command when the Po-
sition Window is open.

�"��$�/"��)����%����������
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Use the Machine Info command on the View Menu to open or close the
Machine Info window.

To open or close the Machine Info window, select Machine Info from the
View Menu. A check mark appears next to the Machine Info command
when the Machine Info Window is open.

0"�� �"���"%� �"''���

Use the Jog Control command on the View Menu to open or close the Jog
Control Panel. You can also use the Jog Control button on the Standard
Toolbar.

To open or close the Jog Control window, select Jog Control from the
View Menu. A check mark appears next to the Jog Control command
when the Jog Control Panel is open.

1,����"�� *���%� �"''���

Use the Operator Panel command on the View Menu to open or close the
Operator Panel.

To open or close the Operator Panel, select Operator Panel from the
View Menu. A check mark appears next to the Operator Panel command
when the Operator Panel is open.

@���-&� ����"(� �"''���

Use the Verify Window command on the View Menu to open or close the
Verify Window.

To open or close the Verify Window, select Verify Window from the
View Menu. A check mark appears next to the Verify Window command
when the Verify Window is open.


""%4���� �"''���

Use the Toolbars command on the View Menu to show or hide the Toolbars.

To show or hide a toolbar:

�9 Select Toolbars from the View Menu. The list of available toolbars is
displayed. Toolbars that are visible have a check mark beside them.

�9 Select the toolbar that you wish to show or hide.
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The Program Menu commands allow you to Run, Verify, or Stop an NC
program.

�"''���$ ����� �"$

Run/Continue Start running or resume running the current NC
program.

Verify Verify the current NC program.

Estimate Runtime Estimate the runtime of the current NC program.

Pause Pause the currently running NC program.

Feedhold Stop movement of all axes.

Stop Immediately halt the currently running NC program.

 ��E�"������� �"''���

The Run/Continue command under the Program Menu runs the currently
selected NC program on the Machining Center. When you select Run/
Continue from the Program Menu, the Run Program dialog box appears, al-
lowing you to select the program, the start block, run settings, and verify set-
tings.

The Run Program dialog box allows you to select an NC program to run,
to set the line from which to begin running the program, and to access the
Run Settings and Verify Settings dialog boxes.

�9 Select an NC Program.

If you have more than one NC program open, use the Program drop-
down list, or press Alt+P, to select the program you wish to run.

�9 Select a starting line.

When you are running an NC program for the first time, it is wise to
start the program from the first line. When you start at a line other than
one, the control program parses through the program to the specified
start point. As it parses, it performs operations such as turning the
spindle on, but it will not execute a Dwell or Pause command, and it
will not move the tool.
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To specify a starting line, click on the Start at Line box, or press
Alt+L, and enter the line number.

:9 Set the Run Settings.

To bring up the Run Settings dialog box click on the Run Settings button,
or press Alt+U.

�9 Set the Verification Settings.

To bring up the Verify Settings dialog box click on the Verify Set-
tings button, or press Alt+E.

;9 Run the Program.

To start running the program, click on the Run Program button, or
press Alt+R. To cancel running the program, click on the Cancel but-
ton, or press Esc.

While a program is running, the Machine Info Window and the Message
Bar keep you informed by providing information on:

� The name of the NC program.

� Which block is currently being executed.

� How many blocks are in the program.

� Which tool is being used.

� The number of passes made.

� The tool diameter.

� The spindle speed.

� Operator messages such as which block paused the program or the er-
ror that caused the program to stop.

@���-&� �"''���

The Verify command allows you to view tool path verifications of your
NC part programs. When you select Verify from the Program Menu, the
Verify Program dialog box appears.
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This dialog box allows you to select a program to verify from a pull-down list
of currently open NC part programs. Prior to verifying the part program,
you may wish to alter the Run Settings, alter the Verification Settings, or
select a starting block in the program. The default starting block is line
one.

Begin the verification by pressing the Verify Program button. If the Verify
Window is not already open, it will open automatically.

Tool path verification is displayed in the Verify Window. The workpiece and
tool are displayed according to the choices you made in the Verify Set-
tings dialog box.

����'����  ����'�� �"''���

Use the Estimate Runtime command to calculate the approximate amount
of time BENCHMAN requires to machine your part, and the approximate
distance the machine travels while machining your part.

The Estimate Runtime command accounts for Dwell times and subpro-
grams when calculating estimated run time, but it can not account for
stops that have indefinite length of stop time. These program stops in-
clude:

� Pause (G05/M00)

� Chain (M20)

� Skip (G31)

� Wait for input high/low (G25/G26)

� Write to file (M22)

� Rerun (M47)

The Estimate Runtime command treats M47 Rewind codes as M2 End of
Program codes.

This command also verifies the syntax of your NC programs while calcu-
lating the estimated run time. If an error is found, the Estimate Run Time
command alerts you with a dialog box, and places the cursor near the er-
ror.
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Use the Pause command to pause a running NC program. Pause may also be
used during tool path verification. The pause is not immediate; it takes effect
after the current NC block has been executed.

To use the Pause command, select Pause from the Program Menu, or click
the Pause button on the Standard Toolbar.

You may jog the machine and operate outputs during a Pause. If you jog the
machine during a pause and don’t return to where the pause started, you will
be prompted with a dialog box. The software will force you to return to the
resume position before continuing.

To resume running a program after a Pause, press F5, click the Run button on
the Standard Toolbar or the Go button on the Message Bar, or press the Cycle
Start button on the machine.

.����"%�� �"''���

The Feedhold command is very similar to the Pause command. Use it to
pause a running NC program. The differences between a Pause and a
Feedhold are:

� A Feedhold pauses the NC program immediately; it does not wait until
the current block is executed.

� Feedhold does not work during tool path verification.

� You cannot jog the machine or operate outputs during a Feedhold.

To use the Feedhold command, select Feedhold from the Program menu.

To resume running a program after a Feedhold, press F5, click the Run but-
ton on the Standard Toolbar or the Go button on the Message Bar, or press
the Cycle Start button on the machine.

#�",� �"''���

You can use the Stop command under the Program Menu to halt a running NC
program. The machining center will immediately halt cutting.

To use the Stop command:

�9 Select Stop from the Program Menu, press Ctrl+Space, or click the Stop
(red) button on the Standard Toolbar. A message box appears.

�9 Clear the box by clicking OK or pressing Enter. You are automatically
returned to the Edit mode.

To restart a program after a Stop is performed through the Control Pro-
gram:

�9 Manually jog the tool so it is above the workpiece to avoid a tool crash.

�9 Select the Run/Continue command to restart the NC program. The pro-
gram will begin at the first line, unless otherwise specified.

�"��$�,���&�'��!����%�����
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The Tools Menu commands allow you to select tools, set up and use a tool
library, and configure, operate, and (if your machine is equipped with an
ATC), initialize the Automatic Tool Changer .

�"''���$ ����� �"$

Setup Library Define tools used with the machining center.

Setup Tool Wizard Aid in establishing tool lengths for use with mul-
tiple tool programs.

Select Tool Select a tool for use on the machining center.

Insert Tool from ... Automatically change tools using the Automatic
Tool Changer.

Configure ATC Assign particular tools for use with the Automatic
Tool Changer.

Operate ATC Control the draw bar and individual tool stations,
and monitor related inputs.

Initialize Station
Location ... Select a tool station for initialization to a specific

reference point.

#���,� 3�4���&� �"''���

Use the Setup Library command under the Tools Menu to assign param-
eters to multiple types of tools used on the machining center. When you
select the Setup Library command, the Setup Tool Library dialog box ap-
pears.
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You can create a new tool two ways:

� Use the Copy and Paste buttons to copy an existing tool in the Tool Library
box and paste it into the Tool Library box under an unassigned tool number.
Assigned tool numbers are displayed with a tool icon. Unassigned tool num-
bers have no tool icon.

� Manually create a tool using  the Setup Tool Library dialog box.

To create a new tool:

�9 Select an unassigned tool number from the Tool Library list.

�9 Select a tool type, such as End Mill, from the Tool Type drop-down menu.

:9 Enter a name for the tool in the Description field.

�9 Select a Station for the tool. Station numbers are provided for those sys-
tems that are equipped with an Automatic Tool Changer. If you do not
have an Automatic Tool Changer, select Station #1.

;9 Enter the number of teeth (Num Teeth) on the tool.

=9 Enter the Material Type from which the tool should be made.

>9 There is a secondary library for tool materials. You can use this library
to create new materials or edit existing materials. To do this, click on
the Edit Tool Materials button.

a) Enter a material Name.

b) Select a Material Class.

c) Enter a Multiplier. This should be set to “1” for now. This is used
when integrating with CAM for calculating feed rates and spindle
speeds when generating tool paths.

d) Click on the Add button.

e) Click on the Delete button to remove materials you no longer need.

f) Press Enter or click on OK to accept the new material. Click on
Cancel to exit the Tool Material Type dialog box without changing
the material library.

?9 Enter a tool Diameter.

B9 Enter a tool Height/Offset value. You may also click on the Current Z
button to establish the current Z axis position of the tool as the
Height/Offset.

�
9 Enter a Diameter Offset. The Diameter Offset is the amount of devia-
tion from the actual cutter diameter to the programmed cutter diameter.
This parameter is very important when using tool diameter cutter com-
pensation. For example, a 0.125” diameter end mill may be specified for
a job. When loading tools, the diameter of the end mill may actually
measure 0.1248”. The deviation in diameter is the Diameter Offset.
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��9 Apply the new parameters to the selected tool number by clicking the
Apply button.

��9 Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool li-
brary.

To alter an existing tool:

�9 Select an existing tool from the Tool Library list.

�9 Make the desired changes to the tool parameters, then click on the
Apply button.

:9 Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool li-
brary.

#���,� 
""%� ��H���� �"''���

Use the Setup Tool Wizard as an aid in establishing tool heights for use with
multiple tool programs. The Wizard can be used if you are manually chang-
ing tools, or if you are using an Automatic Tool Changer.

To use the Setup Tool Wizard:

�9 Select Setup Tool Wizard from the Tools Menu. This starts the Wiz-
ard.

�9 Follow the Wizard’s instructions carefully.

#�%���� 
""%� �"''���

Use the Select Tool command under the Tools Menu to select a tool for use
on the machining center.

To select a tool:

�9 Select the Select Tool command from the Tools Menu. The Select Tool
for Use dialog box appears.

�9 Select a tool from the drop-down Tool list. The tool parameters appear
in the window to the right of the list.

:9 Select an action to exit the dialog box:

� Click the Select Tool button if the tool is already in the spindle.

� Click Insert Tool to perform a tool change cycle. The machining
center moves to its tool change position (maximum Z axis height)
and you are prompted to insert a tool into the spindle. The machine
will remain in this position until another motion is programmed.

� Click Cancel to exit the Select Tool for Use dialog box without
selecting a tool.

�"��$�����#"��+���%#�/����&������
�3��������%"�����
���#��<��''���	�#"
���,/&������3�����"������������
���������#������#��#"��
'�����*�/"�
��%"����	���������#��5��	�	"�#�#���
�
����#"��
'��������3����������!��
'��!���*
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Use the Insert Tool From command under the Tools Menu to automatically
change tools using the Automatic Tool Changer. When you select the Insert
Tool From command, a fly-out menu appears. The menu contains a list of
the available tool stations, one through four. If you select Station 1,
BENCHMAN automatically inserts the tool located in Station #1 on the ATC.

If your BENCHMAN is not equipped with an Automatic Tool Changer, the
fly-out menu will be grayed out (the station commands are unavailable).

�"�-������ �
�� �"''���

The Configure ATC command under the Tools Menu allows you to select a
particular tool for use in a specific tool station on the Automatic Tool
Changer. You must use the Configure ATC dialog box to tell the software
which tools have been placed in each station. Each tool station has its own
list of tools. The tools are assigned to a particular station by using the Station
entry in the Tool Library dialog box.

To assign a tool to a station:

�9 Select the Setup Library command from the Tools Menu.

�9 Select the icon for the tool you wish to use from the Tool Library list.

:9 Using the Station pull-down list, select the station in which you intend
to place the tool.

�9 Select OK, or select Apply then assign other tools.

;9 Once you have exited the Tool Library dialog box, select Configure
ATC from the Tools Menu.

=9 Using the pull-down lists, select a tool for each station. Select the tool
that is actually in the station. If the station is empty and that station’s
tool is NOT the one in the spindle, select the empty-holder icon from
the list (the first one in the list).

>9 If one of the tools is currently in the spindle, select the In Use button
for that station.
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?9 Press Enter or click on OK to accept the new configuration, or click on Can-
cel to exit the Configure ATC dialog box without changing the configura-
tion.

1,������ �
�� �"''���

The Operate ATC command under the Tools Menu launches the Automatic
Tool Changer (ATC) Control screen.  The ATC Control screen allows you to
change the state of each tool station (raised or lowered) and the draw bar
(clamped or unclamped). It also allows you to raise, lower, extend, or retract the
tool platter.

The spindle’s rotational Home position can be set or tested, and the spindle can be
sent to Home at any time.  The Home position can be fine tuned for precise tool
fork engagement through the Spindle Setup feature.

When you are finished, select the Done button to exit the dialog box.

��#�L��3�����"������#��

�!������#���
#����#����
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The Setup Menu commands control the parameters for setting up tool po-
sitioning, jogging, running and verifying programs, coordinate systems,
tool offsets, etc.

�"''���$ ����� �"$

Set Position Establish the X, Y and Z position of the tool.

Zero Position Set the current tool position to X0, Y0, Z0.

Jog Settings Establish speed and distance parameters for jog-
ging the tool.

Run Settings Establish options for running an NC part program.

Verify Settings Establish options for verifying an NC part pro-
gram.

Verify Type Select centerline or solid view for tool path verifica-
tion.

Set/Check Home Establish or check a fixed known position on the
machine.

Goto Position Automatically move the tool to a specific set of
coordinates on the machining center.

Units Select Inch or Metric units of measure.

Coordinate Systems Define multiple coordinate systems or select a
new coordinate system.

Offsets Modify the table of offset values used for certain
NC codes.

Spindle Specify a spindle speed if you have not used an S
code in your NC program.

Backlash Define the amount of  backlash in the machining
center axes.

Soft Limits Establish software limits for each axis within the
machine coordinate system.

Preferences Establish defaults for saving files and security fea-
tures.
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Use the Set Position command under the Setup Menu to set new X, Y and
Z positions for the tool. This command establishes a Work Coordinate
System in relationship to the Machine Coordinate System. Setting the X,
Y and Z coordinates for the tool also defines the zero point of the coordinate
system for absolute motion. For more information on coordinate systems, see
page H-27.

This command is also available under the Position Window Pop-up Menu.

To set a new position:

�9 Move the tool to the desired position.

�9 Select Set Position from the
Setup Menu.

:9 Enter a new X position.

�9 Enter a new Y position.

;9 Enter a new Z position.

=9 Press Enter or click on OK.

The new position is displayed in the Position Window.

F��"� *"����"�� �"''���

Use the Zero Position command under the Setup Menu to reset the point
of origin (0,0,0) at any position on the machining center. Since the tool length
and the workpiece position on the cross slide may vary from one tooling
set up to another, the zero position must be initialized each time set up is
changed.

This command is also available under the Position Window Pop-up Menu.

To set the zero point:

�9 Move the tool to the point on the workpiece you intend to establish as
the zero point.

�9 Select Zero Position from the Setup Menu. The new position (0,0,0)
is displayed in the Position Window.

�"��$�/"�
�%�������
�#
�#"�
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To set jog parameters:

�9 Select Jog Settings from the Setup Menu.

�9 Enter the desired jog speeds and distances.

:9 Select OK or press Enter. The new values are applied to the Jog Control
Panel.

0"��#,���

The jog speed is the rate at which the tool moves along the X, Y, or Z
axes. Select the speed by pressing the appropriate button. The speed can
be Slow, Medium, or Fast.

Default Values for Speed:

� 2 ipm for Slow (52 mm/per minute)
� 30 ipm for Medium (780 mmpm)
� 100 ipm for Fast (2600 mmpm)

0"��+�������� C#��,�D

Distance values determine how far the tool moves each time a key is
pressed. Referred to as Steps, the distance is selected by pressing the A, B or
C buttons. The distance can be set at a low value (for instance 0.005 inch)
to move the tool for a precise cut, or at a higher value to position a tool.

Default Values for Steps:

� 0.001 inch (0.0254 mm) for Step A
� 0.01 inch (0.254mm) for Step B
� 0.1 inch (2.54mm) for Step C

0"�� #�������� �"''���

Use the Jog Settings command to enter speed and distance values for the
Jog Control Panel. This command is also available through the Jog Con-
trol Panel Pop-up Menu.
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Use the Run Settings dialog box to set or clear options for running your
NC program. The available options are:

� Single Step

� Optional Skip

� Optional Stop

� Enable Subprograms

� Arc Centers Incremental

� Treat Warnings as Errors

� Restore Unit Mode When Done

� Verify While Running

#���%�� #��,

This option inserts a Pause after each line of the NC program. To move on
to the next line in the program, you can:

� Click the Run button on the Standard Toolbar.

� Click the GO button on the Message Bar.

� Press F5.

� Press Enter.

� Select Run/Continue from the Program menu.

� Press the Cycle Start button.

1,��"��%� #)�,

Use this option to enable or disable the optional skip code. The optional
skip code allows you to skip blocks of code as the NC program is run.

Make sure to check off the Optional Skip box in the Run Settings dialog
box or activate the Optional Skip button on the Operator Panel. Then
place a forward slash ( / ) in front of each line in the NC program you
want to skip.

With Optional Skip off, each skip code is ignored and each block of code
is executed. With Optional Skip on, each skip code is recognized and each
block of code that has been tagged with a skip code is skipped.

To execute particular blocks every nth pass, place a number after the op-
tional skip. For example:  /5G28; Home every fifth pass
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This enables or disables the optional stop code (M01). The optional stop
code allows you to place an optional stop in your NC program. To activate
the optional stop, select the Optional Stop box in the Run Settings dialog
box, or select the Optional Stop button on the Operator Panel. Be sure you
have put an M01 code on the line where you would like to pause.

With the Optional Stop option on, the M01 works like an M00 or  G05.
With Optional Stop off, the M01 code is ignored, the other codes on the
line are executed as usual.

���4%�� #�4,�"���'�

Use this option to enable or disable the use of subprograms. With this option
disabled, M98 commands generate an error. Running or verifying a pro-
gram with subprograms enabled takes longer to start because the software
parses the entire file for subprogram information. This extra delay should
only be noticeable with large programs.

���� �������� !����'����%

Use this checkbox to specify the default mode for programming arc centers. If
this box is checked, the default mode is the Fanuc mode, in which arc centers
are always incremental. If this box isn’t checked, the default mode is EIA-
274, in which arc centers follow the general programming mode: Absolute
when the mode is absolute, and incremental when the mode is incremen-
tal.


��������������������"��

This command is used for special applications, where you don’t want any
unexpected pauses in the program execution. For example, a warning is dis-
played and the program pauses, waiting for your input before it continues.

When this item is selected, any warning will halt the program, performing
a Program Stop. When motion is stopped, all outputs are turned off.

 ���"���������"��������+"��

If you normally work in one unit mode (inch or metric) but would like to
run a program in another mode without disrupting your default settings,
select this box.

Select a specific unit mode by using one of the G20/G21 or G70/G71
commands at the beginning of your NC program. Once the NC program is
executed, your default unit mode will be restored.

For instance, if you normally work in Inch Mode, but have a particular
program you would like to run in Metric Mode, select the Restore Unit
Mode When Done box. Place a G21 code at the beginning of your pro-
gram, then run it. When the program is finished, the default for your sys-
tem will still be Inch Mode.

�"��$�/"���&�'��!�����#
��3�%��
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If this box is selected, the Verify window will display the program verifi-
cation while the program is running. The verification does not show ex-
actly what is happening on the machining center. There is a delay between
each tool motion. You will see each tool motion on the screen, but the
verification screen will pause  until the machine finishes the motion and
the next program block is read.

@���-&� #�������� �"''���

Use the Verify Settings command to open the Verify Setup dialog box.
This dialog box controls the appearance of the tool path verification. You
can also access this dialog box using the Verify Window Pop-up Menu.

The Verify Settings dialog box is tabbed, with the settings organized into
three  panels: View Panel, Stock Panel and Options Panel.
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The View panel allows you to control the view style and zoom factor. It
also offers a selection of preset views.

Style
Use these radio buttons to select between Solid and Centerline views of the
stock. Solid View is a solid three-dimensional view of the workpiece and
toolpath. Centerline View is a view that depicts the centerline of the
toolpath. Instead of a solid model, the workpiece is shown in wireframe.

Zoom
Use these buttons to control the size of the stock in the Verify Window.
You can click on the buttons or use Alt key combinations (Alt++, Alt+-, and
Alt+A). Each mouse click or key combination used zooms by an increment
of one.

����"� .�����"�

+ Zoom in on the stock.
- Zoom away from the stock.
All Fit the stock into the window.

Preset View
Use these buttons to select a perspective, then use the Preview Window to
fine-tune the angle:

����"� .�����"�

Front View the stock directly from the front. The stock
appears as a rectangle along the X, Z axes.

Top View the stock directly from above. The stock ap-
pears as a rectangle along the X, Y axes.

Isometric View the stock at an angle, in three dimensions.

#�"�)�*���%

All stock values are interpreted according to the Units Mode in effect at
the time they are set. To quickly see which Units Mode is currently in effect,
check the Position window.

Stock Dimensions
Use this area to set the dimensions of the stock used in the verification
process. You will see the stock in the Preview Window change as soon as
you enter a dimension.

Origin
Use this area to adjust the verification for different workpiece setups. Most
NC programs set the 0,0,0 point at the top of the front-left corner of the stock.
Occasionally, however, you may want to use a different origin (the center of
the stock, for example). In this case, you must enter that point to properly
verify your program. The values entered should correspond to the coordinates
for the front left corner of the stock relative to the 0,0,0 point for the program.
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For instance, if the origin for the program is the center of a 3x2x1 piece of
stock, set the origin to -1.5, -1.0.

Initial Tool Position
You can select a tool start point using Initial Tool Position. This parameter is
only used for verification, not for actually running a program. When Verifying
While Running, the actual tool position is used as the initial tool position.

1,��"��� *���%

The Verify Options control certain aspects of the solid and centerline
verification display.

Solid Options
Auto-refresh automatically refreshes the solid display of the workpiece
during verification. The screen is updated when something changes, such
as resizing the Verify Window, changing the view, or changing the stock
dimensions. When auto-refresh is disabled, you will need to manually
cause the verify window to update by selecting the Redraw command
from the Verify Window’s Pop-up Menu. This setting only affects refresh-
ing the window when no verification is in progress.

Centerline Options
Auto-refresh automatically refreshes the centerline display of the
workpiece when something changes during verification.

Show Tool controls whether or not the tool is displayed in the Verify Win-
dow.

Show Rapid Moves displays the rapid moves made between the end point of
one cut to the start point of another.


���*��/��(�����"(

The Preview Window appears in each of the above groups. The Preview
Window shows you approximately what the Verify Window will look
like. The Preview Window always depicts the stock in Centerline view.

In addition to depicting how the Verify Window will look, you can use the
preview box to change the orientation of the stock:

� Use the slider bars on the side of the Preview Window to rotate the
stock along the X, Y plane and along the Z plane. There are two ways
to control the sliders:

�9 Select the slider button by clicking on it with the mouse. Hold the
left mouse button down while sliding the button along the bar un-
til the stock is in the desired position.

�9 Select the slider button by tabbing to it. The button will blink to
indicate it is selected. Use the arrow keys on the keyboard to
move the slider button along the bar until the stock is in the de-
sired position.

�"��$��3�������
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� Use the mouse to rotate the stock in all planes simultaneously. “Grab”
the stock by clicking and holding it with the mouse. Move the stock
with the mouse until the stock is in the desired position.

����"��

The OK button at the bottom of the dialog box applies the changes you
have made and closes the dialog box.

The Cancel button closes the dialog box without applying any of the
changes you have made.

The Help button brings up this Help topic.

@���-&� 
&,�� �"''���

Verify Type allows you to choose between a solid view and a centerline
view in the Verify Window. Solid View is a solid three-dimensional view
of the workpiece and tool. Centerline View is a view that depicts the
centerline of the tool. Instead of a solid model of the tool, the workpiece is
shown in wireframe.

#��E����)� �"'�� �"''���

Use the Set/Check Home command under the Setup Menu to establish or
check a fixed known position on the machine. This command is also avail-
able through the Jog Control Panel Pop-Up Menu.

�"'�

This option moves the machining center’s spindle, cross slide and saddle
to the ends of travel along each axis and sets the Machine Coordinate Sys-
tem to X0, Y0, Z0.

I���)��"'�

This option is for homing when you have lost position slightly, or when
you start the machine at the beginning of the day and the machine hasn’t
moved. Using this option, the Control Program assumes that it is close to be-
ing homed (that it knows approximately what the machine position is). The
Control Program rapids the machine to a short distance from the limits be-
fore homing; this is much faster than feeding in at the normal rate. The
Quick-Home feature is particularly useful for homing the machine after hitting
a limit or after pressing the Emergency Stop while the machine is moving
at a high speed.

����)��"'�

This option checks the reference point, identical to using a G27 code. It com-
pares the reported position against zero to see if any position has been lost.



8
�� 7�3����%��2����L�+�%#����8

�"�"� *"����"�� �"''���

The Goto Position command opens the Goto Position dialog box. Use the
Goto Position dialog box to move the tool to a particular coordinate posi-
tion on the machining center.

This command is also available under the Position Window Pop-Up Menu
and Jog Control Panel Pop-up Menu. You can also double click on the Po-
sition Window.

To use the Goto Position command:

�9 Enter the coordinates for the new
tool position.

�9 Enter the feed rate at which you
would like the tool to travel.

:9 Click on the Go button. The tool
moves to the new position at the
defined feed rate.

������ �"''���

Use the Units command under the Setup Menu to select the unit of mea-
sure for the application. When you select the Units command, a fly-out menu
appears allowing you the option of using Inch (standard) or Metric measure-
ment.

�""�������� #&���'�� �"''���

Use the Coordinate Systems command under the Setup Menu to define mul-
tiple coordinate systems for machining more than one workpiece. This is
often done for production runs of the same part.  This command is also
available under the Position Window Pop-up Menu. For an overview of
coordinate systems, see page H-27.

To select an existing coordinate system:

�9 Select Coordinate Systems from the Setup Menu.

�9 Select an existing coordinate system from the fly-out menu. The coordi-
nate systems available, CS1 through CS6, are equivalent to using the
codes G54 through G59 in your NC program.

:9 Or select the Work Coordinates command to cancel the Coordinate Sys-
tem offsets and return to Work Coordinates.

To define a coordinate system:

�9 Select Coordinate Systems from the Setup Menu.

�9 Select Setup from the fly-out menu.

�"��$��3�����	�������5��#"��#����#�
#�������#�#"��7�'���3������#���%��%5���
#"���"� �,�����##�����
#���*
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:9 Select a coordinate system, then enter and apply the offsets.

a) Select a CS from the System box.

The system titled “Work CS” contains the current values for the
work coordinate system. This is like adding a G92 code to your NC
program. You can change the default for the work coordinate system
by entering new values in the Offsets boxes. These values are offset
from the true origin of a coordinate system and affect all coordinate
systems.

b) Select the offsets for the user-coordinate system using one of the
following methods:

� Entering X, Y and Z offset values in the Offsets boxes.

� Clicking the Current Pos button to establish offset values
based on the current tool position.

� Selecting a Marker in the Preview Area for the coordinate sys-
tem and dragging it to the desired position.

� Copying offsets from one CS to another using the Copy Offsets
and Paste Offsets buttons.

c) Make the currently selected CS the active CS by selecting the Make
Active button.

d) Apply the coordinates or exit the dialog box:

� The OK button applies the changes you have made and closes
the dialog box.

� The Cancel button closes the dialog box without applying any
of the changes you have made since clicking the Apply button.

� The Apply button applies the changes you have made and
leaves the dialog box open in case you wish to make more
changes (you can still cancel changes once they have been ap-
plied by selecting the Cancel button).

!�*1 
��
� �1
�$

$�%"����%�������#�
������
#����
"��
���(����!�#"��
�
#���#���
#����
"��
'���#��3����!����#�#"�����
��3�#�����
���#"��$�%"����!�&��#��*�?�%�
�
#����
"����#"�
��%�������#�

�������3�4��*�8�%"�#��������#������
#"����%"����!�%��#��������
"�����+�#
(�������#"��+�#�'�$���*�$�
#
��%"�����'���#���
�	������<�����#"�
*

���5�%�������#�
�������33����#*
�"��������
��#"��+�#���
�#���
%�������#��
�#���'���#��3����!�����
#"��	��5'��%������������%#�����
��#����!���'�
�#����#"�#��
��33
�#
3����#"��3�4�����%"����'�
�#���*�/"�

����#"��!��%%��
�	"��������
���
2�0�%���*

���5�&�������#�
�������#�3�4��Q�#"��
%�������
#����
"������	"�������#"�

�
#�������
��!���#"���#"��+�#
��
�#����%����������#"��2�0�%���*

��#"���#"�����5�&�������#�
�����%��

�#�
�'���#��%�������#��
�
#��

�
��!�#"��%���
�2=��#"���!"�2=�����
#"��+�#�'�&�������#��+�
#��
������!
��4*

�3�������
�#�#"�����5�&�������#�

��#"���	�#"���2�0�%����������#"�
�����!���4��#"��2=�
2=��&�������#�
+�
#����33
�#
�	����%"��!�
�%%�����!��*

�3�����(����#"����%"����	"���
�
��!�&�������#��
�
#��
��#"���33
�#

	������#�����33�%#��*



8
�> 7�3����%��2����L�+�%#����8

To enter a compensation offset:

�9 Select Offsets from the Setup Menu.

�9 Click on an Offset Number (the numbers 1 through 199 are available).
This number only acts as a designation (a name) for the offset.

:9 Enter an Offset Value in the Value box, or select the Current Z but-
ton to use the current Z position (this is useful for defining tool
heights if you are using G43 or G44 to specify tool heights).

�9 Press Enter or click on OK. The Offset Value has been associated
with the Offset Number. The next time you open the Offsets Table,
you will see the new offset.


���1--����
�4%�

The Offset Table stores up to 200 values which are used in several opera-
tions including tool offset adjustment, cutter compensation, and tool
length compensation to ensure uniform application of an offset value. The
numbers are stored as unit-less values; their interpretation depends on the
Units currently in effect.

Set the values in the Offset Table using the Offsets command under the Setup
Menu. The Offsets are stored in the Bench4k.ini file when running with a
machine, and in TESTCTL.INI when running in simulation mode.

1--����� �"''���

Use the Offsets command under the Setup Menu to modify the table of Offset
Values used for certain NC codes. These offsets are typically used to compen-
sate for variations in the cutting tools being used. The offset values are used
for tool length offset, cutter compensation, and tool offset adjustment NC
codes.
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#,���%�� �"''���

Use the Spindle command under the Setup Menu to specify a spindle
speed if you have not used an S code in your NC program.

To specify a spindle speed:

�9 Select the Spindle command from the Setup Menu. The Spindle Setup
dialog box appears.

�9 Select a spindle speed by entering a value in the RPM box, or by using
the slider and arrow buttons.

Also in this dialog box:

� Reset the spindle override value to 100% by clicking on the Reset
Override to 100% button.

� Change the On/Off state of the spindle using the On and Off buttons
in the Spindle State area.

� Reverse spindle direction by selecting the Reverse Direction box.

� Disable spindle operation by selecting the Disable option. This is use-
ful if you have a device mounted in the spindle that should not be ro-
tated, such as a wired probe.

� Select Done to close the dialog box.



8
�� 7�3����%��2����L�+�%#����8

���)%���� �"''���

Use the Backlash command under the Setup Menu to define the amount of
distance that is lost when reversing direction. The system default is set at
a backlash value of 0.0 on all three axes, with a feed rate of 10 ipm.

To establish new backlash param-
eters:

�9 Select Backlash from the Setup
Menu.

�9 Enter the desired backlash
distances and feed rate.

:9 Press Enter or click on OK to ac-
cept
the new backlash parameters, or
click on Cancel to exit the Setup
Backlash dialog box without setting  new backlash parameters.

#"-�� 3�'���� �"''���

Use the Soft Limits command under the Setup Menu to establish software
limits for each axis. The limits are different than the fixed hardware limits
on the machining center. Soft limits can confine the tool travel to an area
smaller than the normal maximum travel.

The machining center shuts down if it trips a soft limit, just as it does
when it trips one of the limit switches. This is helpful when working with
devices such as robots, or when you have installed fixtures within the nor-
mal work area that you don’t want the tool to hit.

To establish software limits on the machining center:

�9 Select Soft Limits from the Setup Menu.

�9 Enter the coordinates, relative
to the Home position, that de-
fine the software perimeter
you wish to establish.

:9 Click on the Enable Soft Lim-
its option to enable soft limits.
Use this option to turn soft lim-
its on or off as you need to use
them.

�9 Press Enter or click on OK to
accept the new soft limit parameters, or click on Cancel to exit the
Setup Soft Limits dialog box without setting new soft limit param-
eters.

�$�?7/,�/6
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�"���"%� *��-�������

The Control Preferences allow you to control some of the machine mo-
tions. If you want the feed rate override setting to affect the speed of rapid
moves, select the checkbox on this panel.  Forcing the machine to use Safe
Rapid Moves means moving the spindle away from the workpiece before
executing any rapid moves.

����"�� *��-�������

The Editor Preferences allow you to automatically save your NC program
files at regular intervals, and establish a default directory in which to store
your files. When you select the Editor tab in the Preferences dialog box,
the Editor panel appears.

The Hilite Comments box will highlight comments in the NC program in
a different color.

The Quick Run/Verify by Default box suppresses the messages and dia-
log boxes that appear asking for the file name and starting line when you
run a program.

To select AutoSave features:

� Select Save when idle and enter a value in the Every:___ minutes
box to save your NC programs automatically at the specified time in-
crement.

*��-�������� �"''���

Use the Preferences command under the Setup Menu to establish defaults
for saving files and setting security features.

To alter the system preferences:

�9 Select the Preferences command from the Setup Menu.

�9 Select the Control, Editor, or Security preferences tab.
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� Select Save Before Running to save changes to your NC program
prior to running it for the first time with the changes.

� Select Prompt Before AutoSaving if you wish to be prompted by the
Control Program before it automatically saves the NC program at the
specified time increment.

To select File Default features:

� Enter an Extension for your NC part program files. The default is “NC.”

� Select Lock Files When Opened to have your NC programs locked by
default. Deselect this feature to have your NC programs unlocked by de-
fault.

� Select the Set button to specify a target directory in which to save
your NC program files. The default directory appears in the Directory
box.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click
on Cancel to exit the Preferences dialog box without setting new Edi-
tor or Security Preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.

#������&� *��-�������

The Security Preferences allow you to control which features others may
use. When you select the Security tab in the Preferences dialog box, the
Security panel appears.

The Security Preferences panel offers two modes, User and Administra-
tor. Administrator Mode allows a supervisor, such as a teacher in a class-
room, to turn commands on or off using the Allowed Commands list.
User Mode does not have access to this feature.

To secure the software using Administrator Mode:

�9 Set the Default Mode to User. (Note that this will not change the
current mode.)

�9 Use the Change Password button to create a password. The default
password is blank (no password).

:9 Select the Allowed Commands. Double-click on the listed com-
mands to enable or disable them. If the commands are enabled, they
are marked with an X. A description of each selected command is dis-
played on the right side of the panel.

�9 Use the Change Mode button to change to User Mode.

;9 Select OK or press Enter to exit the Preferences dialog box.
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The software is now running in User Mode. The next time you open the
Preferences dialog box, the Security preference panel is displayed in User
Mode. In this mode it is not possible to turn commands on or off.

To return to Administrator Mode:

�9 Use the Change Mode button to toggle the Mode from User to Ad-
ministrator. A dialog box appears, prompting you to enter your pass-
word.

�9 Enter your password and press Enter or click on OK.

To change your password:

�9 Click on the Change Password button.

�9 Enter your current password.

:9 Enter the new password.

�9 Enter the new password again to verify that it is correct.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click
on Cancel to exit the Preferences dialog box without setting new Edi-
tor or Security Preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.

����"(� ����

The Window Menu commands allow you to manipulate the arrangement
of the Program Edit Windows.

�"''���$ ����� �"$

Cascade Layer the open edit windows.

Tile Tile the open edit windows.

Arrange Icons Arrange any minimized edit windows along the
bottom of the edit area.

Window List Display and select from the currently open NC pro-
grams by their file names.

�������� �"''���

Similar to the standard Windows/Cascade command. Places the open Pro-
gram Edit Windows in a layered format, cascading down to the right with
the currently selected window on top.
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�%�� �"''���

Similar to the standard Windows/Tile command. Places the open Program
Edit Windows in a tiled format, filling the Edit Area from top to bottom.

�������� !�"��� �"''���

When you minimize a Program Edit Window, it becomes a small icon. The
Arrange command under the Window Menu arranges these icons along the
bottom of the edit area.

����"(� 3���� �"''���

Lists the currently open Program Edit Windows. The currently selected window
is designated with a check mark. You may select any window by clicking
on the window itself, or by selecting the window name from this list.

��%,� ����

The Help Menu commands allow you to navigate through the Help files, to
save or restore parameters set throughout the current session, and provides
handy tips and other information about the Control Program.

�"''���$ ����� �"$

Help Display Help for the current task or command.

Index List Help topics.

Using Help Display instructions about how to use Help.

Save Settings Save the current machine and application settings.

Restore Settings Reset machine and application settings from defaults.

Tip of the Day Display a Tip of the Day.

About Benchman Display program information, version number and
copyrights.

��%,� �"''���

Use the Help command to access the Help contents. You can also press the
F1 key to get information about the currently highlighted command on a
drop-down or pop-up menu.

!���5� �"''���

Use the Help Index command to access an index of available Help topics.

��#�L��"���������
�#���%"���
��3���#
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������ ��%,� �"''���

Use the Using Help command to obtain information on using the Help utility.

#�/�� #�������� �"''���

The Save Settings command allows you to retain current library, security,
screen and control settings as defaults.

� Click on a particular setting(s) to tag it, then click on the Save button to
save the selected items and exit the dialog box.

� Click on the Save All button to save all settings without having to se-
lect each one.

� Click on the Cancel button to exit the Save Defaults dialog box without
changing the existing defaults.

 ���"��� #�������� �"''���

The Restore Settings command allows you to restore all or some of the cur-
rent settings to the defaults you set using the Save Settings command (User
Defaults) or to the factory set defaults.

� Click on a particular setting(s) to tag it, then click on a Restore From
option. Click the Restore button to restore the selected items and exit
the dialog box.

� Click on the Restore All button to restore all settings without having to
select each one.

� Click on the Cancel button to exit the Restore Defaults dialog box without
changing the existing defaults.


�,� "-� ����+�&� �"''���

This command brings up information about the operation of the machining
center, tips & tricks for using the Control Program, and NC programming ideas.

�4"��� ��������� 999� �"''���

This command brings up the BENCHMAN information box. Included is in-
formation on the Control Program version number, the release date, and
copyright information.

The Details box allows you to see what options have been installed, and the
software and firmware versions.
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#�%������� �"''����
There are a few different ways to select commands in the Control Pro-
gram. Use the method that is most convenient for you.

#�%���� �� �"''���������� *",��,������

Clicking the right mouse button on certain windows or panels brings up a
pop-up menu. Each pop-up menu is context-sensitive. Commands which
cannot be performed at that time are grayed out.

To select a pop-up menu command:

�9 Position the cursor on the window or panel.

�9 Click the right mouse button. The context-sensitive menu appears.

:9 Select a command by moving the pointer over it and clicking the left
mouse button.

The following windows have pop-up menus:

� Program Edit Window

� Position Window

� Verify Window

� Jog Control Panel

The Machine Info Window and Operator Panel only provide the Dockable
and Hide commands on their Pop-up menus.

*�"���'� ����� ����"(� *",��,� ����

The Program Edit Window Pop-Up Menu contains different combinations
of these commands, depending on whether the file is locked, is being run
or verified, and if text is selected.

���� �"''���

Cut is the same as selecting the Cut command from the Edit Menu.

�",&� �"''���

Copy is the same as selecting the Copy command from the Edit Menu.

*����� �"''���

Paste is the same as selecting the Paste command from the Edit Menu.
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�%���� �"''���

Cut is the same as selecting the Cut command from the Edit Menu.

�/�%����� #�%����"�

This command evaluates the selected text (expression) and replaces it with
the result (e.g. selecting 3/4 and evaluating it replaces 3/4 with .75). You
can use parentheses, normal operations (+.-.*,/), modulus (%), power (^),
trig functions (cos, sin, tan, acos, atan, asin) and SQRT.

To use the Evaluate Selection command, the program must be unlocked,
and a single line selected.

�"�"�3�����"''���

Goto Line is the same as selecting the Goto Line command from the Edit
Menu.

 ���'4��� �"''���

The Renumber command is the same as selecting Renumber from the Edit
Menu. A dialog box appears that allows you to alter the N codes in the NC
program.

#�/�� �"''���

Saves the current program.

I���) ��� �"''���

The QuickRun command is a shortcut that runs the currently selected NC
part program. When you click on this command, the program behaves as
though you had selected the Run/Continue Command from the Program
Menu with the following exceptions:

� You do not have the option of selecting a starting line.

� You do not have the option of changing any settings.

I���)@���-&� �"''���

The QuickVerify command is a shortcut that verifies the currently se-
lected NC part program. When you click on this command, the program be-
haves as though you had selected the Verify Command from the Program
Menu with the following exceptions:

� You do not have the option of selecting a starting line.

� You do not have the option of changing any settings.

����'����  ����'�

This command performs the same function as the Estimate Runtime com-
mand under the Program Menu.



8
=> 7�3����%��2����L�+�%#����8

*"����"�� ����"(� *",��,� ����

The Position Window Pop-Up Menu  contains these commands:

!���� �"''���

Automatically switches the units of  measure to inches.

������� �"''���

Automatically switches the units of measure for the application to metric units.

�""�������� #&���'�� �"''���

Produces a fly-out menu that allows you to set up and select coordinate sys-
tems.

#���*"����"���"''���

Opens the Set Position dialog box.

F��"�*"����"�� �"''���

Sets the current tool position to zero on all axes.

�"�"� �"''���

Opens the Goto Position dialog box.

+"�)�4%�� �"''���

The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more in-
formation. This command is available on all pop-up menus for the windows
and panels available under the View Menu.

����� �"''���

The Hide command closes the window. To open the window again, select it
from the View Menu. This command is available on all pop-up menus for
the windows and panels available under the View Menu.

@���-&� ����"(� *",��,� ����

The Verify Window Pop-Up Menu contains these
commands:

#"%��� �"''���

Switches the verification to a solid view.

������%���� �"''���

Switches the verification to a centerline view.

#���,999

Opens the Verify Setup dialog box.
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 ����(� �"''���

This command repeats the most recent tool path verification simulation.

#�",� ����(��"''���

This command will interrupt a redraw currently in progress.

 ����� �"''���

This command resets the Verify Window; it clears the tool path lines and re-
sets the tool to the starting position.

+"�)�4%�� �"''���

The Dockable command toggles the window between being a dockable
window and being undockable. See Docking and Floating Windows for
more information. This command is available on all pop-up menus for the
windows and panels available under the View Menu.

����� �"''���

The Hide command closes the window. To open the window again, select
it from the View Menu. This command is available on all pop-up menus
for the windows and panels available under the View Menu.

0"�� �"���"%� *���%� *",��,� ����

The Jog Control Panel Pop-Up Menu contains these commands:

#���,� �"''���

This command opens the Jog Settings dialog box.

�"�"� �"''���

This command opens the Goto Position dialog box.

#��E����)��"'���"''���

This command opens Machine Home/Reference Point dialog box.

+"�)�4%�� �"''���

The Dockable command toggles the window between being a dockable
window and being undockable. See Docking and Floating Windows for
more information. This command is available on all pop-up menus for the
windows and panels available under the View Menu.

����� �"''���

The Hide command closes the window. To open the window again, select
it from the View Menu. This command is available on all pop-up menus
for the windows and panels available under the View Menu.
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#�%���� ���"''�����������"��2�&�

Some menu commands have one or more key designations listed next to
them on the menus; these are the hot keys for that command. Pressing the
hot key(s) selects the corresponding command.

To select a command using hot keys:

Press the hot key for the desired command. For example, press Ctrl+S to
save your file. Here’s a list of the available hot keys:

2�&C�D$ ����E�"''���$

Ctrl+C Edit Menu/Copy

Ctrl+F Edit Menu/Find

Ctrl+G Edit Menu/Goto Line

Ctrl+H Setup Menu/Set/Check Home

Ctrl+L Edit Menu/Lock

Ctrl+N File Menu/New

Ctrl+O File Menu/Open

Ctrl+P File Menu/Print

Ctrl+R Setup Menu/Run Settings

Ctrl+S File Menu/Save

Ctrl+Space Program Menu/Stop

Ctrl+T Tools Menu/Setup Library

Ctrl+V Edit Menu/Paste

Ctrl+X Edit Menu/Cut

Ctrl+Y Edit Menu/Redo

Ctrl+Z Edit Menu/Undo

Ctrl+Shift+Z Setup Menu/Zero Position

Ctrl+Shift+E Evaluate Selection

F1 Help Menu/Help

F2 Edit Menu/Delete Line

F5 Program Menu/Run/Continue

F6 Program Menu/Verify

F8 Setup Menu/Goto Position

Ctrl+KeyPad+ Increase Feed rate Override
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Ctrl+KeyPad- Decrease Feed rate Override

Ctrl+Backspace Edit Menu/Undo

Shift+Delete Edit Menu/Cut

Shift+F1 Context Help

F4 Activate Jog Control

Ctrl+F5 QuickRun

Ctrl+F6 QuickVerify

Ctrl+TAB Next Edit Window

Ctrl+Insert Edit Menu/Copy

Shift+Insert Edit Menu/Paste

Pause Pause

#�%���� �� �"''���������� 
""%4���

The Toolbars contain buttons that correspond to frequently used menu
commands. Clicking a button on a toolbar is equivalent to selecting the
same command from a menu, and is usually quicker. The BENCHMAN
XT Control Program provides Standard, ATC, Input, and Output toolbars.
Use the commands under the View Menu to control whether each toolbar
is displayed or hidden.
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*"����"����� #������ �"',"�����
The Control Program interface is easily configured and optimized by open-
ing, closing, resizing, and repositioning the screen components.

*"����"����� 
""%4���

You can reposition any of the toolbars (Standard, Inputs, Outputs or ATC
Control) simply by dragging them off their docking areas. Once away from
the docking area, the toolbar becomes a floating window, which can be moved
and closed like any other window. To move the toolbar, click on the toolbar
background (the area around the buttons) and drag.

*"����"����� ����"(�� ���� *���%�

The windows and panels (Position Window, Machine Info Window, Verify
Window, Jog Control Panel, and Operator Panel) are initially docked on the
docking area on the right side of the screen. If these items are moved away
from the docking area, they become floating windows or panels until they are
moved back to the docking area.

The Verify window is initially not dockable.

To move a window or panel (create a floating window):

�9 Press the Ctrl key.

�9 Click on the information area with the left mouse button.

:9 Hold and drag the area off the docking area.

�9 Release the Ctrl key.

;9 When the floating window is over its new location, release the mouse button.
You can move and close the window  as you would any other window.

To return a floating window to its docking area (the window must be
dockable):

�9 Click on the title bar of the floating window.

�9 Drag the area back to the docking area.

:9 Release the mouse button.

For more information about Dockable and Undockable windows, see page E-
62.
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Program Edit Windows can be moved, resized or closed just like any other
window. The only restriction is that the Edit Windows can not be moved
out of the edit area. For instance, you can not move an Edit Window to a
docking area.

#�/���� ��������"(� *"����"��

After arranging the application’s windows on the screen, you can save
their positions. Use the Save Settings command on the Help menu to save
the window positions (and any other selected items). To restore your
saved window positions, or to restore the default window positions (the
factory preset positions), use the Restore Settings command on the Help
menu.

The Control Program automatically stores the current window positions when
you exit the software, and automatically restores them the next time you run it.
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Windows and Toolbars can behave in two ways; they can be placed in a
stationary state, docked, or they can be in a free-floating state, and move-
able.

+"�)��� #������ �"',"�����

A docked screen component is fixed in place, unlike a floating component
which can be placed anywhere on the screen. When a screen component is
docked, the window frame and title disappear.

.%"������ #������ �"',"�����

A floating screen component can be moved to any position on the Control
Program screen, unlike a docked screen component, which is fixed in
place. When a screen component is floating it has a window frame and
title.

To select the Docking/Floating state of a toolbar:

� Click on the background area of the toolbar and drag it away to float
it.

� Click on the background, or the title bar of the toolbar and drag it to the
docking area to dock it.

To select the Docking/Floating state of a window:

�9 Position the mouse pointer over the window you would like to dock/float.

�9 Click the right mouse button.

:9 Select Dockable from the drop-down menu.

When the Dockable command is checked, the window can be dragged to a
docking area and docked. It can also be kept floating by moving it away
from the docking areas and keeping the Ctrl key pressed. Dockable win-
dows can not be resized.

When the Dockable command is not checked, the window will float and
can not be docked. Floating windows can be resized.
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The Offset Table stores 200 values which are used in several operations in-
cluding tool offset adjustment, cutter compensation, and tool length compen-
sation to ensure uniform application of an offset value. The numbers are
stored as unit-less values; their interpretation depends on the Unit mode cur-
rently in effect. Offset zero is always 0.0 and cannot be modified. Using Off-
set zero for most compensations cancels that compensation.

Set the values in the Offset Table using the Offsets command under the
Setup Menu. The Offsets are stored separately for the machine, and for
Simulation Mode.

�"�)���� ��� #�'�%���"�� �"��
Simulation mode is provided to allow the Control Program to be used when
your computer is not connected to a BXT-4021 Machining Center. This is pri-
marily to support the off-line development of NC programs.

NC program verification and running is supported in Simulation Mode.
Programs will run in approximately the same amount of time that they
would if a machine were attached (excluding stops that have indefinite
length of stop time, see Estimate Runtime).

The principal difference between Simulation Mode and Normal Mode is,
since no machine is available to send and receive data, there are no Inputs
and Outputs. The Inputs and Outputs buttons on the toolbars have no affect.
If your program contains commands to wait for certain input values that
are not the default, the events will never occur. If the values are the de-
fault, the wait will occur immediately.
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The Setup Program allows you to select a number of  program and hard-
ware defaults, as well as configure the options installed on the machine.
To access the Setup Program, you must exit the Control Program. Then
select the Start Menu> Programs> BENCHMAN> Setup. The program
will start and you will see the Welcome screen. You may choose from the
file tabs to view the defaults for each category.

The Setup Program provides defaults under the following categories:

� Welcome

� General

� Options

� Interface Card

��%�"'�� *���%

This panel provides one option, Units Default. This option sets the default
unit of measure (Inch or Metric) for the Control Program and the Setup Pro-
gram. When running the Control Software, you can change the default us-
ing the Units command under the Setup Menu.
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This panel allows to you alter several software defaults.

����� Run Offline starts the Control Program in Simulate Mode without
checking for a machine connection.

����� Decimal Places for Inch Values controls the display of values in dia-
log boxes. When in Metric mode, the software displays 1 less than the
specified number of decimal places.

����� Tool Shaft Height controls the tool shaft length in the Preview Win-
dow (in the Verify Settings dialog box) and the Verify Window. The
control software uses this value to insure that the tool with the small-
est length offset is verified with a length at least as large as this value.

����� NC Programming Settings controls several programming options:

The maximum number of subprograms.

The maximum depth of subprograms; the number of nested subprograms.

The maximum arc radii deviation; the allowable difference be-
tween the two radii, r1 and r2, of an arc before being considered
an error.

The default L-factor; the angle at which a line segment approxi-
mates a portion of an arc.

The default feed rate; the initial feed rate when running or verify-
ing an NC program; used until a  feed rate is specified in the NC pro-
gram.
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The Options Panel allows you to match your software settings to the hard-
ware configuration of your machine.

In the Installed Options list, select the options you want to enable or dis-
able by checking/unchecking  the box next to the option. If there are more
settings for a particular option, they will be listed to the right.

If the option you want to install is not shown, select the Reinstall button at
the bottom of the panel. This displays a list of the available options. Select
the desired option by placing a check in the box and choosing reinstall.

You can choose to remove or reinstall options by selecting the buttons at
the bottom of the window, or restore the default settings for that option.
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This panel allows you to change the Interface Card Address. Once you
have installed the Interface Card and software, and performed the initial
setup, this address should not change. However, if the Control Program
does not recognize the motion control card,  you probably have an address
conflict and need to reset this address. For complete instructions for in-
stalling the interface card and setting the interrupt address, see Section A:
Installation.
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Part programs generally incorporate two types of instructions: those which
define the tool path (such as X, Y and Z axis coordinates), and those
which specify machine operations (such as turning the spindle on or off).
Each instruction is coded in a form the computer can understand.

An NC program is composed of blocks (lines) of code. The maximum num-
ber of blocks per program is limited by the memory (RAM) on your com-
puter. You can, if necessary, chain programs together to form very large part
programs.

Each block contains a string of words. An NC word is a code made up of
an alphabetic character (called an address character) and a number
(called a parameter). There are many categories of address characters
used in NC part programs for the machining center (see Categories of NC
Code).

Each block of NC code specifies the movement of the cutting tool on the
machining center and a variety of conditions that support it. For example,
a block of NC code might read:

N0G90G01X.5Y1.5Z0F1

If the machine is currently set for inch units, the individual words in this
block translate as:

N0 This is the block sequence number for the program. Block 0 is the
first block in the program.

G90 This indicates absolute coordinates are used to define tool posi-
tion.

G01 This specifies linear interpolation.

X.5 This specifies the X axis destination position as 0.5".

Y1.5 This specifies the Y axis destination position as 1.5".

Z0 This specifies the Z axis destination position as 0". The cutting
tool will move to the absolute coordinate position (0.5,1.5,0).

F1 This specifies a feed rate of 1 inch per minute, the speed at which
the tool will advance to the specified coordinate points.
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There are many categories of NC code used for programming. The following
is a list of the NC codes (designated by the address character) supported by
the  BENCHMAN XT.

Code: Function:

%  Incremental Arc Centers (Fanuc).
$  Absolute Arc Centers (LMC).
\ Skip.
/ Optional skip.
D Compensation offset value.
F Feed rate in inches per minute; with G04, the number of seconds

to dwell.
G Preparatory codes.
H Input selection number; Tool length offset.
I Arc center, X axis dimension (circular interpolation).
J Arc center, Y axis dimension (circular interpolation).
K Arc center, Z axis dimension (circular interpolation).
L Loop counter; Program cycle (repeat) counter for blocks and

subprograms; Specify homing tolerance.
M Miscellaneous codes.
N Block number (user reference only).
O Subprogram starting block number.
P Subprogram reference number (with M98); Uniform scale multi-

plier (with G51).
Q Peck depth for pecking canned cycle.
R Arc radius for circular interpolation (with G02 or G03); Starting

reference point for peck drilling (with canned cycle codes).
S Spindle speed.
T Tool specification.
U Incremental X motion dimension for absolute dimensioning.
V Incremental Y motion dimension for absolute dimensioning.
W Incremental Z motion dimension for absolute dimensioning.
X X axis motion coordinate.
Y Y axis motion coordinate.
Z Z axis motion coordinate.
; Comments.
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The incremental arc center code selects the Fanuc mode for programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the Fanuc mode, arc centers are always incremental, regardless of whether the
system is in G90 (absolute) or G91 (incremental) mode. In contrast, arc center
specifications in EIA-274 mode follow the selected programming mode, abso-
lute or incremental.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.

�4�"%���� ���� �������� CKD

The absolute arc center code selects the EIA-274 mode of programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the EIA-274 mode, the mode of programming arc centers follows the selected
programming mode; absolute (G90) or incremental (G91). In contrast, arc center
specifications in Fanuc mode are always incremental, regardless of whether the
whether the system is in absolute or incremental mode.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.

#)�,� CLD�����1,��"��%�#)�,� CED

The Skip and Optional Skip codes allow you to skip particular lines of code in
your program.

To use the Skip code (\):

Place the code at the beginning of the line you wish to skip. When you run the
NC program, the specified line will be skipped.

To use the Skip code (\) with a parameter:

Use the Skip code with a parameter to instruct the Control Program to execute
the line of code every nth pass. Place the code at the beginning of the line you
wish to skip.
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The syntax is: \n, where n is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place
\5 as the first code at the beginning of the block.

To use the Optional Skip code (/):

�9 Place the code at the beginning of the line you wish to skip.

�9 Select the Optional Skip option from the Run Settings dialog box or
the Operator Panel.

When you run the NC program, the specified line will be skipped. If you
do not select the Optional Skip option in the Run Settings dialog box, the
skip code is ignored and the line is executed normally.

To use the Optional Skip code (/) with a parameter:

Use the Optional Skip code with a parameter to instruct the Control Program to
execute the line of code every nth pass. Place the code at the beginning of
the line you wish to optionally skip.

The syntax is: /n, where n is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place
/5 as the first code at the beginning of the block.

�"',������"�� 1--���� @�%��� C+� �"��D

The D code is used to select a value from the Control Program Offset
Table. For example, D1 selects entry number 1 from the Offset Table.

Use the D code with:

� Cutter compensation codes to specify the tool radius.

� Tool offset adjust codes to specify a consistent increase or decrease in
the commanded movement.

Use the Offsets command under the Setup Menu to view and manage the
Offsets Table.
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Use the F code to:

� Specify the rate of speed at which the tool moves (feed rate).This can
be   inches per minute (ipm), or millimeters per minute (mm/pm) de-
pending on the Units setting.  For example, F3 equals 3 ipm or mm/
pm.

The feed rate should be set to a low value (up to 50 ipm) for cutting op-
erations. Feed rate values are in millimeters per minute (mm/pm) when
using metric units. The Control Program limits the programmed feed
rate so it doesn’t exceed the maximum allowed by the machining center.

� Specify the number of seconds to dwell when used with the G04 code.

*��,����"�&� �"���� C�� �"���D

G codes take effect before a motion is specified. They contain information
such as the type of cut to be made, whether absolute or incremental di-
mensioning is being used, whether to pause for operator intervention, and
so on.

More than one G code from different groups can appear in each NC block.
However, you may not place more than one G code from the same group
in the same block.

The G codes supported by the Control Program fall into the following
groups:

� The Interpolation Group

� The Units Group

� The Plane Selection Group

� The Wait Group

� The Canned Cycle Group

� The Programming Mode Group

� The Preset Position Group

� The Compensation Functions Group

� The Coordinate System Group

� The Polar Programming Group
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The interpolation group allows you to specify the type of motion for inter-
polation. These G codes are retained until superseded in the NC program
by another code from the interpolation group.

The supported interpolation G codes are:

G00 Rapid traverse
G01 Linear interpolation (default)
G02 Circular interpolation (clockwise)
G03 Circular interpolation (counterclockwise)
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By default, an NC program is interpreted using the units of measure (inch
or metric) specified using the Units command on the Setup Menu.

The codes in the Units group, G70 (inch) and G71 (metric), are used to
override the Units command, for the entire program, or for a single line.

If the code is placed at the beginning of the program before any tool mo-
tions are made, that unit of measure is assumed for the entire program. If
the code appears in a block of code, the unit of measure is in effect for
that block and all following blocks.  You can use these codes to switch be-
tween inch and metric modes throughout your program at your conve-
nience.

The Fanuc equivalents, G20 (inch) and G21 (metric), can also be used.
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This group of codes allows you to select different planes for circular inter-
polation. G17 is the Control Program default.

The supported Plane Selection Group codes are:

G17 Select the X, Y plane for circular interpolation. The arc center
coordinates are given by I for the X axis and J for the Y axis.

G18 Select the X, Z plane for circular interpolation. The arc center
coordinates are given by I for the X axis and K for the Z axis.

G19 Select the Y, Z plane for circular interpolation. The arc center
coordinates are given by J for the Y axis and K for the Z axis.
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Wait Group codes apply only to the block in which they appear. The pro-
gram does not continue until the wait conditions are satisfied.

The supported Wait Group codes are:

G04 Dwell (wait): Stop motion on all axes for the number of seconds
specified by the F code, then continue the program. Because the
F code is used to specify the number of seconds, you cannot also
specify a new feed rate in the same block.
Example: G04F10; Wait for 10 seconds

G05 Pause: Used for operator intervention. Stop motion on all axes
until the operator manually resumes program execution.

G25 Wait until TTL input #1 goes low before executing the opera-
tions on this block. Used for external device synchronization.

G26 Wait until TTL input #1 goes high before executing the opera-
tions on this block. Used for external device synchronization.

G31 Linear move to specified coordinate; used with H code to specify
both the input number and the High or Low condition for stop
(designated by the input operator, + or -). The move occurs until
an input is triggered or until a coordinate is reached. The move stops
short if specified input goes High (if H is positive) or Low (if H is
negative). The default is input 1 High.
You can have the control program go to a specified block (N
Code number) if the input meets the required condition. Use a P
code to specify the destination, as with the M98 code.
For example,  G31X5Y5H-2P50000  instructs:

Move (using the current programming mode) to the X
and Y given.
If input 2 goes low during the move, jump to block
number 50000.
If input 2 doesn’t go low, continue with the next block
in the program.

G35 Wait until TTL input #2 goes low before executing the opera-
tions on this block. Used for external device synchronization.

G36 Wait until TTL input #2 goes high before executing the opera-
tions on this block. Used for external device synchronization.

G131 Specifically for digitizing with the probe. The user specifies a Z
position and a feedrate. The probe moves from its current posi-
tion to the specified Z position at the specified feedrate (or cur-
rent feedrate if not specified on the same block). If the probe in-
put is tripped before reaching the specified Z position, a valid
point is captured. In either event (point or no point), when the
probe stops moving down, it rapids back to the initial Z position.
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Canned cycle codes allow you to perform a number of tool motions by speci-
fying just one code. Canned Cycle codes are typically used for repetitive op-
erations to reduce the amount of data required in an NC program. Canned
cycle codes are retained until superseded in the program by another canned
cycle code.

The supported Canned Cycle codes are:

G80 Canned cycle cancel
G81 Canned cycle drilling
G82 Canned cycle straight drilling with dwell
G83 Canned cycle peck drilling
G83 Canned cycle thread tapping
G83 Canned cycle rigid tapping
G85 Canned cycle boring
G86 Canned cycle boring with spindle off (dwell optional)
G89 Canned cycle boring with dwell
Refer to Section G  for more information on these functions.
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Programming mode G codes select the programming mode, absolute
(G90) or incremental (G91). These codes remain in effect until superseded
by each other. The default code on program start up is G90.

With absolute programming, all X, Y and Z coordinates are relative to ori-
gin of the current coordinate system. With incremental programming, each
motion to a new coordinate is relative to the previous coordinate.

The supported Programming Mode codes are:

G90 Absolute programming mode
G91 Incremental programming mode
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The preset position G codes move the tool to a predetermined position, or
affect how future motions will be interpreted.

The supported Preset Position codes are:

G27 Check reference point: This code moves the machine to its home
position and compares the reported position against zero to see if
any position has been lost. The difference between the reported po-
sition and zero is compared to a tolerance value specified using
the Setup Program. Use the L code in this block to override the
tolerance value in the Setup Program.

G28 Set reference point: This code moves the machine to its home posi-
tion and sets the machine position to 0,0,0. The G28 code performs
an automatic calibration of the axes.
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G92 Set position: This code works like the Set Position command un-
der the Setup Menu. The X, Y and Z coordinates following a
G92 code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle complete.
G99 Rapid move to point R (surface of material or other reference

point) after canned cycle complete.
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Use the cutter compensation NC codes to automatically compensate for
the variations in a cutting tool’s radius and length. Refer to Section H for
more information on using cutter compensation.

The supported Compensation codes are:

G39 Corner offset circular interpolation.
G40 Cancel cutter compensation.
G41 Left cutter compensation: Enables cutter compensation to the left

of programmed tool path.
G42 Right cutter compensation: Enables cutter compensation to the

right of programmed tool path.
G43 Tool length offset: Shifts Z axis in a positive direction by a value

in the Offset Table, specified by an H code.
G44 Tool length offset: Shifts Z axis in a negative direction by a

value in the Offset Table, specified by an H code.
G45 Tool offset adjust: Increases the movement amount by the value

stored in the offset value memory.
G46 Tool offset adjust: Decreases the movement amount by the value

stored in the offset value memory.
G47 Tool offset adjust: Increases the movement amount by twice the

value stored in the offset value memory.
G40 Tool offset adjust: Decreases the movement amount by twice the

value stored in the offset value memory.
G49 Cancels tool length offset.
G50 Cancels scaling.
G51 Invokes scaling.
G68 Invokes rotation.
G69 Cancels rotation.
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Use the coordinate system codes to establish multiple coordinate systems
on one work piece to create multiple parts.

For instance, you can run a part program using a typical coordinate system
(with the point of origin on the surface of the front left corner of the
workpiece), then select another coordinate system which has its origin at a
different point on the surface of the workpiece. For an overview of coordi-
nate systems, see page H-27.

There are seven coordinate system codes. One of these codes (G53) is
used to rapid to specified machine coordinates. The other six codes allow
you to make up to six individual parts on the same workpiece by specify-
ing different work coordinate systems for each part.

The coordinate system codes are G54 through G59, referring to coordinate
systems 1 through 6 respectively. These coordinate systems may be set
through the Coordinate Systems command on the Setup Menu.
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The polar programming codes allow you to perform polar programming op-
erations, based on polar coordinates. The polar coordinates are defined by X
(radius) and Y (angle in degrees) when programming for the X, Y plane. Re-
fer to Section H of this Guide  for more information on using polar program-
ming.

The supported Polar Programming codes are:

G15 Polar programming ON
G16 Polar programming OFF
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The H code has multiple uses. It can be used to specify inputs, input state
changes, outputs, and offset amounts.

Use the H code in conjunction with:

� The wait codes G25 and G26, to specify the input number.  If the H code is
not used with these G codes, input 1 is assumed.

� The wait code G31, to specify input change to high or low. If the H code is
not used with this G code, input 1 High is assumed.

� The tool length offset codes G43 and G44, to specify the amount of Z axis
shift. (The Offset Table you use for Tool Length Offset H values is the same
table you use for Cutter Compensation and Tool Offset Adjust D values.)

� The transmit codes M25 and M26 for interfacing with robots or other exter-
nal devices, to specify the output number. If the H code is not used with
these M codes, output 4 is assumed.

	��5����""��������"-��������*"���� C!��"��D

In absolute programming mode (G90), the I code specifies the X axis coordinate
of the center point of a circle when using circular interpolation. In incremen-
tal mode (G91), the I code specifies the X axis distance from the end of the last
motion to the center point of the circle for circular interpolation.

If no I code is specified, the system uses the current X axis location as the X
axis center of the arc.

In Fanuc mode, all arc centers are incremental.

The I code is also used with the G51 code to specify the scale factor for the X
axis when performing scaling functions, including scaling each axis and mir-
ror scaling. Refer to Reference Guide Section H for more information on using scal-
ing.
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In absolute programming mode (G90), the J code specifies the Y axis coordinate
of the center point of a circle when using circular interpolation. In incremental
mode (G91), the J code specifies the Y axis distance from the start point of mo-
tion to the center point of the circle for circular interpolation.

If no J code is specified, the system uses the current Y axis location as the Y
axis center of the arc.
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In Fanuc mode, all arc centers are incremental.

The J code is also used with the G51 code to specify the scale factor for the Y
axis when performing scaling functions, including scaling each axis and mir-
ror scaling. Refer to Reference Guide: Section I for more information on using
scaling.

F��5����""��������"-��������*"���� C2��"��D

In absolute programming mode (G90), the K code specifies the Z axis coordi-
nate of the center point of a circle when using circular interpolation. In incre-
mental mode (G91), the K code specifies the Z axis distance from the end of
the last motion to the center point of the circle for circular interpolation.

If no K code is specified, the system uses the current Z axis location as the
center of the arc.

In Fanuc mode, all arc centers are incremental.

The K code is also used with the G51 code to specify the scale factor for
the Z axis when performing scaling functions, including scaling each axis
and mirror scaling. Refer to Reference Guide: Section I for more informa-
tion on using scaling.

���%��"-����� ��"%���"�A�3"",��"������ C3��"��D

The L code specifies the angle of arc resolution in circular interpolation
programming. With BENCHMAN, it is only used if a helical motion is executed,
or if you specifically enable approximated arcs in that program (M111 com-
mand).

Use the L code with:

� The M98 code as a loop counter for subprograms.

� The M47 code as a program cycle counter, to repeat a program a
specified number of times.

� The G27 code to specify tolerance with homing commands (this is an
LMC-specific NC language extension). The difference between the cur-
rent position and 0 is compared to a tolerance value specified using
the Setup Program; use the L code to override this tolerance value.
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M codes control a variety of  functions while a part program is running. M
codes should be placed on separate blocks to avoid confusion over
whether an M code is activated during or after a motion command.

The supported M codes are:

M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.
M01 Optional Stop: Allows you to place an optional pause in your

code. Place an M01 in the block of code where you would like
to pause. There are switches to activate or deactivate the Optional
Stop code in the Run Settings  dialog box and on the Operator
Panel.
With Optional Stop on, the M01 works like a G05 pause.
With Optional Stop off, the M01 code is ignored, and the other
codes on the block are executed as usual.

M02 End of Program: Takes effect after all motion has stopped; turns
off drive motors, spindle and accessories.

M03 Spindle Motor On Forward: Activated concurrently with motion
specified in the program block; remains in effect until super-
seded by M04 or M05.

M04 Spindle Motor On Reverse: Activated concurrently with motion
specified in the program block; remains in effect until super-
seded by M03 or M05.

M05 Spindle Motor Off: Activated after the motion specified in the pro-
gram block; remains in effect until superseded by M03 or M04.

M06 Tool Change: Pauses all operations, turns off spindle, retracts
spindle for tool change.

M08 Coolant On: Turns on coolant; remains in effect until superseded
by M09.

M09 Coolant Off: Turns off coolant; remains in effect until super-
seded by M08.

M10 Air Vise On: Unclamps Air Vise; remains in effect until super-
seded by M11.

M11 Air Vise Off: Clamps Air Vise; remains in effect until super-
seded by M10.

M20 Chain to Next Program: This code is used to chain several NC files
together. It appears at the end of a part program and is followed
on the next line by the file name of another program which is ex-
ecuted when all motion stops. Here’s an example of a part pro-
gram chain to another program:

N37 Z.2
N38 M20
PROGRAM2.NC ;CHAIN TO PROGRAM TWO

�"��$
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If the two programs you are chaining are not in the same direc-
tory on your computer, you must specify the full path name for
the next program file.

M22 Output current position to file. Typically used in digitizing.
M25 Set TTL output #1 Off: Used for external device synchroniza-

tion.
M26 Set TTL output #1 On: Used for external device synchronization.
M30 End of program: Same as M02.
M35 Set TTL output #2 Off: Used for external device synchroniza-

tion.
M36 Set TTL output #2 On: Used for external device synchronization.
M47 Rewind: Restarts the currently running program; takes effect af-

ter all motion comes to a stop. Typically used with an L code to
repeat a program a set number of times.

M98 Call to subprogram. Use the P code to specify the subprogram
starting block number. Use the L code to specify the number of
times the subroutine is executed. You can nest subprogram calls
to a depth of 20.

M99 Return from Subprogram; Goto
M105 Operator Message (LMC)
M122 Output current position to file. Almost identical to M22, except that

if a macro (@X@Y@Z) is used to insert a coordinate, the position
of the digitized point will be used, rather than the current machine
position.

���$� 1��,��� �������� *"����"�� �"� .�%�

The M22 code is used to write information to a file while a program is run-
ning.  Typically, this code is used when digitizing to write the current X, Y,
and Z machine coordinates to a file. The proper format for using this code is:
M22(filename)DataToWriteToFile. The first time the Control Program en-
counters an M22 code, it opens the specified file. You must enclose the name
of the file in parentheses for the Control Program to recognize it. If you do not
specify any DataToWriteToFile text, the default data is output. This default is the
current position, equivalent to specifying ‘X@X Y@Y Z@Z’. Notice that the
@X,@Y,@Z ‘macros’ are replaced by the actual machine position when the
data is written. Each M22 code automatically adds a line feed to the end of its
output so the next M22 starts on a new line.

If the file name is followed by “,A” (e.g., test.nc,A), the Control Program does
not delete previous information from the file, it appends the information to the
end of the existing information. If the file does not exist, it is created.

If you use more than one M22, only the first occurrence must have the file
name in the parentheses. The remaining M22’s may have empty parenthe-
ses, ( ), or may specify a different file.
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If you want to generate more than one file at a time, you must include the
filename each time you specify M22. If a filename is not specified, the
first file opened is used.

Example:

. . . ; code to move to position
; Open my1.xyz, discard contents, write coordinates
M22(my1.xyz)
. . . ; code to move to next position
; Append to currently open data file
M22( )
. . . ; code to move to next position
; Open my2.xyz and append coordinates
M22(my2.xyz,A)

Information about digitizing is provided with the digitizing package. For
additional information, please call Light Machines Technical Support.

Special codes that can be used with M22 to generate run-time reports:

@X Current X position (in current coordinate system).

@Y Current Y position (in current coordinate system).

@Z Current Z position (in current coordinate system).

~ (tilde) New Line (starts a new line in the file).

@TD Time of Day (12 hour)   “11:59:59AM”

@TC Time (elapsed) for cycle   “99:11:59” (0’s trimmed from
left)

@TT Time Total (program run)   “99:11:59”

@TA Time Average (per cycle)   “99:11:59” (“??:??” if first
part)

@TL Current Tool #.   “5”

@C Cycle # (Current Pass)   “3”

@D Date  “12/31/94”

@FN Current File (w/o path)   “PART.NC” (“UNTITLED.NC” if
untitled)

\t TAB

\\ Outputs a single ‘\’ character.

Example:

; Start of file

… ; Process a single part
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; Output part time statistics to file c:\Reports\Stats.txt (c:\Reports
directory must exist)

M22 (c:\Reports\Stats.txt,A) Part #@C processed in @TC.

M47 L50 ; We want to process 50 parts.

�BB$�  ������ -�"'� #�4,�"���'A� �"�"

The M99 code has two specific uses; it can be used as a command to re-
turn from a subprogram or it can be used as a goto command.

Using M99 with subprograms:

When used in a subprogram, this code returns you to the block following
the last M98 (Call to Subprogram) command.

You can use the P code plus a block number to override the block returned
to; however, if this feature is used from a nested subprogram call, all re-
turn targets are discarded. The rules for a Goto target block apply to this use
as well.

Using M99 as a Goto command:

This command can be used in the main NC program as a Goto command
to jump to a block on a line before the M02 command.

Use the P code to identify the block number being jumped to. Control is
transferred to the first occurrence of this N code; it cannot be used to
transfer control between chained programs (see M20).

This command can be used anywhere in the program to change the flow of
program execution. It is good programming practice to place this com-
mand on a line by itself to improve the program’s readability.

��
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This command is used to display messages in the Control Program. It pro-
vides a way to display messages to the operator on the Message Bar while
an NC program is running. You can also pause the program with a custom
message. This code is a non-standard, Light Machines code.

By default, the message is centered, displayed as black characters on a
white background, and is persistent (not cleared until the operator manu-
ally does so or until the next message is displayed).

The correct format for using this code is:

M105(the message);comment

For instance, the following line of code displays a simple message:

M105(End of Roughing Segment);Display message in white;continue
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Messages can be altered by using the following alternate characters:

^ Displays the message and performs a pause requiring operator inter-
vention to continue.

~ Displays the message as a Warning Message.

\b Beeps when the message is shown.

The format for using the M105 code with an alternate character is:

M105(alternate character plus the message) ;comment

For example:

M105(~WARNING);Message in yellow, continue

Here are some other examples of how to use this code:

M105( ) ; clears current message
M105(^Please stop and read this!) ; Normal Message, pauses
M105(~^I MEAN IT!) ; Warning Message, pauses
M105(\b\b\b) ; Clears current message, beeps 3 times, and doesn’t pause

�%"�)���'4��� C�� �"��D

N codes have two uses:

� To provide destinations for Gotos (M99) elsewhere in the program.

� To clearly show the organization of the code and improve readability.

Using the N code is optional; however, when you do use the N code, it
must be the first character in a block of NC codes.

Other than for the above stated uses, N codes are not recognized by the Con-
trol Program. Their presence, absence, or sequential value does not affect the
execution of the NC program in any way (unless the target of a goto is miss-
ing).

You may have N codes on some blocks and not on others. N code se-
quence numbers do not have to be in order, but regular sequential order
does make it easier to follow the program.The Control Program can
change the N codes in a program by inserting, removing, or renumbering
them. See Edit Menu, Renumber Command in Section E.
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The O code is used to indicate the start of a subprogram, and must be fol-
lowed by a number which identifies the subprogram. The O code replaces
the N code in the first block of the subprogram.

To call a subprogram, use the M98 code; the P code specifies which subpro-
gram to execute. To return from the subprogram, use the M99 code.

Only the first block in the subprogram contains the O code. The remaining
blocks may contain N codes. The O and N code numbers may be used to help
identify and set apart the subprogram to improve readability, for example:

M98P50000;call to first subprogram
…;after first subprogram is finished, M99 code returns to this point
…
M98P60000 ;call to second subprogram
…;after second subprogram is finished, M99 code returns to this point
…
O50000 ;start of subprogram
N50010 ;first line of subprogram
N50020 ;second line of subprogram
N50030M99 ;last line of subprogram
…
O60000 ;second subprogram
N60010 ;first line of second subprogram
N60020 ;second line of second subprogram
N60030M99 ;last line of second subprogram

#�4,�"���'�  �-������� ��'4��� C*� �"��D

Use the P code with:

� The G31 code to reference a goto target block.

� The G51 code to specify a uniform scaling factor.

� The M98 code to reference a subprogram using the subprogram block number.

� The M99 code to specify a return block number as a goto target.

*��)�+�,��� CI��"��D

The Q code is used with the G83 code in canned cycle peck drilling to
specify the depth of each peck.
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As an alternative to specifying the center point of an arc (I Code, J Code,
or K Code) you can specify the arc radius. Use the same value for the ra-
dius in both absolute and incremental programming modes.

G02 or G03 specifies the direction of motion.

Positive values for R (radius) are specified for arcs up to 180°. Negative
values are used for arcs greater than 180°. Full circle arcs cannot be per-
formed with an R code. Spit the circle into two arcs, or use center point (I,
J, and K) values for full 360° circles.

Use the R code in canned cycles to specify a Z axis reference point for
peck drilling. The point can be at the material surface or at another refer-
ence point. The R code is also used to specify the rotation angle, in de-
grees, with the G68 code.

#,���%�� #,���� C#� �"��D

Use the S code to set the spindle speed from within the NC program. Spindle
speed is specified by the address character “S” followed by a parameter
that represents the speed in RPM. For example, S750 is the designation for
a spindle speed of 750 RPM. For the S code to have affect the spindle
must be turned on by the M03 or M04 command. If the spindle is off, the
spindle speed is stored and used when the spindle is turned on again within the
program. Use the M05 command to turn the spindle off.
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T codes specify the tool offset (number) in the Tool Library in multiple
tool machining operations. They do not specify the Automatic Tool
Changer (ATC) station number, but they do have an ATC station associated
with them. Tools are specified by the address character “T” followed by a
parameter that represents the number of the tool. For example, T3 is the
designation for tool number three.
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An X code specifies the coordinate of the destination along the X axis. A
U code is used in absolute programming mode (G90) to specify an incremen-
tal X motion. You cannot use the U code to mix incremental and absolute
programming in the same block.

6��5����""��������C6�"��@��"��D

A Y code specifies the coordinate of the destination along the Y axis. A V
code is used in absolute programming mode (G90) to specify an incremental
Y motion.  You cannot use the V code to mix incremental and absolute
programming in the same block.

F��5����""��������CF�"�����"��D

A Z code specifies the coordinate of the destination along the Z axis
(spindle axis). A W code is used in absolute programming mode (G90) to
specify an incremental Z motion. You cannot use the W code to mix incre-
mental and absolute programming in the same block.
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The Control Program allows you to add comments to your NC blocks. The
Control Program recognizes two comment codes:

� A semicolon “;”

� An open parenthesis “(“

These two comment codes are equivalent. The use of either of these codes
at the end of an NC block indicates that a comment follows.

Comments must follow all other NC codes in the block. Comments are ig-
nored when the part program is executed. Comments can be placed on a
block without any NC codes to document what is occurring within a pro-
gram. NC programmers use these comments to annotate their programs.

Here is an example of an NC block with a comment:

X0Y0Z0;MOVE TO ZERO POINT

The comment tells us that the X, Y and Z codes in this block command
the cutting tool to move to the zero point (coordinate 0,0,0).

Comments can be combined with the G05 pause and the M06 Tool
Change codes to display messages to the operator during program execu-
tion. Here is an example of an NC block with a pause coded comment:

G05(ROUGH DIAMETER SHOULD BE 0.5 in.

When the program pauses, the program line, and thus the comment, is dis-
played on the message bar, telling the operator to verify the diameter of
the workpiece before continuing. The M105 code provides a more versa-
tile and powerful message facility.

By using the Renumber command you can strip the comments from a program
with a single command; however, comments cannot subsequently be replaced
automatically.
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The following rules should be followed when writing NC part programs.

� The sequence of words (address characters plus parameters) in an NC
block must appear in the following order: H����D?E��2��.�D)E��;�DBE��C�D�E��,����

G��A��7��M��(�� �����+��/��$�����Q A different order may cause unpredictable re-
sults.

� In many cases, a word need not be repeated in the next block (line).
The system assumes no change in codes unless a new code appears.
This does not apply to: N words, I, J, and K, G04, G05, G25, G26, G92, F
used for dwell, M02, M20, M25, M26, M30, M47, M98 or M99.

� You can use more than one G code in a block; however, you can use
only one G code from any one group in a single block.

� N codes (sequence numbers) are not required in a part program; how-
ever, they can be useful in identifying a block when editing a long NC
part program.

� An O code is required to mark the beginning of a subprogram and
does not have to be in sequence with the N codes.

� The first instruction in a part program should move the tool to a safe
starting position. This makes restarts much easier.

� The last block of a program should move the tool back to the starting
position. The tool will then be in position to start cutting another part.

� Part programs should reference the zero point with Z0 at the point
where the tool just touches the work piece. This convention allows for
standardization of programming.

� Before running an NC part program:
a. Look for the typical coding error that places two X codes, two Y

codes, or two Z codes in the same block.
b. Be sure that all required coordinates have been written into appro-

priate blocks.
c. Verify the part program to discover any program errors.
d. Run the part program without mounting stock in the Machining

Center to see if the tool movements are logical.

� The first portion of a part program should turn on the spindle and estab-
lish the feed rate and spindle speed.

� M codes should be placed on separate blocks to avoid confusion over
whether an M code is activated before or after a motion command.

� Double-check all program blocks against your coding sheet to locate
and correct typographical errors.
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Linear interpolation is the movement of the tool in a straight line from its
current position to a coordinate location specified by an NC block. Here’s
a typical block of NC code using linear interpolation:

�=2��2��.*�;�*0�0

Broken down into individual words:

�; The block sequence number is 5
�B
 Coordinates are given using absolute dimensioning
�
� Linear interpolation is specified
	9> X axis coordinate of end point = .7
6�9� Y axis coordinate of end point = 1.2
.� Feed rate is 2 inches per minute

The G01 code is required when switching from circular interpolation or
rapid traverse positioning back to linear interpolation. If we assume the
current position of the tool is X.5, Y.5, the tool movement generated by
the above block is something like this:

An equivalent movement is achieved with incremental dimensioning
(G91):

�=2��2��.*0;*��0
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Circular interpolation moves the cutting tool along an arc from the start-
ing point specified in one block, to an end point specified in the next block.
The curvature of motion is determined by the location of the center point
(I, J, or K), which must also be specified in the second NC block.

The direction of rotation from the starting point determines the actual shape
of the arc relative to the spindle axis. A G02 code moves the tool in a
clockwise (CW) motion from the starting point. A G03 code moves the
tool in a counterclockwise (CCW) motion from the starting point.

Here are two typical blocks of NC code using circular interpolation:

��2��.�;�Q+8/�+/,7/��?��/

���2��.�;��
�G��0Q&?)�/87& ?&A��+8�/?�.��;�

The first block defines the starting point. The second block defines the
end point and the center of the arc. Broken down into individual words,
the second block reads:

��
 The block sequence number is 10
�
: The tool will proceed in a counterclockwise direction from the

starting point to specified (X, Y) coordinates; center point of arc
is specified by (I, J) coordinates

	
 X axis coordinate of end point = 0
6� Y axis coordinate of end point = 1
!�� I coordinate of center point of arc = -1 (relative to start point)
0
 J coordinate of center point of arc = 0 (relative to start point)
.� Feed rate is 2 inches per minute

2�0�D&�E�����2���D&&�E�%�##��!
'�#"
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The tool path generated by the preceding block is something like this:

/�'�%���#�����������#��
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X

Y

1

1

Start Point
(X1,Y0)

End Point
(X0,Y1)

Tool Motion

Center Point
.5

.5

An equivalent movement is achieved with incremental dimensioning
(G91):

��2��.�;�Q+8/�+/,7/��?��/
���2��.
�;��
�G��0

In this NC block, the X and Y values are the distance the tool is to move
from its current position. In both cases, the I and J values are equal to the
X and Y distance from the start point to the center point.

�����%��� !����,"%���"�� "�� 1����� *%����

To perform circular interpolation on a plane other than the X, Y plane, use
a G18 code to select the X, Z plane, or use a G19 code to select the Y, Z
plane. This feature is rarely used in manual part programming, but may be
used by CAM systems to generate surfaces of revolution. The G17 code is
used to return to the X, Y plane. An example of circular interpolation on
the X, Z plane is:

��.�C�
���2��2��2��.�C���A*=�0

In this NC block, the X and Z values are the destination position of the
tool. The I and K values are the incremental location of the center point of
the curvature of motion.
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Helical interpolation is performed when the axis not used in circular interpola-
tion is commanded to move. For example (assuming a start point of 0,0,0):

���2��2��.�;�C���G*=�0

This block would cause the Z axis to move at a constant feed to Z1 while the
X and Y axes move in a circular path, resulting in a helical motion. Heli-
cal interpolation works with circular motion on the X,Z and Y,Z planes as
well.

Here is an example of an NC program using helical interpolation.

2��$��+�=��
2�.�;�C�*���
2�.0;0
2�C
�*=���
2�0.�;0C��
�G����
$�0
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On the Machining Center, the rapid traverse code (G00) can move the tool
at the maximum available feed rate (200 ipm) to specified coordinates.
Rapid traverse is used to reposition the tool before ending a program, or in
preparation for the next cut.

�� �!��

/"��#����
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Rapid traverse can be used for all tool positioning motions. This will re-
duce the run time for the part program. The G00 code remains in effect
until linear (G01) or circular (G02, G03) interpolation is again specified.
Linear or circular interpolation resumes at the feed rate last specified prior
to the rapid traverse motion(s) unless you specify a new feed rate.

Here’s a sequence of typical NC blocks using rapid traverse:

�B
�
�	�.�M�$?B8����,�+/7,�2(/� ��8�/?�.�S���,/�0���$

�

	�M�7,��@�/7,B87+8�/?�.S0

	:M�7,��@�/7,B87+8�/?�.S�

�
�	�M�$?B8����,�+/7,�2(/� ��8�/?�.S��,/�0���$



2
�$����&�&����!������!

������� �&�%�� *�"���''���
Canned cycle commands allow you to perform drilling operations by specify-
ing just a few codes. They are typically used for repetitive operations to
reduce the amount of data required in an NC program. Canned cycle
codes are retained until superseded in the program by another canned
cycle code.  The supported canned cycles codes are:

G80 Canned cycle cancel
G81 Straight drilling
G82 Straight drilling with dwell at bottom
G83 Peck drilling
G84 Thread tapping

G84.1 Rigid tapping
G85 Boring cycle
G86 Boring cycle with spindle off (dwell optional)
G89 Boring cycle with dwell

These codes are used in conjunction with canned cycle codes:

G98 Rapid to initial position after canned cycle complete; this is the
system default

G99 Rapid to point R after canned cycle complete
Q Code Specifies the depth of cut. In peck drilling each peck uses the

same Q value. The Q value is always positive. If a negative
value is specified, it is converted to a positive value.

R Code Used for specifying a starting reference point for peck drilling.
The point can be at the material surface or at another reference
point.

������ �?


To cancel a canned cycle, use the G80 code. This code cancels the cur-
rently running canned cycle and resumes normal operation. All other drill-
ing data is cancelled as well. You can also cancel canned cycles by using a
G00 or G01 code; a G80 is automatically performed before the G00, G01,
G02, or G03.
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The G81 code performs straight drilling operations. By specifying an R
value of zero, the tool will return to the initial point after drilling to point
Z. Here is a sample G81 program.

2�.�;�C*�Q7,��@�/?�������*�

2��2��C
*=7��0Q@7�  �/?�@8�/(�?��
*=��7,��@�/?����/�, ��?��/

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$

This program will generate tool motions similar to this:

More than one canned cycle can be accomplished by specifying only X
and Y coordinates. For example:

2�.�;�C*�Q7,��@�/?�������*�

2��2��C
*=7��0Q@7�  �/?�@8�/(�?��
*=��7,��@�/?����/�, ��?��/

.*=;�Q�8&A�,/��8��.�;�&??7@��,/8+

.*0=;�Q�8&A�,/��8��.�;�&??7@��,/8+

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$
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A G82 works just like a G81, except it is used when you wish to incorpo-
rate a dwell (P code) at the bottom of the hole (point Z). A block of code
utilizing the G82 and P code, and the tool motion it creates are shown be-
low.

2�.�;�C*�Q7,��@�/?�������*�

2�02��C
*=7��=�0Q@7�  �/?�@8�/(�?��
*=��7,��@�/?����/�, ��?��/�,�/87�,�@�8  
?����B8�+8&?�@+

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$

������ �?:

The G83 code is used for peck drilling cycles. By adding a Q depth to the
code block, you can specify drilling increments. For instance, the follow-
ing code will peck drill to a depth of -.5 in .1 increments. The tool will
rapid back to point R after each peck drill. Also, before each peck the tool
will rapid to .005 (.13mm) above the start point.

2�.�;�C*�Q7,��@�/?�������*�

2��2��C
*=7�M*���Q�8&A�@7�  �/?�@8�/(�?��
*=��7,��@�/?�7

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$
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A G84 is used for tapping threads. You specify the depth of the tapped
hole. When the tap reaches that depth, it is pulled out in at a rate 1.6 times
the rate of insertion (60% faster). The G84 tells the computer to calculate
the insertion/extraction ratio. You must use a tapping head with a revers-
ing mechanism when using G84.

2�.�;�C*�Q7,��@�/?�������*�

2��2��C
*=7��0Q/,��/?�@8�/(�?��
*=��7,��@�/?����/�, ��?��/

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$

������ �?�9�

A G84.1 is used for rigid tapping.  The Tapping cycle has MANY different
parameters, some are optional, some are not.

This Fixed Cycle allows the use of rigid tap holders, providing precise
thread generation and hole depth control while eliminating the need for ex-
pensive floating tap holders.
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The thread is generated by controlling the rotation of the spindle and the
Z-axis synchronously.  This provides very accurate and repeatable depth
control and thread form.

The CODE for the tapping cycle is G84.1.  The complete list of codes
curerntly used is:

Z! Final depth of tapped hole (position; meaning if G91, it’s
REL, if G90 it’s ABS)

R! As with other cycles, the ‘Top’ of the cycle [Tapping
cycle rapids to this depth before starting TAP]

S* Spindle RPM for cycle.  This value fixes the rate the
spindle rotates during the tapping cycle.

F* If G94 is effective, specifies the desired feedrate on the Z-
Axis for the cycle (meaning it will adjust the pitch such
that for the given Spindle Speed (‘S’), the feedrate of the
Z axis is ‘F’

If G95, this specifies the PITCH of the tapped thread (1/
(threads per inch)).  Only used if Peck-type tap Q - Ad
vance per peck (in Spindle Revolutions [or Threads]).

# Revolutions advanced per ‘peck’ from the last ‘peck’
(NOT from last retract from last peck)

P Retract per peck (in Spindle Revolutions [or Threads]).
MUST be specified if ‘Q’is specified.

J Retract Ratio - Retract feedrate as a multiple of the effec
tive PLUNGE feedrate (see ‘F’). Default is 1, meaning
peck retracts at same feedrate it plunges at.  To Retract at
twice the plunge rate, for example, J2 should be used.

! = Required Code.  If this value isn’t specified for the G84.1 command,
an error is raised.

* = Recommended Value.  This value is part of the set of values uniquely-
defining any thread

G00Z0.1; PLUNGE TO Z0.1 - SAFE RAPID HEIGHT

G84.1Z-1R0S500F.1Q2P.5G95J2; TAP A 1" DEEP HOLE, TOP = 0".
ROTATE @ 500 RPM, PITCH = .1 (10 TPI) [using G95],PECK
HOLE, PLUNGE 2 REVOLUTIONS, RETRACT 0.5 REVOLU-
TIONS, 2 TIMES FASTER THAN PLUNGE.

G80; CANCEL CANNED CYCLE

M2; END PROGRAM
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A G86 works like a G82 except the spindle stops at the bottom of the
hole. The dwell (optional) allows the spindle to come to a complete stop
before the tool rapids back to the initial point.

2�.�;�C*�Q7,��@�/?�������*�

2�>2��C
*=7��=�0Q@7�  �/?�@8�/(�?��
*=��+()/�?���+���@ 8��7,��@�/?����/�, 
�?��/�,�/87�,�@�8  �?����B8�+8&?�@+

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$

������ �?;

A G85 specifies a boring cycle. After the tool plunges, it retracts at the
same feed to point R. This sometimes gives a better surface finish on the
hole. Then the tool rapids to the initial point.

2�.�;�C*�Q7,��@�/?�������*�

2�=2��C
*=7��0Q-?78�/?�@8�/(�?��
*=��7,��@�/?����/�, ��?��/��7?$��?��/�7

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$
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The G89 code works like the G85 except it utilizes a dwell at the bottom
of the hole.

2�.�;�C*�Q7,��@�/?�������*�

2��2��C
*=7��=�0Q-?78�/?�@8�/(�?��
*=���,)+8��?7���B8�+8&?�@+�/(8��7,��@
?)/��7?$��?��/�7

2��Q&,�&8 �&,��8@�&;& 8

$0Q8�@��7?27,$
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2
�� 7�3����%��2����L�+�%#����2

#�4,�"���'� *�"���''���
Subprograms are used to execute repetitive routines in an NC program.
Since a subprogram can be called again and again, you don’t have to enter
the same data more than once. This is especially useful if the machining
operation you wish to repeat is lengthy or complex. The NC codes used
for subprogramming on the Machining Center are:

M98 Call to subprogram.
M99 Return from subprogram.

P Code The P code is used to reference the first block of the subprogram
(which begins with an O code). The P code immediately follows
an M98.

L Code The L code is used as a loop counter when used in
subprogramming. The computer executes the subprogram as
many times as defined by the L code. For instance, if the code is
L5, the subprogram is executed five times. (Optional)

O Code The O code replaces the N code on the first block of a subprogram.

A subprogram is called by an M98 and a P code. When an M98 calls the sub-
program, the main program is interrupted while the subprogram is executed.

The P code references the subprogram’s address (the first block of the
subprogram). The first block of the subprogram uses an O code instead of
an N code for block numbering.

When the M99 is executed, the main portion of the NC program continues
to execute from the block after the subprogram was called.

Subprograms can also be nested within other subprograms. This means
that while a subprogram is being executed, it can call another subpro-
gram. The default number of levels that subprograms can be nested is 20
levels deep. You can change the default by using the Setup Program
(click on the Setup icon in the BENCHMAN program group).
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Using polar coordinates allows you to specify a radius and an angle by
specifying a G16 code (polar programming on), then X and Y codes. The
X code specifies the radius. The Y code specifies the angle in degrees. A
G15 is used to cancel the polar programming mode. This programming
method can be used in both absolute and incremental programming.

Polar programming is especially useful when writing programs for machin-
ing bolt holes. An L code can be used as a multiplier for the angle value.
For instance, this bit of code:

2�.�;�C�*��

$��

2�>

2��.0;�

$���� �0

$0

?�;��

2��C
*�7�

2��

$��

combines the use of polar programming with a canned cycle and a subpro-
gram to drill a hole at 30o increments. The L value was determined by di-
viding 360 degrees by 30.

You can also cut an arc using code similar to:

2�>

2��.0;�

$���� �>�

2�=

$0

?�;�

$��

In polar programming, the center point is the origin if you specify G90
and the radius (X code). The center point is the current center if you
specify only the angle (X and Y codes). The center point is the current
point if you specify G91 and the radius (X code).
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The Homing commands allow you to establish a point of origin at the
ends of travel on the Machining Center. The Machining Center then uses
this point as a reference for all machine coordinate movements. The Ma-
chining Center can then move consistently to the same location when pro-
grammed to do so.

������ ��?

The G28 code “homes” the machine: It moves the machining center’s
spindle, cross slide, and saddle to the ends of travel along each axis and
sets the Machine Coordinate System to (0,0,0). This zero point is located
at the positive limits of the X, Y, and Z axes. Use G28 to automatically
initialize the machine every time it’s turned on. See the sample NC pro-
gram below for one use of the G28 code.

��������?� ��� ������*�"���'

Here is an example of an NC program using Homing commands (the
Homing commands and related commands are in italics):

��	
�(?$��2�/(8�$,&(��8

$�+����Q�+���@ 8�$?/?7�?��+�88@�����

���
�)+8�&??7@��,/8�+;+/8$�?�8

�
�
�
�

�7,��@�/?�?�?�?

2�C
�*����=Q�&)//��2�/(8���8&8

2�.�

2�;�*0=

2�.�

;�

2�C�*���

$0

The G28 code homes the machine and sets the Machine Coordinates and
World Coordinates to zero. Use a G27 if you want to check the home po-
sition, but do not want to set that position to zero.

The G54 calls up Coordinate System One (CS1), which contains the off-
set values relative to the machine’s home position. These are the values
you entered for Coordinate System One in the  Setup Coordinate Systems
dialog box. The coordinates in the Position Window on the screen change
to the coordinates of Coordinate System One

20��
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The next line (G0X0Y0Z0) calls for the machine to perform a rapid traverse
motion from the Home position to point 0,0,0 in Coordinate System One.

The remaining lines of code instruct the machine to cut a square in a
piece of stock.

������ ��?� ��-"��� #������� #"-�� 3�'���

Remember, Soft Limits are based on Machine Coordinates. You can not use
Soft Limits until you have set the machine to the reference point using the
G28 code or pressing the Home button in the Machine Home / Reference
Point dialog box (access using the Set/Check Home command under the Setup
Menu).

������ ��>

After you have set a reference point (using either the Setup Coordinate Sys-
tems dialog box or a G28 code) you can use the G27 code to check the ac-
tual machine position against the expected machine position. This command
causes the machine to perform a homing-like function, moving each axis in-
dependently from its current position to the reference point. The Control
Program then compares the current position to the one set by the G28. If
the deviation is larger than a threshold you can specify in the SETUP file,
the Control Program reports an error after all axes are checked. If there is
no deviation, the program continues.

G27 also takes an optional position specified by XYZ. This position is
called the intermediate position. You do not need to specify all axes for
the intermediate point, but for each axis that you specify the current coor-
dinate for the intermediate point is updated to that value. Only axes that have
specified coordinates move when you specify an intermediate point. For ex-
ample, if the first intermediate point commanded is G27Z.6, the interme-
diate point motion is only to move the Z axis to .6. The machine first
moves to the current intermediate point at rapid traverse, then performs
the reference point check.



(
=,����%���&�&����!������!

������ ��B

The G29 code moves the tool at a rapid traverse rate to a coordinate specified
by XYZ. If you have set an intermediate point on one or more axes, the ma-
chine first rapids from the current position to the intermediate point then con-
tinues to the specified destination. If you command a G29 code in Incremental
mode, your specified XYZ point is relative to the intermediate point. If you
have not specified an intermediate point, your specified XYZ point is relative
to the current position. Use the G29 code after a G28 command to return the
tool to a position closer to the part. The example below shows the use of a
G28 code and a G29 code.

��20�.0;0C
�Q���/87$8@�,/8��?��/�/(8��(?$8

�020�.�;�C�Q�2?�/?�20���?��/

+Y

+X

G29 Point (4,1)

(0,0)

Intermediate Point (2,2)

Reference Point (3.5,4)

(1,1)

������%5�����#"��#��������
�3���
�#
�%�����#�'���#�#��#"�
��#�������#��'���#��#"���#��#"�
��3����%��'���#*

������%5��0��#"��#��������
�3���
#"����3����%��'���#��#"���!"�#"�
��#�������#��'���#��#��#"����	
'���#��
#����
"������#"��20�
%���*



(
> 7�3����%��2����L�+�%#����(

Programmed Tool Path

Compensated Tool Path
(Left)

Tool

Compensated Tool Path
(Right)

Tool

G41 G42

Programmed Tool Path

������ ������� �"',������"�
Cutter compensation automatically adjusts the BXT-4021 to compensate for
variations in a cutting tool’s radius. It uses values from the Offset Table
(tool radius values) to determine the compensation offset value. Use the
following codes for cutter compensation:

�:B Inserts an arc at the corner of compensated path
��
 Cancels cutter compensation
��� Invokes left cutter compensation
��� Invokes right cutter compensation
+ Compensation offset value (Tool Radius Value)

Determine left and right cutter compensation in relation to the direction of
the tool path. Use left compensation when you need to move the tool to the
left of the programmed tool path. Use right compensation when you need
to move the tool to the right of the programmed tool path.
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Select compensation offset values for D from the Offset Table. You can
store 200 offset values in the table. Remember, however, that these offset
values are the same values you use for adjusting tool length offsets.
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You can start cutter compensation by inserting a G41 (for left compensa-
tion) or G42 (for right compensation) into your NC program. In the ex-
ample below, left cutter compensation is enabled and the compensation
value is equal to offset value 1 from the Offset Table.

2�.�;�

2��Q���&78$8�/, 

2��@�Q�&)//87�&?$��?�

2�.*0=;*0=Q�$?B8�/?���

2�.�;�Q�$?B8�/?��0

2�.*�=;�Q�$?B8�/?���

2�.*0=;
*0=Q�$?B8�/?���

2�.�;
*�=Q�$?B8�/?��=

The following illustrations show how the Control Program constructs the
compensated tool path for the NC code above:

Segment 2

Segment 3

Segment 4

Segment 5

Start Point

Tool

P1

P2 P3

P4

P5
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Any G41 or G42 command can include an IJK vector, which defines the
end point direction vector and the end point offset vector. For example, if,
for segment 3 of the previous illustration, we had specified

2��.*�=��G�

instead of just

.*�=

the compensated tool path would look like this:

(D1=.25)

Start Point

Normal Offset 
Vector (Segment 3)

Offset Vector
(Segment 2)

A

Segment 1

Segment 2

Segment 3

Segment 4

B

Offset Vector
(Segment 4)

New Offset Vector
New Direction 
Vector (IJ)C

P1

P2 P3

P4

The IJK Vector represents an incremental direction (the length of the vec-
tor is not important. For example, I1J2<=>I3J6. By default, the end direc-
tion vector is tangent to the segment.
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#������� ������� �"',������"�� 1--����� C+D

Select Setup Offsets from the Setup Menu to set the value for D (the cut-
ter compensation offset value). The following dialog box appears:

�"��$�;���%����#��

�!����������#�
�33
�#���������*�/"���33
�#������
3����33
�#�����������
���	��
�F���*

Select an offset to modify from the list. Change its value in the Value Edit
box, or use the Current Z button to use the current Z position.
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While cutter compensation is active, you can change offsets by specifying
a new offset number with the D code. For example:

��2��

�02��@�.*0=;*0=

��;*0=

��.*0=@�Q�)+8�?��+8/�U�

�=;
*0=

V

In this example, the offset number changes from 1 to 3 in line N4. Be-
cause the value of offset 3 is greater than the value of offset 1, the com-
pensated path moves farther away from the programmed path and is at the
new offset value by the time the tool reaches point C.

���#"�
��4��'��L�@�S*������
@�S*��

B

C

D3=.03D1=.01

Offset Vector

D3=.03

A



(
��,����%���&�&����!������!

The same situation would occur if you made the offset value negative.
For the example above, changing the D value from .01 to -.01 would pro-
duce the same result as changing from G41 to G42.

��������� 1--���� #����

You can change the side of compensation sides during cutter compensa-
tion. For example, you can start cutter compensation to the left then
change to the right while in cutter compensation:

2��

2��@�.*0=;*0=Q� 8�/�&&�?�

;*0=

2�0.*0=Q�7�2(/�&&�?�

�;
*0=

V

In this example, left cutter compensation is on at point A, but right cutter
compensation begins as the tool moves towards point B. In this case, the
offset value (D) is the same for both left and right cutter compensation.

B C

D1D1

D1

D1

A
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(X0,Y1)

(D1)

Start point

Tool

Default Offset Vector

Offset Vector

Direction 
(IJK) Vector

Default Endpoint

������ �"�����1--���� �����%��� !����,"%���"�� C�:BD

The G39 code inserts an arc at the corner of a cutter compensated tool
path. The G39 instructs the cutter compensation function to complete the
current segment by moving to its default endpoint (the endpoint of the Offset
Vector). It then creates an arc (with a radius equal to the offset value),
starting at the buffered segment’s default endpoint, and ending at the end-
point of the offset vector (IJ). Here is an example of an NC program us-
ing G39:

2��

2��@�V

V

;*0=

.*0=

2����G
�Q��&?7�87�?��+8/
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Use the G40 code to cancel cutter compensation. G40 is effective for
only one move. There are six methods for cancelling cutter compensa-
tion.

�9 2��

�9 2��.;C

:9 2��.;C�GA

�9 @�

;9 @�.;C

=9 2��H�0@�.;C�GA

With methods 4 through 6 above, setting the offset number to zero has
the same effect as cancelling cutter compensation. However, cutter com-
pensation is still active.

����"����������

With method 1 the G40 code cancels cutter compensation. The cutter
moves from the offset path to the programmed end point. The same oc-
curs with method 4, where you set the D value to zero.

2��2��@�

V

.*0=

;
*0=

C*0Q�78/7,&/

2��Q�?7�@�

.
*=;
*0=

$0

Center of 
programmed tool path

Start point

G40 
Tool travels to 
programmed path

Center of compensated tool path
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With methods 2 and 5, the G40 (or the D0) cancels the cutter compensa-
tion, but a subsequent motion (X-.5Y-.25) is included in the program.
The tool moves towards the programmed path in the direction of X-.5Y-
.25.

2��2��@�

V

.*0=

;
*0=

C*0Q78/7,&/

2��.
*=;
*0=

$0

Center of 
programmed tool path

Center of compensated tool path

Start point

G40 
Tool travels along compensated 
path towards X-.5Y-.25

ToolX-.5Y-.25
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With these methods an IJK vector specifies the direction of movement af-
ter cutter compensation is cancelled.

2��2��@�

V

.*0=

;
*0=

C*0Q�78/7,&/

2��.
*=;
*0=�
*=G
*0=

$0

Center of 
programmed tool path

Center of compensated tool path

Start point

IJ Vector

Normal vector to IJK

Default end point



(
�� 7�3����%��2����L�+�%#����(

�"��$��3����������#�
'�%�3�������3
#"��%�������#�
�3���#"��
%����!
%��#����#"��%�����#�'�
�#����3��
��
'�%�3�����4�
���%���
�#"�

%����!�%��#���%�������#�*

���
!1�

)
��!�����&����#��
%������
��#����'��%��	�����33�%#�#"��C��4�
�
	"�%"�	�����33�%#�����
'��!���������'#"
��3�%�#
*�)
�
%��#����	"���'��3�����!�
%����!
�'���#���
*

������ #��%���� ����  "����"�� �"���
Scaling codes and rotating codes can be used separately or they can be
combined. Each of these functions is described in the following para-
graphs.

#��%���

Use the scaling codes to scale one or more axes of a part from a fixed scal-
ing origin. You can scale the entire piece uniformly, or set different scaling
factors for each axis. Use the following codes for scaling:

G50 Cancels scaling
G51 Invokes scaling

P Uniform scale multiplier

���-"�'� #��%���

Use a P Code to scale an entire piece uniformly along each axis. When
you specify a value for P, subsequent motions are scaled by that value,
starting from the scaling center. The Control Program measures the dis-
tance from the scaling center to the start and end points of the shape, then
multiplies those values by the P value.

The NC program below creates a half-circle then scales those motions by two
to create a larger, uniformly-scaled half-circle (the scaling codes are in  italics):

��2�C*=

��.�;�*=

�02�C
*����

��20;*=G
*=

��2�C�

����������
��
� ����������� �������� ����� � ��� �

�>2�C*=

��.�;�*=

��2�C
*����

��20;*=G
*=

���2�C�

�����

� ������� �������

The values for X, Y, and Z in line N5 represent the absolute position of
the scaling center. The P value represents the scale factor. In this example,
the entire part is scaled by two. The G50 in line N11 cancels the scaling.
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You can scale each axis by different magnifications. The following NC pro-
gram uses scaling to change the proportions of a motion by scaling each
axis separately (the scaling codes are in bold print):

��2�C*=

��.�;�*=

�02�C
*����

��20;*=G
*=

��2�C�

�;�;�	�6�F
!�9;0�9>;2�M� #��3!��� 1�

�>2�C*=

��.�;�*=

��2�C
*����

��20;*=G
*=

���2�C�

����;
M������3�#��3!��

The values for X, Y, and Z in line 5 represent the absolute position of the
scaling center. The I, J, and K values represent the scale factors for the
X, Y, and Z axes respectively. When scaling each axis individually, you
do not use a P code.
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You can create mirror images of shapes by specifying negative values for I, J,
and K. The NC program below uses negative I and J values to create a mirror
image of the original shape on the XY plane (the scaling codes are in ital-
ics):

��2�C*=

��.�;�*=

�02�C
*����

��20;*=G
*=

��2�C�

����������
�!�"!�#�
� �������� ��

�>2�C*=

��.�;�*=

��2�C
*����

��20;*=G
*=

���2�C�

�����

� ������� �������

The values for X, Y, and Z in line 5 represent the absolute position of the
scaling center. The I, J, and K values represent the scale factors for the X,
Y, and Z axes respectively. Notice the negative I and J values for mirror-
ing on the XY plane. Remember that performing Z axis mirroring is an ad-
vanced operation. Use caution when machining negative Z values.
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Rotation codes allow you to rotate a programmed shape around a rotation
origin. You can rotate a shape on any plane, one plane at a time. Use the
Rotation code to modify an NC program when a work piece has been ro-
tated from the programmed position on the machine.

G68 Invokes rotation
G69 Cancels rotation

Here is an example of an NC program using Rotation (the Rotation codes
are in italics):

��2�C*=

��.�;�*=

�02�C
*����

��20;*=G
*=

��2�C�

���$	��%�	&��%�'(

� '�������� ��� '�������� �'����� ��

�>2�C*=

��.�;�*=

��2�C
*����

��20;*=G
*=

���2�C�

����$(
� ������� '�������

7�#�#����?��!��
D�*=�����*=E
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The X and Y values in line N5 are the coordinates of the rotation origin;
the rotation occurs around this point. The R value represents the absolute
value of the rotation angle. The G69 in line N11 cancels the rotation.

Note that positive R values represent counterclockwise rotation angles;
negative R values represent clockwise rotation angles.

+R -R

Counterclockwise
Positive Rotation Value

Clockwise
Negative Rotation Value

Rotation Origin Rotation Origin
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You can combine scaling and rotation in the same NC program. The portion
of the NC program below combines the scaling and rotation codes neces-
sary to machine the following part (the actual subprogram to cut the shield
(O100) is not listed here).

��Q�@?�/(8�?7�2��, ���7+/

�0$������

��Q��?��+&, 8�-;��H0�,�@�7?/,/8����&&�

��2=�.�*=��;�C��*=G*=A�Q�+&, ��2�?�

�=2>�.�*=��;�*=7��Q�7?/,/�?��?�

�>$������Q�+8&?�@��,7/
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The BXT-4021 allows you to define up to 20 different tools for use during
milling operations. If your machine is equipped with an optional Auto-
matic Tool Changer (ATC), multiple tool programs require very little user
intervention, other than setup.

You will need to define tools, configure the ATC, and write the tool
changes into the NC program. For defining tools and ATC configuration,
the easiest method is to use the Setup Tool Wizard under the Tools menu.
This will walk the user through all the setup steps.

Even if your machine is not equipped with the ATC, you may use the
Wizard. Defining tools is explained in the tutorial on page D-8 of this
guide. Programming codes, reference tools, offsets, and testing are de-
scribed below.

��������%��,%�� 
""%� �"���

The T code is used in the NC program to offset the cutter so that the NC
program becomes independent of the cutter length, which is set up in the
Setup Tool Library dialog box. This means you can replace a worn tool with
a tool of a different length without changing the NC program, just by enter-
ing new offsets. (Any actual tool change is performed manually.) The T
code can be located anywhere within the block of NC code, but it is nor-
mally placed after the G code.

When you place T codes in your program for tool changes, you should
also use the M06 code to retract and shut off the spindle. This code in-
structs the machining center to shut off and retract the spindle to the top of the
vertical column, where it pauses until you manually change the tool. Pressing
the Enter key turns the spindle back on and moves it back to the previous
position to continue with the NC program.
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When using multiple tools, a reference tool, normally Tool #1, is set to
zero for the Z axis. This establishes a reference tool position which is
used as a reference point for additional tools. For demonstration
purposes, we will use Tool #1 as the reference tool and Tool #2 as the
additional tool.

To set the reference tool:

�9 Decide on a reference point (a point on the workpiece, or on a gauge,
where you will jog the tip of each tool).

�9 Install a tool into the spindle.

:9 From the Tools Menu, choose Select Tool. If the tool is not already de-
fined in the pull down menu, see page D-8 to define the tool.

�9 Choose the tool you are using, then click the Select Tool button.

;9 If you are using a Tool Height Sensor (included in the Quick Change
tooling package), place it on the cross slide or other conductive sur-
face.

=9 Using the Jog Control Panel, jog tool #1 to the tip of the sensor until
the lights come on.

>9 Select Set Position from the Setup Menu, set the Z axis value to
zero, and click OK.

Tool #1 is now established as the reference tool.

����4%������� 
""%� 1--����

Now that the reference tool is established, additional tools can be as-
signed offsets. You can move the tool and accept its current Z axis posi-
tion as the offset value, or you can manually enter offset values.

To set the offset for Tool #2:

�9 Install tool #2 in the spindle.

�9 From the Tools Menu, choose Select Tool. If the tool is not already de-
fined in the pull down menu, see page D-8 to define the tool.

:9 Choose the tool you are using, then click Select Tool.

�9 Jog tool #2 to the tip of the sensor until the lights come on.

;9 Select Offsets from the Setup Menu.
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=9 Choose the correct tool (the description that matches the tool you in-
stalled) from the list, and click on the Current Z button at the bottom
of the window. Select OK to save the value.

>9 Repeat this process for each additional tool.

The offset for Tool #2 is now established.


������� 6"�����%��,%�� 
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After setting all of the tool offsets, test run your program without a work-
piece mounted and with the spindle speed turned down.

�9 After installing Tool #1, close the safety shield, put on your safety
glasses, and complete the safety checklist.

�9 Select the Run/Continue command from the Program Menu. Enter
zero as the start block and select the Run Program button. Throughout
the test, be prepared to press the emergency stop switch on the machin-
ing center, or the space bar on the computer keyboard in case of a tool
crash. The computer will run the program until it reaches the M06
code. If your machine is equipped with an ATC, the tool change will
take place automatically, and you may ignore steps 3-7. The M06
code stops the NC program and retracts the spindle.

:9 When the spindle has completely stopped and the Pause message ap-
pears on the screen, push in the Emergency Stop button on the front
panel.

�9 Open the safety shield.

;9 Remove Tool #1 and install Tool #2, making certain it is securely fas-
tened to the spindle.

=9 Close the door, and pull out the Emergency Stop button. Press the En-
ter key on the computer keyboard. The spindle turns on and moves to
the previous position. Operation continues as programmed until the
next M06 code is encountered.

>9 At each pause, repeat Steps 3 through 6, installing the appropriate tool
at the appropriate points in the program.

?9 Edit the program, if required. When you are satisfied that the program
works correctly, mount the workpiece, set the spindle speed, and run
your multiple tool program.
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For a beginning user, understanding coordinate systems can be difficult.
The first thing to remember is before performing most machining operations,
you are required to set the machine to “home” position. This returns the ma-
chine to the machine zero point, and acts as a reference point for all opera-
tions. It is a good idea to home the machine at power on.

�������� �""��������

Machine Zero is the extreme positive end of travel on the X,Y and Z. This
is a fixed point on the machine, and cannot be changed. The machine uses
this as a starting point for all operations. If the machine is not homed (set
to the machine zero) it cannot coordinate the position of the Automatic
Tool Changer, or accurately locate the workpiece on the cross slide. The
machine is homed by selecting Set/Check Home under the Setup Menu,
and choosing the Set Home button; or by using a G28 code in the NC pro-
gram.

�"�)� �""��������

Once home is set, your program will need a point of origin to start from. Set-
ting a point of origin will establish the work coordinates.Work coordinates re-
late to the workpiece, and are usually set from the top of the front left corner
of the workpiece mounted on the cross slide. Once the stock is mounted on
the cross slide, jog the spindle to the top of the front left corner of the
workpiece. From the Setup Menu, select Set Position. The spindle coordi-
nates appear in the dialog box. Click on OK to set the current tool posi-
tion as the point of origin on the workpiece.

��%��,%�� �""�������� #&���'�

For more advanced operations, such as machining multiple parts, you can set
up multiple coordinate systems. For example, three or four workpieces are at-
tached to a pallet, and the pallet is secured to the cross slide. Set the work co-
ordinate point of origin (0,0) at the corner of the pallet using the Set Position
dialog box from the Setup Menu. After setting the corner of the pallet as the
origin, select Coordinate Systems from the Setup menu. The Setup Coordinate
Systems dialog box appears. Select a “User CS”, enter the coordinates for the
first workpiece, and click on Apply. Repeat this procedure  for as many User
CS’ as necessary. (For a detailed description of the Setup Coordinate Systems
procedure, see page E-44.)
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Setting tool length offsets is explained in Establishing Tool Offsets on
page H-25. When you command a tool change in the program and the tool
is loaded, the offset is automatically read as part of the tool information
that was entered when the tool was defined.

However, if you are programming in Fanuc mode, that information is not
recognized. Use the tool length offset codes to adjust the machine for
variations in tool lengths. The tool length offset codes are:

G43 Compensate for a longer tool.
G44 Compensate for a shorter tool.
G49 Cancel tool length offset.

H Specifies the offset number from the offset table. (The Offset
Table you use for Tool Length Offset H values is the same table

G44

Tool

Offset Value

Z0

Offset Value

Tool

G43

you use for Cutter Compensation and Tool Offset Adjust D val-
ues.)

The G43 compensates for a longer tool by retracting the spindle away
from the cross slide. The G44 compensates for a shorter tool by moving the
spindle closer to the cross slide.

The T code normally specifies the tool, its diameter, and offset value.
When you include a G43 or G44, the computer ignores the T code offset
value and uses the offset you assign to H.

Here is an example of the tool length offset code used in an NC program:

$�>

2��/0(�

The M06 code stops the machine. The G43 compensates for a tool that is
longer than the reference tool. The T2 refers to the tool number and the
tool diameter, but not the offset value. The H1 represents the offset value
set in the Offset Table.
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Use these codes for making critical dimension adjustments to the offset
values. When you specify tool offset adjust codes, you can increase or de-
crease the movement distance of the specified axis by the offset value
(D). The tool offset adjust codes are:

G45 Increases the movement amount by the value stored in the offset
table

G46 Decreases the movement amount by the value stored in the offset
table

G47 Increases the movement amount by twice the value stored in the
offset table

G48 Decreases the movement amount by twice the value stored in
the offset table

D Offset value

You must command a motion for tool offset adjust codes to adjust the
offset values. Following are examples of the motions caused by tool offset
adjust codes.

5.5
Actual Movement

Commanded Movement

Offset Value

4.0

1.5

5.5

Actual Movement

Commanded Movement

Offset Value

4.0

-1.5

������ ��;

�9 The offset value increases the actual movement by 1.5 beyond the
commanded movement.

 ��!���#���
������2���#����#��%#
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�9 The negative offset value decreases the actual movement by 1.5 from
the commanded movement. Note that A G45 code with a negative off-
set value is the same as a G46 code with a positive value.
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1.0
Actual Movement

Commanded Movement

Double Offset Value

4.0

3.0

7.0
Actual Movement

Commanded Movement

Double Offset Value

4.0

3.0

5.5

Actual Movement

Commanded Movement

Offset Value

4.0

1.5

������ ��=

The G46 code decreases the commanded movement by the offset value.
Note that the G46 code is the same as reversing the positive or negative
direction specified by the offset value of a G45 code.

������ ��>

The G47 code increases the commanded movement by twice the offset
value.

������ ��?

The G48 code decreases the commanded movement by twice the offset
value. Note that the G46 code is the same as reversing the positive or
negative direction specified by the offset value of a G47 code.
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Two terms used in general machining are feed and cut.

Normal machining on the machining center involves removing material
from the surface of the workpiece. This is accomplished by advancing the
cutting tool into the workpiece by an appropriate amount (depth of cut).

The rate of tool travel is called the feed rate, and is controlled by the X and
Y axis drive motors.The depth of cut is set by the vertical column (Z
axis) drive motor. The depth of cut and feed rate you select should de-
pend on the turning speed of the spindle, the type of material and lubri-
cant used, and the type of cutting tool used for the operation.

Speed
Depth
of Cut

Feed

C
u
t
t
e
r

Stock

Excessive depth of cut and high feed rates place greater strain on the
spindle, may bind the tool and workpiece, or produce a poor surface finish
on the part.
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The relative hardness of the material and the type of cutting tool (end
mill or drill) affect spindle speed. The harder the material is, the slower
the speed should be.

High spindle speeds may produce excess heat which causes the
workpiece to expand. If the workpiece expands, the cutting tool will rub
rather than cut the material, resulting in a poor surface finish. Slow
spindle speeds cause no harm, but may be inappropriate for finishing cer-
tain types of materials.

The load put on the spindle motor must also be taken into account. Heavy
cuts at low speeds will make the motor run hotter than lighter cuts at
higher speeds. The selected feed rate and depth of cut should not cause
the spindle motor to greatly lose speed or cause the tool to chatter against
the workpiece.

.����  ���� ���� #,���%�� #,���� #�%����"�
Feed rate selection for machining parts on the BXT-4021 depends on
factors such as: type of material, type of cut, depth of cut, and spindle
speed. The type of tool chosen to make the cuts also affects the depth of
cut and, therefore, the feed rate. Consult your Machinist’s Handbook for
selecting a feed rate based on spindle speed and material type.
Experience and experimentation will enable you to establish feed rates
best suited to particular applications.
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Cutting tools are usually made from hardened steel and are ground to various
shapes. The clearances ground behind cutting edges are adjusted for the
type of material the tool will cut and the direction the tool will be fed
along the workpiece.

Insufficient clearance behind the cutting edge will cause the tool to rub.
Excessive clearance will produce a ridged or wavy finish due to the small
length of tool edge in contact with the workpiece. Standard tool types are:
end mills, center drills, drills and boring tools. Tools are often ground to
shape by the operator to suit a particular cutting requirement.

���� ��%%�

End mills come in many shapes and configurations. They should be sharp
and must run true. Holding end mills in a drill chuck is a poor practice;
use collets instead. Be certain the spindle speed is set correctly for the
type of material being machined. An end mill can be instantly damaged if
a cut is attempted at excessive speed.

When plunging into the workpiece, use a center cutting end mill. Center cut-
ting end mills have teeth at the end of the mill going into the center of the mill.

Begin with light cuts and progressively increase cuts until satisfactory re-
sults are obtained. End mills should not be used for drilling holes, but they
can be used to enlarge holes.
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Drills and center drills are used to drill holes in a workpiece. Center drills
have a tip that starts the hole before the actual drilling takes place. The
workpiece is mounted in a vise or on the cross slide.

Use small amounts of cutting lubricant with center drills. Clear the drill
frequently, otherwise the tip may clog and twist off even in soft materi-
als.

�"����� 
""%�

Boring tools are used to enlarge or modify a drilled or cored hole in a
workpiece. The workpiece is mounted in a vise or on the cross slide.
Clearance must be maintained behind the cutting point of the tool.

A slow feed rate and frequent tool withdrawals are required with boring
tools because chips cannot freely escape from the hole. Depth of cut and
feed rates must be reduced to avoid chatter.

The tool should not be driven deeply into a hole. When boring a hole
where a flat bottom is required, stop the down feed at least 0.002 inch
above the desired depth of the smaller hole being bored out.
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The following safety rules should be reviewed and practiced by all opera-
tors of the BXT-4021.

����� #�-��&� �%�����

Foresight is better than no sight. During operation any power tool can
throw foreign objects and harmful chemicals into your eyes. Always put
on safety glasses or eye shields before starting up the machining center.
Safety glasses or shields should provide full protection at the sides, as
well as the front of the eyes.

2�"(�6"����������� 
""%

Read this guide carefully before you use the machining center and keep it
readily accessible for quick reference. Know the intended applications
and limitations of the machining center as well as its hazards.

��"�����%%� 
""%�

The machining center has an AC power cord terminated by a three-prong
plug. The power cord should be plugged into a three-hole, grounded recep-
tacle. If a grounding adapter is used to accommodate a two-prong recep-
tacle, the adapter wire must be attached to a known ground. Never re-
move the third prong from the plug on the AC power cord.

2��,� ����#�-��&�#���%�� ���*%���

The safety shield should remain in place whenever the spindle motor is
on or the cross slide is moving.

�����3����#��%�'��#"�
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Make it a habit to check that keys and adjusting wrenches are removed
from the machining center before turning on the machine.

2��,� �����"�)�������%���

Cluttered work areas and bench tops invite accidents.

�/"��� �� +�����"��� ��/��"�'���

Don’t use the machining center in damp or wet locations. Never operate
electrical equipment in the presence of volatile and flammable petro-
leum-based solvents and lubricants.

2��,����������� @����"��� �(�&� -�"'� ���� �8��,'���

Children, and visitors unfamiliar with the hazards of rotating machinery,
should always be kept away from the work area.

*��/���� ������"��H��� ������ -�"'� 1,�������� ���
'��������� ������

Lock and remove the key from the machining center control panel when
the system is not in use.

+"��"��."������
""%

Select the feed rate and depth of cut best suited to the design, construc-
tion and purpose of the cutting tool. It is always better to take too light a
cut than too heavy a cut.
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Select the type of cutting tool best suited to the milling operation. Don't
force a tool or attachment to do a job it wasn't designed to do.

+����� �,,�",�����%&

Don't wear loose clothing or jewelry which can get caught in moving
parts. Wear a hat or net, or tie your hair back to keep it away from mov-
ing parts.

#������ ���� �"�),����

Be certain that you have firmly secured the workpiece  and the cutting
tool in the collet before turning on the spindle motor.

+"��"��1/�������

Keep your footing and balance at all times so you won’t fall into or grab
the moving machine.

��������� �������� 
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Keep cutting tools sharp and clean. Lubricate and clean machining center
components on a regular basis.

+���"������ 
""%�� ��-"��� #��/�����

Always use the emergency stop switch to disconnect power  and disable
the spindle motor before mounting or removing the workpiece, or changing
tools. Do not rely solely on a programmed Pause command to disable ma-
chining center operation.
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Make sure the power switch on the machining center is off before plug-
ging in the power cord.

����  ��"''������ ������"����

To avoid stressing the machining center and creating a hazardous machining
environment, use only those accessories designed for use with the BXT-4021
machining center, available through Light Machines Corporation.
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Tighten the collet. Do not over-tighten tool holding devices. Over-tighten-
ing may damage threads or warp parts, thereby reducing accuracy and effec-
tiveness.

2��,� �""%���� �(�&� -�"'� �%�������%� �"',"�����

Do not allow coolant to splash into or near the computer.

+"��"��1,������ ������������������ ���� !�-%�����
"-��%�"�"%�"��+����

Alcohol or drugs may impair your judgement and reaction time, which
could contribute to an on-the-job accident.

�/"��� +��������"������%��  ������� �����������

Use simple common sense and pay attention while operating any piece of
machinery.
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Before you enter the work area:

❑ Put on safety glasses.

❑ Tie back loose hair and clothing.

❑ Remove jewelry including rings, bracelets and wristwatches.

Before machining a part:

❑ Make sure you have the correct tool for the job.

❑ Secure the tool properly.

❑ Make sure all tool positions have been properly initialized.

❑ Verify the NC program on the computer before machining.

❑ Remove all loose parts and pieces from the machine.

❑ Remove adjusting keys and wrenches from the machine.

❑ Close the safety shield.

❑ Only operate the machine after being properly trained in its use.

❑ Perform a dry run:

❑ Set the spindle speed to lowest manual speed setting.

❑ Make certain there is no workpiece in place.

❑ Run the NC program to make sure all the moves make sense be
fore running the program with a workpiece in place.

❑ After completing the dry run, properly secure the workpiece to the ma-
chine.

❑ Keep fluids away from all electrical connections, electronic or elec-
trical devices, the computer and nearby electrical outlets.

While machining a part:

❑ Do not touch moving or rotating parts.

❑ Press the Emergency Stop button before opening the safety shield.

❑ Only open the safety shield after the spindle has stopped rotating.

❑ Press the Emergency Stop button whenever changing tools or mount-
ing or removing a workpiece.

❑ Pull the Emergency Stop button out only after closing the safety
shield.

❑ Keep all unauthorized persons away from the work area.
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Antes de entrar en el área de trabajo:

❑ Use sus lentes de seguridad.

❑ Procure recogerse el cabello y no usar ropa floja.

❑ No use joyería como:  anillos, pulseras y relojes.

Antes de trabajar a máquina una pieza:

❑ Utilize la herramienta correcta para el trabajo. Asegurela de forma
correcta en el husillo con una boquilla.

❑ Asegurese que la posición de la herramienta de corte ha sido
inicializada correctamente.

❑ Remueva todas las partes sueltas y coloquelas lejos de la Fresadora.
Limpie todos los residuos de la Fresadora después de cada corrida.

❑ Cierre la guarda de seguridad antes de ejecutar cualquier operación
en la Fresadora.

❑ Corra los programas por primera vez con el motor del husillo
apagado y sin pieza de trabajo. Asegurese que todos los movimientos
sean correctos.

❑ Asegure la pieza de trabjo a la mesa. Quite las herramientas y llaves
antes de cerrar la guarda de seguridad.

❑ Asegurese que todos los contactos de corriente A.C. esten
aterrizados.

❑ Mantenga los líquidos refrigerantes lejos de la Caja
de Control, Computadora y cualquier Suministro Eléctrico.

Mientras trabaja a máquina una pieza:

❑ Nunca levante la guarda de seguridad mientras que la Computadora
este ejecutando un programa. Presione siempre primero el botón de
“Paro de Emergencia”.

❑ Presione siempre el botón de “Paro de Emergencia” cuando se
cambie una herramienta, se coloque o remueva una pieza de trabajo.
Jale el botón de “Paro de Emergencia” después de haber puesto la
guarda de seguridad.

❑ Mantenga fuera del área de trabjo a toda persona no autorizada.
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All BENCHMAN operators must be fully aware of how to shut down the
machine quickly, should the need arise.

� In an emergency, you should always use the red Emergency Stop but-
ton on the machine front panel.

� You can also stop the machine by pressing the Control and Space keys
on the computer keyboard, or by clicking on the stop buttons on the
screen with the mouse. But, in an emergency, always use the Emer-
gency Stop button on the machine.
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G00 Rapid traverse

G01 Linear interpolation

G02 Circular interpolation (clockwise)

G03 Circular interpolation (counterclockwise)

G90 Absolute coordinate programming (Fanuc uses U,W):  All X, Y
and Z axes coordinates are relative to a (0,0) location on a mill.

G91 Incremental coordinate programming: Each command is relative
to the one before it in the program.

G70 Inch: Used to instruct the mill that inches are the unit of measure
for the part program. (Fanuc G20)

G71 Metric: Used to instruct the mill that millimeters are the unit of
measure for the part program. (Fanuc G21)

G04 Dwell (wait): Equals the value of the feed rate (F code) in seconds
(used primarily for robotic operations). G04 excludes motion
commands with a new feed rate on the same line (block).

G05 Pause: Used for operator intervention. The order of action for the
pause and dwell codes in one NC block is G05, G04 (pause,
dwell).

G25 Wait for robot input to be high: Used in conjunction with H code,
which specifies input number. Used for robot synchronization.

G26 Wait for robot input to be low: Used in conjunction with H code,
which specifies input number. Used for robot synchronization.

G31 Linear to specified coordinate. Stop short if specified input goes
High (if H is positive) or Low (if H is negative).

G131 Specifically for digitizing with the probe. The user specifies a Z
position and a feedrate. The probe moves from its current position
to the specified Z position at the specified feedrate (or current
feedrate if not specified on the same block). If the probe input is
tripped before reaching the specified Z position, a valid point is
captured. In either event (point or not point), when the probe stops
moving down, it rapids back to the initial Z position.

!����,"%���"�
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G15 Polar programming cancel.

  G16 Begin polar programming.

G53 Rapid traverse to specified coordinates in the Machine Coordinate
System. (e.g. G53X0Y0Z0 rapids to machine reference point)

G54 Use coordinate system one.

G55 Use coordinate system two.

G56 Use coordinate system three.

G57 Use coordinate system four.

G58 Use coordinate system five.

G59 Use coordinate system six.

G80 Canned cycle cancel.

G81 Canned cycle drilling.

G82 Canned cycle straight drilling with dwell.

G83 Canned cycle peck drilling.

G84 Canned cycle tapping.

G84.1 Canned cycle rigid tapping.

G85 Canned cycle boring.

G86 Canned cycle boring with spindle off (dwell optional).

G89 Canned cycle boring with dwell.

G27 Check reference point: This code moves the tool to its home position
on the machining center to check the calibration of the axes. Compares
reported position against zero to see if position has been lost.

G28 Set reference point: This code moves the tool to the home position on
the machining center and calibrates the axes. This position is the Ma-
chine Coordinate System point of origin.

G29 Return to reference point: Moves the tool to a coordinate specified by
XYZ. Typically used after a G27 or G28 code.

G92 Set position: This code works like the Set Position function under the
Setup Menu (see Section 3). The X, Y and Z coordinates following a
G92 code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle complete (Section
5).

G99 Rapid move to point R (surface of material or other reference point)
after canned cycle complete (Section 5).

*"%��� *�"���''���
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G17 Select the X,Y plane for circular interpolation. This is the default
plane for circular interpolation. Use this code to switch back to the
X,Y plane after circular moves on the X,Z or Y, Z planes. The arc
center coordinates are given by I for the X axis and J for the Y axis.

G18 Select the X,Z plane for circular interpolation. Use this code to per-
form circular interpolation on the X,Z plane. The arc center coordi-
nates are given by I for the X axis and K for the Z axis.

G19 Select the Y,Z plane for circular interpolation. Use this code to per-
form circular interpolation on the Y,Z plane. The arc center coordi-
nates are given by J for the Y axis and K for the Z axis.

G50 Cancel scaling.

G51 Invoke scaling. Use this code to scale axes with independent factors
around a fixed origin. The default is 1.

G68 Invoke rotation. Use this code to rotate a geometry from its origin by
an arbitrary angle. Rotation works on any plane, one plane at a time.

G69 Cancel rotation.

G39 Corner offset in circular interpolation.

G40 Cancel cutter compensation.

G41 Invoke cutter compensation left.

G42 Invoke cutter compensation right.

D Specifies the offset number from the Offset Table.

G43 Shifts Z axis in a positive direction by a value specified by H.

G44 Shifts Z axis in a negative direction by a value specified by H.

G49 Cancel Tool Length Offsets.

H Specifies the offset number from the Offset Table.

G45 Increases the movement amount by the value of D.

G46 Decreases the movement amount by the value of D.

G47 Increases the movement amount by twice the value of D.

G48 Decreases the movement amount by twice the value of D.

D Specifies the offset number from the Offset Table.

*%���� #�%����"�
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  M00 Pause: Allows you to place a pause in your code. Acts like a G05
pause.

  M01 Optional Stop: Allows you to place an optional stop in your code.
Place an M01 in the block of code where you would like to pause.
With Optional Stop on, the M01 works like a G05. With Optional
Stop off, the M01 code is ignored, the other codes on the block are
executed as usual.

  M02 End of Program: Takes effect after all motion has stopped; turns off
drive motors, spindle and accessory outlets.

  M30 Program stop: Same as M02.

  M03 Spindle Motor On: Activated concurrently with motion specified in
the program block; remains in effect until superseded by M05.

  M05 Spindle Motor Off: Activated after the motion specified in the pro-
gram block; remains in effect until superseded by M03.

  M06 Tool Change: Used in conjunction with a T code to perform multiple
tool operations. See Section F.

  M08 Coolant On: Turns on coolant concurrently with the motion specified in
the program block; remains in effect until superseded by M09.

  M09 Coolant Off: Turns off coolant; remains in effect until superseded by
M08.

  M10 Clamp ACC2: Turns on ACC2. Closes air vise accessory concurrently
with the motion specified in the program block; remains in effect until
superseded by M11.

  M11 Unclamp ACC2: Turns off ACC2. Opens air vise accessory after the
motion specified in the program block; remains in effect until super-
seded by M10.

*�"���'� #�",E���� ��"�,
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  M20 Chain to Next Program: This code appears at the end of a part pro-
gram and is followed on the next line by the file name of another pro-
gram which is executed when all motion stops. Here’s an example of
a part program chain to another program:

N37Z.2
N38M20
PROGRAM TWO

If the two programs you are chaining are not in the same directory,
you must specify the full pathname for each file. If the specified file is
not found, the Open dialog box appears so you can locate it.

  M22 Output to file: Outputs information to a file. The first time the Control
Program encounters an M22 code, it opens the specified file. You
must enclose the name of the file in parentheses for the Control Pro-
gram to recognize it.

The proper format for using this code is: M22([filename.ext [,A]])
[text and macros]. Items in brackets [ ] are optional, except that a
filename is required for the first M22. If no text is specified to be out-
put to the file, the current axis positions are output. M22 automati-
cally adds a tilde (~) to the output text, so the next M22 starts on a
new line in the file.

If you use more than one M22, only the first occurrence must have the
filename in the parentheses. The remaining M22's may have empty
parentheses, ( ). If you want to generate more than one file at a time
you must include the filename each time you specify M22. If a filename
is not specified, the first file opened is used.

Following is a list of special codes that can be used with M22 to gen-
erate run-time reports.

@X Current X position (in current coordinate system)
@Y Current Y position (in current coordinate system)
@Z Current Z position (in current coordinate system)

~ (tilde) New line (starts a new line in the file)
@TD Time of day (12hour): “11:59:59AM”
@TC Time (elapsed) for cycle: “99:11:59” (0’s trimmed from

left)
@TT Time total (of program run): “99:11:59”
@TA Time Average (per cycle): “99:11:59” (“??:??” if first

part)
@TL Current tool number:  “5”

@C Cycle number (current pass): “3”
@D Date: “12/31/94”

@FN Current file (without path): “PART.NC”
(“UNTITLED.NC” if untitled)

\t Tab
\\ Outputs a single backslash character to the file

The M22 code supports multiple output files. The first occurrence of
a filename opens the file. In the name M22(FILE.OUT,A) TEXT...
the output is appended to the file (if it exists). Each unique filename
opens a separate file. For backward compatibility, empty parentheses
M22( ) TEXT... cause the M22 output to go to the first file that was
opened with an M22.

*�"���'� ������'���� ��"�,
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  M47 Rewind: Restarts the currently running program; takes effect after all
motion comes to a stop. Use the L code to repeat a finite number of
times. The L code defines the number of times to run. For example,
M47L2 rewinds twice.

  M98 Call to subprogram

  M99 Return from subprogram: Returns you to the block following the ini-
tial M98 command.

Go to: Used with P code. P code defines N code destination. Goes to
first occurrence of N code within the main program. The N code can
not follow any subprogram (O code).

M105 This command is used to display messages in the Control Program.

M122 Output current position to file. Almost identical to M22, except that if
a macro (@X@Y@Z) is used to insert a coordinate, the position of
the digitized point will be used, rather than the current machine posi-
tion.

  M25 Set device output: Used for external device synchronization. Used in
conjunction with H code to specify output number.

  M26 Set device output: Used for external device synchronization. Used in
conjunction with H code to specify output number.

� !E1���"�,
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