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Before connecting and running your new Turning Center, you should:

01 Check your shipment to make sure you received everything you need.

2. Register your Turning Center so you are covered by your warranty.

21 Prepare a work space for the Turning Center and controller.

31 Unpack and set up the Turning Center.

41 Install the interface card in the computer.

Once these procedures are complete, connect the spectraLIGHT Turning
Center and Controller Box to your personal computer, and install the Control
Program.
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The first thing you must do after receiving your Turning Center is inspect
the packaging for any visible signs of damage. If there is damage to the outside
packaging, contact the shipping company as well as Light Machines Corp.
After checking the packaging, locate the packing slip. This slip lists all of the
items you should have received with your Turning Center. Check all of the
items on the list. If any item is missing, contact Light Machines' Customer
Service Department (800/221/2763).

The Turning Center components include:

� spectraLIGHT Turning Center

� Controller Box

� Interface Card

� Control Program Software

� Documentation

� Accessory Kit

#�������
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You’ll find a registration card in the small box with the documentation and
software disks. Clearly print all the requested information and return this
card to Light Machines Corporation.
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Make sure you have all the items on hand necessary to perform the installation.
To install the spectraLIGHT Turning Center, you must have:

� A sturdy table on which you’ll place the Turning Center and your com-
puter. Placing the table against a wall provides more stability. Make sure
the wall has a 120VAC, 15 Amp polarized outlet, or a 220VAC, 8 Amp
outlet for international users.

� A personal computer running Windows 95 or Windows NT version
3.51 (or greater). See page A-19 for a complete list of the necessary
computer equipment.

� Your PC Owner’s Manual or equivalent documentation.
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For each standard Turning Center you order, you should receive two large car-
tons. One carton contains the Turning Center. The other carton contains the
Controller Box, the Interface Card, the Control Program software, the docu-
mentation, and the Accessory Kit.

01 Unpack the Controller Box container and use the packing slips to con-
firm that you have received all the items listed.

81 Open the Turning Center container and remove the foam inserts.

21 Lift the Turning Center out of the box and onto the table.

31 Inspect the Turning Center chassis for signs of visual damage such as a
broken shield, a dent in the chassis, or damaged cables. If any damage is
noted, or if you find any discrepancies between the packing slips and the
items received, call Light Machines’ Customer Service Department (800/
221/2763).

41 Remove the protective paper from the safety shield.
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The following paragraphs review the procedures for installing the hardware
components of the spectraLIGHT Turning Center. You should already have
your personal computer set up in accordance with the directions in the com-
puter owner’s manual.

The first thing you have to do is install the spectraLIGHT Interface Card in
your personal computer.
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The Interface Card can be installed in any full-size slot designated for expansion
card use. Refer to your computer owner’s manual to determine particular expan-
sion card restrictions.
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To install the Interface Card, you must remove the cover of the personal
computer. Refer to the installation instructions supplied with your computer
for details on removing the cover. Generally, the cover is secured by four
screws through the rear panel; however, some personal computers may have
push latches, or screws in different locations.
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Set the cover aside and locate an open slot in which to install the Interface
Card. Remove the blank slot cover (if any). Removing the slot cover requires re-
moving a screw at the top rail of the rear panel. You may choose to discard the
cover, but save the screw for installing the Interface Card.
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The card is shipped inside an antistatic envelope. Be careful not to create any
static discharge when removing the card from the envelope; touch a
grounded surface such as the PC enclosure first. Slide the card out of the
envelope and inspect it for signs of damage, such as bent or broken compo-
nents or a warped circuit card. If damage is noted, contact Light Machines
Corporation immediately.
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The following procedures describe how to insert and secure the Interface Card
in the computer.

01 Grasp the Interface Card at the front and back.

81 Position the card above the bus connector at the chosen slot. The inter-
face connector on the end of the card should face the rear panel of the
computer chassis.

21 Slide the card into the bus connector. The interface connectors on the card
should protrude from the rear panel of the computer. Carefully wiggle
the Interface Card back and forth to assure its tightness in the bus con-
nector. Components on the Interface Card should not touch adjacent
cards or other components.

31 Secure the Interface Card to the top rail of the rear panel with the screw
you saved when removing the blank slot cover.

41 Pay particular attention to the location of the slot in which you inserted
the Interface Card. Do not get the Interface Card mixed up with the par-
allel port or serial port which use the same types of connectors.
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After installing the Interface Card, replace the computer chassis cover. Connect
the computer power cord and turn the computer on. The computer should
perform an internal check, then start the Windows operating system.

If the PC fails to start-up, turn off the power, open the chassis and check
your installation to be sure that the Interface Card is located in an appropriate
slot and is properly seated.

When the C:> prompt appears, turn off the power and install the other hard-
ware components.
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The following paragraphs review the procedures for connecting your computer
with the Turning Center and Controller Box. The Interconnection Diagram on
the following page has been provided as a visual aid for the recommended con-
nections.
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The interface cables and power cords are long enough to allow the Controller
Box to be located up to five feet away from the Turning Center. Make sure the
Turning Center is placed on a stable, flat surface and leveled properly.

The Controller Box can be placed beside the Turning Center, or mounted on a
shelf beneath the Turning Center. Make sure the power switch on the front of
the Controller Box is readily accessible. Keep in mind that you may need to
check the fuses on the rear panel of the Controller Box. Locate the Controller
Box in an area where it will not be exposed to metal chips or cutting fluid.
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01 Route the Spindle  Power Cable from the Turning Center to the Con-
troller Box as shown in the Interconnection diagram.

81 Insert the AC power plug from the Turning Center's Spindle Power
Cable into the three-prong receptacle marked SPINDLE on the rear
panel of the Controller Box.

21 Insert the 15-Pin plug from the Turning Center into the 15-Pin
receptacle marked A & B AXES on the rear panel of the Controller Box.

31 Make sure the 15-Pin Connector is secured with screw locks.
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The Interface Card/spindle cable is attached to the rear panel of the Turning
Center and is terminated with a 9-Pin plug. Insert this plug into the 9-Pin re-
ceptacle on the computer Interface Card you installed earlier.
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01 Route the 25-Pin Interface/Controller Cable between the Computer and
the Controller Box.

81 Connect the end of the cable marked COMPUTER to the 25-Pin connector
protruding from the LMC Interface Card in the rear of the computer. As
mentioned before, make sure you are plugging the cable into the Interface
Card connector, not the parallel port.

21 Connect the other end of the cable to the 25-Pin connector marked
COMPUTER on the rear panel of the Controller Box.

31 Make sure all connectors are secured.
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MOTOR DRIVES    MAIN

3A                  12A

ACC 2             ACC 1          SPINDLE

3A                  3A                   5A

COMPUTER                  TTL I/O                               A & B AXES                                   C AXIS

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE

120VAC, 60Hz, 15A

120VAC, 5A    

120VAC, 3A

SPINDLE

ACC1

ACC2

120VAC, 3A

fuse fusefu
se fuse fusefu
se

fuse fusefu
sefuse fusefu
se fuse fusefu
se
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The  Controller Box must be plugged into a grounded 120VAC, 60Hz, 15A
polarized wall outlet (220VAC, 50-60 Hz, 8A for International Users), as
shown in the Interconnection Diagram. This outlet must be capable of sup-
plying up to 12 Amps (6 Amps) of power to the Controller Box.

Locate the loose power cord that came with the Turning Center; this is the
power cord for the Controller Box. Insert the receptacle end of this cord into
the 120VAC (220VAC) three-prong connector on the back of the Controller
Box. Insert the plug end of this cord into a grounded, three-hole, 120VAC,
60Hz (220VAC, 50-60Hz) wall outlet.
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If you are an international user and you need to change the plug on the end
of the electrical cord to accommodate 220VAC, 50 Hz service, the wiring is
color coded as follows:

Line: white

Neutral: black

Ground: green with a yellow stripe

MOTOR DRIVES    MAIN

3A                  12A

ACC 2             ACC 1          SPINDLE

3A                  3A                   5A

COMPUTER                  TTL I/O                               A & B AXES                                   C AXIS

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE

120VAC, 60Hz, 15A

120VAC, 5A    

120VAC, 3A

SPINDLE

ACC1

ACC2

120VAC, 3A

fuse fusefu
se fuse fusefu
se

fuse fusefu
sefuse fusefu
se fuse fusefu
se

1.5A              1.5A         2.5A 

1.5A                6A

220-240VAC, 2.5A          220-240VAC, 1.5A

220-240VAC,1.5A 220-240VAC, 50Hz, 6A
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A three jaw chuck is a standard accessory for the spectraLIGHT turning
Center. Installation instructions for the chuck follow.

01 Remove any device attached to the Turning Center spindle.

81 Insert the Spindle Locking Pin (from the Accessory Kit) through the
hole in the spindle to lock it in place.

21 Holding the Locking Pin with one hand, thread the chuck onto the
spindle nose and hand tighten securely. Remove the Locking Pin.

���� '����� '����
2����9��



!��
�''�
��� �+��

#��
����

�����

�����0�
��
	�����
��''��
<�1��$���
	���

�����0�9��
�� ��
�����&'�

'����

4���/��
	�����
�

�/��
���(����
	���'$�
�� ��(�
	���

�����0�9��
�� ��
�����&'�
&�(���������
�����
���
��
	���

�����0

����

������
	�����
��''���<�1�

MOTOR DRIVES    MAIN

3A                  12A

ACC 2             ACC 1          SPINDLE

3A                  3A                   5A

COMPUTER                 TTL I/O                              A & B AXES                                  C AXIS

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE

120VAC, 60Hz, 15A

120VAC, 5A    

120VAC, 3A

SPINDLE

ACC1

ACC2

120VAC, 3A

fuse

fuse
fuse

fuse

fuse
fuse

fuse

fuse
fuse

fuse

fuse
fuse

fuse

fuse
fuse

Accessory Port Adapter Cable

Plug end
(to ACC1 on the 
Controller Box)

Receptacle end

Power Cord 
(from an Accessory)
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If you have purchased the optional Air Chuck, plug the power cord from the
solenoid valve on the vise into the receptacle end of the accessory port adapter
cable. Plug the other end of the accessory port adapter cable into the recep-
tacle labelled ACC 1 on the rear panel of the Controller Box.

You can also connect a second 120VAC accessory to your lathe. Plug the
accessory’s power cord into the receptacle end of another accessory port adapter
cable. Insert the plug end of the cable into the receptacle labelled ACC 2 on
the rear of the Controller Box; the current draw for such accessories, however,
is limited to 3 amps.

A 9-Pin male connector (labeled TTL I/O) is provided on the rear panel of
the Controller Box for interfacing to an I/O device such as a robot. See the
Reference Guide, Section L for details on interfacing with robots.
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The following paragraphs describe the installation procedures for the Auto-
matic Tool Turret option.
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After you install the Control Program software on your computer, run the
Setup.exe  program that was installed in the WSLT program group. In the
Configure WSLT Window that appears, select the Control tab. You must
check Tool Turret Installed on the Turret Settings box before you can use
the turret on the spectraLIGHT Turning Center. You will need to adjust
your NC coding for tool turret installation.

!����������
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It is important to understand that since the turret is mounted on the backside
of the cross slide (on the backside of the workpiece), the polarity of the X axis is
reversed. Therefore, you will see references to this reversed X axis situation
throughout this guide.

The reversal in X axis polarity does not mean you must program in the -X
quadrant to get your programs to work. Write your NC programs as you
normally would, in the +X quadrant, and the Control Program software will
take care of the conversion by your indication of the installed tool turret, and
normal or frontside versus backside operation. The only type of program-
ming you should not consider with the turret is cutting from backside, which
is now the front side.



!��
�''�
��� �+�)

	���������
� �
������

(����
� �
������

To mount the turret body onto the top edge of the cross slide, align the T-
nuts on the turret body with the cross slide slots. Slide the turret along the
slots until the turret is approximately .875" from the upper edge of the cross
slide. Tighten the four socket head cap screws using a 5/32" hex key. The
stepper motor on the turret body should extend out over the X axis stepper
motor.
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Attach the 9-pin connector from the turret stepper motor to the 9-pin con-
nector on the Turning Center as shown.

You'll find an 8-Pin round connector on the rear panel of the Turning Cen-
ter. This is the turret interface connector.

Use the cable with an 8-Pin circular connector at one end and a 9-pin con-
nector at the other end to connect the Turning Center to the Controller
Box. Insert the 8-Pin circular connector of the cable into the 8-Pin circular
receptacle on the rear panel of the Turning Center. Push and turn the con-
nector collar to lock the connector in place.

Insert the 9-pin connector of the cable into the mating 9-pin connector la-
beled C AXIS on the rear panel of the Light Machines Controller Box (see
Interconnection Diagram on following page). Tighten the screws on the
connector.
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To complete the turret installation, you must alter a connection to change
the sense of the limit switch. This is to accommodate the reversal in X axis
polarity mentioned earlier.

Turn the Turning Center onto its side (spindle side down) so you can safely
reach the connectors underneath. If you look under the Turning Center, you
can see that there are several small white connectors. Locate the two connec-
tors marked NT (for non-turret) and L (for limit). They should be con-
nected to each other.

To disconnect the NT and L connectors, press down and hold the lever on
the L connector and pull them apart.
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Locate the connector marked T (for turret). Connect the L and T connec-
tors. You will be able to feel the two connectors “snap” together. Carefully
lower the Turning Center back onto it’s feet.
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31 Using the 3/16 pan head machine screws that came with the extension
bracket, attach the extension bracket to the adjustable bracket as shown
above.

41 Attach the limit switch to the opposite end of the extension bracket, us-
ing the two screws that you retained earlier.

:1 Return the adjustable bracket to its original position on the bed and
tighten the thumb screw.
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With the tool turret mounted to the cross slide, the tool turret face may hit the
chuck with the limit fully extended. The solution to this problem is to attach
an extension that moves the limit switch out far enough so the tool turret
face does not contact the chuck. To install the extension:

01 Locate the Z limit switch on the lathe bed. (For the location of the limit
switch, see the illustration on page B-3). The limit switch is fastened to
the bed by an adjustable bracket. Loosen the thumb screw to remove the
adjustable bracket and, therefore, the limit switch from the lathe bed.

81 Remove the screws that hold the limit switch onto the adjustable
bracket. Retain the screws, you will use them again later in this proce-
dure.

21 Remove the extension bracket (and accompanying 3/16 pan head ma-
chine screws) from its package. The extension bracket can be found in
the Accessory Kit that was shipped with the Turning Center.
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The tool turret will support up to eight different tools at one time. All tools
must be mounted upside down in the tooling plate since, when using the
tool turret, the workpiece rotates in a clockwise direction which brings the
material into the tool from the bottom, up.

The tooling plate has three slots (1, 3 and 7) for holding right-hand, left-
hand, profiling and external threading tools, and four holes (2, 4, 6 and 8)
for holding boring, drilling and internal threading tools. Tool position 5 is
for the cut off tool. To mount a tool, lay it in a slot, or insert it in a hole, and
tighten the two set screws.
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The spectraLIGHT Control Program runs on a 586/120MHz  personal
computer. The computer must have:

� Windows 95 or Windows NT 3.51 or higher. (Windows NT users:
check the Readme file for new information).

� 16MB RAM minimum for Windows 95. 20MB RAM minimum for
Windows NT.

� A 3.5" floppy drive.

� A hard drive with at least 5MB of available space.

� An available expansion slot.

� VGA graphics controller and monitor.

� A Windows-compatible mouse.
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The spectraLIGHT Control Program must be installed on the hard drive on
your computer. The spectraLIGHT Control Program is shipped on two
3.5", 1.4MB  disks. The Control Program must be installed on a hard drive
running either Windows 95, or Windows NT version 3.51 (or higher). You
must have at least 5MB of free space on your hard drive to perform this in-
stallation. (See above for system requirements.)
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The following instructions assume that your hard drive is drive C, and your
floppy drive is drive A.

01 Turn on the computer. Wait for it to go through its internal checks and
for it to complete the start up process.

8. When your Windows desktop appears, insert the spectraLIGHT disk in
the computer floppy drive.

21 Using the Windows Explorer, (Start Menu>Programs>Windows
Explorer) open the floppy drive. Note: If you are installing on Windows
NT, use either the File Manager to access the floppy drive, or select
"Run" from the Program Manager.

31 Double click on Setup.exe to start the installation.

41 The Welcome screen appears. You are warned to exit all other running
programs. If no other programs are running, click Next.

:1 The next screen requests that you enter the destination directory for the
Control Program. If you would like to place the Control Program in a
directory other than the default directory, click on Browse and select an
alternate destination. Otherwise, click Next.

>1 A window appears, displaying installation progress, and prompting you
on how to proceed. After installation is complete, you are prompted to
view the Readme file. It is beneficial to view the Readme file at this time
because it contains important information about the software and the
lathe that may not be included in this guide.

?1 Run the Control Program by double clicking the program icon.

@1 If running Windows NT, you need to reboot the computer.
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In the event you need to remove the Control Program from your hard drive,
there is an uninstall program included on the software disks. The uninstall
program was copied onto your hard drive when you installed the Control
Program.

To uninstall the Control Program, just double click the Remove Program
icon (it should be in the same folder as the Control Program). A message ap-
pears asking if you are sure you wish to remove the program and all its files.
Click on Yes to uninstall, or Cancel to exit the Uninstall program.
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The Control Program automatically sets most variables for you.

If you will be using the Automatic Tool Turret, you must confirm this in the
Configure WSLT Window. Choose the Control tab, and on Turret Settings,
check Tool Turret Installed.

If you need to access the Setup Program for other configurations, see the
Reference Guide: Section E in this manual.
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If you are experiencing start-up problems after installing the Control
Program software, check the items listed below.

� Are the computer and monitor adequately supplied with power from
an AC outlet?

� Is the monitor correctly connected to the computer?

� Are all the interface connections secure?

� Are the monitor and the computer turned on?

� If you are using a mouse, was the mouse driver software loaded be
fore the Control Program software?

� Do you have enough memory on the computer to run the Control
Program? More RAM can be gained by closing other applications.

If the WSLT Window is still not displayed after following the steps in the
Control Program Installation process, refer to your PC Owner's Manual or
call Technical Support for assistance.
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Should you require technical assistance, contact your local Light Machines
dealer. If you are unable to resolve your problem through your local dealer, free
technical support is available by phone, fax or email from 8:15 A.M. to 5:00
P.M. EST.
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Make sure you have the following information gathered before contacting
our Technical Support group.

� The product serial number.
� The name of the owner of the product.
� The specifications of your computer (e.g. hard drive size, clock speed, etc.).
� Notes on any Control Program error messages.

When you call, make sure you have access to both your Turning Center and
your computer. This will allow our technical support representatives to walk
through the problem with you. Our technical support numbers are:

U. S. (800) 221-2763
Canada (800) 637-4829

Fax (603) 625-2137
email support@lmcorp.com

WWW Site http://www.lmcorp.com/lmcorp

,�������

Light Machines' products (excluding software) carry a one-year limited war-
ranty from date of purchase. Defective products may be returned for repair or
replacement according to the conditions outlined in the Terms and Conditions
of Sale agreement. If you need to return a product, call Light Machines and a
Technical Support representative will issue you a Return Materials Authori-
zation number (RMA). You must write the RMA and your return address on
the outside of the product carton or crate. Failure to do so can result in a de-
lay in the return of your product.
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The spectraLIGHT Turning Center is a two-axis tabletop lathe which you can
run directly from your personal computer. The spectraLIGHT Control Pro-
gram, which you load onto your computer, accepts standard EIA RS-274D
G&M codes that CNC machine tools recognize. You'll find a comprehensive
list of options and accessories for the spectraLIGHT Turning Center on the
last page of this guide.

&�������

Some of the spectraLIGHT Turning Center’s most notable hardware and
software features include:

� X axis travel of 4.6 inches (116mm)

� Z axis travel of 6 inches (152mm)

� Feed rates up to 12 ipm (rapid traverse up to 30 ipm)

� Feed rate and spindle speed override functions

� Tailstock

� EIA RS-274D standard G&M code programming

� Multiple tool programming

� Computer-controlled spindle speeds from 200 to 2,500 RPM

� A built-in full-screen NC program editor

� User's Guide and Introduction to CNC Workbook

� An on-line help utility

� Safety shield and limit switches

� Emergency stops from the Turning Center and computer keyboard

� �
�������
������
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There are, of course, more components on the Turning Center than those
shown here, but, to begin, you need only be concerned with the depicted
major components.
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The Safety Shield encloses the turning area to help protect the operator from
flying chips. A magnetic Shield Interlock Switch prevents the machine from
operating with the shield open.

The X and Z motion of the machine is performed by Stepper Drive Motors on
each axis. There is an adjustable Limit Switch mounted under the chuck  to
prevent the machine from crashing.

The  Spindle Head supports a 1/2 hp DC permanent magnet Spindle Motor.

You can’t miss the most important control on the machine; the Emergency
Stop button. When pressed, this bright red palm button immediately halts
machine operation. To resume operation, the button must be pulled back
out. It’s important that this button be pressed before performing any manual
operations, like changing the stock or the tooling.

Use the Spindle Speed switch to establish the spindle speed. The min and
max positions on the switch are equivalent to approximately 200 (min) to
2,500 (max) RPM. Use the Computer position when you want to set spindle
speeds from the Control Program.

Emergency Stop
Button

Spindle Speed
Switch

X Axis
Drive Motor

3-Jaw Chuck

Tool Post

Safety Shield

Z Axis 
Drive Motor

Tailstock

Lathe 
Bed

Cross
Slide

Limit 
Switch

Safety Interlock

Adjustable Limit Switch
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The Controller Box houses the power- and interface-related controls for the
machine. The power switch and keylock switch are on the front panel of the
box. The Key Lock switch keeps unauthorized persons from turning on the
machine. Once the Key Lock is in the unlocked position, the Power switch
can be turned on. The Power switch lights up when power is on.

The rear panel houses the power and interface connectors, and the fuses. The
machine has five fuses; for Main Power, the Spindle, the Stepper Motors,
and the two accessory outlets (labeled ACC 1 and ACC 2). The values for
these fuses are clearly printed next to the fuse receptacles. Do not use fuses
with amperages other than those shown on the machine.

The interface connectors are used to interface the Controller Box with the
Turning Center and your computer. Cables are provided in the Accessory
Kit for this purpose. Refer to Section A for correct installation procedures.

MOTOR DRIVES    MAIN

3A                  12A

ACC 2             ACC 1          SPINDLE

3A                  3A                   5A

COMPUTER                  TTL I/O                               A & B AXES                                   C AXIS

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE

120VAC, 60Hz, 15A

120VAC, 5A    

120VAC, 3A

SPINDLE

ACC1

ACC2

120VAC, 3A

fus
e fusefuse

fus
e fusefuse

fus
e fusefuse
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e fusefuse
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e fusefuse
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The Accessory Kit that comes with the Turning Center contains all the tools
and hardware necessary for installing and maintaining the Turning Center. It
also contains a collet and tools to get you started; other tool holding devices
and tools are available as options.

The accessories that come standard with the Turning Center are:

� One indexable Tool Holder

� One carbide profiling tool

� One spindle locking pin

� Five Allen keys (5/32", 3/32", 1/8", 5/64", and 9/64")

� One 25-Pin Cable

� One AC Power Cord

�B����*��
)������

Light Machines Corporation offers a variety of Turning Center accessories,
CAM software, curriculum and documentation. For more information
about these products, call your local Light Machines dealer, or call Light
Machines directly at (800)221-2763 or (603)625-8600.

A convenient listing of products is located on the last page of this User's
Guide.
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Performing preventative maintenance, like routine cleaning, lubrication, and
correct adjustment, on your spectraLIGHT Turning Center ensures a longer,
trouble-free life for the machine.
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Gibs are fitted at the rear of the saddle and on the right-hand side of the
cross slide. A gib is a wedge that is adjusted by loosening the gib locking
screws and pushing the gib inward until any play is eliminated. Correct ad-
justment of the gibs will ensure smooth and steady operation of the slide.

If any end play develops in the main spindle, it can be eliminated by readjusting
the preload unit.

01 Remove the upper safety shield from the Turning Center. Remove the
drive belt.

81 Remove the main pulley from the spindle.

21 Loosen the setscrew and tighten the preload nut while turning the
spindle until the play is removed.

31 Tighten the preload nut just enough to remove excess play or the bear-
ings may be damaged (0.0002-inch play is recommended).

'����

4�$
����
'��������� �'$&��
�
������� 

����

�� 5$�
���
��(�
	����&����''
���$�����'���������'�(��



���

���!"�#��0�
������ ���� <+,

��<������
� �
����
�����
� ����
��������

You should periodically inspect the lead screw bearings because they can
loosen over time. These brass bearings are mounted on the lead screw next
to the flexible couplings on each axis. Tighten the bearings whenever you
measure the backlash and it is more than 0.008-inch, or whenever you see a
gap between one of the bearings and the cross slide.
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01 There is a black boot covering the lower portion of the flexible
coupling. Loosen the set screw that is visible above the black boot.

81 Slide the black boot up to expose the lower half of the flexible coupling.

21 Loosen the set screw on the lower half of the flexible coupling.

s p e c t r a L I G H T
T u r n i n g C e n t e r

LIGHT MACHINES
C O R P O R A T I O N

M A N C H E S T E R ,  N E W  H A M P S H I R E ,  U . S . A .

EMERGENCY STOP

Spindle Speed

Computer

MaxMin

Boot
Flex 
Coupling

Set Screw

Lift boot to reveal lower 
portion of coupling

Set 
Screw
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31 Press the lathe table toward the front of the Turning Center by exerting
pressure on the stepper motor.

41 While still pressing the stepper motor, press the flexible coupling in the
same direction.

:1 While holding the stepper motor and flexible coupling in place, tighten
the lower set screw, then release the flexible coupling and stepper motor.

>1 Slide the boot down and tighten the top set screw.
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31 Pull the cross slide toward the Z axis stepper motor.

41 While still pulling the cross slide, press the flexible coupling in the oppo-
site direction, toward the cross slide.

:1 While holding the cross slide and flexible coupling in place, tighten the
lower set screw, then release the flexible coupling and cross slide.

>1 Slide the boot down and tighten the top set screw.



���

���!"�#��0�
������ ���� <+�

#��������
� �
�����
�����
������
'��

If the backlash is still more than 0.008 inch after you tighten the bearings, you
may need to replace the cross slide saddle nut.

To replace the cross slide saddle nut:

1. Remove the X axis stepper motor from its bracket by removing the four
screws holding it to the bracket.

2. Turn the flexible coupling to the right to turn the cross slide lead screw.
As you turn the lead screw, you can see that it pulls the cross slide in the
+X direction (toward the saddle). Turn the lead screw until the front-
most edge of the cross slide is flush with the front-most edge of the
saddle.

You should now be able to see the saddle nut. The saddle nut is inserted
in a recess in the front of the saddle.

3. The saddle nut is held in place by an set screw. The set screw is embedded
inside the saddle directly beneath the saddle nut. The only way to access
the set screw is from beneath the front of the saddle. You should be able
to probe the underside of the saddle with an Allen wrench, locate the set
screw and loosen it to release the pressure on the saddle nut.

4. Once you have loosened the set screw, press the cross slide down toward
the front of the Turning Center (in the -X direction). The cross slide
lead screw should move with the cross slide and appear out of the recess
in which the saddle nut resided.

5. The saddle nut should be threaded onto the end of the lead screw. Un-
screw the old saddle nut and screw on a new one (part number L4089).

6. Push the cross slide back into its original position. The lead screw will
follow, pulling the new saddle nut into the recess in the front of the saddle.

7. Reach back under the saddle with the Allen wrench and tighten the set
screw until you can feel a slight resistance when you turn the lead screw.

8. Turn the flexible coupling to the left to move the cross slide down in the
-X direction (enough so you can replace the X axis stepper motor).
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Backlash is the amount of play in the lead screws. Backlash compensation re-
moves excess play whenever the machine changes direction. The amount of
play in these screws is minimized by adjustments made during assembly and
test of the Turning Center at the factory. However, you should still check the
backlash compensation after the first four or five hours of use, and every 10
to 20 hours of use thereafter, or whenever you find parts outside acceptable
tolerances.

01 Mount a dial indicator on the lathe bed or chip tray with the tip of the
indicator touching a tool post or the cross slide. Carefully align the indi-
cator parallel to the axis you are calibrating. Calibrate the X axis first,
then the Z axis.

81 Turn on the computer and the Controller Box, and start the Control
Program.

21 Select Backlash from the Setup Menu, and set the distance for all axes to
zero.

31 Set the speed for all axes to 3ipm (75mm/min.).

41 Use the Jog Keypad to jog 0.020-inch in one direction along the X axis.
Take a reading from the dial indicator.

:1 Jog 0.020 in the other direction on the X axis and take a second reading
from the dial indicator.

>1 Calculate the difference between the two readings and subtract this value
from 0.020 to get the actual backlash.

?1 Select Backlash from the Setup Menu and change the X axis distance to
the value found in Step 7.

@1 Align the dial indicator on the lathe bed parallel to the Z axis and follow
Steps 5 through 8 to determine the actual backlash value for the Z axis.

0D1 Select Backlash from the Setup Menu and change the Z axis distance to
the value found in Step 7.

001 Reactivate the safety interlock on the shield if you have deactivated it.
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The Automatic Tool Turret (ACC-5601) is an option that allows your
Turning Center to make automatic tool changes while running NC pro-
grams. It is critical for part tolerances that the tool tip and spindle centerline
lie on the same plane.

Because different tools may be set up differently, you may need to make some
gross adjustments of the tool turret before you can make fine adjustments
and start machining parts. There are several steps involved in tool turret ad-
justment:

1. Mount all the tools you intend to use.

2. Attach a chuck to the spindle and mount a dead center in the chuck. The
dead center is used as a reference for the spindle centerline.

3. Rotate each tool as close as possible to the tip of the dead center. Some
tools may fall below the spindle centerline, some may fall above the cen-
terline. Some tools may be even with the centerline. Record the distance
from the centerline for each tool.

4. If any tools fall below the spindle centerline, place a shim beneath the
turret to bring the lowest tool even with the spindle centerline. (The shim
thickness should be equal to the distance between the lowest tool and the
spindle centerline.) This means that the remaining tools will be above the
centerline, but that will be remedied by making fine adjustments.

Spindle
Centerline

Direction of
stock rotation

Stock

1

2

4

5

6

8

7

3
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Spindle
centerline

Stock

Direction of
stock rotation

Direction of 
tool movement

Spindle
centerline

Stock

Direction of
stock rotation

Direction of 
tool movement

Spindle
centerline

Stock

Direction of
stock rotation

Direction of 
tool movement
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5. Make the fine adjustments to each tool.

a. Remove the dead center and place a piece of stock in the chuck.

b. Rotate a tool into cutting position and make a facing cut on the stock.

c. Stop the machine just before the tool reaches the spindle centerline. Vi-
sually check the position of the tool in relation to the center of the stock.

If the tool is even with the centerline, you do not need to make any fur-
ther adjustment.

If the tool is below the centerline, adjust the shim below the turret and
begin the fine adjustment process again.

If the tool is above the centerline, allow the tool to continue past the
center of the stock. Stop the machine. There should be a small nub left
at the center of the face of the stock. Use calipers to measure the diam-
eter of the nub of material. Divide the measured value by two. The re-
sulting value is the amount that the tool must be shimmed to bring it
down to the centerline of the spindle.

Place shims above the tool holder as shown below. The thickness of the
shims should be equal to the radius of the leftover nub.

Direction of
stock rotation

Diameter of 
nub left on stock 
after facing cut

Stock

1

2

8

3

Shim added

Stock
Spindle 
centerline
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If the Turning Center sits idle for two weeks or more, you should clean and
oil it to prevent dust buildup. In addition, you should always clean the cross
slide, saddle, and bed at the end of each work session. Periodically maintain
the following parts:

� Bed, saddle, cross slide. Use a light oil, such as sewing machine oil, on
all points where there is a sliding contact. You should do this immedi-
ately after each cleanup.

� Lead screw, cross slide screw. Place a light oil along all threads regularly.
At the same time, check that the threads are free of any metal chips. Also
put a few drops of light oil between the lead screw bushings and the sta-
tionary bushings to minimize wear and increase the capabilities of the
drive motors.

� Tailstock spindle. On a weekly basis, wind out the spindle as far as it
will go and oil it with a light oil.

� Headstock bearings. These bearings are lubricated at the factory and
sealed to last the lifetime of the machine. They should not need further
lubrication if the seals remain unbroken.

� Thrust bearings. For every 80 hours of machine use, you should lubri-
cate the bearings on both axes with an all-purpose grease.

The bearings are located under the flexible couplings inside the stepper
motor brackets. Slide the black boot covering the flexible coupling to ex-
pose the blue bearing. After lubricating, make sure to slide the black boot
back to its original position.

Boot

Flex Coupling

Lift boot to reveal blue bearing.
Blue
Bearing
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The spectraLIGHT Controller Box requires no special maintenance, except
that it should be kept in a dust-free environment.

If you are having problems with the AC Outlet function, or if the stepper
motors are not running, you may need to change a fuse in the Controller
Box. A blown fuse can occur if you overload one of the AC outlets. To
change a fuse:

01 Turn the power off, and disconnect the power cords to the Controller
Box and the Turning Center.
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81 The fuse holders are externally mounted on the rear panel of the Con-
troller Box and are labelled to correspond with each AC outlet. Locate
the correct fuse holder.

21 Remove the fuse by turning the fuse cap counterclockwise while pressing
slightly inward. The fuse is removed with the cap.

31 Visually inspect the fuse. If the fuse element appears broken, it is blown.
You can also use an ohm meter to check the continuity of each fuse.

fuse
fusefus

e

fuse

fusefus
e

fuse

fusefus
e

fuse

fusefus
e

fuse

fusefus
e
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41 Replace the blown fuse with a standard Slo-Blo fuse of the appropriate rat-
ing. Three-amp (1.5A for International Users) fuses are used for the mo-
tor drives, ACC 1, and ACC 2. A five-amp (2.5A) fuse is used for the
spindle, and a twelve-amp (6A) fuse is used for main AC power.

:1 Replace the fuse holder cap by pushing inward and turning clockwise.

>1 Reconnect power.

MOTOR DRIVES     MAIN

1.5A                 6A

ACC 2            ACC 1          SPINDLE

1.5A                1.5A               2.5A

COMPUTER                  TTL I/O                               A & B AXES                                    C AXIS

220-240VAC, 50Hz, 6A

220-240VAC, 2.5A  

220-240VAC, 1.5A

SPINDLE

ACC1

ACC2

220-240VAC, 1.5A

fus
efusefuse
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e fusefuse

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE
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Here are a few general guidelines for maintaining your personal computer
and software in a shop environment. See your owner’s manual for mainte-
nance procedures specific to your computer.
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Follow these general rules for computer care.

� Keep the computer and peripherals (mouse, keyboard, external drive,
printer) out of direct sunlight and away from sources of heat and in a
relatively clean environment (i.e., not right next to the foundry room).

� Keep liquids (soda, coffee, cutting fluid, grease) away from the computer
and peripherals.

� Keep oil, grease, metal chips and excess dust away from the computer,
keyboard and floppy disks. You should consider erecting a clear plastic
shield between the computer and the lathe to keep chips off the computer.

� Use grounded, three-prong outlets for the computer and peripherals. Take
precautions against current overload. A line-surge suppression unit can
be purchased at your local computer store to help alleviate this problem.

� Don’t block the vent holes in the computer or drives; they are required for
air circulation.
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Floppy disks are simple to use but require a few precautions to maintain their
integrity.

� Don’t touch the magnetic disk part of the disk (the shiny, record-like
part inside the disk jacket). Dust or grease from your hand can ruin any
part of the disk that you touch and can possibly destroy the entire disk.

� Keep disks in a disk box or special disk container instead of spreading
them out on your work space.

� Handle disks gently, don’t bend or crease them.

� Don’t write on disk labels with a ball point pen. If you must write on the
label, always write very lightly with a felt tip pen.

� Keep disks in a clean, cool environment away from excess amounts of
dust, heat, or sun.

� Beware of getting machining fluids on the disks. If you spill a liquid or
cutting fluid on a disk, it is almost percent certain that the disk and all
the data on it can never be used again.

� Keep disks away from all magnetic sources including telephones, high-
voltage power sources and lathe motors.

� Make backup copies of all NC program disks each time you update them.

� Print copies of all NC programs in case of disk failure or lost disks.

No matter how cautious you are, disks will go bad; they develop bad blocks (un-
readable surfaces). If this happens while you are editing a program, the program
will be lost. The solution to this disaster is simple—make backup copies.
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To start the spectraLIGHT Control Program:

From Windows 95 select Start from the Task Bar, then select “Progams” and the
WSLT folder. In that folder, select WSLT Windows CNC Control. You can
also create a Windows 95 shortcut by opening the WSLT directory and dragging
WSLT.EXE onto your desktop.

From Windows NT double-click the WSLT icon in the WSLT Group.

You should have the controller box connected and powered up before starting
the control software, unless you are going to be working in the Simulate Mode.
The safety shield should be closed, and the Emergency Stop button pulled out.
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You can access online help by using the commands under the Help Menu, or
by pressing F1.

For information on many of the functions and screens in the WSLT software,
you can also refer to the Reference Guide: Section E.
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You should become familiar with the main parts of the Control Program
screen before you begin using the Control Program to run NC part pro-
grams. The following are the default components that make up the screen.
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The Menu Bar contains all of the menu commands for the Control Program. For
an explanation of each menu and its relative commands, refer to the Reference
Guide: Section E.
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The Standard Tool Bar provides easy access to the most often used com-
mands available in the Control Program.
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In order to make use of this toolbar, the use of the optional Tool Turret
must be specified in the Setup Program. See page A-12 for directions on set-
ting the Control Program Software for the Tool Turret.

The Turret Control Toolbar configures the optional Tool Turret by specify-
ing which tool is in which station to make tool changes more accessable. To
change the tool, activate one of the eight Tool Station buttons. The tools
must be defined in the Tool Library dialog box which an be accessed through
the Tool menu.
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The Outputs Tool Bar is an active tool bar. It provides switches to supply
power to the spindle, and to the Accessory outlets on the Controller Box.
Switches for Robotic outputs 1 and 2 are also provided. Power is on when
the buttons are depressed.
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The Inputs Tool Bar is an inactive tool bar. It provides information only on
the state of the Emergency Stop, the Safety Shield, and the negative limit
switch. Indicators for Robotic inputs 1 and 2 are also provided. An input is
active (on) when the button is depressed.
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Whenever you open an NC part program file it appears in its own edit
window. These windows have the same characteristics as other Windows 95
windows (scroll bars, minimize/maximize buttons, etc.). You can have
multiple edit windows open at a time, the maximum number of which
depends on available memory.

By default, each new window is locked; you can not edit a locked window.
To unlock the window, use the Lock command under the Edit Menu.
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The left side of the Status Bar provides information about the currently selected
function. The right side of the status bar provides information on:

� Whether or not the Turning Center is homed

� Whether or not the Caps Lock key is activated

� Whether or not the Num Lock key is activated

� The current line and total number of lines in the program

� Whether or not the current NC part program is locked

� Whether or not the current NC part program has been modified

� The current time according to your computer

When the indicator is dimmed, the function is in the off condition.
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The Position Readout provides information on the current X and Z coordi-
nates of the tool position. The units of measure in the Position Readout are
determined by the Units command under the Setup Menu.
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The Machine Info Panel provides information on the current tool, tool
reference point, feed rate, spindle speed, number of  passes made, coordi-
nate system in use, as well as the current block and total number of
blocks in the program.
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The Verify Window displays a simulation of your part program when you
select the Verify command from the Program Menu, or when you click the
Verify Program button on the Standard Tool Bar.

Many elements in the Verify Window can be altered according to your pref-
erences in the Display section of the Verify Setup dialog box. The view of the
workpiece can be centered, zoomed in or out, color coded and instantly
updated after the window is resized.
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Like any other power tool, the spectraLIGHT Turning Center is a poten-
tially dangerous machine if operated in a careless manner. The importance of
safely operating the spectraLIGHT Turning Center, including the need for
protection against personal injury and the prevention of damage to the
equipment, can not be stressed enough. You will find more information on
safe machining in the Reference Guide: Section J.
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Proper setup of the Turning Center is essential for safe machining. These proce-
dures must be followed each time a new tool is mounted. General setup re-
quirements for the Turning Center include checking components for cleanness
and lubrication, mounting the cutting tool, setting the limit switch, mount-
ing the workpiece, and setting the spindle rotation speed.

The following safety rules should be practiced by all operators of the spectra-
LIGHT Turning Center for each use.
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Always examine the bed saddle, cross slide and lead screw to be sure they are
free of shavings and particles from previous operations. Remove such debris
from the lathe to avoid possible binding of components which may result in
possible damage to the lathe, the workpiece or the operator.

Always make sure the machine is properly lubricated.
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Make a habit of checking that keys and adjusting wrenches are removed
from the Turning Center before operating the machine.

"�
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Select the feed rate and depth of cut best suited to the design, construc-
tion and purpose of the cutting tool. It is always better to take too light a
cut than too heavy a cut.

���
� �
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Select the type of cutting tool best suited to the turning operation. Don’t
force a tool or attachment to do a job it wasn’t designed to do.
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Each cutting tool used in the machining operation must be sharp and tightly in-
serted in the tool post. The cutting edge of the tool must be on the centerline or
just below the centerline (0.004  inch or 0.1mm maximum) of the axis of ro-
tation of the lathe.
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The workpiece can be held in a three or four jaw chuck, or with a collet. Be
certain that you have firmly secured the workpiece on the cross slide and the
cutting tool in the spindle before turning on the spindle motor.
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Manually turning the spindle allows you to safely determine that the tool will
not hit the Turning Center bed, cross slide, or stock on start up.
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The spectraLIGHT Turning Center is equipped with an electronically-con-
trolled spindle motor which produces a comprehensive range of spindle rota-
tion speeds. Speed can be set with the Control Software or by using an S
code in the NC program. With the Control Software select Spindle from the
Setup menu, and adjust the spindle speed. The spindle can also be turned on
or off from this dialog box.
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Tighten the work holders and tool holders. Do not overtighten these devices.
Overtightening may damage threads or warp parts, thereby reducing accuracy
and effectiveness.
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Before you run the spectraLIGHT Turning Center for the first time, you
should know how to stop the machine should an emergency situation arise.
There are a number of ways an emergency stop can be initiated on the Turn-
ing Center: by pressing the Emergency Stop button, by simultaneously press-
ing the Control and Space Bar keys on the computer keyboard, by activating one
of the limit switches, or by activating the safety shield interlock switch.
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There is an Emergency Stop button located on the front panel of the Turning
Center; it has an oversized red cap. Before power can be applied to the Turning
Center, the Emergency Stop button must be pulled fully out from the front
panel. The full-out position allows power to be supplied to the Turning Center.
The Emergency Stop button disables the spindle even if the computer is
turned off.

In the event that a tool crashes into the workpiece, you can immediately kill
power to the Turning Center by pushing in the Emergency Stop button. The
Emergency Stop button should be your first target in an emergency situation.
Pushing in the Emergency Stop button terminates the part program. Wait
until the Turning Center has completely stopped moving before opening the
safety shield.

When the tool crash has been cleared and the Emergency Stop button is reset
(pulled back out), edit the part program to remove the cause of the tool crash
before running the program again. Reset the tool position using the Set Posi-
tion command from the Setup Menu.
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The execution of the part program can be interrupted by pressing keys on the
computer keyboard. Unlike using the Emergency Stop button, this method
of stopping the Turning Center does not cause the software to lose track of
the tool position.

To stop the part program with the keyboard, press the Control key and
Space Bar simultaneously. The cutting stops immediately and the cutting
tool remains in position. To restart the program from a keyboard-gener-
ated stop, select the Run/Continue command from the Program Menu.
In the Start At Line box, enter the number of the last line executed, then
click on the Run Program button. (When you stopped the program, the last
line executed is displayed on the Machine Info Panel, and the cursor is
placed on the same line in the file.)
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The spectraLIGHT Turning Center is equipped with a limit switch on the Z
to sense the end of travel in the negative Z direction (i.e., when the tool trav-
els left towards the work piece). If the Z axis travel exceeds the end of travel,
the limit switch is activated and shuts down machine operation.

Once the limit switch is activated, the tool must be jogged away from it using
the Jog Control Panel (see the Reference Guide, Section E). To move the
spindle away from the limit switch, you must jog it in the opposite direction,
in the positive Z direction.

If the spindle comes close enough to the end of travel to activate the limit
switch, the following procedure must be followed to restore normal operation.

01 Select Jog Control from the View Menu or from the Standard Tool Bar.

81 Click on the appropriate jog key on the jog keypad, to move the spindle
away from the triggered limit switch.

21 Check your initial machine set up to make sure it was performed correctly.
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When you installed the spectraLIGHT Control Program an NC part pro-
gram file, named Turnone.nc, was copied into the WSLT/SAMPLES direc-
tory along with the other files. The Turnone.nc program is meant to turn a
3" (length) x 0.75" (diameter) cylindrical piece of machinable brass, alumi-
num, Delrin or wax. You will be using this file to create your first workpiece
on the Turning Center.

,�#'	'


=����
��

���
�
�������
��
	�����

���!"�#�#$���������
��
��
	�$
���/��������''��(�
	����(�
0����
�$
�������
�(��
	����
	�
4�(����
��"$� �B���

����E�

)���
�������1��

01 Select the Open command from the File Menu, or click on the Open
button on the Standard Tool Bar. The Open dialog box appears.

81 Double-click on the Turnone.nc file name, or click on the file name
then click on the Open button. The edit window for Turnone.nc
appears.
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After opening the NC program, you need to adjust the Verify Settings for the
part you are about to turn. To view the Verify Settings dialog box, select
Verify Window  from the View Menu; double click on the Verify window when
it appears. Alternatively, you may select Verify Settings from the Setup
menu.
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01 Select the Display tab.

81 Use the Zoom controls to alter the size of the workpiece, and to position
the workpiece in the Verify window, as shown in the Preview Window.

21 Use the Verify Speed control to alter the speed at which the verify pro-
gram will be executed in the Verify Window. If you would like to view
the verify program in slow motion, move the slider to the left. If you
would like to view the verify program at a faster speed, move the slider to
the right.

31 Use the Colors controls to choose the color indicators for the back-
ground, stock and tool in the Verify Window.

41 Check Auto Refresh on Resize so that you may adjust the Verify Win-
dow size if necessary without disturbing the Verify program.
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01 Select the Tool Position tab.

81 Enter the Initial Tool Position for the Turnone.nc part program.
The positions are Z=2.01" and X=.375". These points are based on
the origin and the size of the stock and are always positive values.

21 Select Below Stock for the Tool Location for this sample NC program.
If you have a tool turret installed, you will need to select Above Stock.

2.0"0.5"
(inside chuck)

Initialization 
Point

0.5"
(outside chuck)

!��
��'�#��'�9���
���



#$
����'B���
	������������'��9��
 =+�

"����������
� �
����5
��E�

1. Check your NC part program for the maximum X value. This value
is used to determine the required diameter of the workpiece. For in-
stance, if the maximum X value in your program is 0.45 inches, you
will need a workpiece with a 1-inch diameter.

When writing a part program for a turned part, the maximum X value in
the program is equal to the radius of the largest portion of the finished
part. Multiply the radius of the largest portion of your finished work-
piece by 2 to approximate the required diameter of the workpiece.

2. Check your NC part program for the maximum Z value. This value is
used to determine the required length of the workpiece. If the maximum
Z value in your program is 1.9 inches, you would assume that you need
a workpiece 2 inches long. In addition, you have to account for the stock
held inside the chuck by adding 0.5 inch to the workpiece length. Also,
you should add another 0.5 inch so that the tool does not hit the chuck.

Therefore, to turn a part with a finished length of 1.9 inches, you need a
workpiece thatis 2" + 0.5" + 0.5", or 3 inches long. When entering this
stock size in the stock window, only the usable dimensions are defined.

.45"

1.0"
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01 Select the Stock tab.

81 Enter the stock Dimensions for the Turnone.nc part program. The stock
dimensions are Z=2.0" and X=0.75". These dimensions should define
the usable dimensions of the stock, excluding the amount clamped in the
spindle chuck.

21 Set the Origin of Stock to Z=0.5" and X=0". The origin of the stock is
based on where your 0,0 point is set on the machine, relative to the left
center of the stock.

31 Check the box labeled Show Chuck and Origin Marker to view these
items in the Preview and Verify Windows.

41 Select OK. The dialog box closes, and your changes are applied to the
workpiece in the Verify Window.
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To turn this part, you will use a diamond profiling tool. You will use the pa-
rameters for this particular tool for the tool path verification as well. To define
the tool parameters, first select the tool from the tool library, then select the
tool for verification.
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01 Select Setup Library from the Tools Menu. The Setup Tools dialog box
appears. There are already a number of tools defined. From these, select
Tool 01, a left hand diamond profiling tool with outside orientation.

81 Click on the Apply button.

21 Click on OK to exit the Tool Library.
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01 Select the Select Tool command from the Tools Menu. The Select
Tool for Use dialog box appears.

81 Select the tool you previously defined by using the Tool pull-down list.

21 Click on the Select Tool button.
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Tool path verification allows you to check for programming errors before ac-
tually running the part program on the Turning Center.

01 Select Verify from the Program Menu or from the Standard Tool Bar.
The Verify Program dialog box appears. The default starting line for the
program is Line 1. When verifying a program for the first time, you
should begin on Line 1.

81 Click on the Verify Program button, then watch the Verify Window.
You will see the Turnone.nc program executed on the cylindrical work-
piece. Turnone.nc has a programmed pause. The operator must press
Cycle Start from the Operator Panel or Go from the status line to see
the entire verification process.

21 After verification is completed, the Normal Program Stop dialog box is
displayed. Select OK.
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Before you run your part program for the first time, you should perform a
dry run (run the program with no stock mounted). This will ensure that all
the movements of the Turning Center make sense and that the tool is in no
danger of striking any fixtures of the Turning Center. Although you should
dry run the program with no stock mounted, set the point of origin using the
workpiece and then remove it.

Begin with the Emergency Stop button pressed in, and the spindle speed
turned all the way down. The tool should be mounted in the tool post.

01 Mount the workpiece in the chuck. Your workpiece should be a cylindri-
cal piece, 3" by 0.75" diameter.

81 Close the Safety Shield and  pull out the Emergency Stop button.

21 Select Jog Control from the View Menu (or the Standard Toolbar). The
Jog Keypad appears.

31 Use the Jog Keypad to jog the tool to the bottom of the front right cor-
ner of the workpiece (the end of the stock furthest from the chuck and at
the edge of the stock). If a Tool Turret is installed, jog the tool to the top
of the front right corner of the workpiece, instead of the bottom.

2.0"

Initialization 
Point

0.5"
(outside chuck)

0.5"
(inside chuck)

3.0"
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?1 Jog the tool up and away from the workpiece. Press the Emergency Stop
button, open the Safety Shield and remove the workpiece.

@1 Return the Safety Shield to the closed position and pull out the Emergency
Stop button.

0D1 Put on a pair of safety glasses and complete the Safety Checklist (refer to
the Reference Guide: Section J).

001 Select Run/Continue from the Programs Menu. The Run Program dialog
box appears.

081 Click on the Run Program button.

021 As the part program runs, observe the tool motion in relation to the
chuck (and eventually the workpiece). Look for signs of a possible tool
crash and be prepared to press the Emergency Stop switch on the Turn-
ing Center. Edit the program as required. When you are satisfied that
the tool motions are correct, you can mount the workpiece.

41 Select Set Position from the Setup Menu. The Set Position dialog box appears.

:1 Enter  Z= 2.0 and X= 0.375.

>1 Click on OK. The values in the Position Readout all change to zero.
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01 Using the Jog Keypad, jog the tool post up and out of the way.

81 Before mounting the workpiece, push the Emergency Stop button in.

21 Mount the 3"x.75" workpiece in the chuck. Take care to position the
workpiece perpendicular to the tool post.

31 Pull the Emergency Stop button out.

41 Jog the tool to position the center of the tool tip at the top of the front,
right corner of the workpiece. Jog until the tip of the end mill touches
the surface of the workpiece.

:1 Select the Set Position command from the Setup Menu and enter Z=
2.0 and X= 0.375. Select the Operator Panel and check that the spindle
speed is set to 100%.

The workpiece is now correctly mounted.
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Before executing the Turnone.nc program, check that all safety precautions
have been taken. The Turning Center safety shield should be closed, and you
should be wearing safety glasses.

If anything goes wrong, immediately press the Emergency Stop button on
the Turning Center to stop the operation. A safety checklist has been pro-
vided in the Reference Guide: Section J of this guide. Post a copy of this
checklist near the Turning Center and review it before you run any NC pro-
gram.

To run the program:

01 After reviewing the Safety Checklist, select the Run/Continue command
from the Program Menu. The Run Program dialog box appears.
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81 Make sure that the Start Line box is set to line 1 of the program.

21 Click on the Run Settings button. The Run Settings dialog box appears.

31 Make desired changes in the Run Settings dialog box, then select OK.

41 Click on the Run Program button to begin running your program.

:1 After the part is turned, press the Emergency Stop button before opening
the safety shield and removing the finished part.
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The Control Program interface (the screen) is composed of several components
that allow you to create NC part programs and interact with the Turning
Center.
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The Message Bar is located directly beneath the Menu Bar. When an NC
program is running or being verified, the Message Bar displays the name of
the NC file currently being run, or the most recent operator message. When
a program is running, the Message Bar also displays control buttons (Go or
Stop). When there is no program running, the Message Bar displays the
Control Program copyright notice.
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Windows can be used to display information or accept input from the machine
operator. Some windows can be docked or they can be floating windows (see
Docking and Floating Windows and Toolbars later in this section). Windows
are activated or hidden using the commands under the View Menu.

Panels are used to control machine operation. They can also be docked or
they can be floating windows.

The following windows and panels are available:

� Program Edit Windows

� Position Window

� Machine Info Window

� Verify Window

� Jog Control Panel

� Operator Panel
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When you open an existing NC part program file, or create a new one, the
program appears in a program edit window. Program Edit Windows have all
of the features common to other windows, including a title bar which dis-
plays the program file name and controls for minimizing, maximizing, and
closing the window.

Program Edit Windows appear in the Edit Area (the large central area) of the
screen. The Edit Area can be closed and moved. First select Cascade from
the Window menu, then the window is movable and resizable. The Edit Area
can contain multiple Edit Windows.

If a Program Edit Window is locked, the background of the edit window is
gray. In the locked position, no edits can be made. If the window is un-
locked, it is white. The lock command can be found in the Edit menu of the
menu toolbar.

When other windows, panels, and toolbars are closed, the space that their
docking areas occupy is given to the Edit Area.

When other windows, panels, and toolbars are open, the space that their
docking areas occupy is taken from the Edit Area.

The Windows Menu has several commands for managing program Edit
Windows, and allows you to select a particular window from a list of all cur-
rent windows, identified by file names.
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This is a dynamic display. When a program is running or being verified, the
current position of the tool is indicated here.

If you double-click on this window, the Goto Position dialog box appears,
allowing you to move the tool to specific coordinates.
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The information displayed in the Machine Info Window varies with the
particular operation being performed:

When the machine is idle, the Machine Info Window displays information
about the:

� Current tool number

� Tool reference point

� Feed rate

� Spindle speed

� Number of passes* made for
the current program

� Coordinate system being used

� Current block number*

� Number of blocks* in the current program

(*The passes, current block, and total number of blocks refer to the last pro-
gram verified or run.)

When a program is running, the Machine Info Window becomes a dynamic
display. In addition to updating the previously mentioned information, each
line of code (as it is executed) is displayed along with the previous and next
lines of code. Also, a clock provides the elapsed run time for the program.
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When a program is being verified, the Machine Info Window displays the
current line of code, plus the previous and next lines, along with all informa-
tion given for an actual run of the program.
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The Verify Window can be opened
and closed by selecting the Verify
Window command from the View
Menu.

The Verify Window displays a
simulation of your part program
(tool path verification) when you
select the Verify command from
the Program Menu, or when you
click the Verify Program
button on the Standard Toolbar.

Choices made in the Verify Setup dialog box will be displayed in this Verify
Window. These choices include a centered view, a view zoomed in or out,
colors, the speed of the Verify Program and updating the Window after
resizing it.
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The Jog Control Panel is accessed by selecting the Jog Control command under
the View Menu, or by clicking on the Jog Control button on the Standard
Toolbar. The Jog Control Panel allows you to manually move (jog) the tool
on the Turning Center.

Each axis on the machine is represented by buttons. The Z axis is represented
by two horizontal buttons, one for negative motion and one for positive mo-
tion. The X axis is represented by two vertical buttons, one for negative mo-
tion and one for positive motion. Pressing any of the axis buttons moves the
tool in the indicated direction as long as the system is not in Simulate Mode.

Jogging occurs in specific increments of speed and distance. The speed and
distance values are selected on this panel as well. You can alter the speed and
distance parameters for jogging by selecting the Jog Settings command under
the Setup Menu, or by double clicking on the Jog Control Panel.

To jog a tool:

0. Define the Speeds and Steps (distances) for jogging by selecting the Jog
Settings command under the Setup Menu.

8. Click on the Axis button on the Jog Keypad to move the tool in the de-
sired direction. The tool moves at the speed and distance indicated by
the Speed and Step buttons.
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The Operator Panel provides controls that are used while running an NC
program on the Turning Center.

The Operator Panel controls include:

����� Optional Skip: Allows you to execute or ignore any optional skips
( / codes) you have embedded in the NC program.

����� Optional Stop: Allows you to execute or ignore any optional stops
(M01 codes) you have embedded in the NC program.

����� Single Step: Causes the NC program to pause after each block is ex-
ecuted. This allows you to check each step of the cutting operation.

����� Stop: Immediately halts the currently running NC program. This but-
ton works the same as the Ctrl + Space Bar combination.

����� Cycle Start: Begins running the current NC program from the begin-
ning or from a paused condition.

����� Feedhold: Pauses the currently running NC program. To continue run-
ning the program from a Feedhold, press the Feedhold button again or
press the Cycle Start button.

����� Feed Rate Override: Overrides the programmed feed rate.

����� Spindle Speed Override: Overrides the programmed spindle speed.
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Toolbars carry buttons that correspond to frequently used menu commands.
You can click on these buttons to quickly select the associated menu com-
mand. Toolbars also operate Outputs and display the state of Inputs. Toolbars
can be placed anywhere on your screen, and can be hidden if you do not use
them often or want the additional space for program windows. Toolbars are
revealed and hidden using the Toolbars command under the View Menu.

The toolbars include:

� Standard Toolbar

� Inputs Toolbar

� Outputs Toolbar

� Turret Control Toolbar
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The Standard Toolbar provides quick-access buttons for the following menu
commands:
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New Create a new program edit window

Verify Verify the current NC part program

Run Run the current NC part program

Pause Pause the currently running NC part program

Stop Immediately halt the currently running NC program

Open Open an existing NC program file

Save Save an NC program file

Print Print an NC program

Context Help This button can help you instantly find information
on the items you see on the screen. For instance, click
on the Context Help button, then click on a menu
item, toolbar button, window or other screen element.
The Help topic for that particular item appears.
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Jog Control Panel Show or hide the Jog Control Panel

Operator Panel Show or hide the Operator Panel

Home Sets/Checks the machine’s Home, or reference
point

Verify Verify the current NC part program

Run Run the current NC part program

Pause Pause the currently running NC part program

Stop Immediately halt the currently running NC program
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The Inputs Toolbar isn’t really a toolbar, in that you can not use it to inter-
act with the various Control Program inputs. It is a monitoring
device that keeps track of the state of the various machine inputs.

The state of each input is indicated by the position of its button. If a button
is depressed, the input is “on” or “high.” If a button is not depressed, the
input is “off” or “low.” You can also check the condition of an input by
clicking on it or by holding the mouse over the input button. The state of
the input is displayed on the Status Bar  at the bottom of the screen.

The inputs on the Inputs Toolbar include:

� The Emergency Stop condition. This input is in the “on”
condition (depressed) if the Emergency Stop button on the
Turning Center is pushed in.

� The Safety Shield condition. This input is in the “on”
condition (depressed) if the Safety Shield on the Turning
Center is open.

� The Negative Limit condition. This input is in the “on”
condition (depressed) if the negative Z axis limit has been hit.

� The Robot Input 1 condition. This input is in the “high”
condition (depressed) if robotic input #1 (on the TTL I/O
connector on the Controller Box) is currently in a high state.

� The Robot Input 2 condition. This input is in the “high”
condition (depressed) if robotic input #2 (on the TTL I/O
connector on the Controller Box) is currently in a high state.
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The Outputs Toolbar provides quick-access buttons for controlling the
system outputs.

The state of each output is indicated by the position of its button. If a but-
ton is depressed, the output is “on” or “high.” If a button is not depressed,
the output is “off” or “low.” You can also check the condition of an output
by holding the mouse over the output button. Clicking on the button will
change the state of the output. The name of the output is displayed in a tool
tip, and the state of the output is displayed on the Status Bar at the bottom
of the screen.

The output controls on the Outputs Toolbar include:

� The Spindle control. This button turns the spindle on and
off.

� The ACC1 control. This button turns the Accessory 1 out-
put on and off.

� The ACC2 control. This button turns the Accessory 2 out-
put on and off.

� The Robot Output 1 control. This button toggles Robotic
Output 1 between high and low conditions. When this but-
ton is depressed, it places Robotic Output 1 (on the TTL
I/O connector on the Controller Box) in the “high” condi-
tion. When this button is not depressed, Robotic Output
1 is in the “low” condition.

� The Robot Output 2 control. This button toggles Robotic
Output 2 between high and low conditions. When this
button is depressed, it places Robotic Output 2 (on the
TTL I/O connector on the Controller Box) in the “high” condition.
When this button is not depressed, Robotic Output 2 is in the “low”
condition.
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The Turret Control Toolbar provides quick-access buttons for tools which
are defined under the Tool menu in the Tool Library. The button that is
depressed is the tool that is selected for use in an NC program.

The Tool Turret controls on the Turret Control   Toolbar include:

� Tool Station 1 through Tool Station 8.In the toolbar above, Tool Sta-
tions #1, #4 and #5 are defined, while Tool #1 is selected. Five Tool Sta-
tions are undefined and are still available for input information and use.
The tools must be defined in the Tool Library dialog box which can be
accessed throught he Tool menu.
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The Status Bar displays miscellaneous information about the Turning Center

and the computer. The left side of the Status Bar is reserved for operator
messages such as the one displayed here.

If any of the following are grayed-out, the feature is considered “off.”

� The machine Homed state: Black if the machine is currently homed.

� The Caps Lock key state: Black if the Caps Lock feature is on. Some NC
programmers prefer to type their programs in capital letters. When the
Caps Lock feature is on anything you type will be displayed in capital
letters. Press the Shift key to type lower case letters.

� The Num Lock key state: Black if the Num Lock feature is on. Some
NC programmers prefer to use the numeric keypad on the keyboard to
enter figures. The Num Lock feature must be on to do this.

� Current Line : Total Lines: Displays the line the cursor is currently on,
and the total number of lines in the program.

� The file Locking state: Black if the NC program file is locked.

� The file Modified state: Black if the NC program has been modified
since being opened.
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� The Configure Turret button at the end of the  toolbar configures the
Turret by specifying which tool is in which station.
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The Menu Bar is located at the very top of the screen. It lists the categories of
commands into which the Control Program operations are grouped.

The available menus are:

� File Menu

� Edit Menu

� View Menu

� Program Menu

� Tools Menu

� Setup Menu

� Window Menu

� Help Menu

&���
(���

The File Menu provides typical file management commands and the
command to exit the Control Program.

�������� ����
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New Create a new program window.

Open Open an existing file.

Close Close an open program window.

Save Save a program.

Save As Save a program under a different filename or location.

Print Print an open NC program.

Print Setup Set up your printer for printing.
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Recently opened files Open one of the eight most recently used files.

Exit Exit the Control Program.
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Use the New command under the File Menu to create a new program edit
window. You can create a new program edit window at any time. The num-
ber of program edit windows that you have open at one time is limited by the
amount of memory on your computer.
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To create a new program window, select New from the File Menu, or press
Ctrl+N. A new program window is created. The filename on the Title Bar is
“Untitled,” indicating that this is a new program. The program will remain
untitled until you save it. You should save a new program before it is run or
verified.
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Use the Open command under the File Menu to open an existing NC pro-
gram. The number of program edit windows that you have open at one time
is limited by the amount of memory on your computer.
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01 Select Open from the File Menu, or press Ctrl+O. The Open dialog box
appears.

81 In the dialog box, locate and highlight the desired NC file.
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21 Click the Open button or press Enter. The selected NC program file is
opened. The Title Bar on the Edit Window displays the name of the file.
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� If the open file has changed since it was opened, you are prompted to reload
the original version of the file or to cancel the opening procedure.

� If the open file has not changed since it was opened, it becomes the ac-
tive Program Edit Window.
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You can close a program window at any time. Unless you have already done
so, you will be prompted to save any changes made to the program file.

To close a program window:

01 Make sure the program window you want to close is selected.

81 Select one of several ways to close the open window:
� Select the Close command from the File Menu.
� Single-click the icon on the far left of the Title Bar and select Close

from the drop-down menu. (If the Edit window is maximized, the
icon will be at the far left of the Menu Bar.)

� Double-click the icon on the far left of the Title Bar. (If the Edit
window is maximized, the icon will be at the far left of the Menu Bar.)

� Click on the Close button on the far right of the Title Bar. (If the
Edit window is maximized, the icon will be at the far right of the
Menu Bar.)

� Press Ctrl+F4.
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21 If there are unsaved changes to the current program, the File Save dialog
box appears, prompting you to save the changes. Click one of the buttons
in the dialog box:
� Click Yes to save the changes.
� Click No to discard the changes.
� Click Cancel to exit the dialog box without saving the changes or

closing the program window.
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Use the Save command under the File Menu to save the current program as
an NC file.
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If the current NC program was previously saved, selecting Save saves the
changes to the same file without bringing up a dialog box. If the current pro-
gram is new (and still has the name “Untitled”), selecting Save brings up the
Save As dialog box, with which you name, choose a location for, and save
the new program.

To save a program, select Save from the File Menu, or press Ctrl+S.

The current program is saved to a file. If this is a new program, the Save File
As dialog box appears. Choose a name and location for the new file.
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Use the Save As command under the File Menu to save the current program
to an NC file using a new name or location.
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The Save As dialog box in the WSLT Control Program functions in the
same manner as in other Windows 95 applications.
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To use the Save As dialog box:

01 Select a destination for the file using the Save in:, Up one level and
Create new folder buttons.

81 Enter a filename in the File Name: field.

21 Select a file type in the Save as type: field.

31 Click Save or press Enter to save the file.

41 Click Cancel or press Esc to cancel and exit the dialog box.
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01 Select Save As from the File Menu. The Save As dialog box appears (see
above). It displays the name and location of the current program file.

81 Choose a new drive and directory for the file, if desired.

21 Type in a new file name, if desired.

31 Click Save to save the file, or Cancel to exit the dialog box.
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Use the Print command under the File Menu to print the current NC program.

To print the program:

01 Use one of the following methods to open the Print dialog box:
� Click the Print button on the toolbar.
� Select the Print command from the File Menu.
� Press Ctrl+P.

The Print dialog box appears.

'����

#	�� �(�$'
�����
����������''���('�

�
	�
 ������
� ���� ���� �(�$'
�����
���



?+�����
��'�9�������4�(����
�

81 Choose the desired print options in the dialog box. Clicking Properties
opens the Print Setup dialog box.

21 This dialog box will give options that are specific to your printer, such as
paper, graphics, and device options. customize your print job then select OK.

31 Select OK to print, or select Cancel to exit the Print dialog box without
printing the NC program.

You can print to any printer that is supported by Windows. See your printer
manual or Windows documentation for more information on installing and using
printers with Windows.
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Use the Print Setup command under the File Menu to select a printer. The
Print Setup dialog box allows you to establish parameters for printing your
NC part programs.

To choose print settings:
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01 Select Print Setup from the File Menu. The Print Setup dialog box appears.

81 Select the desired print settings, including:
� The destination printer.
� The size of the paper.
� The paper tray.
� The orientation of the paper.

21 Select OK to print, or select Cancel
to exit the Print dialog box without
setting the printing parameters.
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Use the numeric (1, 2, 3, … 8) com-
mands under the File Menu to open
any of the most recently opened files
(up to the last eight files).

The names and paths of the most recent files appear in the reverse order in
which they were opened.

For instance, in this example, 1 turntwo.nc is the most recently opened file.

The file 2 turnone.nc is the second most recently opened file.

To open one of the listed NC program files, simply select the filename from
the list. The recent program you selected is opened. Once the file Edit Win-
dow is open, the Title Bar displays the name of the program file.
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Use the Exit command under the File Menu to exit the Control Program.
You should always exit the Control Program before you exit Windows.

Use one of the following methods to exit the Control Program:

� Select the Exit command from the File Menu.

� Single-click the icon on the far left of the Control Program Title Bar. Se-
lect Close from the drop-down menu.

� Double-click the icon on the far left of the Control Program Title Bar.

� Click on the Close button on the far right of the Title Bar.

� Press Alt+F4.

If there are unsaved changes to any program window, a dialog box appears
for each unsaved program window, prompting you to save the changes.
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� Click Yes to save the changes and exit.

� Click No to ignore the changes and exit.

� Click Cancel or press Esc to cancel the Exit command and return to the
Control Program.
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The Edit Menu provides typical text editing commands. Before you can edit
the text in an NC program, you must select the text.
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Undo Undo the most recent editing command.

Redo Redo the most recent Undo command.

Cut Cut selected text to the Windows clipboard.

Copy Copy selected text to the Windows clipboard.

Paste Paste text from the Windows clipboard into the
current NC program.

Clear Delete selected text.

Delete Line Delete the line the cursor is currently on.

Find Locate a sequence of characters in an NC program.

Replace Replace one sequence of characters with another,
one or more times.

Goto Line Jump to a particular line in the NC program.

Renumber Modify or insert N codes in an NC program .

Lock Lock or unlock the Program Edit Window to pre-
vent or allow modification to the NC program.

Select Font Change the font currently being used.

����
�������

The Undo command reverses the most recent editing action taken. It is use-
ful for recovering from accidental deletion or inclusion of a block of text.

To undo the last change, select Undo from the Edit Menu, or press Ctrl+Z.
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� If your last editing action deleted selected text, the text is restored.

� If your last editing action deleted a character, the character is restored.

� If your last editing action pasted text, the text is removed.

� If your last editing action typed a character, the character is removed.

� If Undo is grayed-out in the Edit Menu, no changes can be undone.
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The Redo command reverses the action of the most recent undo command.
For example, if you delete a portion of text in an NC program, then decide
that wasn’t such a good idea, the Undo command will return the text to its
original position. If you then decide that the deletion was appropriate after
all, select the Redo command to once again remove the text.
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Use the Cut command under the Edit Menu to remove text from the NC
program (the text is copied to the Windows clipboard). The text can then be
pasted anywhere in the current program, into another program, or into an-
other application such as Notepad. The text remains on the Windows clip-
board until it is replaced by another Cut or Copy operation.

To cut text to the Clipboard:

01 Select the text you wish to cut.

81 Select Cut from the Edit Menu, or press Ctrl+X.
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Use the Copy command under the Edit Menu to duplicate selected text in an
NC program.

To copy text to the Clipboard:

01 Select the text you wish to copy.

81 Select Copy from the Edit Menu, or press Ctrl+C. The selected text is
copied to the Clipboard.
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You can use the Paste command to insert text from the Windows clipboard
into your NC program.

To paste text from the Clipboard:

01 Place the cursor at the point in the NC program where you wish to insert
text that has been previously cut or copied to the Windows clipboard.
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81 Select Paste from the Edit Menu, or press Ctrl+V. The contents of the
clipboard are inserted into the program. If this menu command is
grayed-out, there is no text on the clipboard to paste.
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Use the Clear command under the Edit Menu to delete selected text from
your NC program. The text is not copied to the Windows clipboard. You

can also use the Delete key on your keyboard to achieve the same effect.

To delete text using the Clear command:

01 Select the text you wish to delete.

81 Select the Clear command from the Edit Menu. The selected text is deleted.
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Use the Delete Line command under the Edit Menu to delete an entire line
of NC code from a program without selecting it first.

To delete a program line using the Delete Line command:

01 Place the cursor anywhere on the line of code you wish to delete.

81 Select the Delete Line command from the Edit Menu, or press Ctrl+Y.
The line of code is deleted.
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Use the Find command under the Edit Menu to locate a particular sequence of
characters within an NC program.

To use the Find command:

01 Select Find from the Edit Menu, or press Ctrl+F. The Find dialog box
appears.

81 Enter the character sequence for which you are looking in the Find
what: box.

21 Check the Match whole word only box to restrict the search to whole
words, skipping partial words.

31 Check the Match Case box to restrict the search to finding only those text
strings that match the case (upper or lower) of the text that you entered.
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41 Select Up or Down from the Direction box to search through the text
before or after the cursor position, respectively.

:1 Click Find Next or press Alt+F to begin the search. Click Close or press
ESC to exit the Find dialog box without performing the search.
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Use the Replace command under the Edit Menu to replace an existing char-
acter string with a new character string.

If the Match Case box is checked, this feature is “case-sensitive.” If you enter
a character string in lower case letters, but your NC program is written in all
upper case letters, Replace will not find any occurrence of the string. Make
sure you enter the existing character string exactly as it is shown in the NC
program.

To use the Replace command:

01 Select Replace from the Edit Menu. The Replace dialog box appears.

81 Enter the existing character string in the Find what: box.

21 Enter the new character string in the Replace with: box.

31 Check the Match whole word only box to restrict the search to whole
words, skipping partial words.

41 Check the Match Case box to restrict the search to finding only those text
strings that match the case (upper or lower) of the text that you entered.

:1 To locate the first and successive instances of the character string, click
Find Next.

>1 Select Replace to replace the currently located character string which has
been highlighted for you with the word or phrase which you have indicated.
Replace changes one word at a time, starting at the location of the cursor.
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?1 Select Replace All to replace all similar character strings throughout the
NC program. Replace All will automatically locate each instance of the
word or phrase and change all of them at once and will present a dialog
box telling you how many changes
were made.

@1 Click Close to exit the dialog box .
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Use the Goto Line command under the
Edit Menu to move the cursor to a spe-
cific line in the NC program. This command is also available using the Pro-
gram Edit Window Pop-up Menu.

To use the Goto Line command:

01 Select Goto Line from the Edit Menu, or press Ctrl+G. The Goto Line
dialog box appears.

81 Enter a line number in the Jump to Line Number box. The cursor
moves to the specified line in the NC program. If the line number en-
tered is larger than the number of lines in the program, the cursor is moved
to the end of the program.
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Use the Renumber command under the Edit Menu to alter the N codes in
your NC program.

The Renumber command can be used to:

� Insert N codes in a program that has none.

� Remove N codes from a program.

� Renumber the N codes in a program.
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� Insert, remove or ignore spaces between NC commands.

� Remove comments from the program.
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To insert or renumber the N codes in your program:

01 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

81 Select Renumber N Codes or press Alt+N.

21 Click on the Start N Code box (or press Alt+T), then enter the number
of the first N code. The default starting number is N1.

31 Click on the Increment box (or press Alt+I), then enter the increment you
wish to use. For instance, if you wish to have each N code numbered in
increments of 5, enter 5 in the Start N Code box and enter 5 in the In-
crement box. The N code sequence will then be: N5, N10, N15,
N20…and so on.

This option is useful if you are renumbering a portion of the program to be
inserted into another program, and the N codes must start with a num-
ber greater than 1. Using increments greater than 1 allows you to insert
additional numbered lines without having to renumber the whole program.

41 Select Do It, or press Alt+O, to execute the Renumbering options you
selected. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.
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Although the Renumber command automatically changes P codes used with
M99 codes, it does not renumber P codes used with M98 codes, nor does it
renumber O codes. Although O codes are not altered, the lines which they
occupy are counted. So, the very next N code is numbered as though the O
code has been renumbered, too.

For instance, N41X
N42X…
O25G…
N44…

In this example, although the O code has not been renumbered, the line it
resides on has been counted. The N code on the following line reflects the
next number in the sequence.
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To insert or remove spaces between the NC words in your program:

01 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.
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81 Choose a Spaces option.
����� Insert Spaces inserts a space between each NC word (to the left of

the comment code).
����� Remove Spaces removes any spaces between NC words (to the left

of the comment code).
����� Ignore Spaces ignores any spaces in the NC program.

21 Select Do It, or press Alt+O, to execute the Spaces options you selected.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.
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To remove comments from your program:

01 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

81 Select Remove Comments.

21 Select Do It, or press Alt+O, to execute the Remove Comments com-
mand. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.
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To remove the N codes from your program:

01 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

81 Select Remove N Codes or press Alt+R.

21 Select Do It, or press Alt+O, to execute the Remove N Codes command.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.
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Use the Lock command under the Edit Menu to prevent or allow changes to
your NC programs. When an NC program is unlocked, it can be modified by
the commands on the Edit Menu. When an NC program is locked, the program
cannot be changed by any commands. By default, when you open a file it is
automatically locked to prevent accidental changes. You can change this de-
fault setting in the Preferences dialog box (Seup Menu/Editor Tab).

There are three ways to determine if a selected program is locked or unlocked:

01 If a check mark appears next to the Lock command, the current NC pro-
gram is locked.

81 A locked NC program can be identified by the background color of its
Edit Window. If the background is gray, the file is locked; if it is white,
the file is unlocked.
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21 The Lock Indicator on the Status Bar is gray if the program is unlocked,
black if the program is locked.

To toggle an NC program between the locked and unlocked states, select the
Lock command from the Edit Menu, press Ctrl+L, or double-click the Lock
Indicator on the Status Bar.
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Use the Select Font command under the Edit Menu to change the font settings
for open NC programs. The font settings control the font and font size used
in the program Edit Window. The fonts listed are the true type fonts already
installed on your system. Font Settings are intended for viewing and printing
purposes only. They do not affect the NC program in any way and are not
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stored within the program file. All open program windows use the same font
settings.

To use the Select Font command:

01 Select the Select Font command from the Edit Menu. The Font dialog
box appears.

81 Select a font from the Font list.

21 Select a Font Style.



?+7����
��'�9�������4�(����
�

31 Select a font size from the Size list.

41 Click OK to change the font, or click Cancel or press Esc to exit the
Font dialog box without changing the fonts.
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The View Menu commands control the display of windows and toolbars.
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Position Open or close the Machine Position Window.

Machine Info Open or close the Machine Info Window.

Jog Control Open or close the Jog Control Panel.

Operator Panel Open or close the Operator Panel.

Verify Window Open or close the Verify Window.

Toolbars Open or close one of the toolbars.
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Use the Position command on the View Menu to open or close the Position
Window.

To open or close the Position window, select Position from the View Menu.
A check mark appears next to the Position command when the Position
Window is open.
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Use the Machine Info command on the View Menu to open or close the
Machine Info window.

To open or close the Machine Info window, select Machine Info from the
View Menu. A check mark appears next to the Machine Info command
when the Machine Info Window is open.
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Use the Jog Control command on the View Menu to open or close the Jog Con-
trol Panel. You can also use the Jog Control button on the Standard Toolbar.
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To open or close the Jog Control window, select Jog Control from the View
Menu. A check mark appears next to the Jog Control command when the
Jog Control Panel is open.
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Use the Operator Panel command on the View Menu to open or close the
Operator Panel.

To open or close the Operator Panel, select Operator Panel from the View
Menu. A check mark appears next to the Operator Panel command when the
Operator Panel is open.
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Use the Verify Window command on the View Menu to open or close the
Verify Window.

To open or close the Verify Window, select Verify Window from the View
Menu. A check mark appears next to the Verify Window command when
the Verify Window is open.
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Use the Toolbars command on the View Menu to show or hide the Toolbars.

To show or hide a toolbar:
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01 Select Toolbars from the View Menu. The list of available toolbars is
displayed. Toolbars that are visible have a check mark beside them.

81 Select the toolbar that you wish to show or hide.
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The Program Menu commands allow you to Run, Verify, or Stop an NC
program.
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Run/Continue Start running or resume running the current NC
program.

Verify Verify the current NC program.

Estimate Runtime Estimate the runtime of the current NC program.

Pause Pause the currently running NC program.

Feedhold Stop movement of all axes.

Stop Immediately halt the currently running NC program.�������
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The Run/Continue command under the Program Menu runs the current
NC program on the Turning Center. When you select Run/Continue from
the Program Menu, the Run Program dialog box appears.

The Run Program dialog box allows you to select an NC program to run, to
set the program block from which to begin running the program, and to ac-
cess the Run Settings and Verify Settings dialog boxes.

01 Select an NC Program.

If you have more than one NC program open, use the Program drop-
down list, or press Alt+P, to select the program you wish to run.

81 Select a Starting Line.
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When you are running an NC program for the first time, it is wise to
start the program from the first line. When you start at a line other than
line one, the control program parses through the program to the speci-
fied start point. As it parses, it performs operations such as turning the
spindle on, but it will not execute a Dwell or Pause command, and it
will not move the tool.

To specify a starting block, click on the Start at Line box, or press
Alt+L, and enter the line number.

21 Set the Run Settings

To bring up the Run Settings dialog box click on the Run Settings button,
or press Alt+U.

31 Set the Verification Settings

To bring up the Verify Settings dialog box click on the Verify Settings
button, or press Alt+E.

41 Run the Program

To start running the program, click on the Run Program button, or
press Alt+R. To cancel running the program, click on the Cancel but-
ton, or press Esc.

While a program is running, the Machine Info Window and the Message Bar
keep you informed by providing information on:

� The name of the NC program.

� Which tool is being used.

� The tool reference.

� The feed rate.

� The spindle speed.

� The number of passes made.
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� The coordinate system in use.

� Which block is currently being executed.

� How many blocks are in the program.
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� Operator messages such as which block paused the program or the error
that caused the program to stop.
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The Verify command allows you to view tool path verifications of your NC
part programs. When you select Verify from the Program Menu, the Verify
Program dialog box appears.

This dialog box allows you to select a program to verify from a pull-down list
of currently open NC part programs. Prior to verifying the part program,
you may wish to alter the Run Settings, alter the Verification Settings, or se-
lect a starting line in the program. The default starting line is line one.

Begin the verification by pressing the Verify Program button. If the Verify
Window is not already open, it will open automatically.
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Tool path verification is displayed in the Verify Window. The workpiece
and tool are displayed according to the choices you made in the Verify Settings
dialog box.

Here is an example of how the Verify Window may appear for the part program
Turnone.nc.
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Use the Estimate Runtime command to calculate the approximate amount of
time the spectraLIGHT Turning Center requires to turn your part, and the ap-
proximate distance the machine travels while turning your part.

The Estimate Runtime command accounts for Dwell times and subprograms
when calculating estimated run time, but it can not account for stops that
have indefinite length of stop time. These program stops include:

� Pause (G05/M00)

� Chain (M20)

� Skip (/)

� Wait for input high/low (G26/G25)

� Write to file (M22)

� Rerun (M47)

The Estimate Runtime command treats M47 Rewind codes as M2 End of
Program codes.

This command also verifies the syntax of your NC programs while calculat-
ing the estimated run time. If an error is found, the Estimate Run Time
command alerts you with a dialog box, and places the cursor near the error.
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Use the Pause command to pause a running NC program. Pause may also be
used during tool path verification. The pause is not immediate; it takes effect
after the current NC block has been executed.
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Select Pause from the Program Menu, or click the Pause button on the Standard
Toolbar.
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Press F5, click the Run button on the Standard Toolbar, or click the Go button
on the Message Bar.
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The Feedhold command is very similar to the Pause command. It is used to pause a
running NC program. The differences between a Pause and a Feedhold are:

� A Feedhold pause the NC program immediately; it does not wait until
the current block is executed.

� Feedhold does not work during tool path verification.
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Select Feedhold from the Program Menu.
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Press F5, click the Run button on the Standard Toolbar, or click the Go button
on the Message Bar.
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You can use the Stop command under the Setup Menu to halt a running NC
program. The Turning Center immediately halts cutting and the current tool
position is stored by the computer.

��
���
� �
����
��������

01 Select Stop from the Program Menu, press Ctrl+Space, or click the Stop
(red) button on the Standard Toolbar.

81 A message box appears. Clear the box by clicking OK or pressing Enter.
You are automatically returned to the Edit mode.
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01 Manually jog the tool so it is above the workpiece to avoid a tool crash.
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81 Select the Run/Continue command to restart the NC program. You will
not have to reset the initial tool position (assuming the first block of
your program moves the tool to the start position).
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The Tools Menu commands allow you to select tools, and to set up and use a
tool library.
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Setup Library Define tools used with the Turning Center.

Select Tool Select a tool for use on the Turning Center.
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Use the Setup Library command under the Tools Menu to assign parameters
to multiple types of tools used on the Turning Center. When you select the
Setup Library command, the Setup Tool Library dialog box appears.
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There are two ways to create a new tool in the Setup Tool Library dialog box.

� Use the Copy and Paste buttons to copy an existing tool in the Tool Library
box and paste it into the Tool Library box under an unassigned tool number.
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Assigned tool numbers are displayed with a tool icon. Unassigned tool num-
bers have no tool icon.

� Manually create a tool using the features available in the Setup Tool Library
dialog box.
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01 Select an unassigned tool number from the Tool Library list.

81 Select a tool type, such as Grooving, from the Tool Type drop-down menu.

21 Enter a name for the tool in the Description field.

31 Enter the Material Type from which the tool is made, such as High
Speed Steel.

41 Enter a tool Width, Radius, Right Angle, and/or Angle depending on
the type of tool that you have selected.

:1 Enter a tool Offset value. You may also click on the Use Current Posi-
tion button to establish the current Z, X position of the tool as the
Offset.

>1 Enter an Orientation, either inside (for boring, tapping or drilling
applications),outside (for cuts made on the outside of a workpiece), or
facing.

?1 Enter a point of Reference, either Tool Radius Center for the middle of
the workpiece or Theoretical Sharp Corner for the top or bottom edge of
the workpiece.

@1 Enter a Cut Direction, either Right/Up (cutting away from the chuck)
or Left/Down (cutting toward the chuck).

0D1 If the tool is mounted on the backside, check the box labeled Mounted
on Backside. See page A-12 for a diagram.

001 Apply the new parameters to the selected tool number by clicking the
Apply button.

081 Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool library.
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01 Select an existing tool from the Tool Library list.
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81 Make the desired changes to the tool parameters, then click on the
Apply button.
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There is a secondary library for tool materials. You can use this library to cre-
ate new materials or edit existing materials. To do this, click on the Edit
Tool Materials button, then:

01 Click on the Add button.

81 Enter a material Name.

21 Select a Material Class.

31 Enter a Multiplier. This should be set to “1” for now. This is used when
integrating with CAM for calculating feed rates and spindle speeds when
generating tool paths.

41 Click on the Delete button to remove tool materials you no longer need.

:1 Press Enter or click on OK to accept the new material. Click on Can-
cel to exit the Tool Material Type dialog box without changing the ma-
terial library.
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21 Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool library.
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Use the Select Tool command under the Tools Menu to select a tool for use
on the Turning Center.

To select a tool:

01 Select the Select Tool command from the Tools Menu. The Select Tool
for Use dialog box appears.

81 Select a tool from the drop-down Tool list. The tool parameters appear
in the window to the right of the list.

21 Select an action to exit the dialog box:

� Click Select Tool button if the tool is already in the mounted spindle.

� Click Insert Tool to perform a tool change cycle. When the Turning
Center spindle stops, you are prompted to insert a tool into the tool
post. After you insert the tool and press F5, the Turning Center
returns to its original position.

When using a tool turret which has already been homed, the Insert
Tool command will turn the turret to the station that holdes the se-

lected tool. If the turret has not yet been homed, the following dia-
log box will appear.

Click on OK to home the tool turret.



?+*. 4�(����
��"$� �B���

����?

������
����
&���
�������

After choosing and mounting tools in the turret, you must identify for  the
software program which tools are in the turret and which positions they are
in. When you have defined the tools and assigned each one a tool station, the
turning program will then know which position to rotate the turret to when
cutting. The foolowing tool turret commands will be available to you.

The Select Tool From command provides quick access to each of the tools
which are defined for the tool turret. Each of the eight stations are listed for
easy selection.
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Once you have defined tools to be used by the tool turret, you must identify
where the tools are located in the tool turret. This allows the software to
move the turret to the proper place to perform the cutting operations.

All eight tool stations are displayed in the Configure Turret dialog box. when
you defined the tool, you also should have selected a station. If you click on
the station box, the tool number (which may be  different than the station
number) will show below the box, allowing you to selectit.
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The Operate Turret dialog box allows you to home the Tool Turret, as well
as test turret operation.

Click on the Home button, indicated by the icon, to move the turret to the
home position. When the turret reaches the home position, a black dot ap-
pears the circle on the Homed button.

The up and down arrows under the Home Sensor button allow you to check
the operation of the sensor. Clicking on either arrow will move the turret in
the indicated direction, until the turret encounters either a hard stop or trips
the home sensor. When the Home Sensor is activated, a dot appears on the
button. Clicking on the button has no affect on the sensor.

The Home Sensor button and arrows are primarily for diagnostic purposes,
and are used to verify the operation of the turret and the sensor.

Click on the Done button to exit the Operate Turret dialog box.



?+*7 4�(����
��"$� �B���

����?

The Set Turret Home Position box appears. You may click on Move
Turret Home to move the turret to its home position and leave it
there. you must then reselect the desired tool. You can also Click on
Move Turret Home, then Move Back to Station1, or a different sta-
tion as indicated. The turret will then home and then move to the
proper station.

� Click Cancel to exit the Select Tool for Use dialog box without
selecting a tool.
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The Setup Menu commands control the parameters for tool positioning, jog-
ging, running and verifying programs, coordinate systems, tool offsets, etc.
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Set Position Establish the X and Z position of the tool.

Zero Position Set the current tool position to X0,  Z0.

Jog Settings Establish speed and distance parameters for jogging
the tool.

Run Settings Establish options for running an NC part program.

Verify Settings Establish options for verifying an NC part program.

Set/Check Home Establish or check a fixed known position on the
machine.

Goto Position Automatically move the tool to a specific set of
coordinates on the Turning Center.

Units Select Inch or Metric units of measure.

Coordinate Systems Define multiple coordinate systems for the
Turning Center.

Offsets Modify the table of Offset values used for certain
NC codes.

Spindle Specify a spindle speed if you have not used an S
code in your NC program.
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Backlash Define the amount of play in the Turning Center
turning screws.

Soft Limits Establish software limits for each axis that are
different than the actual fixed hardware limits on
the Turning Center.

Preferences Establish defaults for saving files and security features.
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Use the Set Position command under the Setup Menu to set new X and Z
positions for the tool. This command establishes a World Coordinate System
in relationship to the Machine Coordinate System. Setting the X and Z coor-
dinates for the tool also defines the zero point of the coordinate system for
absolute motion.

This command is also available under the Position Window Pop-up Menu.

To set a new position:

01 Move the tool to the desired
position.

81 Select Set Position from the
Setup Menu. The Set Position
dialog box appears.

21 Enter a new Z position.

31 Enter a new X position.

41 Press Enter or click on OK.

The new position is displayed in the Position Window.
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Use the Zero Position command under the Setup Menu to reset the point of
origin (0,0) at any position on the Turning Center. Since the tool length and
the workpiece position on the cross slide may vary from one tooling setup to
another, the zero position must be initialized each time the  setup is changed.

This command is also available under the Position Window Pop-up Menu.

To set the zero point:
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01 Move the tool to the point on the workpiece you intend to establish as
the zero point.

81 Select Zero Position from the Setup Menu. The new position (0,0) is
displayed in the Position Window.
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Use the Jog Settings command to open the Jog Settings dialog box. This dialog
box is used to enter speed and distance values for the Jog Control Panel. The

Jog Settings command is also available through the Jog Control Panel Pop-up
Menu.

To set jog parameters:

01 Select Jog Settings from the Setup Menu. The Jog Settings dialog box
appears.

81 Enter the desired jog speeds and distances.

21 Select OK or press Enter. The new values are applied to the Jog Control
Panel.
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The jog speed is the rate at which the tool moves along the X and Z axes. Se-
lect the speed by entering the desired speed in the Jog Settings dialog box,
then press the appropriate button (Slow, Medium or Fast) on the Jog Con-
trol Panel.

The default values for speed are:

� 1 ipm for Slow
� 15 ipm for Medium
� 25 ipm for Fast

These feed rates can be set as high as 30 inches per minute.
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Distance values determine how far the tool moves each time a key is pressed.
Referred to as Steps, the distance is selected by pressing the A, B or C buttons
on the Jog Control Panel. Using the Jog Settings dialog box, the distance can
be set at a low value (for instance 0.0005 inch) to move the tool for a precise
cut, or at a high value (e.g. 5 inches) to position a tool.

These are the default values for steps:

� 0.001 inch for Step A
� 0.01 inch for Step B
� 0.1 inch for Step C

Pressing the Continuous (Cont.) button moves the tool continuously as long
as the axis button is depressed. Once the axis button is released, the tool
stops.
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Use the Run Settings dialog box to set or clear options for running your NC
program. The available options are:

� Single Step

� Optional Skip

� Optional Stop

� Enable Subprograms

� Arc Centers Incremental

� Treat Warnings as Errors

� Restore Unit Mode When Done

� Verify While Running
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This option inserts a Pause after each block of the NC program. To move on
to the next block in the program, you can:

� Click the Run button on the Standard Toolbar.

� Click the GO button on the Message Bar.

� Press F5.

� Press Enter.
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� Select Run/Continue from the Program Menu.
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Use this option to enable or disable the optional skip code. The optional skip
code allows you to skip blocks of code as the NC program is run.

Make sure to check off the Optional Skip box in the Run Settings dialog box
or activate the Optional Skip button on the Operator Panel. Then place a
forward slash ( / ) in front of each line in the NC program you want to skip.

With Optional Skip off, each skip code is ignored and each block of code is
executed. With Optional Skip on, each skip code is recognized and each
block of code that has been tagged with a skip code is skipped.

To execute particular blocks every nth pass, place a number after the optional
skip. For example:  /5G28; Home every fifth pass
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Use this option to enable or disable the optional stop code (M01). The op-
tional stop code allows you to place an optional stop in your NC program.

Make sure to check off the Optional Stop box in the Run Settings dialog box
or activate the Optional Stop button on the Operator Panel. Place an M01
on the line of code where you would like to pause.

With the Optional Stop option on, the M01 works like a G05. With Optional
Stop off, the M01 code is ignored, the other codes on the block are executed
as usual.

%��*��
��*��������

Use this option to enable or disable the use of subprograms. With this option
disabled, M98 commands generate an error. Running or verifying a program
with subprograms enabled takes longer to start because the software parses
the entire file for subprogram information. This extra delay should only be
noticeable with very large programs.
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Use this checkbox to specify the default mode for programming arc centers.
If this box is checked, the default mode is the Fanuc mode, in which arc centers
are always incremental. If this box isn’t checked, the default mode is EIA-
274, in which arc centers follow the general programming mode: absolute
when the mode is absolute, and incremental when the mode is incremental.
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This command is used for special applications, such as laser welding, where
you don’t want any unexpected pauses in the program execution. For example,

'����

#	��������������
��'(�
����/���� ��
	�
 �(�$'
�&0��'�
����
	��!�
�����
�'���

���
����GHI�����&��'$
����
����
���
GJI�
� ������
	��(���
�'�����(�
	��(�'��



?+*,���
��'�9�������4�(����
�

when a warning is displayed and the program pauses, waiting for your input
before it continues.

When this item is checked, any warning will halt the program, performing a
program Stop. When motion is stopped, all outputs are turned off.
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If you normally work in one unit mode (inch or metric) but would like to
run a program in another mode without disrupting your default settings,
check this box.

Select a specific unit mode by using one of the G20/G21 or G70/G71
commands at the beginning of your NC program. Once the NC program is
executed, your default unit mode will be restored.

For instance, if you normally work in Inch Mode, but have a particular pro-
gram you would like to run in Metric Mode, check the Restore Unit Mode
When Done box. Place a G21 code at the beginning of your program, then
run it. When the program is finished, the default for your system will still be
Inch Mode.
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If this box is checked, the Verify window will display the program verification
while the program is running. The verification does not show exactly what is

happening on the Turning Center. There is a delay between each tool motion.
You will see each tool motion on the screen, but the screen will pause until
the machine finishes the motion and the next program block is read.
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Use the Verify Setup dialog box to control the appearance of the tool path
verification. You  can also access this dialog box using the Verify Window
Pop-up Menu.

The Verify Settings dialog box is tabbed, with the settings organized into
three groups: the Display Panel, Tool Position Panel and Stock Panel.

"������
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The Display Panel allows you to control the view. It offers a selection of view
preferences.

Zoom

Use these buttons to control the size of the stock in the Verify Window. You
can click on the buttons or use Alt key combinations (Alt++, Alt+-, and Alt+A).
Each mouse click or key combination used zooms by an increment of one.

������ &�������

+ Zoom in on the stock.
- Zoom away from the stock.

All Fit the stock into the window.
Arrows Move in the indicated direction.

Center the stock.

Colors

Use these buttons to select which colors will indicate the background, stock,
and tool in the Preview Window. Color options can be viewed by clicking
on the down arrow to access a bar of various colors.

Verify Speed

Use the slider to alter the speed at which the Verify Program will be executed
in the Verify Window. If you would like to view the verify program in slower
motion, move the slider to the left. If you would like to view the Verify Pro-
gram at a faster rate, move the slider to the right.

� �
!��B���
,�����

The Preview Window appears in the Display and Stock Panels. The Preview
Window shows you approximately what the Verify Window will look like.
The preferences for the Preview and Verify Windows are set in the Display
Panel.
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Other Options

If the Auto Refresh on Resize box is checked, the Verify Window automati-
cally refreshes the display of the workpiece if the Verify Window is resized
during verification. When Auto-refresh is disabled, you will need to manu-

ally cause the verify window to update by selecting the Redraw command
from the window’s context menu. This setting only affects refreshing the
window when no verification is in progress.
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The Tool Position Panel controls the initial tool position and the tool loca-
tion in reference to the stock.

Initial Tool Position

You can select a tool start point using Initial Tool Position. Only use Initial
Tool Position for verification, not for actually running a program. The Ini-
tial Tool Position is used when you verify a program; when verifying an NC
program while running it, the actual physical position of the tool is used as
the initial tool position.
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Tool Location

The specification of tool location depends on where your tool will be
mounted according to the NC program you are using.  You must check ei-

ther Above Stock or Below Stock. Usually the a single tool is mounted on
the tool post below the stock and the optional tool turret is mounted above
the stock.

����5
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The Stock Panel allows you to specify particular information about the stock
and tool position for tool path verification.

All stock values are interpreted according to the Units Mode in effect at the
time they are set. To quickly see which Units Mode is currently in effect, check
the Position window.

Dimensions

Use this area to set the dimensions of the stock used in the verification
process. You will see the stock in the Preview Window change as soon as you
enter a dimension.

Origin

�������

The OK button at the bottom of the dialog box applies the changes you have
made and closes the dialog box.

The Cancel button closes the dialog box without applying any of the changes
you have made.

The Help button brings up the Help topic.
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Use this area to adjust the verification for different workpiece setups. Most
NC programs set the 0,0 point at the left center of the stock, immediately in
front of the chuck. The origin of the stock must be based on this 0,0 point.

The origin of the stock is always 0,0. The stock initialization point varies de-
pending on where the origin is relative to the stock.

Show Chuck and Origin Marker

Check this box to display the Chuck and the Origin Marker in the Preview
and Verify Windows.
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The Set/Check Home command performs two functions, it sets a reference
position on the machine and it helps you to check the reference position on
the machine. When you select the Set/Check Home command the following
dialog box appears.

The Set Home button opens the Reference Point Wizard, which aids you in
setting a machine reference point. Just follow the directions.

The Use Current button uses the last defined Reference Point. Home must
already be set in order for this button to work.

'����

�	�'��
	��4�(����
��9���
���M�� ���
�

�/���
	����
	����(�� ���
�����'���
� 

��7�;�����8�$�
�����
��'
���
	���(�� 
��
��

	���������

!(�0�$�����$�����"7,����"7��
� �����
0�$��������������0�$��$�
�$���
	�
4�(����
��9���
���M�� �
��	����
	�
��
	����(���
�

'����

!(�0�$���$' �'�2��
	��
��'�
��
��/�'��


	��4��� �(�� ���
���
'�
2����
	��
�
#�����&$

������
�� �

01 Enter the coordinates for the
new tool position.

81 Enter the feed rate at which you
would like the tool to travel.

21 Click on the Go button. The
tool moves to the new position
at the defined feed rate.
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The Move Home button moves the machine to the reference point coordi-
nates so you can manually measure the machine position to make sure no po-
sition has been lost.
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The Goto Position command opens the Goto Position dialog box. Use the
Goto Position dialog box to move the tool to a particular coordinate posi-
tion on the Turning Center.

This command is also available under the Position Window Pop-Up Menu
and Jog Control Panel Pop-up Menu. To use the Goto Position command:
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Use the Units command under the Setup Menu to select the unit of measure
for the application. When you select the Units command, a fly-out menu ap-
pears allowing you the option of using Inch (standard) or Metric measurement.
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Use the Coordinate Systems command under the Setup Menu to define multiple
coordinate systems for machining more than one workpiece. This is often
done for production runs of the same part.  This command is also available
under the Position Window Pop-up Menu.
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01 Select Coordinate Systems from the Setup Menu. The coordinates fly-
out menu appears.
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81 Select an existing coordinate system from the fly-out menu. Select one of
the available coordinate systems available, CS1 through CS6, (these are
equivalent to using the codes G54 through G59 in your NC program).

OR

Select the Work Coordinates command to cancel the Coordinate System
offsets and return to Work Coordinates.
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01 Select Coordinate Systems from the Setup Menu.

81 Select Setup from the fly-out menu. The Setup Coordinate Systems dia-
log box appears.

21 Select a coordinate system, then enter and apply the offsets.

a) Select a CS from the System list.

The system titled “Work CS” contains the current values for the work
coordinate system. This is like adding a G92 code to your NC pro-
gram. You can change the default for the work coordinate system by
entering new values in the Offsets boxes. These values are an offset from
the true origin of a coordinate system and affect all coordinate systems.

b) Select the offsets for a user coordinate system by:

� Entering X and Z offset values in the Offsets boxes.
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� Clicking the Current Pos button to establish offset values based
on the current tool position.

� Selecting a Marker in the Preview Area for the coordinate sys-
tem and dragging it to the desired position.

� Copying offsets from one CS to another using the Copy Offsets
and Paste Offsets buttons.

c) Make the currently selected CS the active CS by checking the Active
Offset box.

d) Apply the coordinates or exit the dialog box:

� The OK button applies the changes you have made and closes
the dialog box.

� The Cancel button closes the dialog box without applying any
of the changes you have made.

� The Apply button applies the changes you have made to the se-
lected CS (you can still cancel changes once they have been applied
by selecting the Cancel button).
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Use the Offsets command under the Setup Menu to compensate for varia-
tions in the cutting tools being used. The offset values are used for cutter
compensation and tool offset adjustment NC codes.
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01 Select Offsets from the Setup Menu. The Setup Offsets dialog box appears.
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81 Click on an Offset Number (the numbers 1 through 199 are available).
This number only acts as a designation (a name) for the offset.

3. Enter an Offset Value in the Value box, or select the Current Z button
to use the current Z position (also useful for defining tool heights if you
are using G43 or G44 to specify tool heights).

31 Press Enter or click on OK. The Offset Value has been associated with
the Offset Number. The next time you open the Offsets table, you will
see the new offset.

� �
)$$���
��*��

The Offset Table stores up to 200 values which are used in several operations
including tool offset adjustment, cutter compensation, and tool length com-
pensation to ensure uniform application of an offset value. The numbers are
stored as unit-less values; their interpretation depends on the Units default
currently in effect.

Set the values in the Offset Table using the Offsets command under the Setup
Menu.
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Use the Spindle command under the Setup Menu to specify a spindle speed
if you have not used an S code in your NC program.

The spindle speed is primarily determined by the Mode Switch on the Turning
Center front panel. If the Mode Switch is set to Manual Mode, spindle speed
is controlled by the Spindle Speed Control Knob, also on the front panel. If
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the Mode is set to computer, spindle speed is determined by an S code in the
NC program. If there is no S code in the NC program, spindle speed is de-
termined by the Setup Spindle dialog box.
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01 Select the Spindle command from the Setup Menu. The Spindle Setup
dialog box appears.

81 Select a spindle speed by entering a value in the RPM box, or by using
the slider and arrow buttons.
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� Reset the spindle override value to 100% by clicking on the Reset Override
to 100% button.

� Change the On/Off state of the spindle using the Spindle On and
Spindle Off buttons.

� Select Done to close the dialog box.
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Use the Backlash command under the Setup Menu to define the amount of
play in the Turning Center turning screws. The system default is set at a
backlash value of 0.0 on both axes, with a feed rate of 10 ipm.

To establish new backlash parameters:

01 Select Backlash from the Setup Menu. The Setup Backlash dialog box
appears.
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81 Enter the desired backlash distances and feed rate.

21 Press Enter or click on OK to accept the new backlash parameters, or
click on Cancel to exit the Setup Backlash dialog box without setting
new backlash parameters.
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Use the Soft Limits command under the Setup Menu to establish software
limits for each axis. The limits are different than the actual fixed hardware
limits on the Turning Center. Soft limits can confine the tool travel to an
area smaller than the normal maximum travel.

The Turning Center shuts down if it trips a soft limit, just as it does when it
trips one of the limit switches. This is helpful when working with devices
such as robots, or when you have installed fixtures within the normal work
area that you don’t want the tool to hit.

To establish software limits on the Turning Center:

01 Select Soft Limits from the Setup Menu. The Setup Soft Limits dialog
box appears.

81 Enter the coordinates that define the software perimeter you wish to
establish.

21 Click on the Enable Soft Limits option to enable soft limits. Use this
option to turn soft limits on or off as you need to use them.

31 Press Enter or click on OK to accept the new soft limit parameters, or
click on Cancel to exit the Setup Soft Limits dialog box without setting
new soft limit parameters.
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Use the Preferences command under the Setup Menu to establish defaults for
saving files and setting security features.
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01 Select the Preferences command from the Setup Menu. The Preferences
dialog box appears.
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81 Select one of the Editor ,Security or Misc. preferences tabs.
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The Editor preferences allow you to automatically save your NC program
files at regular intervals, and establish a default directory in which to store
your files. When you select the Editor tab in the Preferences dialog box, the
Editor panel appears (depicted above).

To select AutoSave features:

� Select Save when idle and enter a value in the Every:___ minutes box to
save your NC programs automatically at the specified time increment.

� Select Save Before Running to save changes to your NC program prior
to running it for the first time with the changes.

To select File Default features:

� Enter an Extension for your NC part program files. The default is “NC.”

� Select Lock Files When Opened to have your NC programs locked by de-
fault. Deselect this feature to have your NC programs unlocked by default.

� Select the Set button to specify a target directory in which to save your
NC program files. The default directory appears in the Directory box.
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Other features:

� Select Hilite Comments to distinguish the comments from commands in
your NC program.

� Select Quick Run/Verify by Default to always run or verify without being
prompted to select the file or the start line.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on
Cancel to exit the Preferences dialog box without setting new Editor or
Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.
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The Security preferences allow you to control which features others may use.
When you select the Security tab in the Preferences dialog box, the Security
panel appears.

The Security preferences panel offers two modes, User and Administrator.
Administrator Mode allows a supervisor, such as a teacher in a classroom, to
turn commands on or off using the Allowed Commands list. User Mode
does not have access to this feature.

To secure the software using Administrator Mode:

01 Set the Default Mode to User. (This will not change the current mode.)

81 Use the Change Password button to create a password. The default pass-
word is blank — no password.

21 Select the Allowed Commands. Double-click on the listed commands to
enable or disable them. If the commands are enabled, they are marked
with an X. A description of each selected command is displayed on the
right side of the panel.

31 Use the Change Mode button to change to User Mode.

41 Select OK or press Enter to exit the Preferences dialog box.

The software is now running in User Mode. The next time you open the
Preferences dialog box, the Security preference panel is displayed in User
Mode. In this mode it is not possible to turn commands on or off.

To return to Administrator Mode:

	(!)#��'�7

�������
$��
0�����$����
	��(�''�����
��
$��(��
$�������� ���&'� �&0� �(�$'

�	���
	����(
������������������ ��

� ���� ���
���0�
����G�� ���'�
� 
(��
$���I

� :((��
�

� ��(
�����
�

� 9��(����
��
#	��
����� �������&'� ��&$

��'�

�����
���''������
�(���
	�
� �����
��
���������� �&�(����
	�
9��(����
��� ��'���&�1���������

� <�
2'��	

#	��4��
������

�����
����� �$� ��

	����'�����$�����'��� ���&'� �&0
 �(�$'
�



?+-. 4�(����
��"$� �B���

����?

(���1
!��$�������

The Misc. preferences allows you to choose to Confirm the reference point
by checking the Confirm ‘Zero Position’ Command box. By checking this
box, the warning “Are you sure you want to reset the current position to
ZERO on all axes?” will appear every time the Zero Position Command is
activated in the Setup menu. You must then select Yes to apply the com-
mand.
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01 Use the Change Mode button to toggle the Mode from User to Admin-
istrator. A dialog box appears, prompting you to enter your password.

81 Enter your password and press Enter or click on OK.

To change your password:

01 Click on the Change Password button.

81 Enter your current password.

21 Enter the new password.

31 Enter your new password again to verify that it is correct.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on
Cancel to exit the Preferences dialog box without setting new Editor or
Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.
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The Window Menu commands allow you to manipulate the arrangement of
the Program Edit Windows.
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Cascade Layer the open edit windows.

Tile Tile the open edit windows.

Arrange Icons Arrange any minimized edit windows along the
bottom of the edit area.

Window List Display and select between the currently open NC
programs by their file names.
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Similar to the standard Windows/Cascade command, this command places
the open Program Edit Windows in a layered format, cascading down to the
right with the currently selected window on top.
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Similar to the standard Windows/Tile command. Places the open Program
Edit Windows in a tiled format, filling the Edit Area from top to bottom.
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When you minimize a Program Edit Window, it becomes a small icon. The
Arrange command under the Window Menu arranges these icons along the
bottom of the edit area.

,�����
����
�������

Lists the currently open Program Edit Windows. The currently selected win-
dow is designated with a check mark. You may select any window by clicking
on the window itself, or by selecting the window name from this list.
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The Help Menu commands allow you to navigate through the Help files, to
save or restore parameters set throughout the current session, and provides
handy tips and other information about the Control Program.
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Help Display Help for the current task or command.

Index List Help topics.

Using Help Display instructions about how to use Help.

Save Settings Saves the current machine and application settings.

Restore Settings Resets the machine and application settings from
defaults.

Tip of the Day Display a Tip of the Day.

About WSLT Display program information, version number and
copyright.

����
�������

Use the Help command to access the Help contents. You can also press the
F1 key to get information about the currently highlighted command on a
drop-down or pop-up menu.
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Use the Help Index command access an index of available Help topics.
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Use the Using Help command to obtain information on how to use the
Help utility.
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The Save Settings command brings up a dialog box that allows you to retain
current library, security, screen and control settings as defaults.

� Click on a particular setting(s) to tag it, then click on the Save button to
save the selected items and exit the dialog box.

� Click on the Save All button to save all settings without having to select
each one.

� Click on the Cancel button to exit the Save Defaults dialog box without
changing the existing defaults.
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The Restore Settings command allows you to restore all or some of the cur-
rent settings to the defaults you set using the Save Settings command (User
Defaults) or to the factory set defaults.

� Click on a particular setting(s) to tag it, then click on a Restore From
option. Click the Restore button to restore the selected items and exit
the dialog box.

� Click on the Restore All button to restore all settings without having to
select each one.
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� Click on the Cancel button to exit the Restore Defaults dialog box with-
out changing the existing defaults.
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This command brings up information about the operation of the Turning Cen-
ter, tips and tricks for using the Control Program and NC programming ideas.
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This command simply brings up an information box. Included is informa-
tion on the Control Program version number, the release date, and copyright
information.
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There are a few different ways to select commands in the Control Program.
Use the method that is most convenient for you.
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Clicking the right mouse button on certain windows or panels brings up a
pop-up menu. Each pop-up menu is context-sensitive. Commands which
cannot be performed at that time are grayed out.

To select a pop-up menu command:

01 Position the cursor on the window or panel.

81 Click and hold down the right mouse button. The context-sensitive
menu appears.

21 Highlight a command by moving the mouse
pointer over it, then release the right mouse
button.

The following windows have pop-up menus:

� Program Edit Window

� Position Window

� Verify Window

� Jog Control Panel
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The Machine Info Window and Operator Panel only provide the Dockable
and Hide commands on their Pop-up menus.

!������
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The Program Edit Window Pop-Up Menu contains different combinations
of these commands, depending on whether the file is running or being veri-
fied, and whether or not text is selected.

���
�������

Cut is the same as selecting the Cut command from the Edit Menu.

����
�������

Copy is the same as selecting the Copy command from the Edit Menu.

!����

�������

Paste is the same as selecting the Paste command from the Edit Menu.

�����
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Clear is the same as selecting the Clear command from the Edit Menu.

%B������
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Evaluate Selection will process an equation which is highlighted and replace it with
a result. If the selected text is not a valid numerical equation, there is no result.
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Goto Line is the same as selecting the Goto Line command from the Edit Menu.

#����*��
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The Renumber command is the same as selecting Renumber from the Edit Menu.
A dialog box appears that allows you to alter the N codes in the NC program.

��B�
�������

Save brings up the Save As dialog box.

I���5#��
�������

The QuickRun command is a shortcut that runs the currently selected NC
part program. When you click the right mouse button on this command, the
program behaves as though you had selected the Run/Continue Command
from the Program Menu with the following exceptions:

� You do not have the option of selecting a starting line.



?+-- 4�(����
��"$� �B���

����?

� You do not have the option of changing any settings.

I���5
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The Quick Verify command is a shortcut that veri-
fies the currently selected NC part program. When
you click the right mouse button on this command,
the program behaves as though you had selected the
Verify Command from the Program Menu with the
following exceptions:

� You do not have the option of selecting a start-
ing line.

� You do not have the option of changing any settings.

%�������
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This command performs the same function as the Estimate Runtime com-
mand under the Program Menu.

!�������
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The Position Window Pop-Up Menu contains these commands:

	�� 
�������

Automatically switches the units of measure for the current program to
inch units.

(�����
�������

Automatically switches the units of measure for the current program to
metric units.

����������
�������
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Produces a fly-out menu that allows you to set up and select coordinate sys-
tems just as you would using the Coordinate  Systems command from the
Setup Menu.
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Opens the Set Position dialog box.
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Sets the current tool position to zero on both axes.
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Opens the Goto Position dialog box.
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The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Verify Window Pop-Up Menu contains these commands:

�����
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This command opens the Verify Settings dialog box.

#�����
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This command repeats the most recent tool path
verification simulation.

����
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This command interrupts the verification currently in progress.

#����
�������

This command resets the Verify Window; it clears the tool path lines and re-
sets the tool to the starting position.

"��5�*��
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The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.



?+-� 4�(����
��"$� �B���

����?

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Jog Control Panel Pop-Up Menu contains
these commands:

�����
�������

This command opens the Jog Settings dialog box.
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This command opens the Goto Position dialog box.

���F� ��5
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This command opens Machine Home/Reference Point dialog box.
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The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

����
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The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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Some menu commands have one or more key designations next to them; those
are the hot keys for that command. Pressing the hot key(s) selects the corre-
sponding command. For example, press Ctrl+S to save your file. Other hot
keys are also available for controlling machining functions; for instance, use
the Ctrl+KeyPad+ combination to increase feed rate override.

Here’s a list of the available hot keys:

���G�H� (���F��������

Ctrl+C Edit Menu/Copy
Ctrl+F Edit Menu/Find
Ctrl+G Edit Menu/Goto Line
Ctrl+H Setup Menu/Set/Check Home
Ctrl+L Edit Menu/Lock
Ctrl+N File Menu/New
Ctrl+O File Menu/Open
Ctrl+P File Menu/Print
Ctrl+R Setup Menu/Run Settings
Ctrl+S File Menu/Save
Ctrl+Space Program Menu/Stop
Ctrl+T Tools Menu/Setup Library
Ctrl+V Edit Menu/Paste
Ctrl+X Edit Menu/Cut
Ctrl+Y Edit Menu/Delete Line
Ctrl+Z Edit Menu/Undo
Ctrl+Shift+Z Setup Menu/Zero Position
F1 Help Menu/Help
F2 Edit Menu/Delete Line
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F5 Program Menu/Run/Continue
F6 Program Menu/Verify
F8 Setup Menu/Goto Position
Ctrl+KeyPad+ Increase Feed Rate Override
Ctrl+KeyPad- Decrease Feed Rate Override
Ctrl+Backspace Edit Menu/Undo
Shift+Delete Edit Menu/Cut
Shift+F1 Help Menu/Context Help
F4 Activate Jog Control
Ctrl+F5 QuickRun
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Ctrl+F6 Quick Verify
Ctrl+TAB Next Edit Window
Ctrl+Insert Edit Menu/Copy
Shift+Insert Edit Menu/Paste
Pause Edit Menu/Pause

������
�
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The Tool Bars contain buttons that correspond to frequently used menu
commands. Clicking a button on a toolbar is equivalent to selecting the same
command from a menu, and is usually quicker. The Control Program pro-
vides Standard, Input, Output , and Turret Control toolbars. Use the com-
mands under the View Menu to control whether each tool bar is displayed or
hidden.

!����������
������
����������
The Control Program interface is easily configured and optimized by open-
ing, closing, resizing, and repositioning the screen components.

!����������
����*���

You can reposition any of the toolbars (Standard, Inputs, Outputs, or Turret
Control) simply by dragging them off their docking areas. Once away from
the docking area, the toolbar becomes a floating window, which can be
treated the same as any other window (E.G. move it, resize it, close it). To
move the toolbar, click on the toolbar background (the area behind the but-
tons) and drag.

!����������
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The windows and panels, (Position Window, Machine Info, Jog Control
Panel, Operator Panel, Verify Window) are initially docked on the docking
area on the right side of the screen. If these items are moved away from the
docking area, they become floating windows or panels until they are moved
back to the docking area. (See Docking and Floating Windows and Toolbars
on the following page.) The Verify Window is initially not dockable.
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01 Press and hold the Ctrl key.

81 Click on the window/panel with the left mouse button.

21 Hold and drag the window/panel off the docking area.
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41 When the floating window is over its new location, release the mouse
button. You can now treat the area the same as you would any other
window (e.g., move it, resize it, close it).
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(The Dockable command must be invoked for a window/panel before it can
be docked. See Docking and Floating Windows and Toolbars.)

01 Click on the title bar of the floating window.

81 Drag the area back to the docking area.

21 Release the mouse button.

!����������
!������
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Program Edit Windows can be moved, resized or closed just like any other
window. The only restriction is that the Edit Windows can not be moved
out of the edit area. For instance, you can not move an Edit Window to a
docking area.
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After changing a component’s position on the screen, you can save it’s position
by checking the Window Positions box on the Save Settings dialog box (se-
lect Save Settings from the Help Menu). The next time you use the Control
Program, the component appears in the new position. To restore the default
position (the factory preset position), use the Restore Settings command un-
der the Help Menu.
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Windows and Toolbars can behave in two ways; they can be placed in a sta-
tionary state, docked, or they can be in a free-floating state, and moveable.
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A docked screen component is fixed in place, unlike a floating component
which can be placed anywhere on the screen. When a screen component is
docked, the window frame and title disappear.

&�������
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����������

A floating screen component can be moved to any position on the screen,
unlike a docked screen component, which is fixed in place. When a screen
component is floating it has a window frame and title.
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� Click on the background area of the toolbar and drag it away from the
docking area to float it.

� Click on the background or the title bar of the toolbar and drag it to the
docking area to dock it.
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01 Position the mouse pointer over the window you would like to dock/float.

81 Click the right mouse button.

21 Select Dockable from the drop-down menu.

When the Dockable command is checked, the window can be dragged to a
docking area and docked. Dockable windows can not be resized.

When the Dockable command is not checked, the window will float and can
not be docked. Some floating windows can be resized.
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The Setup Program allows you to set program and hardware defaults. In order to
access the Setup Program, you must first exit the Control program. Locate
the spectraLIGHT LATHE folder on your hard drive, (the default installa-
tion location is C:\ProgramFiles\Programs\LMC\WSLT) and double click
the Setup Icon. The program will start and you will see the Welcome screen.
You may choose from the file tabs to view the settings for each category.

The Setup Program provides settings under the following categories:

� Welcome

� Interface Card

� General
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� Control
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This panel provides one option, Units Default. This option sets the default unit
of measure for the Control Program and the Setup Program. When running
the Control Software, you can change the default using the Units command
under the Setup Menu.

	����$���
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This panel allows you to change the Interface Card Address. Once you have
installed the Interface Card and software, and performed the initial Setup,
this address should not change. The only time you might consider changing
the address is if there is a hardware conflict.


������
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This panel allows to you alter several software defaults.

����� Run Offline starts the Control Program in Simulate Mode without
checking for a machine connection.

Simulation Mode is provided to allow the Control Program to be used
when your computer is not connected to a spectraLIGHT Turning
Center. This is primarily to support the off-line development of NC
programs.

NC program verification and running is supported in Simulation Mode.
Programs will Run in the same amount of time that they would if a ma-
chine were attached (excluding stops that have indefinite length of stop
time, see Estimate Runtime).

The principal difference between Simulation Mode and Normal Mode
is, since no machine is available to send and receive data, there are no In-
puts and Outputs. The Inputs and Outputs buttons on the toolbars are
inoperable. If your program contains commands to wait for certain input
values that are not the default, the events will never occur. If the values
are the default, the wait will occur immediately.

'����

!�
��������
	����1��$���$�&�����
 ��
	��(��$&�����������@$������'��	
'0
����������0�����'����0�$�$�����
�����������
	�
���'�1��$&���������
0�$��	�$' ���
���� �
��
	�����
	���
/�'$���



?+,,���
��'�9�������4�(����
�

����� Decimal Places for Inch Values controls the display of values in dialog
boxes. When in Metric mode, the software displays 1 less than the speci-
fied number of decimal places.

����� NC Programming Settings controls several programming options:

����� The Maximum Number of Subprograms.

����� The Maximum Depth of Subprograms; the number of nested sub-
programs.

����� The Default L-Factor; the angle at which a line segment approxi-
mates a portion of an arc.

����� The Default Run Feed Rate; the initial feed rate when running or
verifying an NC program; used until a  feed rate is specified in the
NC program.

����� The Default Button resets all configurations in the General Panel to the
default settings of the control software. The picture on the previous page
shows the default settings.

�������
!����

The New Controller Box option lets the controller know which version of
Controller electronics you are using. The How Do I Tell button explains the
difference between the controllers.

The Turret Settings Box option lets the control software know if an optional
Tool turret is installed or not.



?+,� 4�(����
��"$� �B���

����?



�+�<���
�����9����������

�����
�'�
!����������

� �
%�������
�$
��
'�
!���
!������

����������
�$
'�
����


������
!����������
�����������

#�$������

�����
�������
&



�+7 4�(����
��"$� �B���

�����

� �
%�������
�$
��
'�
!���
!������
Part programs generally incorporate two types of instructions: those which
define the tool path (such as X and Z axis coordinates), and those which
specify machine operations (such as turning the spindle on or off). Each in-
struction is coded in a form the computer can understand.

An NC program is composed of blocks (lines) of code. The maximum number of
blocks per program is limited by the memory (RAM) on your computer. You
can, if necessary, chain programs together to form very large part programs.

Each block contains a string of words. An NC word is a code made up of an
alphabetic character (called an address character) and a number (called a pa-
rameter or value). There are many categories of address characters used in NC
part programs for the spectraLIGHT Turning Center (see Categories of NC
Code).

Each block of NC code specifies the movement of the cutting tool on the
Turning Center and a variety of conditions that support it. For example, a
block of NC code might read:

N1G90G01X.5Z1.5F1

If the machine is currently set for inch units, the individual words in this
block translate as:

N1 This is the block sequence number for the program. Block 1 is the
first block in the program.

G90 This indicates absolute coordinates are used to define tool
position.

G01 This specifies linear interpolation.

X.5 This specifies the X axis destination position as 0.5".

Z1.5 This specifies the Z axis destination position as 1.5". The cutting
tool will move to the absolute coordinate position (0.5,1.5).

F1 This specifies a feed rate of 1 inch per minute, the speed at which the
tool will advance to the specified coordinate points.
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Many categories of NC codes can be used to program the spectraLIGHT
Turning Center. Here is a list of the NC codes (designated by the address char-
acter) supported by the spectraLIGHT Turning Center.

����� &��������

% Incremental Arc Centers (Fanuc).
$ Absolute Arc Centers.
\ Skip.
/ Optional skip.
F Feed rate in inches per minute; with G04, the number of

seconds to dwell.
G Preparatory codes.
H Input selection number
I Arc center, X axis dimension (circular interpolation).
K Arc center, Z axis dimension (circular interpolation).
L Loop counter; Program cycle (repeat) counter for blocks and sub-

programs, angle of arc resolution.
M Miscellaneous codes.
N Block number (user reference only).
O Subprogram starting block number.
P Subprogram reference number (with M98 or M99).
Q Peck depth for pecking canned cycle.
R Arc radius for circular interpolation (with G02 or G03); Starting

reference point for peck drilling (with canned cycle codes).
S Spindle speed.
T Tool selection.
U Incremental X motion dimension.
W Incremental Z motion dimension.
X X axis motion coordinate.
Z Z axis motion coordinate.
; Comment.
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The incremental arc center code selects the Fanuc mode for programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the Fanuc mode, arc centers are always incremental, regardless of whether
the system is in G90 (absolute) or G91 (incremental) mode. In contrast, arc
center specifications in EIA-274 mode follow the selected programming
mode, absolute or incremental.

You can specify the default arc center mode in the Run Settings dialog box in
the Setup menu.

This character must stand alone on the first line of the NC program in
which it appears.
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The absolute arc center code selects the EIA-274 mode of programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the EIA-274 mode, the mode of programming arc centers follows the selected
programming mode, absolute (G90) or incremental (G91). In contrast, arc
center specifications in Fanuc mode1 are always incremental, regardless of
whether the system is in absolute or incremental mode.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.
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The Skip and Optional Skip codes allow you to skip particular lines of code
in your program.
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Place the code at the beginning of the line you wish to skip. When you run
the NC program, the specified line will be skipped.
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Use the Skip code with a parameter to instruct the Control Program to execute
the line of code every nth pass. Place the code at the beginning of the line
you wish to skip. The syntax is: \n, where n is the number of passes between
executions.

For example, if you want to execute a block of code every 5 passes, place \5
as the first code at the beginning of the block.
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01 Place the code at the beginning of the line you wish to skip.

81. Select the Optional Skip option from the Run Settings dialog box or the
Operator Panel.

When you run the NC program, the specified line will be skipped. If you do
not select the Optional Skip option in the Run Settings dialog box, the skip
code is ignored and the line is executed normally.
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Use the Optional Skip code with a parameter to instruct the Control Program to
execute the line of code every nth pass. Place the code at the beginning of the
line you wish to optionally skip.

The syntax is: /n, where n is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place /5
as the first code at the beginning of the block.
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The F Code is used to specify the rate of speed at which the tool moves (the
feed rate in inches or millimeters per minute, depending on the selected unit
of measure). For example, F3 equals 3 ipm when in inch units or 3mmpm
when in metric units.

The feed rate should be set to a low value (up to 30 ipm) for cutting operations.
Feed rate values are in millimeters per minute (mpm) when using metric
units. The Control Program limits the programmed feed rate so it doesn’t ex-
ceed the maximum allowed by the Turning Center.

The F Code is also used to specify the number of seconds to dwell when used
with the G04 code. For example, G04F5 causes the machine to dwell for five
seconds.
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G codes take effect before a motion is specified. They contain information
such as the type of cut to be made, whether absolute or incremental dimen-
sioning is being used, whether to pause for operator intervention, and so on.

More than one G code from different groups can appear in each NC block. However,
you may not place more than one G code from the same group in the same block.

The G codes supported by the spectraLIGHT Turning Center Control Pro-
gram fall into the following groups:

� The Interpolation Group

� The Units Group

� The Wait Group

� The Canned Cycle Group

� The Programming Mode Group

� The Preset Position Group

� �
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The Interpolation Group allows you to specify the type of motion for inter-
polation. These G codes are retained until superseded in the NC program by
another code from the Interpolation Group.

The supported interpolation G codes are:

G00 Rapid traverse
G01 Linear interpolation (default)
G02 Circular interpolation (clockwise)
G03 Circular interpolation (counterclockwise)

Refer to Section G for more information on these functions.

� �
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By default, an NC program is interpreted using the units of measure (inch or
metric) specified using the Units command on the Setup Menu.

The codes in the Units Group, G70 (inch) and G71 (metric), are used to
override the Units command for the entire program.

If the code is placed at the beginning of the program before any tool motions are
made, that unit of measure is assumed for the entire program. Otherwise, it affects
the rest of the program following the code.  You can use these codes to switch be-
tween inch and metric modes throughout your program at your convenience.

The Fanuc equivalents, G20 (inch) and G21 (metric), can also be used.
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The Units Group Codes are:

G70 Inch Units
G71 Metric Units
G20 Fanuc inch units
G21 Fanuc metric units

� �
,���

����

Wait Group codes apply only to the block in which they appear. The program
does not continue until the wait conditions are satisfied.

The supported Wait Group codes are:

G04 Dwell (wait): Pause between motions on all axes for the number of sec-
onds specified by the F code, then continue the program. This is used pri-
marily for robot integration. Because the F code is used to specify the num-
ber of seconds, you cannot also specify a new feed rate in the same block.
Example: G04F10;Wait for 10 seconds

G05 Pause: Used for operator intervention. Stop motion on all axes until
the operator manually resumes program execution using the Run/
Continue command.

G25 Wait until TTL input #1 (Robot 1 or user input 5) goes high before
executing the operations on this block. Used for robot synchroniza-
tion (see Section L  for more information). Use the H code to
specify an input other than the default, H5.

G26 Wait until TTL input #1 (Robot 1 or user input 5) goes low before
executing the operations on this block. Used for robot synchroniza-
tion (see Section L for more information). Use the H code to
specify an input other than the default, H5.
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Canned cycle codes allow you to perform a number of tool motions by specifying
just one code. Canned Cycle codes are typically used for repetitive operations
to reduce the amount of data required in an NC program. Canned cycle codes
are retained until superseded in the program by another canned cycle code.

The supported Canned Cycle codes are:

G32 Canned cycle thread cutting
G72 Canned cycle arc turning, clockwise
G73 Canned cycle arc turning, counterclockwise
G77 Canned cycle side turning
G79 Canned cycle end turning
G80 Canned cycle cancel
G81 Canned cycle drilling
G83 Canned cycle peck drilling

Refer to Section G  for more information on these functions.
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Programming mode G codes select the programming mode, absolute (G90)
or incremental (G91). These codes remain in effect until superseded by each
other. The default code on program start up is G90.

With absolute programming, all X and Z coordinates are relative to origin of
the current coordinate system. With incremental programming, each motion
to a new coordinate is relative to the previous coordinate.

The supported Programming Mode codes are:

G90 Absolute programming mode
G91 Incremental programming mode
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The preset position G codes move the tool to a predetermined position, or
affect how future motions will be interpreted.

The supported Preset Position codes are:

G28 Set reference point: This code moves the machine to its home posi-
tion and sets the machine position to 0,0. The G28 code performs an
automatic calibration of the axes.

G29 Return to reference point: Moves the tool to a coordinate specified
by XZ. Typically used after a G27 or G28 code.

G92 Preset position: This code works like the Set Position command
under the Setup Menu. The X and Z coordinates following a G92
code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle  complete.
G99 Rapid move to point R (surface of material or other reference

point) after canned cycle complete.
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Use the Coordinate System codes to establish multiple coordinate systems on
one or more workpieces to create multiple parts.

For instance, you can run a part program using a typical coordinate system
(with the point of origin on the left side of the workpiece next to the chuck,
along the centerline of the workpiece), then select another coordinate system
which has its origin at a different point on the surface of the workpiece.

Multiple coordinate systems can be useful for different size workpieces, or
for special set-up conditions

There are seven coordinate system codes. One of these codes (G53) is used to
make a rapid traverse motion to specified machine coordinates. The other six
codes allow you to make up to six individual parts on the same workpiece by
specifying different work coordinate systems for each part.
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The coordinate system codes are G54 through G59, referring to coordinate
systems 1 through 6 respectively. These coordinate systems may be set
through the Coordinate Systems command on the Setup Menu.
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The Polar Programming Group codes allow you to perform polar program-
ming operations, based on polar coordinates.  Refer to Section H for more in-
formation on using polar programming.

The supported Polar Programming codes are:

G15 Polar programming OFF
G16 Polar programming ON
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Use the compensation NC codes to automatically compensate for scaling and
rotation adjustments. Refer to Section H for more information on using scal-
ing and rotation.

The supported Compensation codes are:

G50 Cancels scaling.
G51 Invokes scaling.
G68 Invokes rotation.
G69 Cancels rotation.
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The H code is used to specify inputs and outputs in  robot integration.

Use the H code in conjunction with:

� The wait codes G25 and G26, to specify the input number.  If the H code is
not used with these G codes, input 5 is assumed.

� The transmit codes M25 and M26 for interfacing with robots or other exter-
nal devices, to specify the output number. If the H code is not used with
these M codes, output 4 (Robot 1)  is assumed.
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In absolute programming mode (G90), the I code specifies the X axis coordinate of
the center point of an arc or circle when using circular interpolation. In incre-
mental mode (G91), the I code specifies the X axis distance from the start point
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of motion to the center point of the arc for circular interpolation. If no I code is
specified, the system uses the current X axis location as the X axis center of the arc.

In Fanuc mode, all arc centers are incremental.

The I code is also used with the G51 code to specify the scale factor for the X axis
when performing scaling functions, including scaling each axis and mirror scal-
ing. Refer to Section H for more information on using scaling.
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In absolute programming mode (G90), the K code specifies the Z axis coordinate
of the center point of an arc or a circle when using circular interpolation. In
incremental mode (G91), the K code specifies the Z axis distance from the start
point of motion to the center point of the arc for circular interpolation. If no K
code is specified, the system uses the current Z axis location as the center of the arc.

In Fanuc mode, all arc centers are incremental.

The K code is also used with the G51 code to specify the scale factor for the Z
axis when performing scaling functions, including scaling each axis and mirror
scaling. Refer to Section H for more information on using scaling.
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The L code specifies the angle of arc resolution in circular interpolation pro-
gramming. When the system executes a circular motion, it actually splits the
arc into a series of line segments to approximate the circle. The L code speci-
fies the angle in degrees which a line segment approximates a portion of the
arc. The smaller the angle, the smoother the cut. A negative value for L will
generate a normalized L factor (degrees x radius {in inches}) so larger radii have
smaller degree values. For example, with the default L factor of -1:

� An arc with a radius of 1 inch will have line segments approximating ev-
ery 1 degree of the arc.

� An arc with a radius of .5 inches will have line segments approximating
every 2 degrees of the arc.  (Degrees = -L/R, or Degrees = -(-1) / .5,
which is 2)

The default setting for the Turning Center is 2 degrees, and typically this
will work quite well. You may notice the Turning Center hesitating on arcs if
the resolution is too fine. The L code can be a fraction of a degree (such as L.5),
but it must be large enough so the Turning Center will move at least the mini-
mum motion (.0005") on each of the straight line motions.
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Use the L code with:

� The M98 code as a loop counter for subprograms.

� The M47 code as a program cycle counter, to repeat a program a finite
number of times.

� The G27 code to specify tolerance with homing commands (this is an
LMC-specific NC language extension). The difference between the cur-
rent position and 0 is compared to a tolerance value specified using the
Setup Program; use the L code to override this tolerance value.

� An L code that is not used by one of these codes is used as an Arc Reso-
lution factor.

L20
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M codes control a variety of Turning Center functions while a part program
is running. Only one M code should be specified per NC block. M codes
and motion commands should be placed on separate blocks to avoid confu-
sion over whether an M code is activated during or after a motion command.

M codes can also be used to chain a second program to the end of a part pro-
gram, or to repeat an NC program.

The supported M codes are:

M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.
M01 Optional Stop: Allows you to place an optional pause in your code.

Place an M01 in the block of code where you would like to pause.
There are switches to activate or deactivate the Optional Stop code in
the Run Settings  dialog box and on the Operator Panel.
With Optional Stop on, the M01 works like a G05 pause.
With Optional Stop off, the M01 code is ignored, and the other
codes on the block are executed as usual.

M02 End of Program: Takes effect after all motion has stopped; turns
off drive motors, and all outputs, including the spindle and the ac-
cessory outlets.

M03 Spindle Motor On: Activated concurrently with motion specified
in the program block; remains in effect until superseded by M05.

M05 Spindle Motor Off: Activated after the motion specified in the pro-
gram block; remains in effect until superseded by M03.

M06 Tool Change: Pauses all operations, turns off spindle, retracts the
cross slide for tool change.

M08 Accessory #1 On: Turns on ACC 1 accessory AC outlet concur-
rently with the motion specified in the program block; remains in
effect until superseded by M09. This is the same as using the M25
H2 codes.

M09 Accessory #1 Off: Turns off ACC 1 accessory AC outlet after the
motion specified in the program block is completed; remains in ef-
fect until superseded by M08. This is the same as using the M26
H2 codes.

M10 Accessory #2 On: Turns on ACC 2 accessory AC outlet concur-
rently with the motion specified in the program block; remains in
effect until superseded by M11. This is the same as using the M25
H3 codes.

M11 Accessory #2 Off: Turns off ACC 2 accessory AC outlet after the
motion specified in the program block is completed; remains in ef-
fect until superseded by M10. This is the same as using the M26
H2 codes.
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M20 Chain to Next Program: This code is used to chain several NC
files together. It appears at the end of a part program and is fol-
lowed on the next line by the file name of another program which
is executed when all motion stops. Here’s an example of a part pro-
gram chain to another program:

N37 Z.2

N38 M20

PROGRAM2.NC; Chain to PROGRAM TWO

If the two programs you are chaining are not in the same directory
on your computer, you must specify the full path name for the
next program file. If the software cannot locate the specified file,
you will be prompted to find it.

M22 Output current position or other information to file.
M25 Set TTL output #1 (Robot 1 or Output 4) On: Used for robot

synchronization (see Section L for more information). Use the H
code to specify an output other than the default, H4.

M26 Set TTL output #1 (Robot 1 or Output 4) Off: Used for robot
synchronization (see Section L  for more information). Use the H
code to specify an output other than the default, H4.

M30 End of program: Same as M02.
M35 Set TTL output #2 (Robot 2, or Output 5) On: Used for robot

synchronization (see Section L for more information).
M36 Set TTL output #2 (Robot 2, or Output 5) Off: Used for robot

synchronization (see Section L for more information).
M38 Drive MotorsStandby: Typically used to turn the drive motors to

standby (low power) before a pause (G05); activated after the mo-
tion specified in the program block. M38 is useful when the machine
is left unattended for a long time, such as the interval before reloading
a part.

M47 Rewind: Restarts the currently running program; takes effect after
all motion comes to a stop. Typically used with an L code to repeat
a program a set number of times.

M98 Call to subprogram. Use the P code to specify the subprogram start-
ing block number. Use the L code to specify the number of times the
subroutine is executed. You can nest subprogram calls to a depth of 20.

M99 Return from Subprogram; Goto.
M105 Operator Message (nonstandard Light Machines code).
M111 Home the X axis.
M112 Home the Z axis.
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The M22 code is used to write information to a file while a program is run-
ning.  Typically, this code is used when digitizing to write the current X and
Z machine coordinates to a file. The proper format for using this code is:
M22(filename) Data to Write to File.

'����

!�(����
�����&�$
� ���
�M������
���/� � ���
	�
	�� ���
�M���
��
2����������  �
����'
��(����
������'�����
�''����	

��
	�����#�
	��
�'��$����
�



�+�* 4�(����
��"$� �B���

�����

The first time the Control Program encounters an M22 code, it opens the
specified file. You must enclose the name of the file in parentheses for the
Control Program to recognize it. If you do not specify any DatatoWritetoFile
text, the default data is output. This default is the current position, equiva-
lent to specifying ‘X@X  Z@Z’.  The @X,@Z ‘macros’ are replaced by the ac-
tual machine position when the data is written.

Each M22 code automatically adds a linefeed to the end of its output so the
next M22 starts on a new line.

If the file name is followed by “,A” (e.g., test.nc,A), the Control Program does
not delete previous information from the file, it appends the information to the
end of the existing information. If the file does not exist, it is created.

If you use more than one M22, only the first occurrence must have the file
name in the parentheses. The remaining M22’s may have empty parentheses,
( ), or may specify a different file.

If you want to generate more than one file at a time, you must include the
filename each time you specify M22. If a filename is not specified, the first
file opened is used.

Example:

. . . ; code to move to position
; Open my1.xz, discard contents, write coordinates
M22(my1.xz)
. . . ; code to move to next position
; Append to currently open data file
M22( )
. . . ; code to move to next position
;Open my2.xz and append coordinates
M22(my2.xz,A)

Special codes that can be used with M22 to generate run-time reports.

@X Current X position (in current coordinate system)
@Z Current Z position (in current coordinate system)
~ (tilde) New line (starts a new line in the file)
@TD Time of day (12hour): “11:59:59AM”
@TC Time (elapsed) for cycle: “99:11:59” (0’s trimmed from left)
@TT Time total (of program run): “99:11:59”
@TA Time Average (per cycle): “99:11:59” (“??:??” if first part)
@TL Current Tool number: “5”
@C Cycle number (current pass): “3”
@D Date: “12/31/97”
@FN Current file (without path): “PART.NC”

(“UNTITLED.NC” if untitled)
\t Tab
\\ Outputs a single backslash (‘\’) character to the file
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Example:

; Start of file
… ; Process a single part
; Output part time statistics to file c:\Reports\Stats.txt (c:\Reports
directory must exist)
M22 (c:\Reports\Stats.txt,A) Part #@C processed in @TC.
M47 L50 ; We want to process 50 parts.
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The M99 code has two specific uses; it can be used as a command to return
from a subprogram or it can be used as a goto command.
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When used in a subprogram, this code returns you to the block following
the last M98 (Call to Subprogram) command. If the M98 used an L code to
specify multiple calls to the subprogram, the M99 will return to the block
containing the M98 until all the specified number of subprogram calls have
been made; then it will proceed to the block following the M98.

You can use the P code plus a block number to override the block returned to;
however, if this feature is used from a nested subprogram call, all return tar-
gets are discarded. The rules for a Goto target block apply to this use as well.
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This command can be used in the main NC program as a Goto command to
jump to any line before the first subprogram (as denoted by the O code).

Use the P code to identify the block number being jumped to. Control is
transferred to the first occurrence of this N code; it cannot be used to trans-
fer control between chained programs (see M20).

This command can be used anywhere in the program to change the flow of
program execution. It is good programming practice to place this command
on a line by itself to improve the program’s readability.
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This command is used to display messages in the Control Program. It pro-
vides a way to display messages to the operator on the message bar while an
NC program is running. You can also pause the program with a custom mes-
sage if the first character is “!”. This is a nonstandard, Light Machines code.

By default, the message is centered, displayed as a Normal Message, and is persis-
tent (not cleared until the program clears it or until the next message is displayed).
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M105(the message);comment

For instance, the following line of code displays a simple message:

M105(End of Roughing Segment);Normal Message; doesn’t pause
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! Displays the message and performs a pause requiring operator interven-
tion to continue.

~ Displays the message as a Warning Message.

\b Beeps when the message is shown.
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M105(alternate character plus the message) ;comment

For example:

M105(~WARNING);Warning Message , doesn’t pause
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M105( ) ; clears current message
M105(!Please stop and read this!) ; Normal Message, pauses
M105(~!I MEAN IT!) ; Warning Message, pauses
M105(\b\b\b) ; Clears current message, beeps 3 times, and doesn’t
pause
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N codes have two uses:

� To provide destinations for Gotos (M99) elsewhere in the program.

� To clearly show the organization of the code and improve readability.

Using the N code is optional; however, when you do use the N code, it must
be the first character in the block.

Other than for the above stated uses, N codes are ignored by the Control
Program. Their presence, absence, or sequential value does not affect the ex-
ecution of the NC program in any way (unless the target of a goto is missing).

You may have N codes on some blocks and not on others. N code sequence
numbers do not have to be in order, but regular sequential order does make it
easier to follow and reference sections of the program. The Control Program
can change the N codes in a program by inserting, removing, or renumber-
ing the codes.
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The O code is used to indicate the start of a subprogram, and must be fol-
lowed by a number which identifies the subprogram. The O code replaces
the N code in the first block of the subprogram.

To call a subprogram, use the M98 code; use the P code to specify which
subprogram to execute. To return from the subprogram, use the M99 code.

Only the first block in the subprogram contains the O code. The remaining
blocks may contain N codes. The O and N code numbers may be used to help
identify and set apart the subprogram to improve readability, for example:

M98 P50000 ;call to first subprogram
…;after first subprogram is finished, M99 code returns to this point
…
M98 P60000 ;call to second subprogram
…;after second subprogram is finished, M99 code returns to this point
…
O50000 ;start of subprogram
N50010 ;first line of subprogram
N50020 ;second line of subprogram
N50030 M99 ; last line of subprogram
…
O60000 ;second subprogram
N60010 ;first line of second subprogram
N60020 ;second line of second subprogram
N60030 M99 ; last line of second subprogram

��*�������
#�$������
'��*��
G!
����H

Use the P code with:

� The G31 code to reference a goto target block.

� The M98 code to reference a subprogram using the subprogram block number.

� The M99 code to specify a return block number as a goto target.
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The Q code is used with the G83 code in canned cycle peck drilling to specify
the incremental depth of each peck.
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As an alternative to specifying the center point of an arc (I Code or K Code)
you can specify the arc radius. Use the same value for the radius in both ab-
solute and incremental programming modes.

G02 or G03 specifies the direction of motion.

Positive values for R (radius) are specified for arcs up to 180°. Negative val-
ues are used for arcs greater than 180°. Full circle arcs cannot be performed
with an R code. Split the circle into two arcs, or use center point (I and K)
values for full 360° circles.

Use the R code in canned cycles to specify a Z axis reference point for peck
drilling. The point can be at the material surface or at another reference
point. The R code is also used to specify the rotation angle, in degrees, with
the G68 code.

�������
�����
G�
����H

Use the S code to set the spindle speed from within the NC program. Spindle
speed is specified by the address character “S” followed by a parameter that
represents the speed in RPM. For example, S750 is the designation for a
spindle speed of 750 RPM. For the spindle speed to have an effect the
spindle must be turned on by the M03 command. If the spindle is off, the
spindle speed is stored and used when the spindle is turned on again within
the program. Use the M05 command to turn the spindle off.
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T codes specify the tool (number) in the Tool Library in multiple tool ma-
chining operations. Tools are specified by the address character “T” followed
by a parameter that represents the number of the tool. For example, T3 is the
designation for tool number three.
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An X code specifies the coordinate of the destination along the X axis. A U
code is used in absolute programming mode (G90) to specify an incremental
X motion.  You cannot use the U code to mix incremental and absolute pro-
gramming in the same block.
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The Z code specifies the coordinate of the destination along the Z axis
(spindle axis). A W code is used in absolute programming mode (G90) to
specify an incremental Z motion. You cannot use the W code to mix incre-
mental and absolute programming in the same block.
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The Control Program allows you to add comments (notes) to your NC code
lines. The Control Program recognizes two comment codes, a semicolon “;”
and an open parenthesis “(”. These two comment codes are equivalent. The
use of either of these codes within an NC block indicates that a comment
follows.

Comments must follow all other NC codes in the block. Comments are
ignored when the part program is executed. Comments can be placed on a
block without any NC codes to document what is occurring within a pro-
gram. NC programmers use these comments to annotate their programs.

Here is an example of an NC block with a comment:

X0Z0;MOVE TO ZERO POINT

The comment tells us that the X and Z codes in this block command the cut-
ting tool to move to the zero point (coordinate 0,0).

Comments can be combined with the G05 pause and the M06 Tool Change
codes to display messages to the operator during program execution. Here is
an example of an NC block with a pause coded comment:

M05(SPINDLE OFF
G05(ROUGH DIAMETER SHOULD BE 0.5 in.)

When the program pauses, the comment is displayed on the message bar,
telling the operator to verify the diameter of the workpiece before continu-
ing. The M105 code provides a more versatile and powerful message facility.

The Control Program can strip comments from a program with a single
command; however, the comments can not be subsequently replaced.
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The following rules should be followed when writing NC part programs.

1. The sequence of words (address characters plus parameters) in an NC
block must appear in the following order: J9
K9
L9
F9
'
G)H9

9
C
G�H9;
G,H9

	9�9
#9
I9
�9
&9
�9
�9
(9
!9
M�A different order may cause unpredictable results.

81 In many cases, a word need not be repeated in the next block (line). The
system assumes no change in codes unless a new code appears. Some of
the codes this does not apply to: N words, I and K, G04, G05, G25, G26,
G92, F used for dwell, M02, M20, M25, M26, M30, M47, M98 or M99.

21 You can use more than one G code in a block; however, you can use
only one G code from any one group in a single block.

31 N codes (sequence numbers) are not required in a part program; however,
they can be useful in identifying a block when editing a long NC part
program.

An O code is required to mark the beginning of a subprogram and does
not have to be in sequence with the N codes.

41 The first instruction in a part program should move the tool to the start-
ing position. This makes restarts much easier.

:1 The last block of a program should move the tool back to the starting
position. The tool will then be in position to start cutting another part.

>1 Part programs should reference the zero point with Z0 at the point
where the tool just touches the work piece. This convention allows for
standardization of programming.

?1 Before running an NC part program:
a. Look for the typical coding error that places two X codes or two Z

codes in the same block.
b. Be sure that all required coordinates have been written into appro-

priate blocks.
c. Verify the part program to discover any program errors.
d. Run the part program without mounting stock in the Turning Cen-

ter to see if the tool movements are logical.

@1 The first portion of a part program should turn on the spindle and establish
the feed rate and spindle speed.

0D1 M codes should be placed on separate blocks to avoid confusion over
whether an M code is activated during or after a motion command.

001 Double-check all program blocks against your coding sheet to locate and
correct typographical errors.
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Linear interpolation is the movement of the tool in a line from its current
position to a coordinate location specified by an NC code. Here’s a typical
line of NC code using linear interpolation:

N5G90G01X1Z.5F2

Broken down into individual words:

N5 The line sequence number is 5
G90 Coordinates are given using absolute dimensioning
G01 Linear interpolation is specified

X1 X axis coordinate of end point = 1
Z.5 Z axis coordinate of end point = .5
F2 Feed rate is 2 inches per minute

The G01 code is required when switching from circular interpolation or
rapid traverse positioning back to linear interpolation. If we assume the cur-
rent position of the tool is X.7, Z1.2, the tool movement generated by the
above line is something like this:

An equivalent movement is achieved with incremental dimensioning (G91):

N5G91G01X.3Z-.7F2
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Here are two typical lines of NC code using circular interpolation:

N9G90X0Z1;SET START POINT
N10G02X1Z0I0K0F2;CLOCKWISE TO X1,Z0

The first line defines the starting point. The second line defines the end
point and the center of the arc. Broken down into individual words, the sec-
ond line reads:

N10 The line sequence number is 10
G02 The tool will proceed in a clockwise direction from the starting

point to specified (X, Z) coordinates; center point of arc is speci-
fied by (I,K) coordinates

X1 X axis coordinate of end point = 1
Z0 Z axis coordinate of end point = 0
I0 I coordinate of center point of arc = 0 (relative to start point)

K0 K coordinate of center point of arc = 0 (relative to start point)
F2 Feed rate is 2 inches per minute

��������
	������������
!����������
Circular interpolation moves the cutting tool along an arc from the starting
point specified in one line, to an end point specified in the next line. The
curvature of motion is determined by the location of the center point (I or
K), which must also be specified in the second NC line.

The direction of rotation from the starting point determines the actual shape
of the arc relative to the spindle axis. A G02 code moves the tool in a clock-
wise (CW) motion from the starting point. A G03 code moves the tool in a
counterclockwise (CCW) motion from the starting point.
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Assuming the start point is X0,Z1, the tool path generated by the preceding
lines is something like this:

#0��
�'�
��'���/����
�$�����
��
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��
����'�
����

An equivalent movement is achieved with incremental dimensioning (G91):

N9G91X0Z1;SET START POINT
N10G02X1Z-1I0K-1F2;CLOCKWISE TO X1,Z0

In this NC line, the X and Z values are the distance the tool is to move from
its current position. In both cases, the I and K values are equal to the X and
Z distance from the start point to the center point.
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On the spectraLIGHT Turning Center, the rapid traverse code (G00) can
move the tool at the maximum available feed rate (30 ipm) to specified coor-
dinates. Rapid traverse is used to reposition the tool before ending a program, or
in preparation for the next cut.

,�#'	'
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Rapid traverse can be used for all tool positioning motions. This will reduce
the run time for the part program. The G00 code remains in effect until lin-
ear (G01) or circular (G02, G03) interpolation is again specified. Linear or
circular interpolation resumes at the feed rate last specified prior to the rapid
traverse motion(s) unless you specify a new feed rate.

Rapid traverse is not affected by the feed rate scale factor. If all the position-
ing motions are done in rapid traverse (G00) and all the cutting motions are
done in linear (G01) or circular interpolation (G02, G03), cutting rates can
be adjusted up or down using the feed rate scale factor without affecting
rapid traverse motions.

Here’s a sequence of typical NC lines using rapid traverse:

G90G01X1F2; MOVE IN A STRAIGHT LINE TO X = 1 AT 2 IPM
G00X2; RAPID TRAVERSE TO X=2
X3; RAPID TRAVERSE TO X=3
G01X4; MOVE IN A STRAIGHT LINE TO X=4 AT 2 IPM
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Canned cycle commands allow you to perform many operations by specify-
ing just a few codes. They are typically used for repetitive operations to reduce
the amount of data required in an NC program. Canned cycle codes are re-
tained until superseded in the program by another canned cycle code.

The supported canned cycles codes are:

G32 Canned cycle thread cutting (see Section H for more information)
G72 Canned cycle arc turning (clockwise)
G73 Canned cycle arc turning (counterclockwise)
G77 Canned cycle side turning (Fanuc G90)
G79 Canned cycle end turning (Fanuc G92)
G80 Canned cycle cancel
G81 Straight drilling
G83 Peck drilling

These codes are used in conjunction with canned cycle codes:

G98 Rapid to initial position after canned cycle complete; this is the
system default.

G99 Rapid to point R after canned cycle complete.

K Code Specifies the number of repeats. The default is 1. When K=0,
drilling data is stored.

P Code Specifies the length of dwell time in seconds.
Q Code Specifies the depth of cut. In peck drilling each peck uses the

same Q value. The Q value is always positive. If a negative value
is specified, it is converted to a positive value. In side and end turn-
ing cycles the Q value is used to specify the depth of each roughing
cut.

R Code Used for specifying a starting reference point for peck drilling or for
specifying tapers for side and end turning cycles. The point can be
at the material surface or at another reference point.



"+,����� ���� 9����������

'�������
���� ��� �$��
$������
0
'�

�����'0�&�����(���� �������
@$� ���
Q��
�
�����
�&�����(���� 
�
�����@$� ���
��

G0X0.001Z1

G73X.5Z.5I0K.5Q.004

G80

G0X0.001Z1

G72X.5Z.5I0K.5Q.04

G80
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G72 can be used to cut an arc in one quadrant in a clockwise direction, for
instance:

G0X0.001Z1;START POINT

G72X.5Z.5I0K.5Q.04

G80

In the second block of code, G72 specifies a clockwise arc, uses I and K codes to
specify the center point of the arc, and uses a Q for the depth of the cut. G73
works the same way, except it specifies a counterclockwise arc. These cuts are
made using a facing orientation and a profiling tool.
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The G77 code can be used to perform four functions: for straight side turning,
for roughing cuts (using the Q code for depth of cut), for making tapers and
for boring.

Straight Side Turning

Straight side turning is a simple operation with the G77 code. The tool
makes a rapid move to the X depth, feeds to the Z coordinate, then backs out
and returns to the start point. The following is an example of code using
straight side turning.

G0X.6Z.8

G77X.4Z.5F10

G80

The tool movement for this example would be similar to that shown below.

#��� ���
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Performing roughing cuts with the G77 code works the same as straight side
turning, except that a Q code is placed in the block to specify the depth of
each cut. For instance, this block

G0X.6Z.8

G77X.25Z.5Q.02F10

G80

tells the tool to make 0.0200-inch roughing cuts until it reaches the speci-
fied X and Z coordinates.
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Tapers are created by adding an R code. The following examples show a positive
taper (using a negative R value) and a negative taper (using a positive R value).
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Boring (inside turning cycle) inside is done by using a smaller X value at the
beginning of the operation than at the end of the operation. The tool moves
into the workpiece nears the center, then moves outward with each cut. An
R value can be added to turn an inside taper. To perform a boring opera-
tion, the code would be something like:

G0X0

G77X.375Z.5Q.03F10

G80
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The G79 code can be used to perform an end turning cycle. The cuts are
made on the face of the stock. G79 can be used with a Q code and R code
just like G77. A typical use for G79 is shown in the following example.

G0;START POINT

G79X.2Z.8Q.03F10

G80
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To cancel a canned cycle, use the G80 code. This code cancels the currently
running canned cycle and resumes normal operation. All other turning data
is canceled as well. You can also cancel canned cycles by using a G00 or G01
code; a G80 is automatically performed before the G00 or G01.



"+�7 4�(����
��"$� �B���

����"

�����

?0
���

?2

The G81 code performs straight drilling operations. G83 is used for peck
drilling. By specifying an R value of zero, the tool will return to the initial
point after drilling to point Z. The G98 code is the default for rapid move-
ment to the initial point, or you could also use G99 to rapid to point R. We
placed both rapid return codes in this sample to show how they should be
placed in the program.

G0X0Z1;RAPID TO 0,1
G81Z.9R1F2;CENTER DRILL TO DEPTH OF Z.9 FROM Z1 FEED 2,
RAPID TO INITIAL POINT
G83Z.5R1Q.1F3;PECK DRILL TO Z.5 FROM Z1 EACH PECK .1,
RAPID TO POINT R
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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This program will generate tool motions similar to this:
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In addition to Linear and Circular interpolation, the Turning Center sup-
ports geometric curve definition using Spline interpolation. This feature is
included for advanced users who wish to use a CAD software package to gen-
erate drawing information (end point and control point information) for use
on the spectraLIGHT Turning Center.

Whereas circular interpolation defines arcs as portions of a circle, spline interpola-
tion defines curves based on non-colinear points. These more flexible curves are
called Bezier curves. Unlike arc coordinates defined by a start point and an
end point relative to a center point, coordinates on Bezier curves are defined
relative to two end points and two control points.
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The end points of a Bezier curve are anchored and do not move, so the shape of a
Bezier curve is dependent on the position of the control points. The control
points can change the shape of the curve in any number of ways, allowing for
greater flexibility in curve definition.
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Normally, Bezier curves used in machining operations are generated by a
CAD software package; they are not performed manually. All you need to
know is where the start, end and control points are. Once you plot the coor-
dinates for these points, the computer can perform the mathematical func-
tions necessary to generate the Bezier curve. The following is a simple method
for producing a Bezier curve by construction.
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You can assign coordinates to the start, end and control points of a curve and
enter this information as part of your NC part program. Here is a block of NC
code using spline interpolation:

N24G0X.5Z3;START POINT

N25G101X2Z.5I1.5K3A2C1.5

N26G1Z0

Block N24 moves the tool to the start point.

The second NC block (N25) can be analyzed as:

N25 Block sequence number = 25

G101 The preparatory code for spline interpolation

X2 X-axis coordinate of the end point

Z.5 Z-axis coordinate of the end point

I 1.5 X-axis coordinate of the first control point

K 3 Z-axis coordinate of the first control point

A2 X-axis coordinate of the second control point

C1.5 Z-axis coordinate of the second control point

If the start point is X.5, Z3, the curve generated will be similar to the one
shown below.

��<�M�����$�/����
	�������� 
���� ���
���

.

�

7

)

C

;
� 7 )

(���
�
��
��'�����


��
�� �
��
��'�����


���
��'�����


�� �����




"+�,����� ���� 9����������

�����
� �
�
����
��
������
	������������

Previously, when you used circular interpolation, you defined segments of an
arc in degrees using the L code. In spline interpolation the L code can be
used to define the number of segments required to complete a curve like the
one shown on the previous page. The more segments there are in the curve,
the smoother the curve approximation by the cutter.

Values for L that are too large or too small can create problems. Large values for
L will bog-down the computer and cause the tool motion to slow down.
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Subprograms are used to execute repetitive routines in an NC program. Since
a subprogram can be called again and again, you don’t have to enter the same
data more than once. This is especially useful if the machining operation you
wish to repeat is lengthy or complex. The NC codes used for
subprogramming on the spectraLIGHT Turning Center are:

M98 Call to subprogram.
M99 Return from subprogram.

P Code The P code is used to reference the first line of the subprogram
(which begins with an O code). The P code immediately follows
an M98.

L Code The L code is used as a loop counter when used in
subprogramming. The computer executes the subprogram as many
times as defined by the L code. For instance, if the code is L5, the
subprogram is executed five times. (Optional)

O Code The O code replaces the N code on the first line of a subprogram.

A subprogram is called by an M98 and a P code. When an M98 calls the sub-
program, the main program is interrupted while the subprogram is executed.

The P code references the subprogram’s address (the first line of the subpro-
gram). The first line of the subprogram uses an O code instead of an N code
for line numbering.

When the M99 is executed, the main portion of the NC program continues
to execute from the line after the subprogram was called.

Subprogram calls can also be nested within other subprogram calls. This
means that while a subprogram is being executed, it can call another subpro-
gram. The default number of levels that subprograms can be nested is 20 lev-
els deep. You can change the default by using the Setup Program (click on
the Setup icon in the WSLT program group).
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This subprogram makes a series of light chamfered grooves. It's set up for
stock with a 0.75" diameter and 2" length so you should use a piece slightly
longer 0.75" X 2.5".

Note that the file uses absolute programming in the main program and incre-
mental programming in the subprogram. This makes it necessary to use the
G90 after the subprogram is executed to allow motion back to the start point.

;THIS FILE FOR 2.5 INCH BY 0.75 INCH STOCK MOUNTED IN CHUCK

;USE WITH A PROFILING TOOL NORMAL SIDE ORIENTATION

;SET THE START POINT AT Z2 X0.375

G0G90M03;ABSOLUTE PROGRAMMING

G0X0.380Z2

M98P1000L4;CALLS SUBPROGRAM 1000 AND EXECUTES IT 4 TIMES

G90;ABSOLUTE PROGRAMMING

G0X0.38

G0Z2

M02;END OF PROGRAM

O1000;START OF SUBPROGRAM

G91;INCREMENTAL PROGRAMMING SELECTED

G1X-0.040Z-0.040F3

G1Z-0.125

G1X0.040Z-0.040

G0Z-0.20

M99;END OF SUBPROGRAM
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The Set/Check Homing command under the Setup Menu allows you to es-
tablish a point of origin at the ends of travel on the Turning Center. The
homing commands (G27, G28, G29) allow you to return to and check this
established position. The Turning Center uses this point as a reference for all
machine coordinate movements. This allows you to use the Soft Limits and
Coordinate Systems commands (under the Setup Menu) to move the Turn-
ing Center consistently to the same location.

Before you can use any homing commands, or the Soft Limits and Coordinate
Systems commands, you must use the Set/Check Home command to estab-
lish an initial reference point. See Section E for information on using the
Set/Check Home command.
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The G28 code moves the machine to the coordinates previously established
by the Reference Point Wizard as the home position, and then sets the ma-
chine position to 0,0. If a reference point has not been defined, a warning is
generated and the G28 command is skipped. The G28 code performs an au-
tomatic calibration of the axes.
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The G28 code homes the machine and sets the Machine Coordinates to zero.
Use a G27 if you want to check the home position, but do not want to set
that position to zero.

The G54 calls up coordinate system one, which contains the offset values
relative to the machine’s home position. These would be the values which
were entered for coordinate system one in the Offset from Machine Zero dia-
log box under the Set Coordinates dialog box. The coordinates in the Posi-
tion Window on the screen change to the coordinates of “coordinate system
one.”

The next line (G0X0Z0) would call for the machine to perform a rapid traverse
motion from the Home position to point 0,0 in “coordinate system one.”
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Remember, Soft Limits are based on Machine Coordinates. You can not use Soft
Limits until you have set the machine to the reference point using the Set/Check
Home command under the Setup Menu.

�����
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The G29 code moves the tool at a rapid traverse rate to a coordinate specified
by XZ. If you have set an intermediate point on one or more axes, the ma-
chine first rapids from the current position to the intermediate point then
continues to the specified destination. If you command a G29 code in Incre-
mental mode, your specified XZ point is relative to the intermediate point. If
you have not specified an intermediate point, your specified XZ point is rela-
tive to the current position. Use the G29 code after a G28 code to return the
tool to a position closer to the part. The example below shows the use of a
G28 code and a G29 code.

N1G28X2Z-1; INTERMEDIATE POINT THEN HOME
N2G29X4Z1; GO TO G29 POINT



����6��"$� �B���

������+*

�����
!����
!����������
Using polar coordinates allows you to specify a radius and an angle by speci-
fying a G16 code (polar programming on), then X and Z codes. The X code
specifies the radius. The Z code specifies the angle in degrees. A G15 is used
to cancel the polar programming mode. This programming method can be
used in both absolute and incremental programming.

Polar programming is especially useful when writing programs for machin-
ing bolt holes. An L code can be used as a multiplier for the angle value. For
instance, this bit of code:

G0X0Z0.07
M03
G16
G91X2Z0
M98P1L12
M2
O1Z30
G81Z-.1R0
G80
M99

combines the use of polar programming with a canned cycle and a subprogram
to drill a hole at 30o increments. The L value was determined by dividing
360 degrees by 30.

You can also cut an arc using code similar to:

G16
G91X2Z0
M98P1L360
G15
M2
O1Z1
M99

In polar programming, the center point is the origin if you specify G90 and
the radius (X code). If you specify G91 and the radius (X code), the center
point is the current point. If you specify only the angle (Z code), the center
point is the current center.
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Scaling and rotating codes can be used separately or they can be combined.
Each of these functions is described in the following paragraphs.

�������

Use the scaling codes to scale one or more axes of a part from a fixed scaling
origin. You can scale the entire piece uniformly, or set different scaling fac-
tors for each axis. Use the following codes for scaling:

G50 Cancels scaling
G51 Invokes scaling

Given the information that in G51 X and Z are the origin of the scale, I and
J are the scale factors. I = X and J = Z.

Here is an example of an NC program line using Scaling. In this example,
X,Z is set at zero and is the origin of scale, and both axes are scaled by two.

G51X0Z0I2.J2.

#�������
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Rotation codes allow you to rotate a programmed shape around a rotation
origin. Lathe programs are rarely rotated, however, it funtions in the same
manner as scaling.

G68 Invokes rotation
G69 Cancels rotation

Here is an example of an NC program line using Rotation. In this example,
X,Z is the rotation center, and 90 is the rotation value in degrees.

G68X0Z0R90.
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The spectraLIGHT Turning Center allows you to designate up to 8 different
tool offsets for tool changes during turning operations. Using multiple tool
programs provides the power-user with a great deal of flexibility and freedom
from tool changes. It also allows the user to create more complex parts on the
Turning Center. To designate the tool number, tool diameter and tool offset,
select Setup Library from the Tools Menu.

Multiple tool programing can be set to either wait for a manual change of the
tool, or can be set to move to another tool which is already mounted on a
separate tool post, based on offset values. If a tool turret is installed, the ma-
chine will automatically change tools.

There are four basic steps in setting up the Turning Center for multiple tool
operation:

01 Placing the appropriate codes in your NC program,

81 Establishing a reference tool,

21 Establishing the offsets for other tools from that reference, and

31 Testing your program.
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The T code is used in the NC program to offset the cutter so that the NC
program becomes independent of the cutter length, which is set up in Tool
Definitions. This means you can replace a worn tool with a tool of a different
length without changing the NC program, just by entering new offsets.  The
T code can be located anywhere within the block of NC code, but it is nor-
mally placed after any G codes.

When you place T codes in your program for tool changes, you should also use
the M06 code to shut off the spindle and to retract the cross slide. The M06
code is placed after the T code. This code instructs the Turning Center to
shut off the spindle, while it pauses until you manually change the tool. Press-
ing the Return key will turn the spindle back on to continue with the NC
program.

The tool that is shown in the Machine Info window is the default tool for
the start of a program. The Control Program uses this tool unless another
tool is specified with a T code. Once a tool is specified, any X and Z coordi-
nates are applied to that tool until another T code is encountered in the NC
program.
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All of the X coordinates for a tool cutting on the back side of a workpiece
should be negative unless the tool crosses the centerline into a positive
quadrant, in which case the value of the point would be positive. When
switching to a tool that cuts on the back side of a workpiece within an NC
program which is primarily frontside orientation, make sure that your  pro-
gram reflects the change from a positive quadrant to a negative quadrant.

For example, if T2 is a cut-off tool on the back side of a 3" long, 0.375" di-
ameter workpiece, the codes T2Z1

X1

would tell the tool to cut right through the middle of the workpiece and stop
at 1 inch on the other side of the centerline in the positive quadrant, which is
beyond the necessary cut. For a more precise cut, the codes that should have
been used are:

T2Z1 or T2Z1
X.1 X0
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When using multiple tools for manual changing, a reference tool, normally
Tool #1, is set to zero for the Z axis. This establishes a reference tool position
which is used as a reference point for additional tools. For demonstration
purposes, we will use Tool #1 as the reference tool and Tool #2 as the
additional tool.

To set the reference tool:

01 Decide on a reference point (a point on the workpiece, or on a gauge,
where you will jog the tip of each tool).

81 Open the Jog Control Panel (select Jog Control from the View Menu).
With the tool installed in the spindle, jog Tool #1 to the reference point.
The tip of the tool should barely touch the workpiece, or zero-out a
reference gauge.

21 Select Set Position from the Setup Menu. Set the current position of
Tool #1 to zero on the Z and X axes.

Tool #1 is now established as the reference tool.
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Now that the reference tool is established, additional tools can be assigned
offsets. You can move the tool and accept its current Z and X axes position
as the offset value, or you can manually enter offset values.

To set the offset for Tool #2:

01 The reference tool must first be set to the reference point as previously
described.

81 With tool #2 selected, jog the tool turret to touch the surface of the
workpiece, or offset sensor, at the previously determined reference point.
In the Position Window, the current Z and X coordinates will be dis-
played. These are your offset values from the reference tool.

21 To enter these values as the offset values, select Setup Library from the Tools
Menu and select the Use Current Postion bar. This will automatically enter
the ofset values for you. Alternatively, you may manually enter the offset val-
ues for the Z and X axes by copying the values from the Postion Window.

The offset for Tool #2 is now established.
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After setting all of the tool offsets, test run your program without a work-
piece mounted.

01 After installing Tool #1, close the safety shield, put on your safety
glasses, and complete the safety checklist.

81 Select the Run/Continue command from the Program Menu. Select line
one as the start line and select Start. Throughout the test, be prepared to
press the emergency stop button on the Turning Center in case of a tool
crash. The computer will run the program until it reaches the M06code.
The M06 stops the Turning Center.

21 When the spindle has completely stopped and the Pause message  appears
on the screen, push in the emergency stop button on the Turning Center.

31 Open the safety shield.

41 Remove Tool #1 and install Tool #2, making certain it is securely fas-
tened to the tool post.

:1 Close the shield, and pull out the emergency stop button. Press the Re-
turn key on the computer keyboard. The spindle turns on and the cross
slide moves to the previous position. Operation continues as pro-
grammed until the next M06 code is encountered.
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>1 At each pause, repeat Steps 3 through 6, installing the appropriate
tool at the appropriate points in the program.
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When you installed the spectraLIGHT Control Program an NC part pro-
gram file, named turntwo.nc, was copied into the WSLT directory along with
the other files. The turntwo.nc program is meant to turn a 3" (length) x 0.75"
(diameter) cylindrical piece of machinable brass, aluminum, Delrin or wax.
You will be using this file to create your a workpiece on the Turning Center
using multiple tool programing.
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01 Select the Open command from the File Menu, or click on the Open
button on the Standard Tool Bar. The Open dialog box appears.

81 Double-click on the turntwo.nc file name, or click on the file name then
click on the Open button. The edit window for turntwo.nc appears.
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To turn this part, you will use three tools. To define the tool parameters, first
select Setup Library from the Tools menu.

01 Select Tool 01, a Right-Hand tool, for Tool #1. The specifications are as
follows: Description:  Left Hand Diamond

Tool Type:  Diamond
Station:           1 (May be different with tool turret installed)
Material Type: High Speed Steel
Radius: 0.0001
Angle: 30
Orientation: Outside
Reference: Tool Radius Center
Cut Direction: Left/Down

81 Select Tool 02, a Left-Hand tool, for Tool #2.  The specifications are as
follows: Description:  Facing Grooving

Tool Type:  Grooving
Station:           2 (May be different with tool turret installed)
Material Type: High Speed Steel
Radius: 0.0001
Width: 0.01
Orientation: Facing
Reference: Tool Radius Center
Cut Direction: Right/Up

21 Select Tool 03, a Parting Tool, for Tool #3.  The specifications are as
follows: Description:  Backside Grooving

Tool Type:  Grooving
Station:           3 (May be different with tool turret installed)
Material Type: High Speed Steel
Radius: 0.0001
Width: 0.0313
Orientation: Outside
Reference: Tool Radius Center
Cut Direction: Left/Down
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After opening the NC program, you need to adjust the Verify Settings for the
part you are about to turn, as you did in the turntwo.nc program. To view
the Verify Settings dialog box, select Verify Window  from the View Menu;
double click on the Verify window when it appears.

You may also select Verify from the Program Menu, or from the Standard
Toolbar, then click on the Verify Settings button. The Verify Settings dialog
box appears. Adjust the verify settings for the Display, Tool Position and
Stock. The Initial Tool Position is Z=2.01, X=0.375. The Stock Dimensions
are Z2.5, X0.75. The Origin is Z0.5, X0.
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Tool path verification allows you to check for programming errors before ac-
tually running the part program on the Turning Center.

Since we supplied this program, you shouldn't encounter any errors during
verification. You should, however, make a habit of verifying your programs
more than once to ensure there are no errors before running them on the
Turning Center.

01 Select Verify from the Program Menu or from the Standard Tool Bar.
The Verify Program dialog box appears. The default starting line for the
program is Line 1. When verifying a program for the first time, you
should begin on Line 1.

81 Click on the Verify Program button, then watch the Verify Window.
You will see the turntwo.nc program executed on the cylindrical work-
piece.
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Now that you’ve got the NC program ready to run, you are ready to get the
workpiece and stock set up.
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You should have a Right-Hand tool (tool 1), a Left-Hand tool (tool 2) and a
Parting tool (tool 3) mounted in posts as shown in the following illustration.
You should also mount a 3"x.75" workpiece in the chuck with approximately
.5-inch of the workpiece inside the chuck.

Tool 3

Tool 2

Tool 1

0.50"

2.00"

Chuck

0.50"
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When using multiple tools, a reference tool, normally Tool #1 is set to zero
for both axes. This established position is then used as a reference point for
the other tools.
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81 Close the Safety Shield and  pull out the Emergency Stop button.

21 Select Jog Control from the View Menu (or the Standard Toolbar). The
Jog Keypad appears.

31 Use the Jog Keypad to jog the tool to the bottom of the front right corner of
the workpiece (the end of the stock furthest from the chuck and at the edge
of the stock). You can also select another point on the workpiece as a refer-
ence point. However, this reference point must be consistent for all tools.

41 Select Set Position from the Setup Menu. The Set Position dialog box appears.

:1 Enter zero in the Z and X boxes to establish work origin.

>1 Click on OK. The values in the Position Readout all change to zero.

?1 Jog the tool up and away from the workpiece. Press the Emergency Stop
button, open the Safety Shield and remove the workpiece.

Begin with the Emergency Stop button pressed in, and the spindle speed
turned all the way down. The tool should be mounted in the tool post.

01 Mount the workpiece in the chuck.
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The second tool for this program is a Left-Hand tool used for performing
the facing cuts. The third tool is a cutoff tool. To set the multiple tool offsets
for these two tools:

1. Jog the second tool to the same reference point as Tool #1. Jog in small
increments to move the tool to the exact position of the reference point.

2. Open the Tool Library. For Tool #2, check Use Current Position. Se-
lect OK to accept the new offset.

3. Repeat these two steps for Tool #3.
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To initialize the workpiece origin, you must do one of the following:

In the Setup menu, select Set Position. Enter the desired values for X and Z.

Or  use the G92  code,Preset position. This code works like the Set Position
command under the Setup Menu. The X and Z coordinates following a G92
code define the new current position of the tool.

Or use the G54 code, Use Coordinate System One, to use this preset posi-
tion.
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Before you run this multiple tool part program for the first time, you should
perform a dry run (run the program with no stock mounted). This will en-
sure that all the movements of the Turning Center make sense and that none
of the tools are in no danger of striking any fixtures of the Turning Center
such as the headstock or workpiece. Although you should dry run the pro-
gram with no stock mounted, you must first set the point of origin using the
workpiece as previously instructed, and then remove it.

Begin with the Emergency Stop button pressed in, and the spindle speed
turned all the way down. The tool should still be mounted in the tool post.

01 Jog the tools up and away from the workpiece. Press the Emergency Stop
button, open the Safety Shield and remove the workpiece.

81 Return the Safety Shield to the closed position and pull out the Emergency
Stop button.

21 Put on a pair of safety glasses and complete the Safety Checklist (refer to
the Reference Guide: Section J).

31 Select Run/Continue from the Programs Menu. The Run Program dialog
box appears.
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081 Click on the Run Program button.

021 As the part program runs, observe the tool motion in relation to the
chuck (and eventually the workpiece). Look for signs of a possible tool
crash and be prepared to press the Emergency Stop switch on the Turn-
ing Center. Edit the program as required. When you are satisfied that
the tool motions are correct, you can mount the workpiece and run the
program.
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01 Using the Jog Keypad, jog the tool post up and out of the way.

81 Before mounting the workpiece, push the Emergency Stop button in.

21 Mount the 3"x.75" workpiece in the chuck. Take care to position the
workpiece perpendicular to the tool post.

31 Pull the Emergency Stop button out.

41 Jog Tool #1 to position the center of the tool tip at the top of the front,
right corner of the workpiece or which ever reference point you have set
for each of the three tools. Jog Tool #1 to the corner of the workpiece.

:1 Select the Set Position command from the Setup Menu and enter Z=
2.0", the length of the workpiece, and X= 0.375", the radius of the work-
piece.

The workpiece is now correctly mounted.
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Before executing the turntwo.nc program, check that all safety precautions
have been taken. The Turning Center safety shield should be closed, and you
should be wearing safety glasses.

If anything goes wrong, immediately press the Emergency Stop button on
the Turning Center to stop the operation. A safety checklist has been pro-
vided in the Reference Guide: Section J of this guide. Post a copy of this
checklist near the Turning Center and review it before you run any NC pro-
gram.

To run the program:

01 After reviewing the Safety Checklist, select the Run/Continue command
from the Program Menu. The Run Program dialog box appears.
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81 Make sure that the Start Line box is set to line 1 of the program.

21 Click on the Run Settings button. The Run Settings dialog box appears.

31 Make desired changes in the Run Settings dialog box, then select OK.

41 Click on the Run Program button to begin running your program.

:1 After the part is turned, press the Emergency Stop button before open-
ing the safety shield and removing the finished part.
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When using the Automatic Tool Turret for multiple tool operations, use the
Configure Turret button on the Turret Control Toolbar or the Configure
Turret command in the Tool menu to define each tool in its current position
in the Turret. To establish tool offsets, use the same procedure used for tools
mounted on the cross slide; make one tool the reference tool and offset all
other tools from that reference. Another option is to enter the offsets values
from the Z axis in the Setup Library from the Tools Menu.

You must use an M06 code with the T codes for multiple tool operations
with the Tool Turret. If you do not use an M06 code, the machine will use
the tool currently selected in the turret and interpret the T code as an offset
reference only.

When used with an M06, the T code simply indicates, by number, which
tool and which offset to use. For example, M06T2 tells the turret to rotate to
tool #2 and use offset #2.
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Select the tool you would like to use by selecting the proper Tool Station
button from the Turret Control Toolbar.

You can also select the proper tool in the Select Tool From command from
the Tool menu which will show you a list of each of the defined tools that
are on the Turret Control Toolbar.
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Whenever starting up the machine, you should home the turret to the Tool
#1 position. The turret can then move correctly to any other tool position.
To home the turret, you can use the Set/Check Home command to establish
an initial reference point. See section E for information on using the Set/
Check Home Command.
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Generally, machine screws used in the United States conform to the Ameri-
can National, or Unified Thread System. Threads are specified by the outside
diameter of the thread, then the threads per inch, such as 1/4-20.

Threading with a single point tool is accomplished by taking a series of cuts
in the same helix of the thread (also known as chasing a thread).

The pitch of the thread is the distance that the tool moves along the Z axis for
each revolution of the spindle. The pitch is specified by the F code in the
NC program as the inverse of the number of threads per inch. For example,
the F code parameter for a 1/4-20 UNC thread is specified as 1/20 or 0.05.

A direct ratio exists between the spindle speed, the feed rate, and the pitch of
the thread.

The pitch of the thread multiplied by the spindle speed determines the Z axis
feed rate of the Turning Center.

F (IN/REV) x S(REV/MIN) = Feed Rate (IN/MIN)

So, cutting a 1/4-20 thread with a spindle speed of 200 RPM results in a
feed rate of F0.05 x S200 = Feed Rate 10 ipm.

It is important to specify an appropriate spindle speed for the pitch of the
thread to keep the required Z axis feed rate below the machine's maximum
cutting feed rate of 12 ipm. Specifying an inappropriate spindle speed will
result in a bad thread being cut.
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On many lathes the gear ratio is altered by manually changing gears or by us-
ing a quick change gear box. These gear changes increase or decrease the rate at
which the lead screw turns, thereby changing the feed rate of the tool. The
spectraLIGHT Turning Center, however, utilizes an F code in the NC program
to instruct the Z axis drive motor, which turns the lead screw.
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The spectraLIGHT Turning Center uses electronic gearing. An optical
encoder on the spindle measures the speed of the spindle and instantaneously
varies the speed of the Z axis to keep a constant ratio for cutting a thread.
An index sensor, which triggers once per revolution of the spindle, is also
used, so the thread is started at the same point on the rotation of the part
for multiple passes to rough out the thread.
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Here's a typical NC program for cutting a 20-pitch thread on a .25” diam-
eter rod:

G0X.125Z1.5;TO SET THE START POINT

S200M03;SPINDLE SPEED 200RPM

G04F5;DWELL FOR 5 SECONDS

G32X.095Z1Q.002F.05;X & Z ENDPOINTS, Q=DEPTH, F=PITCH

G80;END CANNED CYCLE

The recommended Q depth for threading is very small; from .001 to .003.
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Start Point
(.125,1.5)

.1,.095

Q=depth 
of cut 

Chuck

0.50"0.50"
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Most threads are cut with a 60o threading tool. For fine threads, the tool can be
ground to a sharp point. For coarse threads, you may wish to radius the
point.

A threading tool is used for external threading operations. An inside thread-
ing tool is used for internal threading, like on a nut.
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Most threaded parts are made with right-hand threads. The Turning Center
can turn both right-hand and left-hand threads. The same tool is used for
both left- and right-handed threading; the direction of the cut is altered.

The procedure for cutting left-hand threads on the Turning Center is the
same as for right-hand threads, except the feed is reversed so the cut is made
from the left to the right.

Make sure the workpiece is tightly secured in the chuck or collet since the
tool will be pulling the workpiece away from the holding device.

FeedFeed
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Most of the same rules that apply to external threading also apply to internal
threading. You have to remember that your starting X value will be smaller
than the ending X value. Also, you won't be able to see the tool, so use cau-
tion.

To perform single point internal threading, a hole is first drilled to 1/16 inch di-
ameter less than the minor diameter. A boring bar is then used to bore the
hole to the minor diameter of the thread. Holes that are smaller than the
minimum diameter the boring bar can turn can not be tapped.
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Before cutting a thread, you should cut a groove, or a relief behind the end
point of the thread. This is so the tool isn’t abruptly removed from the work-
piece after the final thread is cut, making the end of the helix straight.

Make sure the start point is away from the workpiece on the Z axis because
you want the tool and workpiece to be in motion before cutting begins.
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The workpiece should be mounted in a chuck or in a collet. Set the tool
height exactly on the centerline of the workpiece for a correct thread angle.
Locate the zero point of the workpiece just as you would for other turning
operations.

Relief

Feed

You still have to cut a relief groove to provide a starting place for the tool.
Make sure you have sufficient relief on the right side of the tool as well.
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For a beginning user, understanding coordinate systems can be difficult. The
first thing to remember is, before performing most machining operations, you
are required to set the machine to “home” position. This returns the machine
to the machine zero point, and acts as a reference point for all operations. It
is a good idea to home the machine every time you run the control software.
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In machining, the Z axis is always the spindle axis. The Z axis on a machine
tool can be horizontal (as on a lathe) or vertical (as on a vertical mill).

On the spectraLIGHT Turning Center the Z axis is horizontal (parallel to
the spindle axis). The X axis is also considered horizontal, but perpendicular
to the Z axis and parallel to the cross slide. The Y axis is not used because the
tool does not move vertically.

In NC programming, the programs are written as though the workpiece is
stationary and the tool is moving. The motion of the tool from right to left
or left to right, is along the Z axis. The motion of the tool from front to back
(in and out of the workpiece) is along the X axis.

The point of origin can be located anywhere on the workpiece, but is usually
located on the Z axis centerline on the plane along the front of the chuck.
This way, all the work is done in Quadrant 1, with positive values for X and
Z. What this means is that all tool motions will be determined by positive
values. This does not mean that the tool will always move in the positive di-
rection, only that the numbers which describe the coordinates will be posi-
tive. For example, when the tool move into the workpiece, it moves in the
negative X direction.

'����

����1�'���� ������

���������
	�
	�
$����(�
	��#��'�#$���
��
	����'���
0��(

	��C��1��������/���� �

-Z

+Z

+X

-X



"�����'���
	������!�(����
��� !+)

(�� ���
�����������

Machine Zero is usually located on the Z axis centerline on the plane along
the front of the chuck. This is a fixed point on the machine, and can not be
changed. The machine uses this as a reference point for all operations. If the
machine is not homed (set to the machine zero) it can not accurately locate
the workpiece on the cross slide. The machine is homed by using the Set/
Check Home command under the Setup menu.  First, set a measured piece
of stock in the chuck so that you can set the position of the tool at the end of
the stock, which is the X,Z distance from zero. If using a stock piece measur-
ing 3" long and .75" wide, by setting the tool position at the top edge of the
front of the workpiece, above the Z axis centerline with coordinates X=
0.375, Z= 2.5, the Turning Center knows where the Machine Zero is.

,��5
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Once home is set, open an NC program using the Control Program. The NC
program will need a point of origin to start from. Setting a point of origin
will establish the work coordinates. Work coordinates relate to the workpiece,
and are usually set at the top edge of the front of the workpiece, above the Z
axis centerline of the workpiece.  Once the stock is mounted in the chuck,
jog the tool tip to this position on the workpiece. From the Setup Menu, se-
lect Set Position. The tool coordinates appear in the dialog box. Set the co-
ordinates to X= 0.375, Z= 2.5 and click on OK to set the current tool posi-
tion as the point of origin on the workpiece.

X

Z

Spindle
Centerline

Plane Along
Front of
Chuck

Stock Point
of Origin (0,0)

Chuck

Stock
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For more advanced operations, such as machining multiple partson the same
piece of stock, you can set up multiple coordinate systems. For example, if
you have an NC  program that machines a complex shape and you want to
machine that shape in multiple places on the same part, use the following
procedure.

Move the tool tip to the work coordinate point of origin (0,0) using the Set
Position command from the Setup Menu. After setting this location on the
workpiece as the origin, select the Coordinate Systems command from the
Setup Menu. The Setup Coordinate Systems dialog box appears. Select one
of the G54 to G59 codes, enter the coordinates for the first workpiece, and
click on Apply. Repeat this procedure  for as many coordinate systems as
necessary by setting up a coordinate system for each point on the part that
corresponds to the zero point of the shape you are turning. Then in your
program, you move to each coordinate system and run the subprogram that
contains the NC code for the complex shape. (For more information about
the Setup Coordinate Systems procedure, see Section E.)
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Two terms used in general machining are feed and cut.

Normal machining on the Turning Center involves reducing the diameter of
a workpiece. This is accomplished by advancing the cutting tool into the
workpiece by an appropriate amount (depth of cut).

The rate of tool travel is called the feed rate. On machines like the
spectraLIGHT Turning Center, the tool advances into the workpiece and the
workpiece is rotated on its centerline by the spindle.

The depth of cut and feed rate you select should depend on the turning
speed of the spindle, the type of material and lubricant used, and the type of
cutting tool used for the operation.

Excessive depth of cut and high feed rates place greater strain on the spindle,
may bind the tool and workpiece, or produce a poor surface finish on the part.

Spindle

Tool
Bit

Tool
Post

Stock

Depth
of Cut

Speed

Feed
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Turning speed is inversely proportional to the diameter of the workpiece; the
larger the workpiece, the slower the recommended turning speed. The rela-
tive hardness of the material also affects turning speed; the harder the mate-
rial is, the slower the speed should be.

High spindle speeds may produce excess heat which causes the workpiece to
expand. If the workpiece expands, the cutting tool will rub rather than cut
the material, resulting in a poor surface finish. Slow spindle speeds cause no
harm, but may be inappropriate for finishing certain types of materials.

The load put on the spindle motor must also be taken into account. Heavy
cuts at low speeds will make the motor run hotter than lighter cuts at higher
speeds. The selected feed rate and depth of cut should not cause the spindle
motor to greatly lose speed or cause the tool to chatter against the workpiece.

&���
#���
���
�������
�����
���������
Feed rate selection for turning parts on the spectraLIGHT Turning Center
depends on factors such as type of material, type of cut, diameter of rough
stock, depth of cut, and spindle speed. The type of tool chosen to make the
cuts also affects the depth of cut and, therefore, the feed rate. Consult your
machinist’s handbook for selecting a feed rate based on spindle speed and
material type. Experience and experimentation will enable you to establish
feed rates best suited to particular applications.
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Lubricants remove heat from the tool and workpiece and are often used when
high production rates are required or when cutting very hard materials, such as
stainless steel. A mixture of one part soluble oil to six parts water may be
used on steel to assist in producing a smoother finish and to reduce tool
chatter. Aluminum and aluminum alloys may require the use of paraffin, oil
or kerosene to prevent chips from welding to the tool’s cutting edge. Brass
and cast iron are always turned dry.

When lubrication is necessary, small amounts of water-soluble cutting fluids
are recommended for use on the spectraLIGHT Turning Center. Lubricants
should be wiped from the machine after use, because some petroleum-based
fluids may deteriorate the electrical wiring insulation, the plastic safety
shield, or the computer enclosure.
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Cutting tools are usually made from hardened steel and are ground to vari-
ous shapes. The clearances ground behind cutting edges are adjusted for the
type of material the tool will cut and the direction the tool will be fed along
the workpiece. Tools are often ground to shape by the operator to suit a par-
ticular cutting requirement.

Insufficient clearance behind the cutting edge will cause the tool to rub. Ex-
cessive clearance will produce a ridged or wavy finish due to the small length
of tool edge in contact with the workpiece. Standard tool types are: turning
tools, side tools, parting tools and boring tools. Carbide tooling has become
popular in recent years. Carbide is more brittle than steel, but has a longer
tool life.
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Side tools are used to face-off the ends of shoulders or to make facing cuts in
the surface of a workpiece held in a chuck. They may also be used as turning
tools.

Right side (or right-hand) tools feed from right to left and are used to reduce
the workpiece to a desired diameter. The shape of the cutting edge and the
clearance (behind the point between the end of the tool and the workpiece)
determine the surface finish of the workpiece. Rough cuts are made in small
increments until the tool is within approximately 0.010 inch (0.25mm) of
the desired diameter. Final cuts are made at slow feed rates with a very shal-
low depth of cut.

Left side (or left-hand) tools feed from left to right. Side tools cut very flat
surfaces and can be used to produce a part with an exact thickness.
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A parting tool has a dual-edged, dovetail-shaped cutting end which is used to
cutoff workpieces. The parting tool is plunged into the workpiece and the
cross slide is moved across the lathe bed until the workpiece is severed.

Parting tools are clamped to a special tool post with a minimum of over-hang
for maximum rigidity and chatter-free operation. The cutoff point should be
located as close to the spindle center as possible. The cutting end of the part-
ing tool should be perpendicular to the workpiece to avoid sideward drift. A
small square is useful in aligning the tool perpendicular to the workpiece.

Also, the height of the tip of the tool should be positioned so it is vertically
aligned with the center of the stock.

Cutoff operations are performed at a slow turning speed because the parting
tool has a large amount of cutting edge in contact with the workpiece. If the
tool chatters or produces noise, the turning speed and feed rate should be re-
duced.
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Boring tools are used to enlarge or modify a drilled or cored hole in a work-
piece. Clearance must be maintained behind the cutting point of the tool.

A slow feed rate and frequent tool withdrawals are required with boring tools
because chips cannot freely escape from the hole. Depth of cut and feed rates
must be reduced to avoid chatter. The tool should not be driven deeply into
a hole. When boring a hole where a flat bottom is required, stop the  feed at
least 0.002 inch from the desired depth of the smaller hole being bored out.
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Profiling tools are quite popular in CNC applications because they can cut
on both sides and in both directions. A profiling tool cuts in the same way
as a turning tool.
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Most threads are cut with a 60o threading tool. For fine threads, the tool can be
ground to a sharp point. For coarse threads, you may wish to radius the
point.

A threading tool is used for external threading operations. An inside thread-
ing tool is used for internal threading, like on a nut.

60
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Each cutting tool used in the machining operation must be sharp and tightly in-
serted in the tool post. The cutting edge of the tool must be on the centerline or
just below the centerline (0.004  inch or 0.1mm maximum) of the axis of ro-
tation of the lathe.

The cutting tool is mounted by loosening the mounting screws at the top of
the tool post and positioning the tool in the slot beneath the mounting
screws. To assure a rigid mounting and to avoid chatter, the cutting edge of
the tool should not protrude more than necessary from the tool post. The
further the tool extends from the tool post, the more chatter will occur.

You must make sure that only the very tip of the tool is doing the cutting. All
tools must be positioned in a manner that allows them to access all areas they
are to cut. The exception to this is the cutoff tool, which should always be
perpendicular to the stock. Backside tools should be mounted upside-down
and on the centerline or just above.

The position of the cutting edge relative to the centerline of rotation can be
checked at the headstock center. Loosen the bolt holding the tool post to the
cross slide and slide the tool post as close as possible to the center. Check the
location of the cutting edge position.

Tighten the tool holding bolts, reposition the tool post on the cross slide and
tighten the cross slide bolt.
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A cutting tool must be sharpened regularly to preserve its original cutting
angle and shape. Longer tool life will be obtained from cutting edges if they
are finished with a small oilstone. Only the cutting end and sides of the tool
should be ground as required. Never grind the top face of the tool.
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The following safety rules should be reviewed and practiced by all operators
of the spectraLIGHT Turning Center.
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Foresight is better than no sight. During operation any power tool can
throw foreign objects and harmful chemicals into your eyes. Always put
on safety glasses or eye shields before starting up the Turning Center. Safety
glasses or shields should provide full protection at the sides, as well as the
front of the eyes.
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Read this guide carefully before you use the Turning Center and keep it
readily accessible for quick reference. Know the intended applications and
limitations of the Turning Center as well as its hazards.
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The Turning Center has an AC power cord terminated by a three-prong
plug. The power cord should be plugged into a three-hole, grounded recep-
tacle. If a grounding adapter is used to accommodate a two-prong receptacle,
the adapter wire must be attached to a known ground. Never remove the
third prong from the plug on the AC power cord.
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The safety shield should remain in place whenever the spindle motor is
on or the cross slide is moving.
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Make it a habit to check that keys and adjusting wrenches are removed
from the Turning Center before turning on the machine.
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Cluttered work areas and bench tops invite accidents.
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Don’t use the Turning Center in damp or wet locations. Never operate elec-
trical equipment in the presence of volatile and flammable petroleum-based
solvents and lubricants.
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Children and visitors unfamiliar with the hazards of rotating machinery
should always be kept away from the work area.
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Lock and remove the key from the Turning Center control panel when the
system is not in use.
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Select the feed rate and depth of cut best suited to the design, construc-
tion and purpose of the cutting tool. It is always better to take too light a
cut than too heavy a cut.
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Select the type of cutting tool best suited to the turning operation. Don't
force a tool or attachment to do a job it wasn't designed to do.
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Don't wear loose clothing or jewelry which can get caught in moving parts.
Wear a hat or hair net, or tie your hair back to keep it away from moving
parts.
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Be certain that you have firmly secured the workpiece in the spindle and the
cutting tool to the cross slide before turning on the spindle motor.
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Keep your footing and balance at all times so you won’t fall into or grab
the moving machine.
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Keep cutting tools sharp and clean. Lubricate and clean Turning Center
components on a regular basis.
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Always use the emergency stop switch to disconnect power and disable the
spindle motor before mounting or removing the workpiece, or changing
tools. Do not rely solely on a programmed Pause command to disable Turn-
ing Center operation.
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Make sure the power switch on the control box is off before plugging in
the Turning Center power cord.
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To avoid stressing the Turning Center and creating a hazardous machining en-
vironment, use only those accessories designed for use with the spectraLIGHT
Turning Center, available through Light Machines Corporation.
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Do not overtighten tool holding devices. Overtightening may damage threads
or warp parts, thereby reducing accuracy and effectiveness.
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Do not allow coolant to splash into or near the computer.
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Alcohol or drugs may impair your judgement and reaction time, which
could contribute to an on-the-job accident.
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Use simple common sense and pay attention while operating any piece of
machinery.
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All spectraLIGHT operators must be fully aware of how to shut down the
machine quickly, should the need arise.

There are two ways an emergency stop can be initiated on the spectraLIGHT
Turning Center:

� By pressing the emergency stop switch on the Turning Center.

� By pressing a key on the computer keyboard.
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G00 Rapid traverse.

G01 Linear interpolation.

G02 Circular interpolation (clockwise).

G03 Circular interpolation (counterclockwise).

G90 Absolute coordinate programming:  All X and Z axes coordinates are
relative to a (0,0) location on a lathe.

G91 Incremental coordinate programming: Each command is relative to the
one before it in the program.

G70 Inch: Used to instruct the lathe that inches are the unit of measure for
the part program. (Fanuc G20)

G71 Metric: Used to instruct the lathe that millimeters are the unit of measure
for the part program. (Fanuc G21)

G04 Dwell (wait): Equals the value of the feed rate (F code) in seconds (used
primarily for robotic operations). G04 excludes motion commands with a
new feed rate on the same line (block).

G05 Pause: Used for operator intervention. The order of action for the pause
and dwell codes in one NC block is G05, G04 (pause, dwell).

G25 Wait for robot input #1 to be high: Used in conjunction with H code,
which specifies input number. The default is H5. Used for robot
synchronization (see Section L).

G26 Wait for robot input #1 to be low: Used in conjunction with H code,
which specifies input number. The default is H5. Used for robot
synchronization (see Section L).

G15 Polar programming cancel.

  G16 Begin polar programming.

G53 Rapid traverse to specified machine coordinate in Absolute programming
mode. (e.g. G53X0Z0 rapids to machine reference point)

G54 Use coordinate system one.

G55 Use coordinate system two.

G56 Use coordinate system three.

G57 Use coordinate system four.

G58 Use coordinate system five.

G59 Use coordinate system six.
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����

!����������
(���

����

�����

����

,���

����



�����
*�

����

!����
!����������

����

����������
������

����



"��� ����� ������
� �&0�"��$� A+)

G32 Canned cycle thread cutting

G72 Canned cycle arc turning, clockwise

G73 Canned cycle arc turning, counterclockwise

G77 Canned cycle side turning

G79 Canned cycle end turning

G80 Canned cycle cancel.

G81 Canned cycle drilling.

G83 Canned cycle peck drilling.

G27 Check reference point: This code moves the tool to its home position on
the Machining Center to perform automatic calibration of the axes.

G28 Set reference point: Sets machine position to 0,0.

G29 Return to reference point: Moves the tool to a coordinate specified by
XZ. Typically used after a G27 or G28 code.

G92 Set position: This code works like the Set Position function under the
Setup Menu (see Section E). The X and Z coordinates following a G92
code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle complete (Section G).

G99 Rapid move to point R (surface of material or other reference point) after
canned cycle complete (Section G).

G50 Cancel scaling.

G51 Invoke scaling. Use this code to scale axes by a single factor or by
independent factors around a fixed origin. The default scale factor is 1.

G68 Invoke rotation. Use this code to rotate geometry by an arbitrary angle
around a specified point.

G69 Cancel rotation.
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  M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.

  M01 Optional Stop: Allows you to place an optional stop in your code. Place an
M01 in the block of code where you would like to pause. With Optional
Stop on, the M01 works like a G05. With Optional Stop off, the M01
code is ignored, the other codes on the block are executed as usual.

  M02 End of Program: Takes effect after all motion has stopped; turns off drive
motors, spindle and accessory outlets.

  M30 Program stop: Same as M02.

  M03 Spindle Motor On: Activated concurrently with motion specified in the
program block; remains in effect until superseded by M05.

  M05 Spindle Motor Off: Activated after the motion specified in the program
block; remains in effect until superseded by M03.

  M06 Tool Change: Used in conjunction with a T code to perform multiple
tool operations. See Section H.

  M08 ACC1 On: Turns on accessory ACC1 outlet concurrently with the
motion specified in the program block; remains in effect until superseded
by M09.

  M09 ACC1 Off: Turns off accessory ACC1 outlet after the motion specified in
the program block; remains in effect until superseded by M08.

  M10 Clamp ACC2: Turns on ACC2. Closes air vise accessory concurrently
with the motion specified in the program block; remains in effect until
superseded by M11.

  M11 Unclamp ACC2: Turns off ACC2. Opens air vise accessory after the
motion specified in the program block; remains in effect until superseded
by M10.

  M25 Set robot output #1 on: Used for robot synchronization. Used in
conjunction with H code to specify output number. The default is H4.

  M26 Set robot output #1 off: Used for robot synchronization. Used in
conjunction with H code to specify output number. The default is H4.

M35 Set robot output #2 on: Used for robot synchronization.

M36 Set robot output #2 off: Used for robot synchronization.
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  M20 Chain to Next Program: This code appears at the end of a part program
and is followed on the next line by the file name of another program
which is executed when all motion stops. Here’s an example of a part
program chain to another program:

N37Z.2
N38M20
PROGRAM TWO

If the two programs you are chaining are not in the same directory, you
must specify the full pathname for each file. If the specified file is not
found, the Open dialog box appears so you can locate it.

  M22 Output to file: Outputs information to a file. The first time the Control
Program encounters an M22 code, it opens the specified file. You must
enclose the name of the file in parentheses for the Control Program to
recognize it.

The proper format for using this code is: M22([filename.ext [,A]]) [text
and macros]. Items in brackets [ ] are optional, except that a filename is
required for the first M22. If no text is specified to be output to the file,
the current axis positions are output. M22 automatically adds a tilde (~)
to the output text, so the next M22 starts on a new line in the file.

If you use more than one M22, only the first occurrence must have the
filename in the parentheses. The remaining M22's may have empty
parentheses, ( ). If you want to generate more than one file at a time you
must include the filename each time you specify M22. If a filename is not
specified, the first file opened is used.

Following is a list of special codes that can be used with M22 to generate
run-time reports.

@X Current X position (in current coordinate system)
@Z Current Z position (in current coordinate system)
~ (tilde) New line (starts a new line in the file)
@TD Time of day (12hour): “11:59:59AM”
@TC Time (elapsed) for cycle: “99:11:59” (0’s trimmed from left)
@TT Time total (of program run): “99:11:59”
@TA Time Average (per cycle): “99:11:59” (“??:??” if first part)
@TL Current tool number:  “5”
@C Cycle number (current pass): “3”
@D Date: “12/31/94”
@FN Current file (without path): “PART.NC”

(“UNTITLED.NC” if untitled)
\t Tab
\\ Outputs a single backslash character to the file

The M22 code supports multiple output files. The first occurrence of a
filename opens the file. In the name M22(FILE.OUT,A) TEXT... the
output is appended to the file (if it exists). Each unique filename opens a
separate file. For backward compatibility, empty parentheses M22( )
TEXT... cause the M22 output to go to the first file that was opened with
an M22.
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  M47 Rewind: Restarts the currently running program; takes effect after all
motion comes to a stop. Use the L code to repeat a finite number of
times. The L code defines the number of times to run. For example,
M47L2 rewinds once.

  M98 Call to subprogram

  M99 Return from subprogram: Returns you to the block following the initial
M98 command.

Go to: Used with P code. P code defines N code destination. Goes to first
occurrence of N code within the main program. The N code can not
follow any subprogram (O code).

M105 Operator message: A nonstandard Light Machines code used to display
messages in the Control Program.

M111 Home the X axis

M112 Home the Z axis
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The spectraLIGHT Turning Center has a simple interface for interacting
with common robots, like those used for automatic part loading between
turning operations. The Turning Center and the robot communicate by way
of an interface connector (labeled TTL I/0) located on the rear panel of the
Turning Center's Controller Box.

The method of communication between the Turning Center and robot is
very basic. They are both able to transmit and receive high or low signals.
Since communication signals are typically 0 and 5 volts, a high signal is 5
volts (or 3.5 volts or greater) which turns the Turning Center or robot on;
and a low signal is 0 volts (or 1.5 volts or less) which turns the Turning Cen-
ter or robot off. See the figure below.

There are NC codes that you can place in a part program to instruct the
Turning Center to transmit a high or low signal to the robot. There are also
codes that instruct the Turning Center to wait for a high or low signal from
the robot. The Turning Center and robot are set up to recognize any change
in signal state; a low signal must go high, or a high signal must go low for the
change to be detected by either machine.
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Signals sent out are referred to as outputs, while signals coming in are called
inputs. Any signals that the Turning Center transmits to the robot are trans-
mitted through an output pin on the interface connector. Outputs can drive a
maximum load of 1mA. Any signals that the Turning Center receives from
the robot come in through an input pin on the interface connector.

Examples of input and output wiring are shown in the schematic below.
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The 9-pin I/O connector on the interface connector provides a number of
ways for the Turning Center to communicate with robots and other external
mechanisms such as an additional limit switch.

The inputs and outputs on the Turning Center are designated as follows:

!�� &������� 	F)
��B��� '���

1 Input 1 +5V INP 1L

2 External Limit 0 or +5V ELim

3 Output 2 +1V to +3.5V OUTPUT 2

4 Output 1 +1V to +3.5V OUTPUT1

5 Common GND

6 Input 2 0 or +5V INPUT 2

7 Input 1H See Note INPUT 1H

8 Input 2H See Note INPUT 2H

9 Common GND

Other Input/Output Notes:

� All User outputs are disabled by an ESTOP condition.

� Never apply a negative voltage or an AC voltage to an input.

� Outputs are set to source current only. The maximum load on each output is
1mA.

� Do not operate relays, motors or other inductive loads with the TTL
I/O outputs. This will damage the machine. You may however, run an
optical relay.

� The external limit signal can be used to detect motion problems and shut
off the Turning Center. Use a switch that sets that signal (Pin 2) to
Ground (Pins 5 or 9). Grounding this signal has the same affect as when
a limit switch is tripped on the Turning Center.
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1 Robot Input No. 1 Purple
2 External Limit Input White
3 Robot Output No. 2 Yellow
4 Robot Output No. 1 Orange
5 Ground Blue
6 Robot Input No. 2 Black
7 Robot Input No. 1 Red
8 Robot Input No. 2 Brown
9 Ground Green
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There are two groups of input and output pins (group #1 includes pins 1, 4,
5 and 7, and group #2 includes pins 3, 6, 8 and 9). Having two pin group-
ings allows you to interface the Turning Center with more than one robot
(or other device) at a time. Each pin grouping is made up of two input pins,
one output pin, and one ground pin.

In most cases, input signals coming from the robot are in a normally-high
state (input pins 1 and 6). The robot must make the signal go low for the
Turning Center to recognize a change of state. There are cases where a nor-
mally-low state is preferred. That is the reason for the existence of second in-
put pins for each grouping (pins 7 and 8); they are normally-low and the
robot must make them go high for the Turning Center to recognize the
change.
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The NC codes used in robotic communication are:

G25 - wait for High signal
G26 - wait for Low signal
M25 - transmit High signal
M26 - transmit Low signal
H# - specifies the input or output (default is H1)

The H code is used in conjunction with the wait codes and transmit codes.
For example, G25H3 tells the Turning Center to wait until the state at input
#3 goes high.

Assuming the robot’s initial output state is low, if you place this line of code
at the beginning of your program, the Turning Center waits until input #3
goes high, then executes the next line of code.

If the external device sends a low signal, nothing happens because the Turning
Center is waiting for a high signal. If there’s no change to a high signal, the
Turning Center does not execute the next line of NC code in the program.

When the robot sends a high signal, the Turning Center responds by con-
tinuing with the NC program. If the Turning Center does not respond to the
robot as you have programmed it to, check that you have correctly wired the
robot to the interface, and that the robot’s initial output state was not
changed to high during the connection of the robot.
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As previously explained, communication between the Turning Center and
robot is very simple. They only use and recognize high or low signals. Once
the Turning Center sends a signal to the robot, it goes into a wait state and
continues to wait until the robot sends the appropriate signal back. When
the signal is recognized, the Turning Center executes the next instruction in
the part program. After executing the instruction, it sends a signal to the ro-
bot. The robot, which has been in a wait state since its last transmission, re-
ceives the signal, performs as it has been programmed, then again signals the
Turning Center.

This reciprocal system of communication is made possible by the placement
of G and M codes in the part program. The G codes provide the wait in-
structions to the inputs, while the M codes provide the transmit instructions
to the outputs.

The following sequence is typical of communication between the Turning
Center and a robot. Since the robot’s initial output state is low, the lathe’s
inputs have already been pulled down to a low state. This sequence assumes
the Turning Center is equipped with an air chuck.
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N0M11;OPEN CHUCK
N1M25H2;TRANSMIT HIGH SIGNAL THROUGH OUTPUT 2
N2G25H1;WAIT FOR HIGH SIGNAL THROUGH INPUT 1
N3M10;CLOSE CHUCK
N4M26H2;TRANSMIT LOW SIGNAL THROUGH OUTPUT 2
N5G26H1;WAIT FOR LOW SIGNAL THROUGH INPUT 1

N0G0G90X.26Z1.01;MOVE TOOL AWAY FROM WORKPIECE
N1M3;TURN ON SPINDLE
N2X.25;MOVE TOOL TO START POINT
N3G1X.23F2;FIRST ROUGH CUT, SET FEED RATE
N4Z.4
N5G0X.25;BACK OUT AND RETURN
N6Z1.01
N7G1X.21;SECOND ROUGH CUT
N8Z.44
N9G0X.23;BACK OUT AND RETURN
N10Z1.01
N11G1X.19;THIRD ROUGH CUT
N12Z.48
N13G0X.21;BACK OUT AND RETURN
N14Z1.01
N15G1X.17;FOURTH ROUGH CUT
N16Z.52
N17G0X.19;BACK OUT AND RETURN
N18Z1.01
N19G1X.15;FIFTH ROUGH CUT
N20Z.66
N21G0X.17;BACK OUT AND RETURN
N22Z1.01
N23G1X.13;SIXTH ROUGH CUT
N24Z.7
N25G0X.15;BACK OUT AND RETURN
N26Z1.01
N27G1X.11;SEVENTH ROUGH CUT
N28Z.74
N29G0X.13;BACK OUT AND RETURN
N30Z1.01
N31G1X.1;FINISH CUT
N32Z.75
N33X.16Z.63
N34Z.53
N35X.25Z.35
N36G0Z1.01;RAPID TRAVERSE TO START POINT
N37M05;END OF TURNING PORTION OF CYCLE

N38M25H2;TRANSMIT HIGH SIGNAL THROUGH OUTPUT 2
N39G25H1;WAIT FOR HIGH SIGNAL THROUGH INPUT 1
N40M11;OPEN CHUCK
N41M26H2;TRANSMIT LOW SIGNAL THROUGH OUTPUT 2
N42G26H1;WAIT FOR LOW SIGNAL THROUGH INPUT 1
N43M47L3;CYCLE BACK TO N0
N44M2;END OF PROGRAM
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This computer-controlled 8-station
tool turret (ACC-5601) provides
automatic tool changing ability.
The turret accommodates four
1/4" square shank tools, four 1/4"
round shank tools and a parting
tool.

This package also includes all items
listed below in the tool Turret
Tooling Package.
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The Tool Turret Tooling Package
(ACC-5605) includes:

� A profiling tool holder

� Two profiling carbide inserts
(.016" and .031")

� A cut off tool (.045")

� A threading tool

� A boring tool

� A hex key
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The fixture kit (ACC-5610)
includes:

� A collet set (1/16", 1/8", 3/
16", 1/4", and 5/16")

� One live center for the tailstock

� One dead center for the tailstock

� One dead center for the
headstock

� One faceplate

� One lathe dog
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This tool and post set (ACC-5650)
includes:

� Two two-position tool posts

� One carbide tool set with a
right-hand cutting tool, a
left-hand cutting tool and a
threading tool

� One high-speed steel tool set
with a right-hand cutting
tool, a left-hand cutting tool
and a boring tool

� One cutoff tool holder

� One cutoff tool

� One hex key driver (5/32")
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This set (ACC-5630) contains
three carbide inserts for use with
the Carbide Indexable Tool
Holder.
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This set (ACC-5640) includes one
carbide indexable tool holder and
one carbide insert.
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The aluminum stock package
(PKG-9320) is made from 2001
Series aluminum and includes
fourteen pieces each of 1/2" x 2",
1/2" x 3", 3/4" x 2", and 3/4" x 3"
stock.
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The brass stock package (PKG-
9330) is made from 360 free ma-
chining brass and includes:

� Four 1/2" x 3" pieces

� Four 3/4" x 3" pieces

� Six 1/2" x 2" pieces

� Six 3/4" x 2" pieces
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The brass stock package (PKG-
9140) is made from 360 free
machining brass and includes:

� Thirty 3/4" x 3" pieces
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The machinable wax stock
package (PKG- 9350) contains
twenty pieces of blue machinable
wax 1" diameter x 12" long.
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The portable air compressor
(PNU-4535) is an intermittent
duty, 3/4 hp, oil-less air compressor
with a built-in color-coded regulator
and pressure selection chart. It
delivers 2.1 CFM at 90 psi.
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This pneumatic air chuck (PNU-
4615) allows automatic securing
of a workpiece for production
applications. It is ideal for use in
a computer-integrated manufac-
turing system (CIM), a flexible
manufacturing system (FMS), or
for automated factory simulation
with robotics.
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spectraCAM is an industrial
CAD/CAM package that generates
part programs that can be run on
the spectraLIGHT Turning
Center. spectraCAM (CAM-
6601) can import part geometry
from CAD programs that export
DXF files (such as AutoCAD).
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This Windows 95 version of
spectraCAM (CAM-6741) is an
industrial CAM package that
incorporates CAD into the CAM
program to provide the most
comprehensive  and user friendly
package available. Solid model
tool path verification is featured.
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This is a computer-controlled
shield opener that provides
automatic opening and closing of
the Turning Center shield (PNU-
4625). It is ideal for use in a
computer-integrated manufac-
turing system (CIM), a flexible
manufacturing system (FMS), or
for automated factory simulation
with robotics.
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The Chess Set software package
(DOC-7561) includes a profiling
tool, a two-position tool post,
software with NC programs, and
documentation to machine a
complete chess set. Software
supplied on 3.5" disks.
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The Chess Set Project (DOC-
7552) is a series of NC programs
used for the manufacture of a
chess set. The project consists of
a floppy disk containing NC
programs, a special high-speed
steel profiling tool, pre-cut blank
brass and aluminum stock and
documentation. Software supplied
on 3.5" disks. (Requires the use
of a self-centering industrial
grade chuck.)
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A student workbook (DOC-

7631) presenting topics such as
using the lathe, coordinate systems,
NC programming, editing part
programs, and verifying and run-
ning part programs. Includes
CNC turning projects.
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This teacher's workbook (DOC-
7641) is similar to the student
workbook, but includes teacher
notes and instructions to assist in
the presentation of the topics.
Answers to post-test reviews are
provided. Includes sample
programs for turning projects on
3.5" disks.
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The fifteen activity curriculum
guide includes versions for both
the students and the teachers.
These guides provide instruction
for using the CAM-6741
spectraCAM Turning for Win-
dows software.
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This fifteen activity curriculum
guide includes versions for both
the students and the teachers.
These guides provide instruction
for using the spectraLIGHT
Turning Center with the Win-
dows 95 control software.
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