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Before connecting and running your new machining center, you should:

34 Check your shipment to make sure you received everything you need.

�4 Register your machining center so you are covered by your warranty.

54 Prepare a work space for the machining center and controller.

64 Unpack and set up the machining center.

74 Install the interface card in the computer.

Once these procedures are complete, connect the spectraLIGHT Machining
Center and Controller Box to your personal computer, and install the Control
Program.
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The first thing you must do after receiving your machining center is inspect
the packaging for any visible signs of damage. If there is damage to the outside
packaging, contact the shipping company as well as Light Machines Corp.
After checking the packaging, locate the packing slip. This slip lists all of the
items you should have received with your machining center. Check all of the
items on the list. If any item is missing, contact Light Machines' Customer
Service Department (800/221/2763).
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You’ll find a registration card in the small box with the documentation and
software disks. Clearly print all the requested information and return this
card to Light Machines Corporation.
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Make sure you have all the items on hand necessary to perform the installation.
To install the spectraLIGHT Machining Center, you must have:

� A sturdy table on which you’ll place the machining center and your com-
puter. Placing the table against a wall provides more stability. Make sure
the wall has a 120VAC, 15 amp polarized outlet.

� A personal computer running Windows 95 or Windows NT version
3.51 (or greater). See page A-10 for a complete list of the necessary
computer equipment.

� Your PC Owner’s Manual or equivalent documentation.
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For each standard machining center you order, you should receive three large
cartons. One carton contains the machining center. One carton contains the
mill column. The third carton contains the Controller Box, the Interface Card,
the Control Program software, the documentation, and the Accessory Kit.

34 Unpack the Controller Box and mill column containers and use the
packing slips to confirm that you have received all the items listed.

�4 Open the machining center container and remove the foam inserts.

54 Lift the machining center out of the box and onto the table.

64 Inspect the machining center chassis for signs of visual damage such as a
broken shield, a dent in the chassis, or damaged cables. If any damage is
noted, or if you find any discrepancies between the packing slips and the
items received, call Light Machines’ Customer Service Department (800/
221/2763).

74 Remove the protective paper from the safety shield.
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The following paragraphs review the procedures for installing the hardware
components of the spectraLIGHT Machining Center. You should already
have your personal computer set up in accordance with the directions in the
computer owner’s manual.

The first thing you have to do is install the spectraLIGHT Interface Card in
your personal computer.
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The Interface Card can be installed in any full-size slot designated for expansion
card use. Refer to your computer owner’s manual to determine particular expan-
sion card restrictions.
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To install the Interface Card, you must remove the cover of the personal
computer. Refer to the installation instructions supplied with your computer
for details on removing the cover. Generally, the cover is secured by four
screws through the rear panel; however, some personal computers may have
push latches, or screws in different locations.
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Set the cover aside and locate an open slot in which to install the Interface
Card. Remove the blank slot cover (if any). Removing the slot cover requires re-
moving a screw at the top rail of the rear panel. You may choose to discard the
cover, but save the screw for installing the Interface Card.
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The card is shipped inside an antistatic envelope. Be careful not to create any
static discharge when removing the card from the envelope; touch a
grounded surface such as the PC enclosure first. Slide the card out of the
envelope and inspect it for signs of damage, such as bent or broken compo-
nents or a warped circuit card. If damage is noted, contact Light Machines
Corporation immediately.
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The following procedures describe how to insert and secure the Interface Card
in the computer.

34 Grasp the Interface Card at the front and back.

�4 Position the card above the bus connector at the chosen slot. The inter-
face connector on the end of the card should face the rear panel of the
computer chassis.

54 Slide the card into the bus connector. The interface connector on the card
should protrude from the rear panel of the computer. Carefully wiggle
the Interface Card back and forth to assure its tightness in the bus con-
nector. Components on the Interface Card should not touch adjacent
cards or other components.

64 Secure the Interface Card to the top rail of the rear panel with the screw
you saved when removing the blank slot cover.

74 Pay particular attention to the location of the slot in which you inserted
the Interface Card. Do not get the Interface Card mixed up with the par-
allel port which uses the same type of connector.
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After installing the Interface Card, replace the computer chassis cover. Connect
the computer power cord and turn the computer on. The computer should
perform an internal check, run the operating system and display a C:> prompt
(your computer may automatically start Windows, if so programmed).

If the PC fails to start-up, turn off the power, open the chassis and check
your installation to be sure that the Interface Card is located in an appropriate
slot and is properly seated.

When the C:> prompt appears, turn off the power and install the other hard-
ware components.
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The following paragraphs review the procedures for connecting your computer
with the machining center and Controller Box. The Interconnection Diagram
on the following page has been provided as a visual aid for the recommended
connections.
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The interface cables and power cords are long enough to allow the Controller
Box to be located up to five feet away from the machining center. Make sure the
machining center is placed on a stable, flat surface and leveled properly.

The Controller Box can be placed beside the machining center, or mounted on a
shelf beneath the machining center. Make sure the power switch on the front of
the Controller Box is readily accessible. Keep in mind that you may need to
check the fuses on the rear panel of the Controller Box. Locate the Controller
Box in an area where it will not be exposed to metal chips or cutting fluid.
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34 Route the interface and power cables from the machining center to the
Controller Box as shown in the Interconnection diagram.

�4 Insert the 15-pin plug from the machining center into the 15-pin
receptacle marked A & B AXES on the rear panel of the Controller Box.

54 Insert the 9-pin plug from the machining center into the 9-pin receptacle
marked C AXIS on the rear panel of the Controller Box.

64 Insert the AC power plug from the machining center into the 120VAC,
three-prong receptacle marked SPINDLE on the rear panel of the Con-
troller Box.

74 Make sure all connectors are secured with screw locks.
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The Interface Card/spindle cable is attached to the rear panel of the Machining
Center and is terminated with a 9-pin plug. Insert this plug into the 9-pin re-
ceptacle on the computer Interface Card you installed earlier.
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34 Route the 25-pin cable between the Computer and the Controller Box.

�4 Connect the end of the cable marked COMPUTER to the 25-pin connector
protruding from the LMC Interface Card in the rear of the computer. As
mentioned before, make sure you are plugging the cable into the Interface
Card connector, not the parallel port.

54 Connect the other end of the cable to the 25-pin connector marked
COMPUTER on the rear panel of the Controller Box.

64 Make sure all connectors are secured.
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Both the machining center and the Controller Box must be plugged into a
grounded 120VAC, 60Hz, 15A polarized wall outlet, as shown in the Inter-
connection Diagram. This outlet must be capable of supplying up to 12
amps of power to the Controller Box.

Locate the loose power cord that came with the machining center; this is the
power cord for the Controller Box. Insert the receptacle end of this cord into
the 120VAC three-prong connector on the back of the Controller Box. In-
sert the plug end of this cord into a grounded, three-hole, 120VAC, 60Hz
wall outlet.
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If you have purchased the optional Air Vise, plug the power cord from the
solenoid valve on the vise into the receptacle end of the accessory port adapter
cable. Plug the other end of the accessory port adapter cable into the recep-
tacle labelled ACC 2 on the rear panel of the Controller Box.
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You can also connect a second 120VAC accessory to your machine. Plug the
accessory’s power cord into the receptacle end of another accessory port adapter
cable. Insert the plug end of the cable into the receptacle labelled ACC 1 on
the rear of the Controller Box; the current draw for such accessories, however,
is limited to 3 amps.

A 9-pin male connector (labeled TTL I/O) is provided on the rear panel of
the Controller Box for interfacing to an I/O device such as a robot. See the
Reference Guide, Section L for details on interfacing with robots.
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The spectraLIGHT Control Program runs on a586/120MHz  personal
computer. The computer must have:

� Windows 95 or Windows NT 3.51 or higher. (Windows NT users:
check the Readme file for new information.)

� 8MB RAM minimum for Windows 95 (16MB is recommended for best
performance). 16MB RAM minimum for Windows NT.

� A 3.5" floppy drive.

� A hard drive with at least 5MB of available space.

� An available expansion slot.

� VGA graphics controller and monitor.

� A Windows-compatible mouse.
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The spectraLIGHT Control Program must be installed on the hard drive on
your computer. The spectraLIGHT Control Program is shipped on two
3.5", 1.4MB  disks. The Control Program must be installed on a hard drive
running either Windows 95, or Windows NT version 3.51 (or higher). You
must have at least 5MB of free space on your hard drive to perform this in-
stallation. (See above for system requirements.)
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The following instructions assume that your hard drive is drive C, and your
floppy drive is drive A.

34 Turn on the computer. Wait for it to go through its internal checks and
for it to complete the start up process.

�. When your Windows desktop appears, insert the spectraLIGHT disk in
the computer floppy drive.

54 Using the Windows Explorer, (Start Menu>Programs>Windows
Explorer) open the floppy drive. Note: If you are installing on Windows
NT, use either the File Manager to access the floppy drive, or select
"Run" from the Program Manager.

64 Double click on Setup.exe to start the installation.

74 The Welcome screen appears. You are warned to exit all other running
programs. If no other programs are running, click Next.

;4 The next screen requests that you enter the destination directory for the
Control Program. If you would like to place the Control Program in a
directory other than the default directory, click on Browse and select an
alternate destination. Otherwise, click Next.

<4 A window appears, displaying installation progress, and prompting you
on how to proceed. After installation is complete, you are prompted to
view the Readme file. It is beneficial to view the Readme file at this time
because it contains important information about the software and the
machine that may not be included in this guide.

=4 Run the Control Program by double clicking the program icon.

>4 If running Windows NT, you need to reboot the computer.
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In the event you need to remove the Control Program from your hard drive,
there is an uninstall program included on the software disks. The uninstall
program was copied onto your hard drive when you installed the Control
Program.

To uninstall the Control Program, just double click the Remove Program
icon (it should be in the same folder as the Control Program). A message ap-
pears asking if you are sure you wish to remove the program and all its files.
Click on Yes to uninstall, or Cancel to exit the Uninstall program.
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The Control Program automatically sets most variables for you.

If you need to access the Setup Program, see the Reference Guide: Section E
in this manual.
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Should you require technical assistance, contact your local Light Machines
dealer. If you are unable to resolve your problem through your local dealer, free
technical support is available by phone, fax or email from 8:15 A.M. to 5:00
P.M. EST.
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Make sure you have the following information gathered before contacting
our Technical Support group.

� The product serial number.
� The name of the owner of the product.
� The specifications of your computer (e.g. hard drive size, clock speed, etc.).
� Notes on any Control Program error messages.

When you call, make sure you have access to both your machining center
and your computer. This will allow our technical support representatives to
walk through the problem with you. Our technical support numbers are:

U. S. (800) 221-2763
Canada (800) 637-4829

Fax (603) 625-2137
email support@lmcorp.com

WWW Site http://www.lmcorp.com/lmcorp

0������ 

Light Machines' products (excluding software) carry a one-year limited war-
ranty from date of purchase. Defective products may be returned for repair or
replacement according to the conditions outlined in the Terms and Conditions
of Sale agreement. If you need to return a product, call Light Machines and a
Technical Support representative will issue you a Return Materials Authori-
zation number (RMA). You must write the RMA and your return address on
the outside of the product carton or crate. Failure to do so can result in a de-
lay in the return of your product.
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The spectraLIGHT Machining Center is a three-axis tabletop milling machine
which you can run directly from your personal computer. The spectraLIGHT
Control Program, which you load onto your computer, accepts standard EIA
RS-274D G&M codes that CNC machine tools recognize. You'll find a com-
prehensive list of options and accessories for the spectraLIGHT Machining
Center on the last page of this guide.
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Some of the spectraLIGHT Machining Center’s most notable hardware and
software features include:

� X axis travel of 8.5 inches

� Y axis travel of 4.5 inches

� Z axis travel of 5.5 inches

� Feed rates up to 12 ipm

� Safety shield and limit switches

� Computer-controlled spindle speeds from 200 to 2,500 RPM

� EIA RS-274D standard G&M code programming

� Multiple tool programming

� Feed rate and spindle speed override functions

� A built-in full-screen NC program editor

� An on-line help utility

� Simultaneous or simulated, solid or centerline graphic verification
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There are, of course, more components on the machining center than those
shown here, but, to begin, you need only be concerned with the depicted
major components.
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The Safety Shield encloses the milling area to help protect the operator from
flying chips. A magnetic Shield Interlock Switch prevents the machine from
operating with the shield open.

The X, Y and Z motion of the machine is performed by Stepper Drive Motors
on each axis. There are also Limit Switches (beneath the way covers, next to
the drive motor on each axis) to prevent the machine from traveling beyond
its limits on each axis.

The  Spindle Head supports a 1/3 hp DC permanent magnet Spindle Motor.

You can’t miss the most important control on the machine; the Emergency
Stop button. When pressed, this bright red palm button immediately halts
machine operation. To resume operation, the button must be pulled back
out. It’s important that this button be pressed before performing any manual
operations, like changing the stock or the tooling.

Use the Spindle Speed switch to establish the spindle speed. The min and
max positions on the switch are equivalent to approximately 200 (min) to
2,500 (max) RPM. Use the Computer position when you want to set spindle
speeds from the Control Program.
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The Controller Box houses the power- and interface-related controls for the
machine. The power switch and keylock switch are on the front panel of the
box. The Key Lock switch keeps unauthorized persons from turning on the
machine. Once the Key Lock is in the unlocked position, the Power switch
can be turned on. The Power switch lights up when power is on.

The rear panel houses the power and interface connectors, and the fuses. The
machine has five fuses; for Main Power, the Spindle, the Stepper Motors,
and the two accessory outlets (labeled ACC 1 and ACC 2). The values for
these fuses are clearly printed next to the fuse receptacles. Do not use fuses
with amperages other than those shown on the machine.

The interface connectors are used to interface the Controller Box with the
machining center and your computer. Cables are provided in the Accessory
Kit for this purpose. Refer to Section A for correct installation procedures.
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The Accessory Kit that comes with the machining center contains all the
tools and hardware necessary for installing and maintaining the machin-
ing center. It also contains a collet and tools to get you started; other tool
holding devices and tools are available as options.
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Performing preventative maintenance, like routine cleaning, lubrication, and
correct adjustment, on your spectraLIGHT Machining Center ensures a
longer, trouble-free life for the machine.
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Gibs are fitted at the rear of the saddle and on the right-hand side of the
cross slide. A gib is a wedge that is adjusted by loosening the gib locking
screws and pushing the gib inward until any play is eliminated. Correct ad-
justment of the gibs will ensure smooth and steady operation of the slide.

If any end play develops in the main spindle, it can be eliminated by readjsting
the preload unit.

34 Remove the upper safety shield from the Machining center. Remove the
drive belt.

�4 Remove the main pulley from the spindle.

54 Loosen the setscrew and tighten the preload nut while turning the
spindle until the play is removed.

64 Tighten the preload nut just enough to remove excess play or the bear-
ings may be damaged (0.0002-inch play is recommended).
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You should periodically inspect the lead screw bearings because they can
loosen over time. These brass bearings are mounted on the lead screw next
to the flexible couplings on each axis. Tighten the bearings whenever you
measure the backlash and it is more than 0.008-inch, or whenever you see
a gap between one of the bearings and the cross slide.
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3 4 There is a black boot covering the lower portion of the flexible cou-
pling. Loosen the set screw that is visible above the black boot.

�4 Slide the black boot up to expose the lower half of the flexible coupling.

54 Loosen the set screw on the lower half of the flexible coupling.
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64 Press the cross slide to the left (facing the front of the machine) by exert-
ing pressure on the stepper motor.
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64 Pull the cross slide toward the front of the machine.

74 While still pulling the cross slide, press the flexible coupling in the oppo-
site direction, toward the cross slide.

;4 While holding the cross slide and flexible coupling in place, tighten the
lower set screw, then release the flexible coupling and cross slide.

<4 Slide the boot down and tighten the top set screw.
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6 4 Lift the spindle assembly upward.

7 4 While still lifting the spindle assembly, press the flexible coupling
downward.

; 4 While holding the spindle assembly and flexible coupling in place,
tighten the lower set screw, then release the flexible coupling and
spindle assembly.

< 4 Slide the boot down and tighten the top set screw.
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If the backlash is still more than 0.008-inch after you tighten the bearings,
you may need to adjust the anti-backlash nut. The anti-backlash nut is lo-
cated under the saddle.

To adjust the anti-backlash nut:

34 Move the Y axis saddle toward the mill column.

�4 Remove the locking screw and locking tab.

54 Turn the anti-backlash nut counterclockwise (left-hand thread) with the
screwdriver pushing against the notches on the edge of the nut until
backlash is eliminated and the nut is flush against the saddle.

64 Reassemble with the locking screw and locking tab.

74 Follow the above procedure for the X axis except: back-out the cross
slide to remove the locking tab. On the X axis, the anti-backlash nut
tightens clockwise (right-hand thread).
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Backlash is the amount of play in the lead screws. Backlash compensation re-
moves excess play whenever the machine changes direction. The amount of
play in these screws is minimized by adjustments made during assembly and
test of the machining center at the factory. However, you should still check
the backlash compensation after the first four or five hours of use, and every
10 to 20 hours of use thereafter, or whenever you find parts outside accept-
able tolerances. Backlash on the Z axis is minimized by the weight of the
spindle motor; therefore, the backlash compensation should be set to zero.
To set the backlash compensation for the X and Y axes:

34 Mount a dial indicator on the mill bed or chip tray with the tip of the
indicator touching the cross slide. Carefully align the indicator parallel
to the axis you are calibrating. Calibrate the X axis first, then the Y axis.

�4 Turn on the computer and the Controller Box, and and start the Con-
trol Program.

54 Select Backlash from the Setup Menu, and set the distance for all axes to
zero.

64 Set the speed for all axes to 3ipm (75mm/min.).

74 Use the Jog Keypad to jog 0.020-inch in one direction along the X axis.
Take a reading from the dial indicator.

;4 Jog 0.020 in the other direction on the X axis and take a second reading
from the dial indicator.

<4 Calculate the difference between the two readings and subtract this value
from 0.020 to get the actual backlash.

=4 Select Backlash from the Setup Menu and change the X axis distance to
the value found in Step 7.

>4 Align the dial indicator on the mill bed parallel to the Y axis and follow
Steps 5 through 8 to determine the actual backlash value for the Y axis.

3�4 Select Backlash from the Setup Menu and change the Y axis distance to
the value found in Step 7.

334 Reactivate the safety interlock on the shield if you have deactivated it.
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If the machining center sits idle for two weeks or more, you should clean and
oil it to prevent dust buildup. In addition, you should always clean the cross
slide, saddle, and bed at the end of each work session. Periodically maintain
the following parts:

� Bed, saddle, cross slide. Use a light oil, such as sewing machine oil, on
all points where there is a sliding contact. You should do this imme-
diately after each cleanup.

� Lead screw, cross slide screw. Place a light oil along all threads regularly.
At the same time, check that the threads are free of any metal chips.

� Tailstock spindle. On a weekly basis, wind out the spindle as far as it
will go and oil it with a light oil.

� Headstock bearings. These bearings are lubricated at the factory and
sealed to last the lifetime of the machine. They should not need fur-
ther lubrication if the seals remain unbroken.

� Thrust bearings. For every 80 hours of machine use, you should lubri-
cate the bearings on both axes with an all-purpose grease.

The bearings are located under the flexible couplings inside the stepper
motor brackets. Slide the black boot covering the flexible coupling to ex-
pose the blue bearing. After lubricating, make sure to slide the black boot
back to its original position.
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The spectraLIGHT Controller Box requires no special maintenance, except
that it should be kept in a dust-free environment.

If you are having problems with the AC Outlet function, or if the stepper
motors are not running, you may need to change a fuse in the Controller
Box. A blown fuse can occur if you overload one of the AC outlets. To
change a fuse:

34 Turn the power off, and disconnect the power cords to the Controller
Box and the Machining Center.
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� 4 The fuse holders are externally mounted on the rear panel of the Con-
troller Box and are labelled to correspond with each AC outlet. Locate
the correct fuse holder.

54 Remove the fuse by turning the fuse cap counterclockwise while pressing
slightly inward. The fuse is removed with the cap.

64 Visually inspect the fuse. If the fuse element appears broken, it is blown. You
can also use an ohm meter to check the continuity of each fuse.
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74 Replace the blown fuse with a standard slow-blow fuse of the appropriate
rating. Three-amp (3A) fuses are used for the motor drives, ACC 1, and
ACC 2. A five-amp (5A) fuse is used for the spindle, and a twelve-amp
(12A) fuse is used for main AC power.

;4 Replace the fuse holder cap by pushing inward and turning clockwise.

<4 Reconnect power.
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Here are a few general guidelines for maintaining your personal computer
and software in a shop environment. See your owner’s manual for mainte-
nance procedures specific to your computer.
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Follow these general rules for computer care.

� Keep the computer and peripherals (mouse, keyboard, external drive,
printer) out of direct sunlight and away from sources of heat and in a
relatively clean environment (i.e., not right next to the foundry room).

� Keep liquids (soda, coffee, cutting fluid, grease) away from the computer
and peripherals.

� Keep oil, grease, metal chips and excess dust away from the computer,
keyboard and floppy disks. You should consider erecting a clear plastic
shield between the computer and the mill to keep chips off the computer.

� Use grounded, three-prong outlets for the computer and peripherals. Take
precautions against current overload. A line-surge suppression unit can
be purchased at your local computer store to help alleviate this problem.

� Don’t block the vent holes in the computer or drives; they are required for
air circulation.

������
'��
)���� 
%��8�

Floppy disks are simple to use but require a few precautions to maintain their
integrity.

� Don’t touch the magnetic disk part of the disk (the shiny, record-like
part inside the disk jacket). Dust or grease from your hand can ruin any
part of the disk that you touch and can possibly destroy the entire disk.

� Keep disks in a disk box or special disk container instead of spreading
them out on your work space.

� Handle disks gently, don’t bend or crease them.

� Don’t write on disk labels with a ball point pen. If you must write on the
label, always write very lightly with a felt tip pen.

� Keep disks in a clean, cool environment away from excess amounts of
dust, heat, or sun.
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� Beware of getting machining fluids on the disks. If you spill a liquid or
cutting fluid on a disk, it is almost percent certain that the disk and all
the data on it can never be used again.

� Keep disks away from all magnetic sources including telephones, high-
voltage power sources and mill motors.

� Make backup copies of all NC program disks each time you update them.

� Print copies of all NC programs in case of disk failure or lost disks.

No matter how cautious you are, disks will go bad; they develop bad blocks (un-
readable surfaces). If this happens while you are editing a program, the program
will be lost. The solution to this disaster is simple—make backup copies.
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To start the spectraLIGHT Control Program:

From Windows 95 select Start from the Task Bar, then select “Progams” and the
WSLM folder. In that folder, select WSLM Windows CNC Control. You can
also create a Windows 95 shortcut by opening the WSLM directory and drag-
ging WSLM.EXE onto your desktop.

From Windows NT double-click the WSLM icon in the WSLM Group.

You should have the controller box connected and powered up before starting
the control software, unless you are going to be working in the Simulate Mode.
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You can access online help by using the commands under the Help Menu, or
by pressing F1.

For information on many of the functions and screens in the WSLM soft-
ware, you can also refer to the Reference Guide: Section E.
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You should become familiar with the main parts of the Control Program
screen before you begin using the Control Program to run NC part pro-
grams. The following are the default components that make up the screen.
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The Menu Bar contains all of the menu commands for the Control Program. For
an explanation of each menu and its relative commands, refer to the Reference
Guide: Section E.
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The Standard Tool Bar provides easy access to the most often used com-
mands available in the Control Program.
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The Outputs Tool Bar is an active tool bar. It provides switches to supply
power to the spindle, and to the Accessory outlets on the Controller Box.
Switches for Robotic outputs 1 and 2 are also provided. Power is on when
the buttons are depressed.
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The Inputs Tool Bar is an inactive tool bar. It provides information only on
the state of the Emergency Stop, the Safety Shield, and the negative limit
switch. Indicators for Robotic inputs 1 and 2 are also provided. An input is
active (on) when the button is depressed.
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Whenever you open an NC part program file it appears in its own edit
window. These windows have the same characteristics as other Windows 95
windows (scroll bars, minimize/maximize buttons, etc.). You can have
multiple edit windows open at a time, the maximum number of which
depends on available memory.

By default, each new window is locked; you can not edit a locked window.
To unlock the window, use the Lock command under the Edit Menu.
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The left side of the Status Bar provides information about the currently selected
function. The right side of the status bar provides information on:

� Whether or not the machining center is homed

� Whether or not the Caps Lock key is activated

� Whether or not the Num Lock key is activated

� The current line and total number of lines in the program

� Whether or not the current NC part program is locked

� Whether or not the current NC part program has been modified

� The current time according to your computer

When the indicator is dimmed, the function is in the off condition.
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The Position Readout provides information on the current X, Y and Z coor-
dinates of the tool position. The units of measure in the Position Readout
are determined by the Units command under the Setup Menu.
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The Machine Info Panel provides information on the current tool, tool
diameter, feed rate, spindle speed, number of  passes made, coordinate
system in use, as well as the current block and total number of blocks in
the program.
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The Verify Window displays a simulation of your part program when you se-
lect the Verify command from the Program Menu, or when you click the
Verify Program button on the Standard Tool Bar.

Tool path verification can be performed in centerline view or solid view.
Centerline view is based on the centerline of the tool. Solid view is a solid
representation of the tool and workpiece.
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Like any other power tool, the spectraLIGHT Machining Center is a poten-
tially dangerous machine if operated in a careless manner. The importance of
safely operating the spectraLIGHT Machining Center, including the need
for protection against personal injury and the prevention of damage to the
equipment, can not be stressed enough. You will find more information on
safe machining in the Reference Guide: Section J.
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The following safety rules should be practiced by all operators of the spectra-
LIGHT Machining Center.
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Make a habit of checking that keys and adjusting wrenches are removed
from the machining center before operating the machine.
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Select the feed rate and depth of cut best suited to the design, construc-
tion and purpose of the cutting tool. It is always better to take too light a
cut than too heavy a cut.
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Select the type of cutting tool best suited to the milling operation. Don’t
force a tool or attachment to do a job it wasn’t designed to do.
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Be certain that you have firmly secured the workpiece on the cross slide
and the cutting tool in the spindle before turning on the spindle motor.
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Manually turning the spindle allows you to safely determine that the tool
will not hit the machining center bed, cross slide, or stock on start up.
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Tighten the work holders and tool holders. Do not over-tighten these devices.
Over-tightening may damage threads or warp parts, thereby reducing ac-
curacy and effectiveness.
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Before you run the spectraLIGHT Machining Center for the first time, you
should know how to stop the machine should an emergency situation arise.
There are a number of ways an emergency stop can be initiated on the ma-
chining center: by pressing the Emergency Stop button, by simultaneously
pressing the Control and Space Bar keys on the computer keyboard, by activat-
ing one of the limit switches, or by activating the safety shield interlock switch.
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There is an Emergency Stop button located on the front panel of the machining
center; it has an oversized red cap. Before power can be applied to the machin-
ing center, the Emergency Stop button must be pulled fully out from the
front panel. The full-out position allows power to be supplied to the machining
center. The Emergency Stop button disables the spindle even if the computer
is turned off.

In the event that a tool crashes into the workpiece, you can immediately kill
power to the machining center by pushing in the Emergency Stop button. The
Emergency Stop button should be your first target in an emergency situation.
Pushing in the Emergency Stop button terminates the part program. Wait
until the machining center has completely stopped moving before opening
the safety shield.

When the tool crash has been cleared and the Emergency Stop button is reset
(pulled back out), edit the part program to remove the cause of the tool crash
before running the program again. Reset the tool position using the Set Posi-
tion command from the Setup Menu.
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The execution of the part program can be interrupted by pressing keys on the
computer keyboard. Unlike using the Emergency Stop button, this method
of stopping the machining center does not cause the software to lose track of
the tool position.

To stop the part program with the keyboard, press the Control key and
Space Bar simultaneously. The cutting stops immediately and the cutting
tool remains in position. To restart the program from a keyboard-gener-
ated stop, select the Run/Continue command from the Program Menu.
In the Start At Line box, enter the number of the last line executed, then
click on the Run Program button. (When you stopped the program, the last
line executed is displayed on the Machine Info Panel, and the cursor is
placed on the same line in the file.)
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The spectraLIGHT Machining Center is equipped with a limit switch on the
Z axis to sense the end of travel in the negative Z direction (i.e., when the
tool travels down towards the work piece). If the axis travel exceeds the end
of travel, the limit switch is activated and shuts down machine operation.

Once the limit switch is activated, the tool must be jogged away from it using
the Jog Control Panel (see the Reference Guide, Section E). To move the
spindle away from the limit switch, you must jog it in the opposite direction,
in the positive Z direction.

If the spindle comes close enough to the end of travel to activate the limit
switch, the following procedure must be followed to restore normal operation.

34 Select Jog Control from the View Menu or from the Standard Tool Bar.

�4 Click on the appropriate jog key on the jog keypad, to move the spindle
away from the triggered limit switch.

54 Check your initial machine set up to make sure it was performed correctly.

��������
"���
���
��'�� 
������
	�������8
�"����

Opening the safety shield activates a safety interlock switch which interrupts
the NC program and stops machine motion. Cutting stops immediately and
the cutting tool remains in position. To restart the NC program, select Run/
Continue from the Program Menu. This is not recommended as the proper
method of stopping the machine in an emergency situation. Use the Emer-
gency Stop button.

The safety interlock switch interrupts machining operations only when an
NC program is running; you can have the shield open when jogging or tra-
versing the tool with the Jog Control Panel.
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When you installed the spectraLIGHT Control Program an NC part pro-
gram file, named Millone.nc, was copied into the WSLM directory along
with the other files. The Millone.nc program is meant to machine a 3" x 2" x
1.5" piece of machinable wax. You will be using this file to create your first
workpiece on the machining center.
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34 Select the Open command from the File Menu, or click on the Open
button on the Standard Tool Bar. The Open dialog box appears.

�4 Double-click on the Millone.nc filename, or click on the filename then
click on the Open button. The edit window for Millone.nc appears.
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After opening the NC program, you need to adjust the Verify Settings for the
part you are about to machine. To view the Verify Setup dialog box, select
Verify from the View Menu; double click on the Verify window when it appears.

You may also select Verify from the Program Menu, or from the Standard
Toolbar, then click on the Verify Settings button. The Verify Setup dialog
box appears.
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34 Select the View tab.

�4 Select a Style. Solid for a solid representation or Centerline for a center-
line representation of the tool and workpiece.

54 Use the Zoom controls to alter the size of the workpiece in the Verify
window.

64 Select a Preset View. Choose Isometric for a three dimensional view of
the part.
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3 4 Select the Stock tab.

�4 Enter the stock Dimensions for the Millone.nc part program. The stock
dimensions are X=3", Y=2" and Z=1.5".

54 Set the Initial Tool Position to X=0, Y=0 and Z=0.5.

64 Select OK. The dialog box closes, and your changes are applied to the
workpiece in the Verify Window.
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To machine this part, you will use an 1/8" HSS end mill. You will use the
parameters for this particular end mill for the tool path verification as well. To
define the tool parameters, first add the tool to the tool library, then select
the tool for verification.
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34 Select Setup Library from the Tools Menu. The SetupTools dialog box
appears. There are already a number of tools defined, but there is no
1/8" end mill. You need to make one.

�4 In the Tool Library scroll box, scroll down to an undefined tool. We have
selected Tool 11, which is undefined at this point. Highlight the undefined
tool number by clicking on it with your mouse.

54 In the Tool Type pull-down list, select End Mill.

64 Enter "End Mill" in the Description box.

74 Enter 0.125 in the Diameter box.

;4 Click on the Apply button. You have just defined a new tool in the li-
brary. From now on, whenever you need an 1/8" HSS end mill it will
be there.
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<4 Click on OK to exit the Tool Library.
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34 Select the Select Tool command from the Tools Menu. The Select
Tool for Use dialog box appears.

�4 Select the tool you previously defined by using the Tool pull-down list.

54 Click on the Select Tool button.
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Tool path verification allows you to check for programming errors before ac-
tually running the part program on the machining center.

34 Select Verify from the Program Menu or from the Standard Tool Bar.
The Verify Program dialog box appears. The default starting line for the
program is Line 1. When verifying a program for the first time, you
should begin on Line 1.

�4 Click on the Verify Program button, then watch the Verify Window.
You will see the Millone.nc program executed on the graphic workpiece.
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Before you run your part program for the first time, you should perform a
dry run (run the program with no stock mounted). This will ensure that all
the movements of the machining center make sense and that the tool is in no
danger of striking any fixtures or crashing into the cross slide. Although you
should dry run the program with no stock mounted, set the point of origin
using the workpiece and then remove it.

Begin with the Emergency Stop button pressed in, and the spindle speed
turned all the way down. The vise or other work holding device should be
mounted to the cross slide and the tool should be mounted in the spindle.

34 Mount the workpiece in the vise.

�4 Close the Safety Shield and  pull out the Emergency Stop button.

54 Select Jog Control from the View Menu (or the Standard Toolbar). The
Jog Keypad appears.
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64 Use the Jog Keypad to jog the tool to the top of the front left corner of
the workpiece.

74 Select Set Position from the Setup Menu. The Set Position dialog box appears.
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; 4 Enter zero in the X, Y and Z boxes.

< 4 Click on OK. The values in the Position Readout all change to zero.

=4 Jog the tool up and away from the workpiece. Press the Emergency Stop
button, open the Safety Shield and remove the workpiece.

>4 Return the Safety Shield to the closed position and pull out the Emergency
Stop button.

3�4 Put on a pair of safety glasses and complete the Safety Checklist (refer to
the Reference Guide: Section J).

334 Select Run/Continue from the Programs Menu. The Run Program dialog
box appears.

3�4 Click on the Run Program button.

354 As the part program runs, observe the tool motion in relation to the vise
(and eventually the workpiece). Look for signs of a possible tool crash
and be prepared to press the Emergency Stop switch on the machining
center. Edit the program as required. When you are satisfied that the
tool motions are correct, you can mount the workpiece.
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34 Using the Jog Keypad, jog the spindle up and out of the way.

�4 Before mounting the workpiece, push the Emergency Stop button in.

54 Mount the workpiece in the vise leaving at least 1/8" of the stock above
the jaws of the vise. Take care to position the workpiece parallel to the
tool bed. To assure that the piece is flat, place parallel bars underneath to
space it upwards within the vise before clamping.

64 Pull the Emergency Stop button out.

74 Jog the tool to position the center of the tool tip at the top of the front,
left corner of the workpiece. Jog until the tip of the end mill touches the
surface of the workpiece.

;4 Select the Set Position command from the Setup Menu and enter zero
for all three axes. Select the Operator Panel and check that the spindle
speed is set to 100%.

The workpiece is now correctly mounted.
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Before executing the Millone.nc program, check that all safety precautions
have been taken. The machining center safety shield should be closed, and
you should be wearing safety glasses.

If anything goes wrong, immediately press the Emergency Stop button on
the machining center to stop the operation. A safety checklist has been pro-
vided in the Reference Guide: Section J of this guide. Post a copy of this
checklist near the machining center and review it before you run any NC
program.

To run the program:

34 After reviewing the Safety Checklist, select the Run/Continue command
from the Program Menu. The Run Program dialog box appears.
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�4 Make sure that the Start Line box is set to line 1 of the program.

54 Click on the Run Settings button. The Run Settings dialog box appears.

64 Make desired changes in the Run Settings dialog box, then select OK.

74 Click on the Run Program button to begin running your program.

;4 After the part is machined, press the Emergency Stop button before
opening the safety shield and removing the finished part.
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The Control Program interface (the screen) is composed of several components
that allow you to create NC part programs and interact with the machining
center.
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The Message Bar is located directly beneath the Menu Bar. When an NC
program is running or being verified, the Message Bar displays the name of
the NC file currently being run, or the most recent operator message. When
a program is running, the Message Bar also displays control buttons (Go or
Stop). When there is no program running, the Message Bar displays the
Control Program copyright notice.
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Windows can be used to display information or accept input from the machine
operator. Some windows can be docked or they can be floating windows (see
Docking and Floating Windows and Toolbars later in this section). Windows
are activated or hidden using the commands under the View Menu.

The following windows are available:

u Program Edit Windows

u Verify Window

u Machine Info Window

u Position Window
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When you open an existing NC part program file, or create a new one, the
program appears in a program edit window. Program Edit Windows have all
of the features common to other windows, including a title bar which dis-
plays the program file name and controls for minimizing, maximizing, and
closing the window.

Program Edit Windows appear in the Edit Area (the large central area) of the
screen. The Edit Area is fixed in position; you cannot close it or move it.The
Edit Area can contain multiple Edit Windows.

When other windows, panels, and toolbars are closed, the space that their
docking areas occupy is given to the Edit Area.

When other windows, panels, and toolbars are open, the space that their
docking areas occupy is taken from the Edit Area.

The Windows Menu has several commands for managing program Edit
Windows, and allows you to select a particular window from a list of all cur-
rent windows, identified by file names.
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The Verify Window can be opened and
closed by selecting the Verify Window
command from the View Menu.

The Verify Window displays a simula-
tion of your part program (tool path
verification) when you select the Verify
command from the Program Menu, or
when you click the Verify Program
button on the Standard Toolbar.

Tool path verification can be performed in centerline view or solid view.
Centerline view is based on the centerline of the tool. Solid view is a solid
representation of the tool and workpiece.
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The information displayed in the Machine Info Window varies with the
particular operation being performed:

When the machine is idle, the
Machine Info Window displays
information about the:

u Current tool number

u Tool diameter

u Feed rate

u Spindle speed

u Number of passes* made for the current program

u Coordinate system being used

u Current block number*

u Number of blocks* in the current program

(*The passes, current block, and total number of blocks refer to the last pro-
gram verified or run.)
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When a program is running, the
Machine Info Window becomes a
dynamic display. In addition to
updating the previously mentioned
information, each line of code (as
it is executed) is displayed along
with the previous and next lines of
code. Also, a clock provides the
elapsed run time for the program.

When a program is being verified,
the Machine Info Window displays
the current line of code, plus the
previous and next lines. The
elapsed time is not indicated.
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This is a dynamic display. When a program is running or being verified, the
current position of the tool is indicated here.

If you double-click on this window, the Goto Position dialog box appears,
allowing you to move the tool to specific coordinates.
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Toolbars carry buttons that correspond to frequently used menu commands.
You can click on these buttons to quickly select the associated menu com-
mand. Toolbars also operate Outputs and display the state of Inputs. Toolbars
can be placed anywhere on your screen, and can be hidden if you do not use
them often or want the additional space for program windows. Toolbars are
revealed and hidden using the Toolbars command under the View Menu.

The toolbars include:

u Standard Toolbar

u Outputs Toolbar

u Inputs Toolbar
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The Standard Toolbar provides quick-access buttons for the following menu
commands:
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New Create a new program edit window

Open Open an existing NC program file

Save Save an NC program file

Cut Cut text from a program

Copy Copy text from a program

Paste Paste text into a program

Print Print an NC program

Help Access Help

Context Help This button can help you instantly find information
on the items you see on the screen. For instance, click
on the Context Help button, then click on a menu
item, toolbar button, window or other screen element.
The Help topic for that particular item appears.

Jog Control Panel Show or hide the Jog Control Panel
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Operator Panel Show or hide the Operator Panel

Verify Verify the current NC part program

Run Run the current NC part program

Pause Pause the currently running NC part program

Stop Immediately halt the currently running NC program
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The Inputs Toolbar isn’t really a toolbar, in that you can not use it to inter-
act with the various Control Program inputs. Actually, it is a monitoring de-
vice that keeps track of the state of the various machine inputs.

The state of each input is indicated by the position of its button. If a button
is depressed, the input is “on” or “high.” If a button is not depressed, the in-
put is “off” or “low.” You can also check the condition of an input by click-
ing on it or by holding the mouse over the input button. The state of the
input is displayed on the Status Bar  at the bottom of the screen.

The inputs on the Inputs Toolbar include:

u The Emergency Stop condition. This input is in the “on”
condition (depressed) if the Emergency Stop button on the
machining center is pushed in.

u The Safety Shield condition. This input is in the “on” con-
dition (depressed) if the Safety Shield on the machining
center is open.

u The Negative Limit condition. This input is in the “on”
condition (depressed) if the negative Z axis limit has been hit.

u The Robot Input 1 condition. This input is in the “high”
condition (depressed) if robotic input #1(on the TTL I/O
connector on the Controller Box) is currently in a high state.

u The Robot Input 2 condition. This input is in the “high”
condition (depressed) if robotic input #2 (on the TTL I/O
connector on the Controller Box) is currently in a high state.
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The Outputs Toolbar provides quick-access buttons for controlling the
system outputs.

The state of each output is indicated by the position of its button. If a but-
ton is depressed, the output is “on” or “high.” If a button is not depressed,
the output is “off” or “low.” You can also check the condition of an output
by holding the mouse over the output button. Clicking on the button will
change the state of the output. The name of the output is displayed in a tool
tip, and the state of the output is displayed on the Status Bar at the bottom
of the screen.

The output controls on the Outputs Toolbar include:

u The Spindle control. This button turns the spindle on and off.

u The ACC1 control. This button turns the Accessory 1 output
on and off.

u The ACC2 control. This button turns the Accessory 2 output
on and off.

u The Robot Output 1 control. This button toggles Robotic
Output 1 between high and low conditions. When this button
is depressed, it places Robotic Output 1 (on the TTL I/O
connector on the Controller Box) in the “high” condition.
When this button is not depressed, Robotic Output 1 is in
the “low” condition.

u The Robot Output 2 control. This button toggles Robotic Output 2 be-
tween high and low conditions. When this button is depressed, it places
Robotic Output 2 (on the TTL I/O connector on the Controller Box) in
the “high” condition. When this button is not depressed, Robotic Out-
put 2 is in the “low” condition.
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The Jog Control Panel and Operator Panel are used to control machine
operation.
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The Jog Control Panel is accessed by selecting the Jog Control command under
the View Menu, or by clicking on the Jog Control button on the Standard
Toolbar. The Jog Control Panel allows you to manually move (jog) the tool
on the machining center.

Each axis on the machine is represented by buttons. The X and Y axes are
represented by the crosspad. The crosspad follows the Cartesian coordinate
system standard; -X to +X is left to right, while -Y to +Y is bottom to top.
The Z axis is represented by two buttons, one for positive motion and one
for negative motion. Pressing any of the axis buttons moves the tool in the
indicated direction as long as the system is not in Simulate Mode.

Jogging occurs in specific increments of speed and distance. The speed and
distance values are selected on this panel as well. You can alter the speed and
distance parameters for jogging by selecting the Jog Settings command under
the Setup Menu, or by double clicking on the Jog Control Panel.
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To jog a tool:

3. Define the Speeds and Steps (distances) for jogging by selecting the Jog
Settings command under the Setup Menu.

�. Click on the Axis button on the Jog Keypad to move the tool in the de-
sired direction. The tool moves at the speed and distance indicated by
the Speed and Step buttons.
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The Operator Panel controls include:

u Optional Skip: Allows you to execute or ignore any optional skips
( / codes) you have embedded in the NC program.

u Optional Stop: Allows you to execute or ignore any optional stops
(M01 codes) you have embedded in the NC program.

u Single Step: Causes the NC program to pause after each block is ex-
ecuted. This allows you to check each step of the cutting operation.
Single Step is particularly useful after changing the workpiece size.

u Stop: Immediately halts the currently running NC program. This button
works the same as the Ctrl + Space Bar combination.

u Cycle Start: Begins running the current NC program from the begin-
ning or from a paused condition.

u Feedhold: Pauses the currently running NC program. To continue run-
ning the program from a Feedhold, press the Feedhold button again or
press the Cycle Start button.

u Feed Rate Override: Overrides the programmed feed rate.

u Spindle Speed Override: Overrides the programmed spindle speed.
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The Operator Panel provides controls that are used while running an NC
program on the machining center.

2�
�������-�� �
��

����!��
2;����!�

���!	��!

�*
����
��


���!�)�
�
2;����!�

��������
��

2�
�������
��



:+�����
����/�������)�(����
�

�����
���
������
���

The Status Bar displays miscellaneous information about the machining cen-
ter and the computer. The left side of the Status Bar is reserved for operator
messages such as the one displayed here.

If any of the following are grayed-out, the feature is considered “off.”

u The machine Homed state: Black if the machine is currently homed.

u The Caps Lock key state: Black if the Caps Lock feature is on. Some NC
programmers prefer to type their programs in capital letters. When the
Caps Lock feature is on anything you type will be displayed in capital
letters. Press the Shift key to type lower case letters.

u The Num Lock key state: Black if the Num Lock feature is on. Some
NC programmers prefer to use the numeric keypad on the keyboard to
enter figures. The Num Lock feature must be on to do this.

u Current Line : Total Lines: Displays the line the cursor is currently on,
and the total number of lines in the program.

u The file Locking state: Black if the NC program file is locked.

u The file Modified state: Black if the NC program has been modified
since being opened.

u The current time (according to your computer).
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The Menu Bar is located at the very top of the screen. It lists the categories of
commands into which the Control Program operations are grouped.

The available menus are:

u File Menu

u Edit Menu

u View Menu

u Program Menu

u Tools Menu

u Setup Menu

u Window Menu

u Help Menu

)���
����

The File Menu provides typical file management commands and the
command to exit the Control Program.
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New Create a new program window.

Open Open an existing file.

Close Close an open program window.

Save Save a program.

Save As Save a program under a different filename or location.

Print Print an open NC program.

Print Setup Set up your printer for printing.

Recently opened files Open one of the eight most recently used files.

Exit Exit the Control Program.
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Use the New command under the File Menu to create a new program edit
window. You can create a new program edit window at any time. The num-
ber of program edit windows that you have open at one time is limited by
the amount of memory on your computer.

To create a new program window, select New from the File Menu, or press
Ctrl+N. A new program window is created. The filename on the Title Bar is
“Untitled,” indicating that this is a new program. The program will remain
untitled until you save it. You should save a new program before it is run or
verified.
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Use the Open command under the File Menu to open an existing NC pro-
gram. The number of program edit windows that you have open at one time
is limited by the amount of memory on your computer.
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34 Select Open from the File Menu, or press Ctrl+O. The Open dialog box
appears.
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�4 In the dialog box, locate and highlight the desired NC file.

54 Click the Open button or press Enter. The selected NC program file is
opened. The Title Bar on the Edit Window displays the name of the file.
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u If the open file has changed since it was opened, you are prompted to reload
the original version of the file or to cancel the opening procedure.

u If the open file has not changed since it was opened, it becomes the ac-
tive Program Edit Window.
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You can close a program window at any time. Unless you have already done
so, you will be prompted to save any changes made to the program file.

To close a program window:

34 Make sure the program window you want to close is selected.

�4 Select one of several ways to close the open window:
u Select the Close command from the File Menu.
u Single-click the icon on the far left of the Title Bar and select Close

from the drop-down menu. (If the Edit window is maximized, the
icon will be at the far left of the Menu Bar.)

u Double-click the icon on the far left of the Title Bar. (If the Edit
window is maximized, the icon will be at the far left of the Menu Bar.)

u Click on the Close button on the far right of the Title Bar. (If the
Edit window is maximized, the icon will be at the far right of the
Menu Bar.)

u Press Ctrl+F4.

54 If there are unsaved changes to the current program, the File Save dialog
box appears, prompting you to save the changes. Click one of the butons
in the dialog box:
u Click Yes to save the changes.
u Click No to discard the changes.
u Click Cancel to exit the dialog box without saving the changes or

closing the program window.
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Use the Save command under the File Menu to save the current program as
an NC file.

If the current NC program was previously saved, selecting Save saves the
changes to the same file without bringing up a dialog box. If the current pro-
gram is new (and still has the name “Untitled”), selecting Save brings up the
Save As dialog box, with which you name, choose a location for, and save the
new program.

To save a program, select Save from the File Menu, or press Ctrl+S.

The current program is saved to a file. If this is a new program, the Save File
As dialog box appears. Choose a name and location for the new file.
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Use the Save As command under the File Menu to save the current program
to an NC file using a new name or location.
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The Save As dialog box in the WSLM Control Program functions in the
same manner as in other Windows 95 applications.

To use the Save As dialog box:

34 Select a destination for the file using the Save in:, Up one level and
Create new folder buttons.

�4 Enter a filename in the File Name: field.

54 Select a file type in the Save as type: field.

64 Click Save or press Enter to save the file.

74 Click Cancel or press Esc to cancel and exit the dialog box.
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34 Select Save As from the File Menu. The Save As dialog box appears (see
above). It displays the name and location of the current program file.

�4 Choose a new drive and directory for the file, if desired.

54 Type in a new file name, if desired.

64 Click Save to save the file, or Cancel to exit the dialog box.

$����
��!!���

Use the Print command under the File Menu to print the current NC program.

To print the program:

34 Use one of the following methods to open the Print dialog box:
u Click the Print button on the toolbar.
u Select the Print command from the File Menu.
u Press Ctrl+P.

The Print dialog box appears.
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�4 Choose the desired print options in the dialog box. Clicking Setup
opens the Print Setup dialog box.

54 Select OK to print, or select Cancel to exit the Print dialog box without
printing the NC program.

You can print to any printer that is supported by Windows. See your printer
manual or Windows documentation for more information on installing and using
printers with Windows.
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Use the Print Setup command under the File Menu to select a printer. The
Print Setup dialog box allows you to establish parameters for printing your
NC part programs.

To choose print settings:

34 Select Print Setup from the File Menu. The Print Setup dialog box appears.

�4 Select the desired print settings, including:
u The destination printer.
u The size of the paper.
u The paper tray.
u The orientation of the paper.

54 Select OK to print, or select Cancel to exit the Print dialog box without
setting the printing parameters.
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Use the numeric (1, 2, 3, … 8) commands under the File Menu to open any
of the most recently opened files (up to the last eight files).

The names and paths of the most recent files
appear in the reverse order in which they were
opened.

For instance, in this example, 1 Mtemplat.nc

is the most recently opened file.

The file 3 Millone.nc is the third most recently
opened file.

To open one of the listed NC program files,
simply select the filename from the list. The
recent program you selected is opened. Once
the file Edit Window is open, the Title Bar
displays the name of the program file.
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Use the Exit command under the File Menu to exit the Control Program.
You should always exit the Control Program before you exit Windows.

Use one of the following methods to exit the Control Program:

u Select the Exit command from the File Menu.

u Single-click the icon on the far left of the Control Program Title Bar. Se-
lect Close from the drop-down menu.

u Double-click the icon on the far left of the Control Program Title Bar.

u Click on the Close button on the far right of the Title Bar.

u Press Alt+F4.

If there are unsaved changes to any program window, a dialog box appears
for each unsaved program window, prompting you to save the changes.

u Click Yes to save the changes and exit.

u Click No to ignore the changes and exit.

u Click Cancel or press Esc to cancel the Exit command and return to the
Control Program.
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The Edit Menu provides typical text editing commands. Before you can edit
the text in an NC program, you must select the text.
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Undo Undo the most recent editing command.

Redo Redo the most recent Undo command.

Cut Cut selected text to the Windows clipboard.

Copy Copy selected text to the Windows clipboard.

Paste Paste text from the Windows clipboard into the
current NC program.

Clear Delete selected text.

Delete Line Delete the line the cursor is currently on.

Find Locate a sequence of characters in an NC program.

Replace Replace one sequence of characters with another,
one or more times.

Goto Line Jump to a particular line in the NC program.

Renumber Modify or insert N codes in an NC program .

Lock Lock or unlock the Program Edit Window to pre-
vent or allow modification to the NC program.

Select Font Change the font currently being used.
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The Undo command reverses the most recent editing action taken. It is use-
ful for recovering from accidental deletion or inclusion of a block of text.

To undo the last change, select Undo from the Edit Menu, or press Ctrl+Z.

u If your last editing action deleted selected text, the text is restored.

u If your last editing action deleted a character, the character is restored.

u If your last editing action pasted text, the text is removed.

u If your last editing action typed a character, the character is removed.

u If Undo is grayed-out in the Edit Menu, no changes can be undone.
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The Redo command reverses the action of the most recent undo command.
For example, if you delete a portion of text in an NC program, then decide
that wasn’t such a good idea, the Undo command will return the text to its
original position. If you then decide that the deletion was appropriate
afterall, select the Redo command to once again remove the text.
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Use the Cut command under the Edit Menu to remove text from the NC
program (the text is copied to the Windows clipboard). The text can then be
pasted anywhere in the current program, into another program, or into an-
other application such as Notepad. The text remains on the Windows clip-
board until it is replaced by another Cut or Copy operation.

To cut text to the Clipboard:

34 Select the text you wish to cut.

�4 Select Cut from the Edit Menu, or press Ctrl+X.
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Use the Copy command under the Edit Menu to duplicate selected text in an
NC program.

To copy text to the Clipboard:

34 Select the text you wish to copy.

�4 Select Copy from the Edit Menu, or press Ctrl+C. The selected text is
copied to the Clipboard.
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You can use the Paste command to insert text from the Windows clipboard
into your NC program.

To paste text from the Clipboard:

34 Place the cursor at the point in the NC program where you wish to insert
text that has been previously cut or copied to the Windows clipboard.

�4 Select Paste from the Edit Menu, or press Ctrl+V. The contents of the
clipboard are inserted into the program. If this menu command is
grayed-out, there is no text on the clipboard to paste.
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Use the Clear command under the Edit Menu to delete selected text from
your NC program. The text is not copied to the Windows clipboard. You
can also use the Delete key on your keyboard to achieve the same effect.

To delete text using the Clear command:

34 Select the text you wish to delete.

�4 Select the Clear command from the Edit Menu. The selected text is deleted.
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Use the Delete Line command under the Edit Menu to delete an entire line
of NC code from a program without selecting it first.

To delete a program line using the Delete Line command:

34 Place the cursor anywhere on the line of code you wish to delete.

�4 Select the Delete Line command from the Edit Menu, or press Ctrl+Y.
The line of code is deleted.
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Use the Find command under the Edit Menu to locate a particular sequence of
characters within an NC program.

To use the Find command:

34 Select Find from the Edit Menu, or press Ctrl+F. The Find dialog box
appears.

�4 Enter the character sequence for which you are looking in the Find
what: box.

54 Check the Match whole word only box to restrict the search to whole
words, skipping partial words.

64 Check the Match Case box to restrict the search to finding only those text
strings that match the case (upper or lower) of the text that you entered.



:+,0���
����/�������)�(����
�

74 Select Up or Down from the Direction box to search through the text
before or after the cursor position, respectively.

;4 Click Find Next or press Alt+F to begin the search. Click Close or press
ESC to exit the Find dialog box without performing the search.
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Use the Replace command under the Edit Menu to replace an existing char-
acter string with a new character string.

If the Match Case box is checked, this feature is “case-sensitive.” If you enter
a character string in lower case letters, but your NC program is written in all
upper case letters, Replace will not find any occurrence of the string. Make
sure you enter the existing character string exactly as it is shown in the NC
program.

To use the Replace command:

34 Select Replace from the Edit Menu. The Replace dialog box appears.

�4 Enter the existing character string in the Find what: box.

54 Enter the new character string in the Replace with: box.

64 Check the Match whole word only box to restrict the search to whole
words, skipping partial words.

74 Check the Match Case box to restrict the search to finding only those text
strings that match the case (upper or lower) of the text that you entered.

;4 To locate the first and succesive instances of the character string, click
Find Next.

<4 Select Replace to replace the currently located charater string, or select
Replace All to replace all similar character strings throughout the NC
program.

=4 Click Close to exit the dialog box without completing
replacement.
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Use the Goto Line command under the Edit Menu to move the cursor to a
specific line in the NC program. This command is also available using the
Program Edit Window Pop-up Menu.

To use the Goto Line command:

34 Select Goto Line from the Edit
Menu, or press Ctrl+G. The Goto
Line dialog box appears.

�4 Enter a line number in the Jump to
Line Number box. The cursor moves to the specified line in the NC
program. If the line number entered is larger than the number of lines in
the program, the cursor is moved to the end of the program.
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Use the Renumber command under the Edit Menu to alter the N codes in
your NC program.

The Renumber command can be used to:

u Insert N codes in a program that has none.

u Remove N codes from a program.

u Renumber the N codes in a program.

u Insert, remove or ignore spaces between NC commands.

u Remove comments from the program.
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To insert or renumber the N codes in your program:

34 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.
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�4 Select Renumber N Codes or press Alt+N.

54 Click on the Start N Code box (or press Alt+T), then enter the number
of the first N code. The default starting number is N1.

64 Click on the Increment box (or press Alt+I), then enter the increment you
wish to use. For instance, if you wish to have each N code numbered in
increments of 5, enter 5 in the Start N Code box and enter 5 in the In-
crement box. The N code sequence will then be: N5, N10, N15,
N20…and so on.

This option is useful if you are renumbering a portion of the program to be
inserted into another program, and the N codes must start with a num-
ber greater than 1. Using increments greater than 1 allows you to insert
additional numbered lines without having to renumber the whole program.

74 Select Do It, or press Alt+O, to execute the Renumbering options you
selected. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.

&���!.�����
���
��.������!�

Although the Renumber command automatically changes P codes used with
M99 codes, it does not renumber P codes used with M98 codes, nor does it
renumber O codes. Although O codes are not altered, the lines which they
occupy are counted. So, the very next N code is numbered as though the O
code has been renumbered, too.

For instance, N41X
N42X…
O25G…
N44…

In this example, although the O code has not been renumbered, the line it
resides on has been counted. The N code on the following line reflects the
next number in the sequence.
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To insert or remove spaces between the NC words in your program:

34 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

�4 Choose a Spaces option.
u Insert Spaces inserts a space between each NC word (to the left of

the comment code).
u Remove Spaces removes any spaces between NC words (to the left

of the comment code).
u Ignore Spaces ignores any spaces in the NC program.
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54 Select Do It, or press Alt+O, to execute the Spaces options you selected.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.
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To remove comments from your program:

34 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

�4 Select Remove Comments.

54 Select Do It, or press Alt+O, to execute the Remove Comments com-
mand. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.

&�!�+�
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To remove the N codes from your program:

34 Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

�4 Select Remove N Codes or press Alt+R.

54 Select Do It, or press Alt+O, to execute the Remove N Codes command.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.

���8
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Use the Lock command under the Edit Menu to prevent or allow changes to
your NC programs. When an NC program is unlocked, it can be modified by
the commands on the Edit Menu. When an NC program is locked, the program
cannot be changed by any commands. By default, when you open a file it is
automatically locked to prevent accidental changes. You can change this de-
fault setting in the Preferences dialog box (Seup Menu/Editor Tab).

There are three ways to determine if a selected program is locked or unlocked:

34 If a check mark appears next to the Lock command, the current NC pro-
gram is locked.

�4 A locked NC program can be identified by the background color of its
Edit Window. If the background is gray, the file is locked; if it is white,
the file is unlocked.

54 The Lock Indicator on the Status Bar is gray if the program is unlocked,
black if the program is locked.

To toggle an NC program between the locked and unlocked states, select the
Lock command from the Edit Menu, press Ctrl+L, or double-click the Lock
Indicator on the Status Bar.
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Use the Select Font command under the Edit Menu to change the font settings
for open NC programs. The font settings control the font and font size used
in the program Edit Window. The fonts listed are the true type fonts already
installed on your system. Font Settings are intended for viewing and printing
purposes only. They do not affect the NC program in any way and are not
stored within the program file. All open program windows use the same font
settings.

To use the Select Font command:

34 Select the Select Font command from the Edit Menu. The Font dialog
box appears.
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�4 Select a font from the Font list.

54 Select a Font Style.

64 Select a font size from the Size list.

74 Click OK to change the font, or click Cancel or press Esc to exit the
Font dialog box without changing the fonts.
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The View Menu commands control the display of windows and toolbars.
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Position Open or close the Machine Position Window.

Machine Info Open or close the Machine Info Window.

Jog Control Open or close the Jog Control Panel.

Operator Panel Open or close the Operator Panel.

Verify Window Open or close the Verify Window.

Toolbars Open or close one of the toolbars.

$�������
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Use the Position command on the View Menu to open or close the Position
Window.

To open or close the Position window, select Position from the View Menu.
A check mark appears next to the Position command when the Position
Window is open.
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Use the Machine Info command on the View Menu to open or close the
Machine Info window.

To open or close the Machine Info window, select Machine Info from the
View Menu. A check mark appears next to the Machine Info command
when the Machine Info Window is open.
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Use the Jog Control command on the View Menu to open or close the Jog Con-
trol Panel. You can also use the Jog Control button on the Standard Toolbar.

To open or close the Jog Control window, select Jog Control from the View
Menu. A check mark appears next to the Jog Control command when the
Jog Control Panel is open.
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Use the Operator Panel command on the View Menu to open or close the
Operator Panel.

To open or close the Operator Panel, select Operator Panel from the View
Menu. A check mark appears next to the Operator Panel command when the
Operator Panel is open.
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Use the Verify Window command on the View Menu to open or close the
Verify Window.

To open or close the Verify Window, select Verify Window from the View
Menu. A check mark appears next to the Verify Window command when
the Verify Window is open.
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Use the Toolbars command on the View Menu to show or hide the Toolbars.

To show or hide a toolbar:

34 Select Toolbars from the View Menu. The list of available toolbars is
displayed. Toolbars that are visible have a check mark beside them.

�4 Select the toolbar that you wish to show or hide.
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The Program Menu commands allow you to Run, Verify, or Stop an NC
program.
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Run/Continue Start running or resume running the current NC
program.

Verify Verify the current NC program.

Estimate Runtime Estimate the runtime of the current NC program.

Pause Pause the currently running NC program.

Feedhold Stop movement of all axes.

Stop Immediately halt the currently running NC program.
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The Run/Continue command under the Program Menu runs the current
NC program on the machining center. When you select Run/Continue from
the Program Menu, the Run Program dialog box appears.
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The Run Program dialog box allows you to select an NC program to run, to
set the program block from which to begin running the program, and to ac-
cess the Run Settings and Verify Settings dialog boxes.

34 Select an NC Program.

If you have more than one NC program open, use the Program drop-
down list, or press Alt+P, to select the program you wish to run.

�4 Select a Starting Line.

When you are running an NC program for the first time, it is wise to
start the program from the first line. When you start at a line other than
line one, the control program parses through the program to the speci-
fied start point. As it parses, it performs operations such as turning the
spindle on, but it will not execute a Dwell or Pause command, and it
will not move the tool.
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To specify a starting block, click on the Start at Line box, or press
Alt+L, and enter the line number.

54 Set the Run Settings

To bring up the Run Settings dialog box click on the Run Settings button,
or press Alt+U.

64 Set the Verification Settings

To bring up the Verify Settings dialog box click on the Verify Settings
button, or press Alt+E.

74 Run the Program

To start running the program, click on the Run Program button, or
press Alt+R. To cancel running the program, click on the Cancel but-
ton, or press Esc.

While a program is running, the Machine Info Window and the Message Bar
keep you informed by providing information on:

u The name of the NC program.

u Which block is currently being executed.

u How many blocks are in the program.

u Which tool is being used.

u The number of passes made.

u The tool diameter.

u The spindle speed.

u Operator messages such as which block paused the program or the error
that caused the program to stop.
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The Verify command allows you to view tool path verifications of your NC
part programs. When you select Verify from the Program Menu, the Verify
Program dialog box appears.
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This dialog box allows you to select a program to verify from a pull-down list
of currently open NC part programs. Prior to verifying the part program,
you may wish to alter the Run Settings, alter the Verification Settings, or se-
lect a starting line in the program. The default starting line is line one.

Begin the verification by pressing the Verify Program button. If the Verify
Window is not already open, it will open automatically.

Tool path verification is displayed in the Verify Window. The workpiece
and tool are displayed according to the choices you made in the Verify Settings
dialog box.

Here is an example of how the Verify
Window may appear for the part
program Millone.nc.
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Use the Estimate Runtime command to calculate the approximate amount of
time the spectraLIGHT 0200 requires to machine your part, and the approxi-
mate distance the machine travels while machining your part.

The Estimate Runtime command accounts for Dwell times and subprograms
when calculating estimated run time, but it can not account for stops that
have indefinite length of stop time. These program stops include:

u Pause (G05/M00)

u Chain (M20)

u Skip (G31)

u Wait for input high/low (G25/G26)

u Write to file (M22)

u Rerun (M47)

The Estimate Runtime command treats M47 Rewind codes as M2 End of
Program codes.

This command also verifies the syntax of your NC programs while calculat-
ing the estimated run time. If an error is found, the Estimate Run Time
command alerts you with a dialog box, and places the cursor near the error.
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Use the Pause command to pause a running NC program. Pause may also be
used during tool path verification. The pause is not immediate; it takes effect
after the current NC block has been executed.
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Select Pause from the Program Menu, or click the Pause button on the Standard
Toolbar.
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Press F5, click the Run button on the Standard Toolbar, or click the Go button
on the Message Bar.
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The Feedhold command is very similar to the Pause command. It is used to pause a
running NC program. The differences between a Pause and a Feedhold are:

u A Feedhold pause the NC program immediately; it does not wait until
the current block is executed.

u Feedhold does not work during tool path verification.
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Select Feedhold from the Program Menu.
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Press F5, click the Run button on the Standard Toolbar, or click the Go button
on the Message Bar.
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You can use the Stop command under the Setup Menu to halt a running NC
program. The machining center immediately halts cutting and the current
tool position is stored by the computer.
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34 Select Stop from the Program Menu, press Ctrl+Space, or click the Stop
(red) button on the Standard Toolbar.

�4 A message box appears. Clear the box by clicking OK or pressing Enter.
You are automatically returned to the Edit mode.
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34 Manually jog the tool so it is above the workpiece to avoid a tool crash.

�4 Select the Run/Continue command to restart the NC program. You will
not have to reset the initial tool position (assuming the first block of
your program moves the tool to the start position).
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The Tools Menu commands allow you to select tools, and to set up and use a
tool library.
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Setup Library Define tools used with the machining center.

Setup Tool Wizard Aid in establishing tool lengths for use with mul-
tiple tool programs.

Select Tool Select a tool for use on the machining center.
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Use the Setup Library command under the Tools Menu to assign parameters
to multiple types of tools used on the machining center. When you select the
Setup Library command, the Setup Tool Library dialog box appears.
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There are two ways to create a new tool in the Setup Tool Library dialog box.

u Use the Copy and Paste buttons to copy an existing tool in the Tool Library
box and paste it into the Tool Library box under an unassigned tool number.
Assigned tool numbers are displayed with a tool icon. Unassigned tool num-
bers have no tool icon.

u Manually create a tool using the features available in the Setup Tool Library
dialog box.
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34 Select an unassigned tool number from the Tool Library list.

�4 Select a tool type, such as End Mill, from the Tool Type drop-down menu.

54 Enter a name for the tool in the Description field.

64 Enter the number of teeth (Num Teeth) the tool should have.

74 Enter the Material Type from which the tool is made.

;4 Enter a tool Diameter.

<4 Enter a tool Height/Offset value. You may also click on the Current Z
button to establish the current Z axis position of the tool as the
Height/Offset.

=4 Enter a Diameter Offset.

>4 Apply the new parameters to the selected tool number by clicking the
Apply button.

3�4 Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool library.
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34 Select an existing tool from the Tool Library list.

�4 Make the desired changes to the tool parameters, then click on the
Apply button.

54 Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool library.
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Use the Setup Tool Wizard as an aid in establishing tool heights for use with
multiple tool programs. The Wizard can be used if you are manually chang-
ing tools, or if you are using an Automatic Tool Changer.

To use the Setup Tool Wizard:

34 Select Setup Tool Wizard from the Tools Menu. This starts the Wizard.

�4 Follow the Wizard’s instructions very carefully!
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Use the Select Tool command under the Tools Menu to select a tool for use
on the machining center.

To select a tool:

34 Select the Select Tool command from the Tools Menu. The Select Tool
for Use dialog box appears.

�4 Select a tool from the drop-down Tool list. The tool parameters appear
in the window to the right of the list.

54 Select an action to exit the dialog box:

u Click Select Tool button if the tool is already in the mounted spindle.

u Click Insert Tool to perform a tool change cycle. The machining
center moves to its tool change position (maximum Z axis height)
and you are prompted to insert a tool into the spindle. After you in-
sert the tool and press F5, the machining center returns to its
original position.

u Click Cancel to exit the Select Tool for Use dialog box without
selecting a tool.
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The Setup Menu commands control the parameters for tool positioning, jog-
ging, running and verifying programs, coordinate systems, tool offsets, etc.

��!!���� ����
���

Set Position Establish the X, Y and Z position of the tool.

Zero Position Set the current tool position to X0, Y0, Z0.

Jog Settings Establish speed and distance parameters for jogging
the tool.

Run Settings Establish options for running an NC part program.

Verify Settings Establish options for verifying an NC part program.

Verify Type Select centerline or solid view for tool path
verification.

Set/Check Home Establish or check a fixed known position on the
machine.

Goto Position Automatically move the tool to a specific set of
coordinates on the machining center.

Units Select Inch or Metric units of measure.

Coordinate Systems Define multiple coordinate systems for the
machining center.

Offsets Modify the table of Offset values used for certain
NC codes.

Spindle Specify a spindle speed if you have not used an S
code in your NC program.

Backlash Define the amount of play in the machining center
turning screws.

Soft Limits Establish software limits for each axis that are
different than the actual fixed hardware limits on
the machining center.

Preferences Establish defaults for saving files and security features.
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Use the Set Position command under the Setup Menu to set new X, Y and Z
positions for the tool. This command establishes a World Coordinate System
in relationship to the Machine Coordinate System. Setting the X, Y and Z
coordinates for the tool also defines the zero point of the coordinate system
for absolute motion.

This command is also available under the Position Window Pop-up Menu.

To set a new position:

34 Move the tool to the desired
position.

�4 Select Set Position from the
Setup Menu. The Set Position
dialog box appears.

54 Enter a new X position.

64 Enter a new Y position.

74 Enter a new Z position.

;4 Press Enter or click on OK.

The new position is displayed in the Position Window.
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Use the Zero Position command under the Setup Menu to reset the point of
origin (0,0,0) at any position on the machining center. Since the tool length
and the workpiece position on the cross slide may vary from one tooling setup
to another, the zero position must be initialized each time the  setup is changed.

This command is also available under the Position Window Pop-up Menu.

To set the zero point:

34 Move the tool to the point on the workpiece you intend to establish as
the zero point.

�4 Select Zero Position from the Setup Menu. The new position (0,0,0) is
displayed in the Position Window.
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Use the Jog Settings command to open the Jog Settings dialog box. This dialog
box is used to enter speed and distance values for the Jog Control Panel.The
Jog Settings command is also available through the Jog Control Panel Pop-up
Menu.

To set jog parameters:

34 Select Jog Settings from the Setup Menu. The Jog Settings dialog box
appears.

�4 Enter the desired jog speeds and distances.

54 Select OK or press Enter. The new values are applied to the Jog Control
Panel.

,��
�����

The jog speed is the rate at which the tool moves along the X, Y, or Z axes.
Select the speed by entering the desired speed in the Jog Settings dialog box,
then press the appropriate button (Slow, Medium or Fast) on the Jog Con-
trol Panel.

The default values for speed are:

u 1 ipm for Slow
u 15 ipm for Medium
u 25 ipm for Fast

These feed rates can be set as high as 30 inches per minute.
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Distance values determine how far the tool moves each time a key is pressed.
Referred to as Steps, the distance is selected by pressing the A, B or C buttons
on the Jog Control Panel. Using the Jog Settings dialog box, the distance can
be set at a low value (for instance 0.0005 inch) to move the tool for a precise
cut, or at a high value (e.g. 5 inches) to position a tool.
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Pressing the Continuous (Cont.) button moves the tool continuously as long
as the axis button is depressed. Once the axis button is released, the tool
stops.

These are the default values for steps:

u 0.001 inch for Step A
u 0.01 inch for Step B
u 0.1 inch for Step C

&��
��������
��!!���

Use the Run Settings dialog box to set or clear options for running your NC
program. The available options are:

u Single Step

u Optional Skip

u Optional Stop

u Enable Subprograms

u Arc Centers Incremental

u Treat Warnings as Errors

u Restore Unit Mode When Done

u Verify While Running
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This option inserts a Pause after each block of the NC program. To move on
to the next block in the program, you can:

u Click the Run button on the Standard Toolbar.

u Click the GO button on the Message Bar.

u Press F5.

u Press Enter.

u Select Run/Continue from the Program Menu.

-�������
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Use this option to enable or disable the optional skip code. The optional skip
code allows you to skip blocks of code as the NC program is run.

Make sure to check off the Optional Skip box in the Run Settings dialog box
or activate the Optional Skip button on the Operator Panel. Then place a
forward slash ( / ) in front of each line in the NC program you want to skip.
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With Optional Skip off, each skip code is ignored and each block of code is
executed. With Optional Skip on, each skip code is recognized and each
block of code that has been tagged with a skip code is skipped.

To execute particular blocks every nth pass, place a number after the optional
skip. For example:  /5G28; Home every fifth pass

-�������
����

Use this option to enable or disable the optional stop code (M01). The op-
tional stop code allows you to place an optional stop in your NC program.

Make sure to check off the Optional Stop box in the Run Settings dialog box
or activate the Optional Stop button on the Operator Panel. Place an M01
on the line of code where you would like to pause.

With the Optional Stop option on, the M01 works like a G05. With Optional
Stop off, the M01 code is ignored, the other codes on the block are executed
as usual.

(��.��
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Use this option to enable or disable the use of subprograms. With this option
disabled, M98 commands generate an error. Running or verifying a program
with subprograms enabled takes longer to start because the software parses
the entire file for subprogram information. This extra delay should only be
noticeable with large programs.

���
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Use this checkbox to specify the default mode for programming arc centers.
If this box is checked, the default mode is the Fanuc mode, in which arc centers
are always incremental. If this box isn’t checked, the default mode is EIA-
274, in which arc centers follow the general programming mode: absolute
when the mode is absolute, and incremental when the mode is incremental.
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This command is used for special applications, such as laser welding, where
you don’t want any unexpected pauses in the program execution. For example,
when a warning is displayed and the program pauses, waiting for your input
before it continues.

When this item is checked, any warning will halt the program, performing a
program Stop. When motion is stopped, all outputs are turned off.

&������
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If you normally work in one unit mode (inch or metric) but would like to
run a program in another mode without disrupting your default settings,
check this box.
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Select a specific unit mode by using one of the G20/G21 or G70/G71
commands at the beginning of your NC program. Once the NC program is
executed, your default unit mode will be restored.

For instance, if you normally work in Inch Mode, but have a particular pro-
gram you would like to run in Metric Mode, check the Restore Unit Mode
When Done box. Place a G21 code at the beginning of your program, then
run it. When the program is finished, the default for your system will still be
Inch Mode.

E���' 
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If this box is checked, the Verify window will display the program verification
while the program is running. The verification does not show exactly what is
happening on the machining center. There is a delay between each tool motion.
You will see each tool motion on the screen, but the screen will pause until
the machine finishes the motion and the next program block is read.

E���' 
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Use the Verify Setup dialog box to control the appearance of the tool path
verification. You  can also access this dialog box using the Verify Window
Pop-up Menu.

The Verify Settings dialog box is tabbed, with the settings organized into
three groups: the View Panel, Stock Panel and Options Panel.
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The View panel allows you to control the view style and zoom factor. It also
offers a selection of preset views.

Style

Use these radio buttons to select between Solid and Centerline views of the stock.
Solid View is a solid three-dimensional view of the workpiece and tool. Cen-
terline View is a view that depicts the centerline of the tool, instead of a solid
model of the tool. The workpiece is shown in wireframe.

Zoom

Use these buttons to control the size of the stock in the Verify Window. You
can click on the buttons or use Alt key combinations (Alt++, Alt+-, and Alt+A).
Each mouse click or key combination used zooms by an increment of one.

������ )�������

+ Zoom in on the stock.
- Zoom away from the stock.

All Fit the stock into the window.

Preset View

Use these buttons to select a perspective, then use the Preview Window to
fine-tune the angle:

������ )�������

Front View the stock directly from the front. The stock
appears as a rectangle along the X, Z axes.

Top View the stock directly from above. The stock ap-
pears as a rectangle along the X, Y axes.

Isometric View the stock at an angle, in three dimensions.
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The Stock Panel allows you to specify particular information about the stock
and tool position for tool path verification.

All stock values are interpreted according to the Units Mode in effect at the
time they are set. To quickly see which Units Mode is currently in effect, check
the Position window.

Stock Dimensions

Use this area to set the dimensions of the stock used in the verification
process. You will see the stock in the Preview Window change as soon as you
enter a dimension.

Origin

Use this area to adjust the verification for different workpiece setups. Most
NC programs set the 0,0,0 point at the top of the front-left corner of the
stock. Occasionally, however, you may want to use a different origin (the
center of the stock, for example). In this case, you must enter a different ori-
gin to properly verify your program. The values entered should correspond
to the coordinates of the left corner of the stock relative to the 0,0,0 point for
the program.

For instance, if the origin for the program is the center of a 3x2x1 piece of
stock, set the origin to -1.5, -1.0.
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Initial Tool Position

You can select a tool start point using Initial Tool Position. Only use Initial
Tool Position for verification, not for actually running a program. The posi-
tion is used when you verify a program; when verifying while running, the
actual position of the tool is used as the initial tool position.

-������
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The Verify Options Panel controls certain aspects of the solid and center-
line verification display.

Solid Options

Auto-refresh automatically refreshes the solid display of the workpiece if
something changes during verification, such as resizing the verify window,
changing the view, or changing the stock dimensions. When Auto-refresh is
disabled, you will need to manually cause the verify window to update by
selecting the Redraw command from the window’s context menu. This set-
ting only affects refreshing the window when no verification is in progress.

Centerline Options

Auto-refresh automatically refreshes the centerline display of the workpiece
if something changes during verification.

Show Tool controls whether or not the tool is displayed in the Verify Window.

Show Rapid Moves displays the rapid moves made between the end point of one
cut to the start point of another.
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The Preview Window appears in each of the above groups. The Preview
Window shows you approximately what the Verify Window will look like.
The Preview Window always depicts the stock in Centerline view.

In addition to depicting how the Verify Window will look, you can use the
preview box to change the orientation of the stock:

u Use the slider bars on the side of the Preview Window to rotate the stock
along the X, Y plane and along the Z plane. There are two ways to con-
trol the sliders:

34 Select the slider button by clicking on it with the mouse. Hold the
left mouse button down while sliding the button along the bar until
the stock is in the desired position.

�4 Select the slider button by tabbing to it. The button will blink to in-
dicate it is selected. Use the arrow keys on the keyboard to move the
slider button along the bar until the stock is in the desired position.

u Use the mouse to rotate the stock in all planes simultaneously. “Grab”
the stock by clicking and holding it with the mouse. Move the stock
with the mouse until the stock is in the desired position.

�������

The OK button at the bottom of the dialog box applies the changes you have
made and closes the dialog box.

The Cancel button closes the dialog box without applying any of the changes
you have made.

The Help button brings up the Help topic.

E���' 
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The Verify Type command allows you to choose between a solid view and a
centerline view in the Verify Window.
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The Set/Check Home command performs two functions, it sets a reference
position on the machine and it helps you to check the reference position on
the machine. When you select the Set/Check Home command the following
dialog box appears.

*����

"(�*�&���&�!���-��
	��
����
��
��;����
�
	�
)���!�(��!���
���
��
-����
	��
�
&����
'&

������
��!�

*����

 	����
	��)�(����
��/���
� �G��!�����

�;��

	����
	����(��!���
���������
�!�
��,�3����
.�&�
�����
���
���
	���(��!���
��

	!��������

"(�*�&�����&�����#,�����#,7�
�!������*�&�
������������*�&��&�
�&���
	��)�(����
�
/���
� �G��!�
��	����
	����
	����(���
�

The Set Home button opens the Reference Point Wizard, which aids you in
setting a machine reference point. Just follow the directions.

The Move Home button moves the machine to the reference point coordi-
nates so you can manually measure the machine position to make sure no
position has been lost.
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The Goto Position command opens the Goto Position dialog box. Use the
Goto Position dialog box to move the tool to a particular coordinate posi-
tion on the machining center.

This command is also available under
the Position Window Pop-Up Menu
and Jog Control Panel Pop-up
Menu. To use the Goto Position
command:

34 Enter the coordinates for the new
tool position.

�4 Enter the feed rate at which you
would like the tool to travel.

54 Click on the Go button. The
tool moves to the new position at
the defined feed rate.
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Use the Units command under the Setup Menu to select the unit of measure
for the application. When you select the Units command, a fly-out menu ap-
pears allowing you the option of using Inch (standard) or Metric measurement.
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Use the Coordinate Systems command under the Setup Menu to define multiple
coordinate systems for machining more than one workpiece. This is often
done for production runs of the same part.  This command is also available
under the Position Window Pop-up Menu.
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34 Select Coordinate Systems from the Setup Menu. The coordinates fly-
out menu appears.

�4 Select an existing coordinate system from the fly-out menu. Select one of
the available coordinate systems available, CS1 through CS6, (these are
equivalent to using the codes G54 through G59 in your NC program).

OR

Select the Work Coordinates command to cancel the Coordinate System
offsets and return to Work Coordinates.
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34 Select Coordinate Systems from the Setup Menu.

�4 Select Setup from the fly-out menu. The Setup Coordinate Systems dia-
log box appears.

54 Select a coordinate system, then enter and apply the offsets.

a) Select a CS from the System list.

The system titled “Work CS” contains the current values for the work
coordinate system. This is like adding a G92 code to your NC pro-
gram. You can change the default for the work coordinate system by
entering new values in the Offsets boxes. These values are an offset from
the true origin of a coordinate system and affect all coordinate systems.

b) Select the offsets for a user coordinate system by:

u Entering X, Y and Z offset values in the Offsets boxes.

u Clicking the Current Pos button to establish offset values based
on the current tool position.

u Selecting a Marker in the Preview Area for the coordinate sys-
tem and dragging it to the desired position.

u Copying offsets from one CS to another using the Copy Offsets
and Paste Offsets buttons.

c) Make the currently selected CS the active CS by selecting the Make
Active button.

d) Apply the coordinates or exit the dialog box:

u The OK button applies the changes you have made and closes
the dialog box.
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u The Cancel button closes the dialog box without applying any
of the changes you have made.

u The Apply button applies the changes you have made to the se-
lected CS (you can still cancel changes once they have been applied
by selecting the Cancel button).
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Use the Offsets command under the Setup Menu to compensate for varia-
tions in the cutting tools being used. The offset values are used for tool
length offset, cutter compensation, and tool offset adjustment NC codes. For
information on setting tool length offsets for multiple tool programming, see
Section H, Advanced CNC Programming.
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34 Select Offsets from the Setup Menu. The Setup Offsets dialog box appears.

�4 Click on an Offset Number (the numbers 1 through 199 are available).
This number only acts as a designation (a name) for the offset.

3. Enter an Offset Value in the Value box, or select the Current Z button
to use the current Z position (also useful for defining tool heights if you
are using G43 or G44 to specify tool heights).

64 Press Enter or click on OK. The Offset Value has been associated with
the Offset Number. The next time you open the Offsets table, you will
see the new offset.
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The Offset Table stores up to 200 values which are used in several operations
including tool offset adjustment, cutter compensation, and tool length com-
pensation to ensure uniform application of an offset value. The numbers are
stored as unit-less values; their interpretation depends on the Units default
currently in effect.

Set the values in the Offset Table using the Offsets command under the Setup
Menu. The Offsets are stored in the WSLM.INI file when running with a ma-
chine, and in TESTCTL.INI when running in simulation mode.
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Use the Spindle command under the Setup Menu to specify a spindle speed
if you have not used an S code in your NC program.

The spindle speed is primarily determined by the Mode Switch on the machining
center front panel. If the Mode Switch is set to Manual Mode, spindle speed
is controlled by the Spindle Speed Control Knob, also on the front panel. If
the Mode is set to CNC, spindle speed is determined by an S code in the NC
program. If there is no S code in the NC program, spindle speed is deter-
mined by the Setup Spindle dialog box.
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34 Select the Spindle command from the Setup Menu. The Spindle Setup
dialog box appears.

�4 Select a spindle speed by entering a value in the RPM box, or by using
the slider and arrow buttons.
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u Reset the spindle override value to 100% by clicking on the Reset Override
to 100% button.

u Change the On/Off state of the spindle using the On and Off buttons in
the Spindle State area.

u Disable spindle operation by selecting the Disable option. This is useful
if you have a device mounted in the spindle that cannot withstand being
rotated, such as a wired probe.

u Select Done to close the dialog box.
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Use the Backlash command under the Setup Menu to define the amount of
play in the machining center turning screws. The system default is set at a
backlash value of 0.0 on all three axes, with a feed rate of 10 ipm

To establish new backlash parameters:

34 Select Backlash from the Setup Menu. The Setup Backlash dialog box
appears.

�4 Enter the desired backlash distances and feed rate.

54 Press Enter or click on OK to accept the new backlash parameters, or
click on Cancel to exit the Setup Backlash dialog box without setting
new backlash parameters.
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Use the Soft Limits command under the Setup Menu to establish software
limits for each axis. The limits are different than the actual fixed hardware
limits on the machining center. Soft limits can confine the tool travel to an
area smaller than the normal maximum travel.

The machining center shuts down if it trips a soft limit, just as it does when
it trips one of the limit switches. This is helpful when working with devices
such as robots, or when you have installed fixtures within the normal work
area that you don’t want the tool to hit.

To establish software limits on the machining center:

34 Select Soft Limits from the
Setup Menu.The Setup Soft
Limits dialog box appears.

�4 Enter the coordinates that
define the software perim-
eter you wish to establish.

54 Click on the Enable Soft
Limits option to enable soft
limits. Use this option to turn
soft limits on or off as you
need to use them.

64 Press Enter or click on OK to accept the new soft limit parameters, or
click on Cancel to exit the Setup Soft Limits dialog box without setting
new soft limit parameters.
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�4 Select either the Editor preferences tab or the Security preferences tab.
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The Editor preferences allow you to automatically save your NC program
files at regular intervals, and establish a default directory in which to store
your files. When you select the Editor tab in the Preferences dialog box, the
Editor panel appears (depicted above).

To select AutoSave features:

u Select Save when idle and enter a value in the Every:___ minutes box to
save your NC programs automatically at the specified time increment.

u Select Save Before Running to save changes to your NC program prior
to running it for the first time with the changes.

u Select Prompt Before AutoSaving if you wish to be prompted by the
Control Program before it automatically saves the NC program at the
specified time increment.

$��'�������
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Use the Preferences command under the Setup Menu to establish defaults for
saving files and setting security features.
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34 Select the Preferences command from the Setup Menu. The Preferences
dialog box appears.
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To select File Default features:

u Enter an Extension for your NC part program files. The default is “NC.”

u Select Lock Files When Opened to have your NC programs locked by de-
fault. Deselect this feature to have your NC programs unlocked by default.

u Select the Set button to specify a target directory in which to save your
NC program files. The default directory appears in the Directory box.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on
Cancel to exit the Preferences dialog box without setting new Editor or
Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.
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The Security preferences allow you to control which features others may use.
When you select the Security tab in the Preferences dialog box, the Security
panel appears.

The Security preferences panel offers two modes, User and Administrator.
Administrator Mode allows a supervisor, such as a teacher in a classroom, to
turn commands on or off using the Allowed Commands list. User Mode
does not have access to this feature.
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To secure the software using Administrator Mode:

34 Set the Default Mode to User. (This will not change the current mode.)

�4 Use the Change Password button to create a password. The default pass-
word is blank — no password.

54 Select the Allowed Commands. Double-click on the listed commands to
enable or disable them. If the commands are enabled, they are marked
with an X. A description of each selected command is displayed on the
right side of the panel.

64 Use the Change Mode button to change to User Mode.

74 Select OK or press Enter to exit the Preferences dialog box.

The software is now running in User Mode. The next time you open the
Preferences dialog box, the Security preference panel is displayed in User
Mode. In this mode it is not possible to turn commands on or off.

To return to Administrator Mode:

34 Use the Change Mode button to toggle the Mode from User to Admin-
istrator. A dialog box appears, prompting you to enter your password.

�4 Enter your password and press Enter or click on OK.

To change your password:

34 Click on the Change Password button.

�4 Enter your current password.

54 Enter the new password.

64 Enter your new password again to verify that it is correct.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on
Cancel to exit the Preferences dialog box without setting new Editor or
Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.
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The Window Menu commands allow you to manipulate the arrangement of
the Program Edit Windows.
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Cascade Layer the open edit windows.

Tile Tile the open edit windows.

Arrange Icons Arrange any minimized edit windows along the bot-
tom of the edit area.

Window List Display and select between the currently open NC
programs by their file names.
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Similar to the standard Windows/Cascade command, this command places
the open Program Edit Windows in a layered format, cascading down to the
right with the currently selected window on top.
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Similar to the standard Windows/Tile command. Places the open Program
Edit Windows in a tiled format, filling the Edit Area from top to bottom.
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When you minimize a Program Edit Window, it becomes a small icon. The
Arrange command under the Window Menu arranges these icons along the
bottom of the edit area.

0����"
����
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Lists the currently open Program Edit Windows. The currently selected win-
dow is designated with a check mark. You may select any window by clicking
on the window itself, or by selecting the window name from this list.
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The Help Menu commands allow you to navigate through the Help files, to
save or restore parameters set throughout the current session, and provides
handy tips and other information about the Control Program.

��!!���� ����
���

Help Display Help for the current task or command.

Index List Help topics.

Using Help Display instructions about how to use Help.

Save Settings Saves the current machine and application settings.

Restore Settings Resets the machine and application settings from
defaults.

Tip of the Day Display a Tip of the Day.

About WSLM Display program information, version number and
copyright.

����
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Use the Help command to access the Help contents. You can also press the
F1 key to get information about the currently highlighted command on a
drop-down or pop-up menu.

	���/
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Use the Help Index command access an index of available Help topics.

�����
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Use the Using Help command to obtain information on how to use the
Help utility.
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The Save Settings command brings up a dialog box that allows you to retain
current library, security, screen and control settings as defaults.

u Click on a particular setting(s) to tag it, then click on the Save button to
save the selected items and exit the dialog box.

u Click on the Save All button to save all settings without having to select
each one.

u Click on the Cancel button to exit the Save Defaults dialog box without
changing the existing defaults.

&������
��������
��!!���

The Restore Settings command allows you to restore all or some of the cur-
rent settings to the defaults you set using the Save Settings command (User
Defaults) or to the factory set defaults.
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u Click on a particular setting(s) to tag it, then click on a Restore From
option. Click the Restore button to restore the selected items and exit
the dialog box.

u Click on the Restore All button to restore all settings without having to
select each one.

u Click on the Cancel button to exit the Restore Defaults dialog box with-
out changing the existing defaults.
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This command brings up information about the operation of the machining cen-
ter, tips and tricks for using the Control Program and NC programming ideas.

�.���
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This command simply brings up an information box. Included is informa-
tion on the Control Program version number, the release date, and copyright
information.
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There are a few different ways to select commands in the Control Program.
Use the method that is most convenient for you.
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Clicking the right mouse button on certain windows or panels brings up a
pop-up menu. Each pop-up menu is context-sensitive. Commands which
cannot be performed at that time are grayed out.

To select a pop-up menu command:

34 Position the cursor on the window or panel.

�4 Click and hold down the right mouse button. The context-sensitive
menu appears.

54 Highlight a command by moving the mouse pointer over it, then release
the right mouse button.

The following windows have pop-up menus:

u Program Edit Window

u Position Window

u Verify Window

u Jog Control Panel

The Machine Info Window and Operator Panel only provide the Dockable
and Hide commands on their Pop-up menus.

$�����!
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The Program Edit Window Pop-Up Menu con-
tains different combinations of these commands,
depending on whether the file is running or being
verified, and whether or not text is selected.

���
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Cut is the same as selecting the Cut command from
the Edit Menu.

��� 
��!!���

Copy is the same as selecting the Copy command from the Edit Menu.

$����
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Paste is the same as selecting the Paste command from the Edit Menu.
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Clear is the same as selecting the Clear command from the Edit Menu.
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Goto Line is the same as selecting the Goto Line command from the Edit Menu.

&���!.��
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The Renumber command is the same as selecting Renumber from the Edit Menu.
A dialog box appears that allows you to alter the N codes in the NC program.

��+�
��!!���

Save brings up the Save As dialog box.

I���8&��
��!!���

The QuickRun command is a shortcut that runs the currently selected NC
part program. When you click the right mouse button on this command, the
program behaves as though you had selected the Run/Continue Command
from the Program Menu with the following exceptions:

u You do not have the option of selecting a starting line.

u You do not have the option of changing any settings.

I���8E���' 
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The QuickVerify command is a shortcut that verifies the currently selected
NC part program. When you click the right mouse button on this command,
the program behaves as though you had selected the Verify Command from
the Program Menu with the following exceptions:

u You do not have the option of selecting a starting line.

u You do not have the option of changing any settings.

(���!���
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This command performs the same function as the Estimate Runtime com-
mand under the Program Menu.
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The Position Window Pop-Up Menu contains
these commands:

	���
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Automatically switches the units of measure for
the current program to inch units.

������
��!!���

Automatically switches the units of measure for
the current program to metric units.
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Produces a fly-out menu that allows you to set up and select coordinate sys-
tems just as you would using the Coordinate  Systems command from the
Setup Menu.
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Opens the Set Position dialog box.

A���
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Sets the current tool position to zero on all three axes.
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Opens the Goto Position dialog box.

%��8�.��
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The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

����
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The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Verify Window Pop-Up Menu contains
these commands:
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Switches the verification to a solid view.
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Switches the verification to a centerline view.
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This command repeats the most recent tool path verification simulation.
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This command interrupts the verification currently in progress.
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This command resets the Verify Window; it clears the tool path lines and re-
sets the tool to the starting position.

%��8�.��
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The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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The Jog Control Panel Pop-Up Menu contains
these commands:
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This command opens the Jog Settings dialog box.
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This command opens the Goto Position dialog box.
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This command opens Machine Home/Reference Point dialog box.
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The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

����
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The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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Some menu commands have one or more key designations next to them; those
are the hot keys for that command. Pressing the hot key(s) selects the corre-
sponding command. For example, press Ctrl+S to save your file. Other hot
keys are also available for controlling machining functions; for instance, use
the Ctrl+KeyPad+ combination to increase feed rate override.

Here’s a list of the available hot keys:

#� C�D� ����G��!!����

Ctrl+C Edit Menu/Copy
Ctrl+F Edit Menu/Find
Ctrl+G Edit Menu/Goto Line
Ctrl+H Setup Menu/Set/Check Home
Ctrl+L Edit Menu/Lock
Ctrl+N File Menu/New
Ctrl+O File Menu/Open
Ctrl+P File Menu/Print
Ctrl+R Setup Menu/Run Settings
Ctrl+S File Menu/Save
Ctrl+Space Program Menu/Stop
Ctrl+T Tools Menu/Setup Library
Ctrl+V Edit Menu/Paste
Ctrl+X Edit Menu/Cut
Ctrl+Y Edit Menu/Delete Line
Ctrl+Z Edit Menu/Undo
Ctrl+Shift+Z Setup Menu/Zero Position
F1 Help Menu/Help
F5 Program Menu/Run/Continue
F6 Program Menu/Verify
F8 Setup Menu/Goto Position
Ctrl+KeyPad+ Increase Feed Rate Override
Ctrl+KeyPad- Decrease Feed Rate Override
Ctrl+Backspace Edit Menu/Undo
Shift+Delete Edit Menu/Cut
Shift+F1 Help Menu/Context Help
F4 Activate Jog Control
Ctrl+F5 QuickRun
Ctrl+F6 QuickVerify
Ctrl+TAB Next Edit Window
Ctrl+Insert Edit Menu/Copy
Shift+Insert Edit Menu/Paste
Pause Edit Menu/Pause
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The Tool Bars contain buttons that correspond to frequently used menu
commands. Clicking a button on a toolbar is equivalent to selecting the same
command from a menu, and is usually quicker. The Control Program pro-
vides Standard, Input, and Output toolbars. Use the commands under the
View Menu to control whether each tool bar is displayed or hidden.
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The Control Program interface is easily configured and optimized by open-
ing, closing, resizing, and repositioning the screen components.

$����������
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You can reposition any of the toolbars (Standard, Inputs, or Outputs) simply
by dragging them off their docking areas. Once away from the docking area,
the toolbar becomes a floating window, which can be treated the same as any
other window (E.G. move it, resize it, close it). To move the toolbar, click
on the toolbar background (the area behind the buttons) and drag.

$����������
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The windows and panels, (Position Window, Machine Info, Jog Control
Panel, Operator Panel, Verify Window) are initially docked on the docking
area on the right side of the screen. If these items are moved away from the
docking area, they become floating windows or panels until they are moved
back to the docking area. (See Docking and Floating Windows and Toolbars
on the following page.) The Verify Window is initially not dockable.
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34 Press the Ctrl key.

�4 Click on the window/panel with the left mouse button.

54 Hold and drag the window/panel off the docking area.

64 Release the Ctrl key.

74 When the floating window is over its new location, release the mouse
button. You can now treat the area the same as you would any other
window (e.g., move it, resize it, close it).
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(The Dockable command must be invoked for a window/panel before it can
be docked. See Docking and Floating Windows and Toolbars.)

34 Click on the title bar of the floating window.

�4 Drag the area back to the docking area.

54 Release the mouse button.
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Program Edit Windows can be moved, resized or closed just like any other
window. The only restriction is that the Edit Windows can not be moved
out of the edit area. For instance, you can not move an Edit Window to a
docking area.
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After changing a component’s position on the screen, you can save it’s position
by checking the Window Positions box on the Save Settings dialog box (se-
lect Save Settings from the Help Menu). The next time you use the Control
Program, the component appears in the new position. To restore the default
position (the factory preset position), use the Restore Settings command un-
der the Help Menu.
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Windows and Toolbars can behave in two ways; they can be placed in a sta-
tionary state, docked, or they can be in a free-floating state, and moveable.
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A docked screen component is fixed in place, unlike a floating component
which can be placed anywhere on the screen. When a screen component is
docked, the window frame and title disappear.
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A floating screen component can be moved to any position on the screen,
unlike a docked screen component, which is fixed in place. When a screen
component is floating it has a window frame and title.
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u Click on the background area of the toolbar and drag it away from the
docking area to float it.

u Click on the backgound or the title bar of the toolbar and drag it to the
docking area to dock it.
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34 Position the mouse pointer over the window you would like to dock/float.

�4 Click the right mouse button.

54 Select Dockable from the drop-down menu.

When the Dockable command is checked, the window can be dragged to a
docking area and docked. Dockable windows can not be resized.

When the Dockable command is not checked, the window will float and can
not be docked. Some floating windows can be resized.
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The Setup Program allows you to set program and hardware defaults. In order to
access the Setup Program, you must first exit the Control program. Locate
the SLM0200 folder on your hard drive, (the default installation location is
C:\ProgramFiles\Programs\LMC\WSLM) and double click the Setup Icon.
The program will start and you will see the Welcome screen. You may
choose from the file tabs to view the settings for each category.

The Setup Program provides settings under the following categories:

u Welcome

u Interface Card

u General

u Control

u Advanced

u More Advanced
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This panel provides one option, Units Default. This option sets the default unit
of measure for the Control Program and the Setup Program. When running
the Control Software, you can change the default using the Units command
under the Setup Menu.

	����'���
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This panel allows you to change the Interface Card Address. Once you have
installed the Interface Card and software, and performed the initial Setup,
this address should not change. The only time you might consider changing
the address is if there is a hardware conflict.
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This panel allows to you alter several software defaults.

u Run Offline starts the Control Program in Simulate Mode without
checking for a machine connection.

u Decimal Places for Inch Values controls the display of values in dialog
boxes. When in Metric mode, the software displays 1 less than the speci-
fied number of decimal places.

u Tool Shaft Height controls the tool shaft length in the Preview Window
(in the Verify Settings dialog box) and the Verify Window. The control
software uses this value to insure that the tool with the smallest length
offset is verified with a length at least as large as this value.

u NC Programming Settings controls several programming options:

u The Maximum Number of Subprograms.

u The Maximum Depth of Subprograms; the number of nested sub-
programs.

u The Maximum Arc Radii Deviation; the allowable difference between
the two radii, r1 and r2, of an arc before being considered an error.

u The Default L-Factor; the angle at which a line segment approxi-
mates a portion of an arc.

u The Default Run Feed Rate; the initial feed rate when running or
verifying an NC program; used until a  feed rate is specified in the
NC program.
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The New Controller Box option lets the controller know which version of
Controller electronics you are using. The How Do I Tell button explains the
difference between the controllers.

The Spindle Settings option allows you to set delays between the time the
spindle turns on and the next command is executed, and from the time the
spindle is turned off and the next time it is turned on. These values should
not be changed.

��+�����
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These features are Not for Novice Users! They are provided for trouble-
shooting purposes only.

The Spindle Settings allow you to change the maximum spindle speed, the
conversion slope and the conversion offset. If the programmed spindle speed
(or the spindle speed entered in the Setup Spindle dialog box) are not close
enough to the actual feed rate you require, you may fine tune the spindle
speed using these values.

The Feed Rate Settings allow you to change the maximum rapid traverse
feed rate, the minimum machining feed rate and the maximum machining
feed rate. This is not the same as the default feed rate on the General panel.
The default feed rate is the feed rate that is automatically used if no feed rate
is specified in the NC program. The minimum and maximum machining
feed rates define the feed rate range for the machine.

The Resonance Settings allow you to set the low end and high end of the
resonance range; the range in which stepper motors can resonate and lose
position. The software prevents loss of position by slowing down the pro-
grammed feed rate of the machine until the component feed rates for all axes
are outside of this range. If you are using a New Controller Box (as selected
on the Control panel), the High End value is used to help eliminate reso-
nance electrically rather than by modifying feed rates.
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These features are meant for Advanced Users Only! They are provided for
troubleshooting purposes.

The Tool Change Settings allow you to alter the distance that the spindle re-
tracts in order to perform a tool change. It also allows you to alter the feed rate
at which the tool is moved when retracted for a tool change.

The Other Settings Axis SPU option is used to alter the ratio of steps per
unit on the machine; the number of stepper motor steps required to move
the cross slide one inch.
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The Offset Table stores 200 values which are used in several operations including
tool offset adjustment, cutter compensation, and tool length compensation
to ensure uniform application of an offset value. The numbers are stored as
unit-less values; their interpretation depends on the Unit mode currently in
effect. Offset zero is always 0.0 and cannot be modified. Using Offset zero
for most compensations cancels that compensation.

Set the values in the Offset Table using the Offset command under the Setup
Menu. The Offsets are stored separately for the machine, and for Simulation
Mode.
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Simulation Mode is provided to allow the Control Program to be used when
your computer is not connected to a SLM0200 Machining Center. This is
primarily to support the off-line development of NC programs.

NC program verification and running is supported in Simulation Mode.
Programs will Run in the same amount of time that they would if a machine
were attached (excluding stops that have indefinite length of stop time, see
Estimate Runtime).

The principal difference between Simulation Mode and Normal Mode is,
since no machine is available to send and receive data, there are no Inputs
and Outputs. The Inputs and Outputs buttons on the toolbars are inoperable. If
your program contains commands to wait for certain input values that are
not the default, the events will never occur. If the values are the default, the
wait will occur immediately.
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Part programs generally incorporate two types of instructions: those which
define the tool path (such as X, Y and Z axis coordinates), and those which
specify machine operations (such as turning the spindle on or off). Each in-
struction is coded in a form the computer can understand.

An NC program is composed of blocks (lines) of code. The maximum number of
blocks per program is limited by the memory (RAM) on your computer. You
can, if necessary, chain programs together to form very large part programs.

Each block contains a string of words. An NC word is a code made up of an
alphabetic character (called an address character) and a number (called a pa-
rameter or value). There are many categories of address characters used in NC
part programs for the spectraLIGHT Machining Center (see Categories of
NC Code).

Each block of NC code specifies the movement of the cutting tool on the
machining center and a variety of conditions that support it. For example, a
block of NC code might read:

N1G90G01X.5Y1.5Z0F1

If the machine is currently set for inch units, the individual words in this
block translate as:

N1 This is the block sequence number for the program. Block 1 is the
first block in the program.

G90 This indicates absolute coordinates are used to define tool
position.

G01 This specifies linear interpolation.

X.5 This specifies the X axis destination position as 0.5".

Y1.5 This specifies the Y axis destination position as 1.5".

Z0 This specifies the Z axis destination position as 0". The cutting tool
will move to the absolute coordinate position (0.5,1.5,0).

F1 This specifies a feed rate of 1 inch per minute, the speed at which the
tool will advance to the specified coordinate points.
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Many categories of NC codes can be used to program the spectraLIGHT
Machining Center. Here is a list of the NC codes (designated by the address
character) supported by the spectraLIGHT Machining Center.

����� )��������

% Incremental Arc Centers (Fanuc).
$ Absolute Arc Centers (EIA-274D).
\ Skip.
/ Optional skip.
D Compensation offset value.
F Feed rate in inches per minute; with G04, the number of

seconds to dwell.
G Preparatory codes.
H Input selection number; Tool length offset.
I Arc center, X axis dimension (circular interpolation).
J Arc center, Y axis dimension (circular interpolation).
K Arc center, Z axis dimension (circular interpolation).
L Loop counter; Program cycle (repeat) counter for blocks and sub-

programs, arc interpolation control.
M Miscellaneous codes.
N Block number (user reference only).
O Subprogram starting block number.
P Subprogram reference number (with M98 or M99); Uniform

scale multiplier (with G51).
Q Peck depth for pecking canned cycle.
R Arc radius for circular interpolation (with G02 or G03); Starting

reference point for peck drilling (with canned cycle codes); Rota-
tion angle for coordinate rotation.

S Spindle speed.
T Tool selection.
U Incremental X motion dimension.
V Incremental Y motion dimension.
W Incremental Z motion dimension.
X X axis motion coordinate.
Y Y axis motion coordinate.
Z Z axis motion coordinate.
; Comment.
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The incremental arc center code selects the Fanuc mode for programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the Fanuc mode, arc centers are always incremental, regardless of whether
the system is in G90 (absolute) or G91 (incremental) mode. In contrast, arc
center specifications in EIA-274 mode follow the selected programming
mode, absolute or incremental.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.
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The absolute arc center code selects the EIA-274 mode of programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the EIA-274 mode, the mode of programming arc centers follows the selected
programming mode, absolute (G90) or incremental (G91). In contrast, arc
center specifications in Fanuc mode1 are always incremental, regardless of
whether the system is in absolute or incremental mode.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.
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The Skip and Optional Skip codes allow you to skip particular lines of code
in your program.
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Place the code at the beginning of the line you wish to skip. When you run
the NC program, the specified line will be skipped.
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Use the Skip code with a parameter to instruct the Control Program to execute
the line of code every nth pass. Place the code at the beginning of the line
you wish to skip. The syntax is: \n, where n is the number of passes between
executions.

For example, if you want to execute a block of code every 5 passes, place \5
as the first code at the beginning of the block.
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34 Place the code at the beginning of the line you wish to skip.

�4. Select the Optional Skip option from the Run Settings dialog box or the
Operator Panel.

When you run the NC program, the specified line will be skipped. If you do
not select the Optional Skip option in the Run Settings dialog box, the skip
code is ignored and the line is executed normally.
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Use the Optional Skip code with a parameter to instruct the Control Program to
execute the line of code every nth pass. Place the code at the beginning of the
line you wish to optionally skip.

The syntax is: /n, where n is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place /5
as the first code at the beginning of the block.
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The D code is used to select a value from the Control Program Offset Table.
For example, D1 selects entry number 1 from the Offset Table. Selecting off-
set 0 (D0) cancels cutter compensation.

Use the D code with:

u Cutter compensation codes to specify the tool radius.

u Tool offset adjust codes to specify a consistent increase or decrease in the
commanded movement.

Use the Offsets command under the Setup Menu to view and manage the
Offsets Table.
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The F Code is used to specify the rate of speed at which the tool moves (the
feed rate in inches or millimeters per minute, depending on the selected unit
of measure). For example, F3 equals 3 ipm.

The feed rate should be set to a low value (up to 50 ipm) for cutting operations.
Feed rate values are in millimeters per minute (mpm) when using metric
units. The Control Program limits the programmed feed rate so it doesn’t
exceed the maximum allowed by the machining center.

The F Code is also used to specify the number of seconds to dwell when
used with the G04 code.

$��������� 
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G codes take effect before a motion is specified. They contain information
such as the type of cut to be made, whether absolute or incremental dimen-
sioning is being used, whether to pause for operator intervention, and so on.

More than one G code from different groups can appear in each NC block.
However, you may not place more than one G code from the same group in
the same block.

The G codes supported by the spectraLIGHT Control Program fall into the
following groups:

u The Interpolation Group

u The Units Group

u The Plane Selection Group

u The Wait Group

u The Canned Cycle Group

u The Programming Mode Group

u The Preset Position Group

u The Compensation Functions Group

u The Coordinate System Group

u The Polar Programming Group



�+�5���
�����/����������

���
	������������

����

The Interpolation Group allows you to specify the type of motion for inter-
polation. These G codes are retained until superseded in the NC program by
another code from the Interpolation Group.

The supported interpolation G codes are:

G00 Rapid traverse
G01 Linear interpolation (default)
G02 Circular interpolation (clockwise)
G03 Circular interpolation (counterclockwise)

Refer to Section G for more information on these functions.
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By default, an NC program is interpreted using the units of measure (inch or
metric) specified using the Units command on the Setup Menu.

The codes in the Units Group, G70 (inch) and G71 (metric), are used to
override the Units command for the entire program.

If the code is placed at the beginning of the program before any tool motions
are made, that unit of measure is assumed for the entire program. Otherwise,
it affects the rest of the program following the code.  You can use these codes
to switch between inch and metric modes throughout your program at your
convenience.

The Fanuc equivalents, G20 (inch) and G21 (metric), can also be used.
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This group of codes allows you to select different planes for circular interpo-
lation. G17 is the Control Program default.

The supported Plane Selection Group codes are:

G17 Select the X,Y plane for circular interpolation. The arc center coor-
dinates are given by I for the X axis and J for the Y axis.

G18 Select the X,Z plane for circular interpolation. The arc center coor-
dinates are given by I for the X axis and K for the Z axis.

G19 Select the Y,Z plane for circular interpolation. The arc center coor-
dinates are given by J for the Y axis and K for the Z axis.
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Wait Group codes apply only to the block in which they appear. The program
does not continue until the wait conditions are satisfied.

The supported Wait Group codes are:

G04 Dwell (wait): Pause between motions on all axes for the number of
seconds specified by the F code, then continue the program. Because
the F code is used to specify the number of seconds, you cannot
also specify a new feed rate in the same block.
Example: G04F10;Wait for 10 seconds

G05 Pause: Used for operator intervention. Stop motion on all axes until
the operator manually resumes program execution using the Run/
Continue command.

G25 Wait until TTL input #1 (Robot 1 or user input 5) goes high before
executing the operations on this block. Used for robot synchroniza-
tion (see Section L  for more information). Use the H code to
specify an input other than the default, H5.

G26 Wait until TTL input #1 (Robot 1 or user input 5) goes low before
executing the operations on this block. Used for robot synchroniza-
tion (see Section L for more information). Use the H code to
specify an input other than the default, H5.

G31 Linear move to specified coordinate; used with H code to specify both
input number and the High or Low condition for stop (designated
by the operator input , + or -). The move occurs until an input is
triggered or until the specified end point is reached. The move stops
short if specified input goes High (if H is positive) or Low (if H is
negative). The default is input 5 (Robot 1) High.
You can have the control program go to a specified block (N Code
number) if the input meets the required condition. Use a P code to
specify the destination, as with the M99 code.
For example,  G31X5Y5H6P50000  instructs:
� Move (using the current programming mode) to the X5 and Y5.
� If input 6 (Robot 2) goes low during the move, stop the motion

and  jump to block number 50000.
� If input 6 (Robot 2) doesn’t go low, complete the move and

continue with the next block in the program.

G35 Wait until TTL input #2 (Robot 2 or user input 6) goes high before
executing the operations on this block. Used for robot synchroniza-
tion (see Section L for more information).  This is the same as using
the codes G25 H6.

G36 Wait until TTL input #2 (Robot 2 or user input 6)  goes low before
executing the operations on this block. Used for robot synchroniza-
tion (see Section L for more information).  This is the same as using
the codes G26 H6.
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Canned cycle codes allow you to perform a number of tool motions by specifying
just one code. Canned Cycle codes are typically used for repetitive operations
to reduce the amount of data required in an NC program. Canned cycle codes
are retained until superseded in the program by another canned cycle code.

The supported Canned Cycle codes are:

G80 Canned cycle cancel
G81 Canned cycle drilling
G82 Canned cycle straight drilling with dwell
G83 Canned cycle peck drilling
G85 Canned cycle boring
G86 Canned cycle boring with spindle off (dwell optional)
G89 Canned cycle boring with dwell

Refer to Section G  for more information on these functions.
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Programming mode G codes select the programming mode, absolute (G90)
or incremental (G91). These codes remain in effect until superseded by each
other. The default code on program start up is G90.

With absolute programming, all X, Y and Z coordinates are relative to origin
of the current coordinate system. With incremental programming, each mo-
tion to a new coordinate is relative to the previous coordinate.

The supported Programming Mode codes are:

G90 Absolute programming mode
G91 Incremental programming mode
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The preset position G codes move the tool to a predetermined position, or
affect how future motions will be interpreted.

The supported Preset Position codes are:

G27 Check reference point: This code moves the machine to its home
position and compares the reported position against zero to see if any
position has been lost. The difference between the reported posi-
tion and zero is compared to a tolerance value specified using the
Setup Program. Use the L code in this block to override the tolerance
value from the Setup Program.

G28 Set reference point: This code moves the machine to its home posi-
tion and sets the machine position to 0,0,0. The G28 code performs
an automatic calibration of the axes.
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G92 Set position: This code works like the Set Position command under
the Setup Menu. The X, Y and Z coordinates following a G92
code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle  complete.
G99 Rapid move to point R (surface of material or other reference

point) after canned cycle complete.
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Use the cutter compensation NC codes to automatically compensate for the
variations in a cutting tool’s radius and length. Refer to Section H for more
information on using cutter compensation.

The supported Compensation codes are:

G39 Corner offset circular interpolation.
G40 Cancel cutter compensation.
G41 Left cutter compensation: Enables cutter compensation to the left

of programmed tool path.
G42 Right cutter compensation: Enables cutter compensation to the

right of programmed tool path.
G43 Tool length offset: Shifts Z axis in a positive direction by a value in

the Offset Table, specified by an H code.
G44 Tool length offset: Shifts Z axis in a negative direction by a value

in the Offset Table, specified by an H code.
G45 Tool offset adjust: Increases the movement amount by the value

stored in the offset value memory.
G46 Tool offset adjust: Decreases the movement amount by the value

stored in the offset value memory.
G47 Tool offset adjust: Increases the movement amount by twice the

value stored in the offset value memory.
G48 Tool offset adjust: Decreases the movement amount by twice the

value stored in the offset value memory.
G49 Cancels tool length offset.
G50 Cancels scaling.
G51 Invokes scaling.
G68 Invokes rotation.
G69 Cancels rotation.



�+��5���
�����/����������

���
����������
� ���!

����

Use the Coordinate System codes to establish multiple coordinate systems on
one or more workpieces to create multiple parts.

For instance, you can run a part program using a typical coordinate system
(with the point of origin on the surface of the front left corner of the work-
piece), then select another coordinate system which has its origin at a differ-
ent point on the surface of the workpiece.

There are seven coordinate system codes. One of these codes (G53) is used to
rapid to specified machine coordinates. The other six codes allow you to
make up to six individual parts on the same workpiece by specifying different
work coordinate systems for each part.

The coordinate system codes are G54 through G59, referring to coordinate
systems 1 through 6 respectively. These coordinate systems may be set
through the Coordinate Systems command on the Setup Menu.

���
$����
$�����!!���

����

The Polar Programming Group codes allow you to perform polar program-
ming operations, based on polar coordinates. The polar coordinates are defined
by X (radius) and Y (angle in degrees) when programming for the X, Y plane.
Refer to Section H for more information on using polar programming.

The supported Polar Programming codes are:

G15 Polar programming ON
G16 Polar programming OFF
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The H code has multiple uses. It can be used to specify inputs, input state
changes, outputs, and  offset amounts.

Use the H code in conjunction with:

u The wait codes G25 and G26, to specify the input number.  If the H code is
not used with these G codes, input 5 is assumed.

u The wait code G31, to specify input change to high or low. If the H code is
not used with this G code, input 5 High is assumed.

u The tool length offset codes G43 and G44, to specify the amount of Z axis
shift. The Offset Table you use for Tool Length Offset H values is the same
table you use for Cutter Compensation and Tool Offset Adjust D values.

u The transmit codes M25 and M26 for interfacing with robots or other exter-
nal devices, to specify the output number. If the H code is not used with
these M codes, output 4 (Robot 1)  is assumed.
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In absolute programming mode (G90), the I code specifies the X axis coordi-
nate of the center point of an arc or circle when using circular interpolation.
In incremental mode (G91), the I code specifies the X axis distance from the
start point of motion to the center point of the arc for circular interpolation.
If no I code is specified, the system uses the current X axis location as the X
axis center of the arc.

 In Fanuc mode, all arc centers are incremental.

The I code is also used with the G51 code to specify the scale factor for the X axis
when performing scaling functions, including scaling each axis and mirror scal-
ing. Refer to Section H for more information on using scaling.
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In absolute programming mode (G90), the J code specifies the Y axis coordinate
of the center point of an arc or circle when using circular interpolation. In incre-
mental mode (G91), the J code specifies the Y axis distance from the start point
of motion to the center point of the arc for circular interpolation. If no J code is
specified, the system uses the current Y axis location as the Y axis center of
the arc.

In Fanuc mode, all arc centers are incremental.

The J code is also used with the G51 code to specify the scale factor for the Y axis
when performing scaling functions, including scaling each axis and mirror scal-
ing. Refer to Section H for more information on using scaling.
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In absolute programming mode (G90), the K code specifies the Z axis coor-
dinate of the center point of an arc or a circle when using circular interpola-
tion. In incremental mode (G91), the K code specifies the Z axis distance
from the start point of motion to the center point of the arc for circular in-
terpolation. If no K code is specified, the system uses the current Z axis loca-
tion as the center of the arc.

In Fanuc mode, all arc centers are incremental.

The K code is also used with the G51 code to specify the scale factor for the Z
axis when performing scaling functions, including scaling each axis and mirror
scaling. Refer to Section H for more information on using scaling.
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The L code specifies the angle of arc resolution in circular interpolation pro-
gramming. When the system executes a circular motion, it actually splits the
arc into a series of line segments to approximate the circle. The L code speci-
fies the angle in degrees which a line segment approximates a portion of the
arc. The smaller the angle, the smoother the cut. A negative value for L will
generate a normalized L factor (degrees x radius {in inches}) so larger radii have
smaller degree values. For example, with the default L factor of -1:

� An arc with a radius of 1 inch will have line segments approximating ev-
ery 1 degree of the arc.

� An arc with a radius of .5 inches will have line segments approximating
every 2 degrees of the arc.  (Degrees = -L/R, or Degrees = -(-1) / .5,
which is 2)

The default setting for the machining center is -1, and typically this will
work quite well. You may notice the machining center hesitating on arcs if
the resolution is too fine. The L code can be a fraction of a degree (such as L.5),
but it must be large enough so the machining center will move at least the mini-
mum motion (.0005") on each of the straight line motions.

Use the L code with:

u The M98 code as a loop counter for subprograms.

u The M47 code as a program cycle counter, to repeat a program a finite
number of times.

u The G27 code to specify tolerance with homing commands (this is an
LMC-specific NC language extension). The difference between the cur-
rent position and 0 is compared to a tolerance value specified using the
Setup Program; use the L code to override this tolerance value.

u An L code that is not used by one of these codes is used as an Arc Reso-
lution factor.
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M codes control a variety of machining center functions while a part pro-
gram is running. Only one M code should be specified per NC block. M
codes and motion commands should be placed on separate blocks to avoid
confusion over whether an M code is activated during or after a motion
command.

The supported M codes are:

M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.
M01 Optional Stop: Allows you to place an optional pause in your

code. Place an M01 in the block of code where you would like to
pause. There are switches to activate or deactivate the Optional Stop
code in the Run Settings  dialog box and on the Operator Panel.
With Optional Stop on, the M01 works like a G05 pause.
With Optional Stop off, the M01 code is ignored, and the other
codes on the block are executed as usual.

M02 End of Program: Takes effect after all motion has stopped; turns
off drive motors, and all outputs, including the spindle and the ac-
cessory outlets.

M03 Spindle Motor On: Activated concurrently with motion specified
in the program block; remains in effect until superseded by M05.

M05 Spindle Motor Off: Activated after the motion specified in the
program block; remains in effect until superseded by M03.

M06 Tool Change: Pauses all operations, turns off spindle, retracts
spindle for tool change.

M08 Accessory #1 On: Turns on ACC 1 accessory AC outlet concur-
rently with the motion specified in the program block; remains in
effect until superseded by M09. This is the same as using the M25
H2 codes.

M09 Accessory #1 Off: Turns off ACC 1 accessory AC outlet after the
motion specified in the program block is completed; remains in ef-
fect until superseded by M08. This is the same as using the M26
H2 codes.

M10 Accessory #2 On: Turns on ACC 2 accessory AC outlet concur-
rently with the motion specified in the program block; remains in
effect until superseded by M11. This is the same as using the M25
H3 codes.

M11 Accessory #2 Off: Turns off ACC 2 accessory AC outlet after the
motion specified in the program block is completed; remains in ef-
fect until superseded by M10. This is the same as using the M26
H2 codes.
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M20 Chain to Next Program: This code is used to chain several NC files
together. It appears at the end of a part program and is followed on
the next line by the file name of another program which is executed
when all motion stops. Here’s an example of a part program chain
to another program:

N37 Z.2

N38 M20

PROGRAM2.NC; Chain to PROGRAM TWO

If the two programs you are chaining are not in the same directory
on your computer, you must specify the full path name for the next
program file. If the software cannot locate the specified file, you
will be prompted to find it.

M22 Output current position or other information to file.
M25 Set TTL output #1 (Robot 1 or Output 4) On: Used for robot

synchronization (see Section L for more information). Use the H
code to specify an output other than the default, H4.

M26 Set TTL output #1 (Robot 1 or Output 4) Off: Used for robot
synchronization (see Section L  for more information). Use the H
code to specify an output other than the default, H4.

M30 End of program: Same as M02.
M35 Set TTL output #2 (Robot 2, or Output 5) On: Used for robot

synchronization (see Section L for more information).
M36 Set TTL output #2 (Robot 2, or Output 5) Off: Used for robot

synchronization (see Section L for more information).
M47 Rewind: Restarts the currently running program; takes effect after

all motion comes to a stop. Typically used with an L code to repeat
a program a set number of times.

M98 Call to subprogram. Use the P code to specify the subprogram
starting block number. Use the L code to specify the number of
times the subroutine is executed. You can nest subprogram calls to
a depth of 20.

M99 Return from Subprogram; Goto
M105 Operator Message (LMC)
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The M22 code is used to write information to a file while a program is run-
ning.  Typically, this code is used when digitizing to write the current X, Y,
and Z machine coordinates to a file. The proper format for using this code
is: M22(filename) Data to Write to File.

The first time the Control Program encounters an M22 code, it opens the
specified file. You must enclose the name of the file in parentheses for the
Control Program to recognize it. If you do not specify any DatatoWritetoFile
text, the default data is output. This default is the current position, equiva-
lent to specifying ‘X@X Y@Y Z@Z’.  The @X,@Y,@Z ‘macros’ are replaced
by the actual machine position when the data is written.
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Each M22 code automatically adds a linefeed to the end of its output so the
next M22 starts on a new line.

If the file name is followed by “,A” (e.g., test.nc,A), the Control Program does
not delete previous information from the file, it appends the information to the
end of the existing information. If the file does not exist, it is created.

If you use more than one M22, only the first occurrence must have the file
name in the parentheses. The remaining M22’s may have empty parentheses,
( ), or may specify a different file.

If you want to generate more than one file at a time, you must include the
filename each time you specify M22. If a filename is not specified, the first
file opened is used.

Example:

. . . ; code to move to position
; Open my1.xyz, discard contents, write coordinates
M22(my1.xyz)
. . . ; code to move to next position
; Append to currently open data file
M22( )
. . . ; code to move to next position
;Open my2.xyz and append coordinates
M22(my2.xyz,A)

Special codes that can be used with M22 to generate run-time reports.

@XCurrent X position (in current coordinate system).
@YCurrent Y position (in current coordinate system).
@Z Current Z position (in current coordinate system).
~ (tilde) New Line (starts a new line in the file).
@TD Time of Day (12hour)   “11:59:59AM”
@TC Time (elapsed) for cycle “99:11:59” (0’s trimmed from left)
@TT Time Total (program run)   “99:11:59”
@TA Time Average (per cycle)   “99:11:59” (“??:??” if first part)
@TL Current Tool #.   “5”
@CCycle # (Current Pass)   “3”
@DDate  “12/31/94”
@FN Current File (w/o path)   “PART.NC” (“UNTITLED.NC” if
untitled)
\t TAB
\\ Outputs a single ‘\’ character.

Example:

; Start of file
… ; Process a single part
; Output part time statistics to file c:\Reports\Stats.txt (c:\Reports
directory must exist)
M22 (c:\Reports\Stats.txt,A) Part #@C processed in @TC.
M47 L50 ; We want to process 50 parts.
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The M99 code has two specific uses; it can be used as a command to return
from a subprogram or it can be used as a goto command.
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When used in a subprogram, this code returns you to the block following
the last M98 (Call to Subprogram) command. If the M98 used an L code to
specify multiple calls to the subprogram, the M99 will return to the block
containing the M98 until all the specified number of subprogram calls have
been made; then it will proceed to the block following the M98.

You can use the P code plus a block number to override the block returned to;
however, if this feature is used from a nested subprogram call, all return tar-
gets are discarded. The rules for a Goto target block apply to this use as well.
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This command can be used in the main NC program as a Goto command to
jump to any line before the first subprogram (as denoted by the O code).

Use the P code to identify the block number being jumped to. Control is
transferred to the first occurrence of this N code; it cannot be used to trans-
fer control between chained programs (see M20).

This command can be used anywhere in the program to change the flow of
program execution. It is good programming practice to place this command
on a line by itself to improve the program’s readability.
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This command is used to display messages in the Control Program. It pro-
vides a way to display messages to the operator on the message bar while an
NC program is running. You can also pause the program with a custom mes-
sage. This is a nonstandard, Light Machines code.

By default, the message is centered, displayed as a Normal Message, and is
persistent (not cleared until the program clears it or until the next message is
displayed).
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M105(the message);comment

For instance, the following line of code displays a simple message:

M105(End of Roughing Segment);Normal Message; doesn’t pause



�+�7 )�(����
��#&�!�>���

�����

��������
�������
�����
���������
����������

^ Displays the message and performs a pause requiring operator interven-
tion to continue.

~ Displays the message as a Warning Message.

\b Beeps when the message is shown.

�����
���
�3�7
����
"���
��
���������
���������

M105(alternate character plus the message) ;comment

For example:

M105(~WARNING);Warning Message , doesn’t pause
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M105( ) ; clears current message
M105(^Please stop and read this!) ; Normal Message, pauses
M105(~^I MEAN IT!) ; Warning Message, pauses
M105(\b\b\b) ; Clears current message, beeps 3 times, and doesn’t
pause
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N codes have two uses:

u To provide destinations for Gotos (M99) elsewhere in the program.

u To clearly show the organization of the code and improve readability.

Using the N code is optional; however, when you do use the N code, it must
be the first character in the block.

Other than for the above stated uses, N codes are ignored by the Control
Program. Their presence, absence, or sequential value does not affect the ex-
ecution of the NC program in any way (unless the target of a goto is missing).

You may have N codes on some blocks and not on others. N code sequence
numbers do not have to be in order, but regular sequential order does make it
easier to follow and reference sections of the program. The Control Program
can change the N codes in a program by inserting, removing, or renumbering
the codes.
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The O code is used to indicate the start of a subprogram, and must be fol-
lowed by a number which identifies the subprogram. The O code replaces
the N code in the first block of the subprogram.

To call a subprogram, use the M98 code; use the P code to specify which
subprogram to execute. To return from the subprogram, use the M99 code.

Only the first block in the subprogram contains the O code. The remaining
blocks may contain N codes. The O and N code numbers may be used to help
identify and set apart the subprogram to improve readability, for example:

M98 P50000 ;call to first subprogram
…;after first subprogram is finished, M99 code returns to this point
…
M98 P60000 ;call to second subprogram
…;after second subprogram is finished, M99 code returns to this point
…
O50000 ;start of subprogram
N50010 ;first line of subprogram
N50020 ;second line of subprogram
N50030 M99 ; last line of subprogram
…
O60000 ;second subprogram
N60010 ;first line of second subprogram
N60020 ;second line of second subprogram
N60030 M99 ; last line of second subprogram
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Use the P code with:

u The G31 code to reference a goto target block.

u The G51 code to specify a uniform scaling factor.

u The M98 code to reference a subprogram using the subprogram block number.

u The M99 code to specify a return block number as a goto target.
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The Q code is used with the G83 code in canned cycle peck drilling to specify
the incremental depth of each peck.
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As an alternative to specifying the center point of an arc (I Code, J Code, or
K Code) you can specify the arc radius. Use the same value for the radius in
both absolute and incremental programming modes.

G02 or G03 specifies the direction of motion.

Positive values for R (radius) are specified for arcs up to 180°. Negative val-
ues are used for arcs greater than 180°. Full circle arcs cannot be performed
with an R code. Split the circle into two arcs, or use center point (I, J, and K)
values for full circles.

Use the R code in canned cycles to specify a Z axis reference point for peck
drilling. The point can be at the material surface or at another reference
point. The R code is also used to specify the rotation angle, in degrees, with
the G68 code.

�������
�����
C�
����D

Use the S code to set the spindle speed from within the NC program. Spindle
speed is specified by the address character “S” followed by a parameter that
represents the speed in RPM. For example, S750 is the designation for a
spindle speed of 750 RPM. For the spindle speed to have an effect the
spindle must be turned on by the M03 command. If the spindle is off, the
spindle speed is stored and used when the spindle is turned on again within
the program. Use the M05 command to turn the spindle off.
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T codes specify the tool (number) in the Tool Library in multiple tool ma-
chining operations. Tools are specified by the address character “T” followed
by a parameter that represents the number of the tool. For example, T3 is the
designation for tool number three.
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An X code specifies the coordinate of the destination along the X axis. A U
code is used in absolute programming mode (G90) to specify an incremental
X motion.  You cannot use the U code to mix incremental and absolute pro-
gramming in the same block.
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A Y code specifies the coordinate of the destination along the Y axis. The V
code is used in absolute programming mode (G90) to specify an incremental
Y motion. You cannot use the V code to mix incremental and absolute pro-
gramming in the same block.
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The Z code specifies the coordinate of the destination along the Z axis
(spindle axis). A W code is used in absolute programming mode (G90) to
specify an incremental Z motion. You cannot use the W code to mix incre-
mental and absolute programming in the same block.
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The Control Program allows you to add comments (notes) to your NC code
lines. The Control Program recognizes two comment codes, a semicolon “;”
and an open parenthesis “(“. These two comment codes are equivalent. The
use of either of these codes within an NC block indicates that a comment
follows.

Comments must follow all other NC codes in the block. Comments are ig-
nored when the part program is executed. Comments can be placed on a
block without any NC codes to document what is occurring within a pro-
gram. NC programmers use these comments to annotate their programs.

Here is an example of an NC block with a comment:

X0Y0Z0;MOVE TO ZERO POINT

The comment tells us that the X, Y and Z codes in this block command the
cutting tool to move to the zero point (coordinate 0,0,0).

Comments can be combined with the G05 pause and the M06 Tool Change
codes to display messages to the operator during program execution. Here is
an example of an NC block with a pause coded comment:

G05(ROUGH DIAMETER SHOULD BE 0.5 in.)

When the program pauses, the comment is displayed on the message bar,
telling the operator to verify the diameter of the workpiece before continu-
ing. The M105 code provides a more versatile and powerful message facility.

The Control Program can strip comments from a program with a single
command; however, the comments can not be subsequently replaced.
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The following rules should be followed when writing NC part programs.

34 The sequence of words (address characters plus parameters) in an NC block
must appear in the following order: F����A2B��#��?�A�B��.�ADB��@�A B�����"��E��<��)��K�����C�
���������$�����/��Q A different order may cause unpredictable results.

�4 In many cases, a word need not be repeated in the next block (line). The
system assumes no change in codes unless a new code appears. Some of
the codes this does not apply to: N words, I, J, and K, G04, G05, G25, G26,
G92, F used for dwell, M02, M20, M25, M26, M30, M47, M98 or M99.

54 You can use more than one G code in a block; however, you can use
only one G code from any one group in a single block.

64 N codes (sequence numbers) are not required in a part program; however,
they can be useful in identifying a block when editing a long NC part
program.

An O code is required to mark the beginning of a subprogram and does
not have to be in sequence with the N codes.

74 The first instruction in a part program should move the tool to the start-
ing position. This makes restarts much easier.

;4 The last block of a program should move the tool back to the starting
position. The tool will then be in position to start cutting another part.

<4 Part programs should reference the zero point with Z0 at the point
where the tool just touches the work piece. This convention allows for
standardization of programming.

=4 Before running an NC part program:
a. Look for the typical coding error that places two X codes, two Y

codes, or two Z codes in the same block.
b. Be sure that all required coordinates have been written into appro-

priate blocks.
c. Verify the part program to discover any program errors.
d. Run the part program without mounting stock in the machining

center to see if the tool movements are logical.

>4 The first portion of a part program should turn on the spindle and establish
the feed rate and spindle speed.

3�4 M codes should be placed on separate blocks to avoid confusion over
whether an M code is activated during or after a motion command.

334 Double-check all program blocks against your coding sheet to locate and
correct typographical errors.
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Linear interpolation is the movement of the tool in a line from its current
position to a coordinate location specified by an NC code. Here’s a typical
line of NC code using linear interpolation:

N5G90G01X.7Y1.2F2

Broken down into individual words:

N5 The line sequence number is 5
G90 Coordinates are given using absolute dimensioning
G01 Linear interpolation is specified
X.7 X axis coordinate of end point = .7

Y1.2 Y axis coordinate of end point = 1.2
F2 Feed rate is 2 inches per minute

The G01 code is required when switching from circular interpolation or
rapid traverse positioning back to linear interpolation. If we assume the cur-
rent position of the tool is X.5, Y.5, the tool movement generated by the
above line is something like this:

An equivalent movement is achieved with incremental dimensioning (G91):

N5G91G01X.2Y.7F2
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Here are two typical lines of NC code using circular interpolation:

N9G90X1Y0;SET START POINT
N10G03X0Y1I-1J0F2;COUNTERCLOCKWISE TO X0,Y1

The first line defines the starting point. The second line defines the end
point and the center of the arc. Broken down into individual words, the sec-
ond line reads:

N10 The line sequence number is 10
G03 The tool will proceed in a counterclockwise direction from the

starting point to specified (X, Y) coordinates; center point of arc
is specified by (I, J) coordinates

X1 X axis coordinate of end point = 0
Y0 Y axis coordinate of end point = 1
I-1 I coordinate of center point of arc = -1 (relative to start point)
J0 J coordinate of center point of arc = 0 (relative to start point)
F2 Feed rate is 2 inches per minute
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Circular interpolation moves the cutting tool along an arc from the starting
point specified in one line, to an end point specified in the next line. The
curvature of motion is determined by the location of the center point (I, J, or
K), which must also be specified in the second NC line.

The direction of rotation from the starting point determines the actual shape
of the arc relative to the spindle axis. A G02 code moves the tool in a clock-
wise (CW) motion from the starting point. A G03 code moves the tool in a
counterclockwise (CCW) motion from the starting point.
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The tool path generated by the preceding lines is something like this:

An equivalent movement is achieved with incremental dimensioning (G91):
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N9G91X1Y0;SET START POINT
N10G03X-1Y1I-1J0F2

In this NC line, the X and Y values are the distance the tool is to move from
its current position. In both cases, the I and J values are equal to the X and Y
distance from the start point to the center point.
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To perform circular interpolation on a plane other than the X, Y plane, use a
G18 code to select the X, Z plane, or use a G19 code to select the Y, Z plane.
This feature is rarely used in manual part programming, but may be used by
CAM systems to generate surfaces of revolution. The G17 code is used to re-
turn to the X, Y plane. An example of circular interpolation on the X, Z
plane is:

N9X0Z0
N10G90G18G03X0Z1I0K.5F2

In this NC line, the X and Z values are the destination position of the tool.
The I and K values are the incremental location of the center point of the
curvature of motion.
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Helical interpolation is performed when the axis not used in circular interpo-
lation is commanded to move. For example (assuming a start point of 0,0,0):

N10G90G03X0Y1Z1I0J.5F2

This line would cause the Z axis to move at a constant feed to Z1 while the X
and Y axes move in a circular path, resulting in a helical motion. Helical in-
terpolation works with circular motion on the X,Z and Y,Z planes as well.

Here is an example of an NC program using helical interpolation.

G90M03S1500
G0X0Y0Z0.070
G0X2Y2
G1Z-0.5F10
G02X0Y2Z0I-1J0F10
M02
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On the spectraLIGHT Machining Center, the rapid traverse code (G00) can
move the tool at the maximum available feed rate (50 ipm) to specified coor-
dinates. Rapid traverse is used to reposition the tool before ending a program, or
in preparation for the next cut.
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Rapid traverse can be used for all tool positioning motions. This will reduce
the run time for the part program. The G00 code remains in effect until lin-
ear (G01) or circular (G02, G03) interpolation is again specified. Linear or
circular interpolation resumes at the feed rate last specified prior to the rapid
traverse motion(s) unless you specify a new feed rate.

Here’s a sequence of typical NC lines using rapid traverse:

G90G01X1F2; MOVE IN A STRAIGHT LINE TO X = 1 AT 2 IPM
G00X2; RAPID TRAVERSE TO X=2
X3; RAPID TRAVERSE TO X=3
G01X4; MOVE IN A STRAIGHT LINE TO X=4 AT 2 IPM
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Canned cycle commands allow you to perform drilling operations by specify-
ing just a few codes. They are typically used for repetitive operations to reduce
the amount of data required in an NC program. Canned cycle codes are re-
tained until superseded in the program by another canned cycle code.

The supported canned cycles codes are:

G80 Canned cycle cancel
G81 Straight drilling
G82 Straight drilling with dwell at bottom
G83 Peck drilling
G84 Tapping cycle
G85 Boring cycle
G86 Boring cycle with spindle off (dwell optional)
G89 Boring cycle with dwell

These codes are used in conjunction with canned cycle codes:

G98 Rapid to initial position after canned cycle complete; this is the
system default.

G99 Rapid to point R after canned cycle complete.
K Code Specifies the number of repeats. The default is 1. When K=0,

drilling data is stored.
P Code Specifies the length of dwell time in seconds.
Q Code Specifies the depth of cut. In peck drilling each peck uses the

same Q value. The Q value is always positive. If a negative value
is specified, it is converted to a positive value.

R Code Used for specifying a starting reference point for peck drilling. The
point can be at the material surface or at another reference point.

�����
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To cancel a canned cycle, use the G80 code. This code cancels the currently
running canned cycle and resumes normal operation. All other drilling data is
canceled as well. You can also cancel canned cycles by using a G00 or G01
code; a G80 is automatically performed before the G00 or G01.
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The G81 code performs straight drilling operations. By specifying an R value
of zero, the tool will return to the initial point after drilling to point Z. Here
is a sample G81 program.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G81G98Z-.5R0F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL
POINT
G80;CANCEL CANNED CYCLE
M2;END PROGRAM

This program will generate tool motions similar to this:

More than one canned cycle can be accomplished by specifying only X and Y
coordinates. For example:

G0X1Y1Z.1;RAPID TO 1, 1, .1
G81G98Z-.5R0F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL
POINT
X.5Y1;PECK AT NEW X,Y COORDINATES
X.25Y1;PECK AT NEW X,Y COORDINATES
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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A G82 works just like a G81, except it is used when you wish to incorporate
a dwell (P code) at the bottom of the hole (point Z). A line of code utilizing
the G82 and P code, and the tool motion it creates are shown below.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G82G98Z-.5R0P5F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL
POINT AFTER A DWELL OF FIVE SECONDS
G80;CANCEL CANNED CYCLE
M2;END PROGRAM

�����
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The G83 code is used for peck drilling cycles. By adding a Q depth to the
code line, you can specify drilling increments. For instance, the following
code will peck drill to a depth of -.5 in .1 increments. The tool will rapid
back to point R after each peck drill. Also, before each peck the tool will
rapid to .005 (.13mm) above the start point.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G83G99Z-.5R0Q.1F3;PECK DRILL TO DEPTH OF -.5, RAPID TO R
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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A G84 is used for tapping threads. You specify the depth of the tapped hole.
When the tap reaches that depth, it is pulled out in at a rate 1.6 times the
rate of insertion (60% faster). The G84 tells the computer to calculate the in-
sertion/extraction ratio. You must use a tapping head with a reversing
mechanism when using G84.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G84G98Z-.5R0F2;TAP TO DEPTH OF -.5, RAPID TO INITIAL POINT
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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A G86 works like a G82 except the spindle stops at the bottom of the hole.
The dwell (optional) allows the spindle to come to a complete stop before the
tool rapids back to the initial point.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G86G98Z-.5R0P5F2;DRILL TO DEPTH OF -.5, SHUT OFF SPINDLE,
RAPID TO INITIAL POINT AFTER A DWELL OF FIVE SECONDS
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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A G85 specifies a boring cycle. After the tool plunges, it retracts at the same
feed to point R. This sometimes gives a better surface finish on the hole.
Then the tool rapids to the initial point.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G85G98Z-.5R0F2;BORE TO DEPTH OF -.5, RAPID TO INITIAL
POINT FROM POINT R
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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The G89 code works like the G85 except it utilizes a dwell at the bottom of
the hole.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G89G98Z-.5R0P5F2;BORE TO DEPTH OF -.5, PAUSE FOR FIVE
SECONDS THEN RAPID OUT FROM POINT R
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
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Subprograms are used to execute repetitive routines in an NC program. Since
a subprogram can be called again and again, you don’t have to enter the same
data more than once. This is especially useful if the machining operation you
wish to repeat is lengthy or complex. The NC codes used for subprogram-
ming on the spectraLIGHT Machining Center are:

M98 Call to subprogram.
M99 Return from subprogram.

P Code The P code is used to reference the first line of the subprogram
(which begins with an O code). The P code immediately follows
an M98.

L Code The L code is used as a loop counter when used in subprogram-
ming. The computer executes the subprogram as many times as de-
fined by the L code. For instance, if the code is L5, the subprogram
is executed five times. (Optional)

O Code The O code replaces the N code on the first line of a subprogram.

A subprogram is called by an M98 and a P code. When an M98 calls the sub-
program, the main program is interrupted while the subprogram is executed.

The P code references the subprogram’s address (the first line of the subpro-
gram). The first line of the subprogram uses an O code instead of an N code
for line numbering.

When the M99 is executed, the main portion of the NC program continues
to execute from the line after the subprogram was called.

Subprogram calls can also be nested within other subprogram calls. This
means that while a subprogram is being executed, it can call another subpro-
gram. The default number of levels that subprograms can be nested is 20 lev-
els deep. You can change the default by using the Setup Program (click on
the Setup icon in the WSLM program group).
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G05
M03S1000
; SAMPLE OF SUBPROGRAM
; USE 7.25 X 3.00 STOCK FOR VERIFY
G0X1Y1Z.1; RAPID TO 1, 1, .1
M98P1000L4; RUN SUBPROGRAM 1000 FOUR TIMES
G90G0X0Y0Z.1
M2; END OF MAIN PROGRAM
O1000; SUBPROGRAM TO MILL SQUARE AND MOVE TO NEXT
POINT
G90G1Z-.1F2; PLUNGE AT CURRENT LOCATION
G91; INCREMENTAL COORDINATE
X1F5; FIRST MOVE, FEED RATE 5
Y1; SECOND MOVE
X-1; THIRD MOVE
Y-1; FOURTH MOVE
G90G0Z.1; RAPID UP ABOVE WORK
G91X1.5; RAPID TO START OF NEXT SQUARE
M99; RETURN FROM SUBPROGRAM
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Using polar coordinates allows you to specify a radius and an angle by speci-
fying a G16 code (polar programming on), then X and Y codes. The X code
specifies the radius. The Y code specifies the angle in degrees. A G15 is used
to cancel the polar programming mode. This programming method can be
used in both absolute and incremental programming.

Polar programming is especially useful when writing programs for machining
bolt holes. An L code can be used as a multiplier for the angle value. For in-
stance, this bit of code:

G0X0Y0Z0.07
M03
G16
G91X2Y0
M98P1L12
M2
O1Y30
G81Z-.1R0
G80
M99

combines the use of polar programming with a canned cycle and a subprogram
to drill a hole at 30o increments. The L value was determined by dividing
360 degrees by 30.

You can also cut an arc using code similar to:

G16
G91X2Y0
M98P1L360
G15
M2
O1Y1
M99

In polar programming, the center point is the origin if you specify G90 and
the radius (X code). If you specify G91 and the radius (X code), the center
point is the current point. If you specify only the angle (Y code), the center
point is the current center.
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The Set/Check Homing command under the Setup Menu allows you to es-
tablish a point of origin at the ends of travel on the machining center. The
homing commands (G28, G27, G29) allow you to return to and check this
established position. The machining center uses this point as a reference for
all machine coordinate movements. This allows you to use the Soft Limits
and Coordinate Systems commands (under the Setup Menu) to move the
machining center consistently to the same location.

Before you can use any homing commands, or the Soft Limits and Coordinate
Systems commands, you must use the Set/Check Home command to estab-
lish an initial reference point. See Section E for information on using the
Set/Check Home command.

#,7���
������
	������(����
������
����������
�

	����
F�	�
-������
�����!�(����
	����
&�
���&�

�����

�=

The G28 code moves the machine to the coordinates previously established
by the Reference Point Wizard. If a reference point has not been defined, a
warning is generated and the G28 command is skipped.
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The G28 code homes the machine and sets the Machine Coordinates to zero.
Use a G27 if you want to check the home position, but do not want to set
that position to zero.

The G54 calls up coordinate system one, which contains the offset values
relative to the machine’s home position. These are the values you entered for
coordinate system one in the Offset from Machine Zero dialog box under
the Set Coordinates dialog box. The coordinates in the Position Window on
the screen change to the coordinates of “coordinate system one.”

The next line (G0X0Y0Z0) calls for the machine to perform a rapid traverse
motion from the Home position to point 0,0,0 in “coordinate system one.”

The remaining lines of code instruct the machine to cut a square in a
piece of stock.
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Remember, Soft Limits are based on Machine Coordinates. You can not use Soft
Limits until you have set the machine to the reference point using the Set/Check
Home command under the Setup Menu.
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The G27 code can only be used after you have set a reference point using the
Reference Point Wizard. If you have not previously established a reference
point, a warning is generated and the G27 code is skipped. After you have set
a reference point using the Reference Point Wizard, you can use the G27 code
to check the actual machine position against the expected machine position.
This command causes the machine to perform a homing-like function, mov-
ing each axis independently from its current position to the reference point.
You can then manually compare the current position to the one set by the G28.

G27 also takes an optional position specified by XYZ. This position is called
the intermediate position. You do not need to specify all axes for the interme-
diate point, but for each axis that you specify, the current coordinate for the
intermediate point is updated to that value. Only axes that have specified
coorinates move when you specify an intermediate point. For example, if the
first intermediate point commanded is G27Z.6, the intermediate point mo-
tion is only to move the Z axis to .6. The machine first moves to the current
intermediate point at rapid traverse, then performs the reference point check.



����M��#&�!�>���

������+4

�����

�>

The G29 code moves the tool at a rapid traverse rate to a coordinate specified
by XYZ. If you have set an intermediate point on one or more axes, the ma-
chine first rapids from the current position to the intermediate point then
continues to the specified destination. If you command a G29 code in Incre-
mental mode, your specified XYZ point is relative to the intermediate point.
If you have not specified an intermediate point, your specified XYZ point is
relative to the current position. Use the G29 code after a G28 code to return
the tool to a position closer to the part. The example below shows the use of
a G28 code and a G29 code.

N1G28X2Y2Z-1; INTERMEDIATE POINT THEN HOME
N2G29X4Y1Z1; GO TO G29 POINT

+Y

+X

G29 Point (4,1)

(0,0)

Intermediate Point (2,2)

Reference Point (3.5,4)

(1,1)
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Programmed Tool Path

Compensated Tool Path
(Left)

Tool

Compensated Tool Path
(Right)

Tool

G41 G42

Programmed Tool Path
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Cutter compensation automatically adjusts the spectraLIGHT to compensate for
variations in a cutting tool’s radius. It uses values from the Offset Table (tool
radius values) to determine the compensation offset value. Use the following
codes for cutter compensation:

G39 Inserts an arc at the corner of compensated path
G40 Cancels cutter compensation
G41 Invokes left cutter compensation
G42 Invokes right cutter compensation

D Compensation offset value (Tool Radius Value)

Determine left and right cutter compensation in relation to the direction of
the tool path. Use left compensation when you need to move the tool to the
left of the programmed tool path. Use right compensation when you need to
move the tool to the right of the programmed tool path.

Select compensation offset values for D from the Offset Table. You can store
200 offset values in the table. Remember, however, that these offset values
are the same values you use for adjusting tool length offsets.
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You can start cutter compensation by inserting a G41 (for left compensation)
or G42 (for right compensation) into your NC program. In the example be-
low, left cutter compensation is enabled and the compensation value is equal
to offset value 1 from the Offset Table.

G0X0Y0
G91; INCREMENTAL
G41D1; CUTTER COMP ON
G1X.25Y.25; MOVE TO P1
G1X0Y1; MOVE TO P2
G1X.75Y0; MOVE TO P3
G1X.25Y-.25; MOVE TO P4
G1X0Y-.75; MOVE TO P5

The following illustrations show how the Control Program constructs the
compensated tool path for the NC code above:
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Segment 2

Segment 3

Segment 4

Segment 5

Start Point

Tool

P1

P2 P3

P4

P5
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D1

Start Point

Tool

Offset Vector (Segment 2)A

Segment 1

Segment 2

Segment 3

Segment 5

Offset Vector (Segment 1)

A1

Offset Vector
(Segment 1)

Segment 4

P1

P2 P3

P4

P5

Offset Vector
(Segment 3)

D1

D1

Start Point

Tool

Offset Vector (Segment 2)A

Segment 1

Segment 2

Segment 3

Segment 5

Offset Vector (Segment 1)

A1

Offset Vector
(Segment 1)

Segment 4

B

P1

P2 P3

P4

P5
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Offset Vector
(Segment 3)

Start Point

Tool

A

Segment 1

Segment 2

Segment 3

Segment 5

Segment 4

B C
Offset Vector
(Segment 3)

D

P1

P2 P3

P4

P5

Start Point

Tool

A

Segment 1

Segment 2

Segment 3

Segment 5

Segment 4

B C
Offset Vector
(Segment 3)

D

E
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Any G41 or G42 command can include an IJK vector, which defines the end
point direction vector and the end point offset vector. For example, if, for
segment 3 of the previous illustration, we had specified

G41X.75I1J1

instead of just

X.75

the compensated tool path would look like this:
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(D1=.25)

Start Point

Normal Offset 
Vector (Segment 3)

Offset Vector
(Segment 2)

A

Segment 1

Segment 2

Segment 3

Segment 4

B

Offset Vector
(Segment 4)

New Offset Vector
New Direction 
Vector (IJ)C

P1

P2 P3

P4

The IJK Vector represents an incremental direction (the length of the vector
is not important). For example, I1J2<=>I3J6. By default, the end direction
vector is tangent to the segment.
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Select Setup Offsets from the Setup Menu to set the values referenced by D
codes (the cutter compensation offset value). The following dialog box appears:

Select an offset number or set the offset value in the Offset Box. To set the
offset value, double-click on an offset number from the scrolling Offset win-
dow. A check marks appears to the left of the offset number. Enter the offset
value in the Offset Box.
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You can change the D numbers that represent values from the Offset Table
while in cutter compensation. For example:

N1G91
N2G41D1X.25Y.25
N3Y.25
N4X.25D3; USE OFFSET #3
N5Y-.25
…

In this example, the D number changes from 1 to 3 in line N4. Because the
value of D3 is greater than the value of D1, the compensated path moves far-
ther away from the programmed path and is at the new D value by the time
the tool reaches point C.

"��
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B

C

D3=.03D1=.01

Offset Vector

D3=.03

A
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You can change the side of compensation sides during cutter compensation.
For example, you can start cutter compensation to the left, then change to
the right:

G91
G41D1X.25Y.25; LEFT CC ON
Y.25
G42X.25; RIGHT CC ON
 Y-.25
…

In this example, left cutter compensation is on at point A, but right cutter
compensation begins as the tool moves towards point B. In this case, the off-
set value (D) is the same for both left and right cutter compensation.

"��
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B

C

D3=.03D1=.01

Offset Vector

D3=.03

A

The same situation would occur if you made the offset value negative. For
the example above, changing the D code from one that refers to a value of
.01 to one that refers to a value of -.01 would produce the same result as
changing from G41 to G42.
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The G39 code inserts an arc at the corner of a cutter compensated tool path.
The G39 instructs the cutter compensation function to complete the current
segment by moving to its default endpoint (the endpoint of the Offset Vector). It
then creates an arc (with a radius equal to the offset value), starting at the
buffered segment’s default endpoint, and ending at the endpoint of the offset
vector (IJ). Here is an example of an NC program using G39:

G91
G41D1…
…
Y.25
X.25
G39I0J-1;  CORNER OFFSET

(X0,Y1)

(D1)

Start point

Tool

Default Offset Vector

Offset Vector

Direction 
(IJK) Vector

Default Endpoint
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Use the G40 code to cancel cutter compensation. G40 is effective for only
one move. There are six methods for cancelling cutter compensation.

34 G40
�4 G40XYZ
54 G40XYZIJK
64 D0
74 D0XYZ
;4 G41/42D0XYZIJK

With methods 4 through 6 above, setting the offset number to zero is the
same as cancelling cutter compensation.
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With method 1 the G40 code cancels cutter compensation. The cutter moves
from the offset path to the programmed end point. The same occurs with
method 4, where you set the D value to zero.

G91G41D1
…
X.25
Y-.25
Z.2; RETRACT
G40; OR D0
X-.5Y-.25
M2

Center of 
programmed tool path

Start point

G40 
Tool travels to 
programmed path

Center of compensated tool path



�!;��
�!�����/���������� �+��

�������
�
���
7

With methods 2 and 5, the G40 (or the D0) cancels the cutter compensation,
but a subsequent motion (X-.5Y-.25) is included in the program. The tool
moves towards the programmed path in the direction of X-.5Y-.25.

G91G41D1
…
X.25
Y-.25
Z.2;RETRACT
G40X-.5Y-.25
M2

�������
5
���
;

With these methods an IJK vector specifies the direction of movement after
cutter compensation is cancelled.

G91G41D1
…
X.25
Y-.25
Z.2; RETRACT
G40X-.5Y-.25I-.5J-.25
M2

Center of 
programmed tool path

Center of compensated tool path

Start point

G40 
Tool travels along compensated 
path towards X-.5Y-.25

ToolX-.5Y-.25

Center of 
programmed tool path

Center of compensated tool path

Start point

IJ Vector

Normal vector to IJK

Default end point
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Scaling and rotating codes can be used separately or they can be combined.
Each of these functions is described in the following paragraphs.

�������

Use the scaling codes to scale one or more axes of a part from a fixed scaling
origin. You can scale the entire piece uniformly, or set different scaling fac-
tors for each axis. Use the following codes for scaling:

G50 Cancels scaling
G51 Invokes scaling

P Uniform scale multiplier

���'��!
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Use a P Code to scale an entire piece uniformly along each axis. When you
specify a value for P, subsequent motions are scaled by that value, starting
from the scaling center. The Control Program measures the distance from
the scaling center to the start and end points of the shape, then multiplies
those values by the P value.

The NC program below creates a half-circle then scales those motions by two
to create a larger, uniformly-scaled half-circle (the scaling codes are in bold print):

N0G0Z.5

N1X1Y1.5

N2G1Z-.1F10

N3G2Y.5J-.5

N4G0Z1

N5G51X1Y1Z0P2; SUBSEQUENT MOTIONS SCALED BY 2

N6G0Z.5

N7X1Y1.5

N8G1Z-.1F10

N9G2Y.5J-.5

N10G0Z1

N11G50; CANCEL SCALING

The values for X, Y, and Z in line N5 represent the absolute position of the
scaling center. The P value represents the scale factor. In this example, the
entire part is scaled by two. The G50 in line N11 cancels the scaling.
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You can scale each axis by different magnifications. The following NC pro-
gram uses scaling to change the proportions of a motion by scaling each axis
separately (the scaling codes are in bold print):

N0G0Z.5

N1X1Y1.5

N2G1Z-.1F10

N3G2Y.5J-.5

N4G0Z1

N5G51X1Y1Z0I1.5J1.75K1; SCALING ON

N6G0Z.5

N7X1Y1.5

N8G1Z-.1F10

N9G2Y.5J-.5

N10G0Z1

N11G50; CANCEL SCALING

The values for X, Y, and Z in line 5 represent the absolute position of the
scaling center. The I, J, and K values represent the scale factors for the X, Y,
and Z axes respectively. When scaling each axis individually, you do not use
a P code.
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You can create mirror images of shapes by specifying negative values for I, J, and
K. The NC program below uses negative I and J values to create a mirror image
of the original shape on the XY plane (the scaling codes are in bold print):

N0G0Z.5
N1X1Y1.5
N2G1Z-.1F10
N3G2Y.5J-.5
N4G0Z1
N5G51X1Y1Z0I-1J-1K1; SCALING ON
N6G0Z.5
N7X1Y1.5
N8G1Z-.1F10
N9G2Y.5J-.5
N10G0Z1
N11G50; CANCEL SCALING

The values for X, Y, and Z in line 5 represent the absolute position of the
scaling center. The I, J, and K values represent the scale factors for the X, Y,
and Z axes respectively. Notice the negative I and J values for mirroring on
the XY plane. Remember that performing Z axis mirroring is an advanced
operation.
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Rotation codes allow you to rotate a programmed shape around a rotation
origin. You can rotate a shape on any plane, one plane at a time. Use the
Rotation code to modify an NC program when a work piece has been ro-
tated from the programmed position on the machine.

G68 Invokes rotation
G69 Cancels rotation

Here is an example of an NC program using Rotation (the Rotation codes
are in bold):

N0G0Z.5
N1X1Y1.5
N2G1Z-.1F10
N3G2Y.5J-.5
N4G0Z1
N5G68X1.583Y1.5R90; ROTATION ON ROTATION ORIGIN XY
N6G0Z.5
N7X1Y1.5
N8G1Z-.1F10
N9G2Y.5J-.5
N10G0Z1
N11G69; CANCEL ROTATION
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The X and Y values in line N5 are the coordinates of the rotation origin; the
rotation occurs around this point. The R value represents the absolute value
of the rotation angle. The G69 in line N11 cancels the rotation.

Note that positive R values represent counterclockwise rotation angles; nega-
tive R values represent clockwise rotation angles.

+R -R

Counterclockwise
Positive Rotation Value

Clockwise
Negative Rotation Value

Rotation Origin Rotation Origin



�!;��
�!�����/���������� �+,0

��!.�����
�������
���
&�������
�����

You can combine scaling and rotation in the same NC program. The por-
tion of the NC program below combines the scaling and rotation codes nec-
essary to machine the following part (the actual subprogram to cut the shield
(O100) is not listed here).

N1; DO THE ORIGINAL FIRST
N2M98P100
N3; NOW SCALE BY 1/2 AND ROTATE 90 CCW
N4G51X1.583Y0Z0I.5J.5K1; SCALING ON
N5G68X1.583Y1.5R90; ROTATION ON
N6M98P100; SECOND PART
N7; NOW MIRROR AND SCALE BY 1/2, AND ROTATE 90 CCW
N8G69G50
N9G51X1.583Y0Z0I-.5J.5K1
N10G68X1.583Y1.5R90
N11M98P100; THIRD PART
N12; NOW SCALE BY 1/2 AND ROTATE BY 90 CW
N13G69G50
N14G51X1.583Y0Z0I.5J.5K1
N15G68X1.583Y1.5R-90
N16M98P100; FOURTH PART
N17;END OF PROGRAM
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The spectraLIGHT Machining Center allows you to designate up to 8 differ-
ent tool offsets for tool changes during milling operations. To designate the
tool number, tool diameter and Z axis offset, select Setup Library from the
Tools Menu.

There are four basic steps in setting up the Machining Center for multiple
tool operation:

34 Placing the appropriate codes in your NC program,

�4 Establishing a reference tool,

54 Establishing the offsets for other tools from that reference, and

64 Testing your program.
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The T code is used in the NC program to offset the cutter so that the NC
program becomes independent of the cutter length, which is set up in Tool
Definitions. This means you can replace a worn tool with a tool of a different
length without changing the NC program, just by entering new offsets. (Any
actual tool change is performed manually.) The T code can be located any-
where within the block of NC code, but it is normally placed after the G code.

When you place T codes in your program for tool changes, you should also use
the M06 code to retract and shut off the spindle. The M06 code is placed af-
ter the T code. This code instructs Machining Center to shut off and retract
the spindle to the top of the vertical column, where it pauses until you manually
change the tool. Pressing the Return key will turn the spindle back on to
continue with the NC program.
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When using multiple tools, a reference tool, normally Tool #1, is set to zero
for the Z axis. This establishes a reference tool position which is used as a
reference point for additional tools. For demonstration purposes, we will use
Tool #1 as the reference tool and Tool #2 as the additional tool.

To set the reference tool:

34 Decide on a reference point (a point on the workpiece, or on a gauge,
where you will jog the tip of each tool).

�4 Open the Jog Control Panel (select Jog Control from the View Menu).
With the tool installed in the spindle, jog Tool #1 to the reference point.
The tip of the tool should barely touch the workpiece, or zero-out a
reference gauge.

54 Select Set Position from the Setup Menu. Set the current position of
Tool #1 to zero on the Z axis.

Tool #1 is now established as the reference tool.
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Now that the reference tool is established, additional tools can be assigned
offsets. You can move the tool and accept its current Z axis position as the
offset value, or you can manually enter offset values.

To set the offset for Tool #2:

34 Jog the spindle up, insert Tool #2 then jog it down just to touch the sur-
face of the workpiece, or offset sensor, at the previously determined ref-
erence point.

�4 Select Setup Library from the Tools Menu. The Z axis position will be off
by the difference in the length between this tool and the reference tool.

54 Select Tool #2. Click on the Current Z button. The Control Program
assigns the offset value of Tool #2 as minus the current Z position.

The offset for Tool #2 is now established.
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After setting all of the tool offsets, test run your program without a work-
piece mounted and with the spindle speed turned down.

34 After installing Tool #1, close the safety shield, put on your safety
glasses, and complete the safety checklist.

�4 Select the Run/Continue command from the Program Menu. Select line
one as the start line and select Start. Throughout the test, be prepared to
press the emergency stop button on the machining center in case of a tool
crash. The computer will run the program until it reaches the M06 code.
The M06 stops and retracts the spindle.

54 When the spindle has completely stopped and the Pause message appears
on the screen, push in the emergency stop button on the machining center.

64 Open the safety shield.

74 Remove Tool #1 and install Tool #2, making certain it is securely fas-
tened to the spindle.

;4 Close the shield, and pull out the emergency stop button. Press the Re-
turn key on the computer keyboard. The spindle turns on and moves to
the previous position. Operation continues as programmed until the
next M06 code is encountered.

<4 At each pause, repeat Steps 3 through 6, installing the appropriate tool
at the appropriate points in the program.

=4 Edit the program, if required. When you are satisfied that the program
works correctly, mount the workpiece, set the spindle speed, and run
your multiple tool program.
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For a beginning user, understanding coordinate systems can be difficult. The
first thing to remember is, before performing most machining operations, you
are required to set the machine to “home” position. This returns the machine
to the machine zero point, and acts as a reference point for all operations. It
is a good idea to home the machine every time you run the control software.
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Machine Zero is the extreme negative end of travel on the X and Y axes, and
the extreme positive end of travel on the Z axis. This is a fixed point on the
machine, and can not be changed. The machine uses this as a reference point
for all operations. If the machine is not homed (set to the machine zero) it
can not accurately locate the workpiece on the cross slide. The machine is
homed by using the Set/Check Home command under the Setup menu, or
by using a G28 code in the NC program.

0��8
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Once home is set, open an NC program using the Control Program. The NC
program will need a point of origin to start from. Setting a point of origin
will establish the work coordinates. Work coordinates relate to the workpiece,
and are usually set from the top of the front left corner of the workpiece
mounted on the cross slide. Once the stock is mounted on the cross slide, jog
the spindle to the top of the front left corner of the workpiece. From the
Setup Menu, select Set Position. The tool coordinates appear in the dialog
box. Set the coordinates to X0, Y0, Z0 and click on OK to set the current
tool position as the point of origin on the workpiece.



����M��#&�!�>���

������+,7

��������
����������

� ���!�

For more advanced operations, such as machining multiple parts, you can set
up multiple coordinate systems. For example, if you have three or four
workpieces attached to a pallet, and the pallet secured to the cross slide, use
the following procedure.

Move the tool tip to the work coordinate point of origin (0,0) at the corner
of the pallet using the Set Position command from the Setup Menu. After
setting the corner of the pallet as the origin, select the Coordinate Systems
command from the Setup Menu. The Setup Coordinate Systems dialog box
appears. Select a “User CS”, enter the coordinates for the first workpiece, and
click on Apply. Repeat this procedure  for as many coordinate systems as nec-
essary. (For a detailed description of the Setup Coordinate Systems proce-
dure, see Section E.)
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Use the tool length offset codes to adjust the machine for variations in tool
lengths. The tool length offset codes are:

G43 Compensate for a longer tool.
G44 Compensate for a shorter tool.
G49 Cancel tool length offset.

H Specifies the offset number from the offset table. (The Offset Table
you use for Tool Length Offset H values is the same table you use
for Cutter Compensation and Tool Offset Adjust D values.)

The G43 compensates for a longer tool by retracting the spindle away from
the cross slide. The G44 compensates for a shorter tool by moving the spindle
closer to the cross slide.

G44

Tool

Offset Value

Z0

Offset Value

Tool

G43�������
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The T code normally specifies the tool, its diameter, and offset value. When
you include a G43 or G44, the computer ignores the T code offset value and
uses the offset you assign to H.

Here is an example of the tool length offset code used in an NC program:

M06G43T2H1

The M06 code initiates a tool change cycle. Once the tool change is com-
plete, the G43 adds the value from the offset table to the Z offset. The G43
compensates for a tool that is longer than the reference tool. The T2 refers to
the tool number and the tool diameter, but not the offset value. The H1 rep-
resents the offset value set in the Offset Table.
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Use these codes for making critical dimension adjustments to the offset val-
ues. When you specify tool offset adjust codes, you can increase or decrease
the movement distance of the specified axis by the offset value (D). The tool
offset adjust codes are:

G45 Increases the movement amount by the value stored in the offset table
G46 Decreases the movement amount by the value stored in the offset table
G47 Increases the movement amount by twice the value stored in the

offset table
G48 Decreases the movement amount by twice the value stored in the

offset table
D Offset value

You must command a motion for tool offset adjust codes to adjust the offset
values. Following are examples of the motions caused by tool offset adjust codes.

�����

67

34 The offset value increases the actual movement by 1.5 beyond the com-
manded movement.

5.5
Actual Movement

Commanded Movement

Offset Value

4.0

1.5

5.5

Actual Movement

Commanded Movement

Offset Value

4.0

-1.5

�4 The negative offset value decreases the actual movement by 1.5 from the
commanded movement. Note that A G45 code with a negative offset
value is the same as a G46 code with a positive value.
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The G46 code decreases the commanded movement by the offset value. Note
that the G46 code is the same as reversing the positive or negative direction
specified by the offset value of a G45 code.

1.0
Actual Movement

Commanded Movement

Double Offset Value

4.0

3.0

7.0
Actual Movement

Commanded Movement

Double Offset Value

4.0

3.0

5.5

Actual Movement

Commanded Movement

Offset Value

4.0

1.5

�����
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The G47 code increases the commanded movement by twice the offset value.
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The G48 code decreases the commanded movement by twice the offset value.
Note that the G46 code is the same as reversing the positive or negative di-
rection specified by the offset value of a G47 code.
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Two terms used in general machining are feed and cut.

Normal machining on the machining center involves removing material
from the surface of the workpiece. This is accomplished by advancing the
cutting tool into the workpiece by an appropriate amount (depth of cut).

The rate of tool travel is called the feed rate. On machines like the
spectraLIGHT Machining Center, the tool does not advance into the
workpiece; instead, the cross slide moves the workpiece beneath the tool.
However, the same feed rate principle applies.

The depth of cut is set by the vertical column (Z axis) drive motor and
the feed is controlled by the X and Y axis drive motors. The depth of cut
and feed rate you select should depend on the turning speed of the
spindle, the type of material and lubricant used, and the type of cutting
tool used for the operation.

Speed
Depth
of Cut

Feed

C
u
t
t
e
r

Stock

Excessive depth of cut and high feed rates place greater strain on the spindle,
may bind the tool and workpiece, or produce a poor surface finish on the part.
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The relative hardness of the material and the type of cutting tool (end mill or
drill) affect spindle speed. The harder the material is, the slower the speed
should be.

High spindle speeds may produce excess heat which causes the workpiece to
expand. If the workpiece expands, the cutting tool will rub rather than cut
the material, resulting in a poor surface finish. Slow spindle speeds cause no
harm, but may be inappropriate for finishing certain types of materials.

The load put on the spindle motor must also be taken into account. Heavy
cuts at low speeds will make the motor run hotter than lighter cuts at higher
speeds. The selected feed rate and depth of cut should not cause the spindle
motor to greatly lose speed or cause the tool to chatter against the workpiece.
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Feed rate selection for machining parts on the spectraLIGHT Machining
Center depends on factors such as type of material, type of cut, depth of cut,
and spindle speed. The type of tool chosen to make the cuts also affects the
depth of cut and, therefore, the feed rate. Consult your machinist’s
handbook for selecting a feed rate based on spindle speed and material type.
Experience and experimentation will enable you to establish feed rates best
suited to particular applications.

��.�������
���
��������
Lubricants remove heat from the tool and workpiece and are often used when
high production rates are required or when cutting very hard materials, such as
stainless steel. A mixture of one part soluble oil to six parts water may be
used on steel to assist in producing a smoother finish and to reduce tool
chatter. Aluminum and aluminum alloys may require the use of paraffin, oil
or kerosene to prevent chips from welding to the tool’s cutting edge. Brass
and cast iron are always milled dry.

When lubrication is necessary, small amounts of water-soluble cutting fluids
are recommended for use on the spectraLIGHT Machining Center. Lubricants
should be wiped from the machine after use, because some petroleum-based
fluids may deteriorate the electrical wiring insulation, the plastic safety
shield, or the computer enclosure.
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Cutting tools are usually made from hardened steel and are ground to vari-
ous shapes. The clearances ground behind cutting edges are adjusted for the
type of material the tool will cut and the direction the tool will be fed along
the workpiece.

Insufficient clearance behind the cutting edge will cause the tool to rub. Ex-
cessive clearance will produce a ridged or wavy finish due to the small length
of tool edge in contact with the workpiece. Standard tool types are: end
mills, center drills, drills and boring tools. Tools are often ground to shape
by the operator to suit a particular cutting requirement.

(��
�����

End mills come in two types: flat end mills and ball end mills. They should
be sharp and must run true. Holding end mills in a drill chuck is a poor
practice; use collets instead. Be certain the spindle speed is set correctly for
the type of material being machined. An end mill can be instantly damaged if
a cut is attempted at excessive speed. Begin with light cuts and progressively
increase cuts until satisfactory results are obtained. End mills should not be
used for drilling holes, but they can be used to enlarge holes.

When plunging into the workpiece, use a center cutting end mill. The teeth
on center cutting end mills go from the end of the mill into the center.
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Center drills are used to drill holes in a workpiece. The workpiece is
mounted in a vise or on the cross slide.

Use small amounts of cutting lubricant with center drills. Clear the drill fre-
quently, otherwise the tip may clog and twist off even in soft materials.
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Boring tools are used to enlarge or modify a drilled or cored hole in a work-
piece. The workpiece is mounted in a vise or on the cross slide. Clearance
must be maintained behind the cutting point of the tool.

A slow feed rate and frequent tool withdrawals are required with boring tools
because chips cannot freely escape from the hole. Depth of cut and feed rates
must be reduced to avoid chatter. The tool should not be driven deeply into
a hole. When boring a hole where a flat bottom is required, stop the down
feed at least 0.002 inch above the desired depth of the smaller hole being
bored out.
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A cutting tool must be sharpened regularly to preserve its original cutting
angle and shape. Longer tool life will be obtained from cutting edges if they
are finished with a small oilstone. Only the cutting end and sides of the tool
should be ground as required. Never grind the top face of the tool.
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The following safety rules should be reviewed and practiced by all operators
of the spectraLIGHT Machining Center.
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Foresight is better than no sight. During operation any power tool can
throw foreign objects and harmful chemicals into your eyes. Always put
on safety glasses or eye shields before starting up the machining center.
Safety glasses or shields should provide full protection at the sides, as well
as the front of the eyes.
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Read this guide carefully before you use the machining center and keep it
readily accessible for quick reference. Know the intended applications and
limitations of the machining center as well as its hazards.
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The machining center has an AC power cord terminated by a three-prong
plug. The power cord should be plugged into a three-hole, grounded recep-
tacle. If a grounding adapter is used to accommodate a two-prong receptacle,
the adapter wire must be attached to a known ground. Never remove the
third prong from the plug on the AC power cord.
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The safety shield should remain in place whenever the spindle motor is
on or the cross slide is moving.
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Make it a habit to check that keys and adjusting wrenches are removed
from the machining center before turning on the machine.
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Cluttered work areas and bench tops invite accidents.
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Don’t use the machining center in damp or wet locations. Never operate
electrical equipment in the presence of volatile and flammable petroleum-
based solvents and lubricants.
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Children and visitors unfamiliar with the hazards of rotating machinery
should always be kept away from the work area.
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Lock and remove the key from the machining center control panel when
the system is not in use.
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Select the feed rate and depth of cut best suited to the design, construc-
tion and purpose of the cutting tool. It is always better to take too light a
cut than too heavy a cut.
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Select the type of cutting tool best suited to the milling operation. Don't
force a tool or attachment to do a job it wasn't designed to do.
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Don't wear loose clothing or jewelry which can get caught in moving parts.
Wear a hat or hair net, or tie your hair back to keep it away from moving
parts.
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Be certain that you have firmly secured the workpiece in the vise and the
cutting tool to the collet before turning on the spindle motor.
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Keep your footing and balance at all times so you won’t fall into or grab
the moving machine.
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Keep cutting tools sharp and clean. Lubricate and clean machining center
components on a regular basis.
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Always use the emergency stop switch to disconnect power and disable the
spindle motor before mounting or removing the workpiece, or changing
tools. Do not rely solely on a programmed Pause command to disable ma-
chining center operation.
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Make sure the power switch on the control box is off before plugging in
the machining center power cord.
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To avoid stressing the machining center and creating a hazardous machining
environment, use only those accessories designed for use with the spectraLIGHT
Machining Center, available through Light Machines Corporation.
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Tighten the collet. Do not over-tighten tool holding devices. Over-tightening
may damage threads or warp parts, thereby reducing accuracy and effectiveness.
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Do not allow coolant to splash into or near the computer.
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Alcohol or drugs may impair your judgement and reaction time, which
could contribute to an on-the-job accident.

�+���
%�����������
0����
&������
���
�������

Use simple common sense and pay attention while operating any piece of
machinery.



)�(����
��#&�!�>���

����EE+4

��'�� 
����8����

������� ���� ��
��� 
	�� ��� � ����!

� /��� ��� ������� ��������

� ���� ��
,� ������ ���	� ���� 
��������

� 2�
���� 3����	�� ��
������� 	����%� �	�
������ ���� �	������
����

������� "�
	������ �� ���
!

� ��,�� ��	�� ���� ����� ���� 
�		�
�� ����� ��	� ���� 3���

� .�
�	�� ���� ����� �	���	���

� ��,�� ��	�� ���� ����� ���������� ����� ����� �	���	��� ��������4���

� 5�	���� ���� 6�� �	��	�
� ��� ���� 
�
����	� ����	�� 
�
�������

� 2�
���� ���� ������ ��	��� ���� ���
��� �	�
� ���� 
�
�����

� 2�
���� ��3������� ,���� ���� �	��
���� �	�


���� 
�
�����

� ������ ���� ������� �������

� 7���� ���	���� ���� 
�
����� ����	� ������ �	���	��� �	������ ��

���� ����

� /�	��	
� �� �	�� 	��8

� .��� ���� �������� 
���	� ����
�� ��� ������� 
������ �����

��������

� ��,�� 
�	����� ���	�� ��� ��� ��	,���
�� ��� ���
��

� 2��� ���� 6�� �	��	�
� ��� 
�,�� ��	�� ���� ���� 
����� 
�,�

������ ����	�� 	������� ���� �	��	�
� ����� �� ��	,���
�� ��

���
��

� ����	� 
�
�������� ���� �	�� 	��%� �	���	��� ��
�	�� ���

��	,���
�� ��� ���� 
�
�����

� 9���� ������� ����� �	�
� ���� ���
�	�
��� 
����
�����%� ���
�	���


�	� ���
�	�
��� ����
��%� ���� 
�
����	� ���� ���	��� ���
�	�
��

��������

#	���� "�
	������ �� ���
!

� :�� ���� ���
�� 
������ �	� 	�������� ��	���

� /	���� ���� ;
�	���
�� .���� ������� ����	�� �������� ���

������� �������

� 7���� ����� ���� ������� ������� ����	� ���� �������� ���� �������

	��������

� /	���� ���� ;
�	���
�� .���� ������� �������	� 
�������� �����

�	� 
�������� �	� 	�
������ �� ��	,���
��

� /���� ���� ;
�	���
�� .���� ������� ���� ����� ����	� 
������� ���

������� �������

� 9���� ���� �������	�4��� ��	����� ����� �	�
� ���� ��	,� �	���

	�$-&��*�:

/��
�
�������(�
	���
	�
-���
����
	�
���-�������D���(*�
	�
������
���
����
	�
-�!+�((�������
����
	
�����
�����(�
	������"#�$
��
	���������
���



��(����
	���������
���2����
��� E+�

�����
��
���������

��
��� ��� ��
���� ��� ��� $���� ��� 
��%�&�!

� 0��� ���� ������� ��� ����	�����

� /	�
�	�� 	�
���	��� ��� 
������� �� ��� ���	� 	���� ���3��

� 6�� ���� 3���	<�� 
�
�8� � �������%� �����	��� �� 	���3���

��
��� ��� 
��%�&��� �� "$'����� ���� ���(�!

� 0����4�� ��� ��		�
������ 
�		�
��� ��	�� ��� �	���3��� �����	���� ��

��	
�� 
�		�
��� ��� ��� �������� 
��� ���� ��=������

� �����	���� =��� ��� ����
�>�� ��� ��� ��		�
������ ��� 
�	��� ��� ����

���
����4���� 
�		�
��
�����

� 2�
����� ������ ���� ��	���� �������� �� 
���=������ ��3��� ��� ��

?	�����	��� ��
���� ������ ���� 	�������� ��� ��� ?	�����	�

�����@�� ��� 
���� 
�		����

� ���		�� ��� ���	��� ��� ����	����� ������ ��� �3�
���	� 
���=���	

���	�
�>�� ��� ��� ?	�����	��

� ��		�� ���� �	��	�
��� ��	� �	�
�	�� ��4� 
��� ��� 
���	� ���

�������� �������� �� ���� ���4�� ��� �	���3��� �����	���� =��� �����

���� 
���
������� ����� 
�		�
����

� �����	�� ��� ���4�� ��� �	��3�� �� ��� 
����� A����� ���� ��		�
������� �

������� ������ ��� 
�		�	� ��� ���	��� ��� ����	�����

� �����	���� =��� ������ ���� 
����
���� ��� 
�		������ ����� �����

���		�4�����

� ��������� ���� �<=������ 	��	���	������ ��3��� ��� ��� ��3�

��� ����	��%� ��
������	�� �� 
���=���	� .�
�����	�

;�@
�	�
��

����
���� 
��%�&�� �� "$'����� ���� ���(�!

� 6��
�� �������� ��� ���	��� ��� ����	����� 
����	��� =��� ��

��
������	�� ����� �3�
������� ��� �	��	�
��� /	������

���
�	�� �	�
�	�� ��� ���>�� ��� B/�	�� ��� ;
�	���
��C�

� /	������� ���
�	�� ��� ���>�� ��� B/�	�� ��� ;
�	���
��C


������ ��� 
�
���� ���� ��		�
�����%� ��� 
���=��� �� 	�
����

���� ���4�� ��� �	���3��� D���� ��� ���>�� ��� B/�	�� ��

;
�	���
��C� �����@�� ��� ����	� ������� ��� ���	��� ��

����	�����

� ��������� ���	�� ���� E	��� ��� �	��3�� �� ����� ��	����� ��

����	�4����

M	�$-&��*�(:

/��&��
������������U����!�

��'�=���D���(�8&��8&��
�!������
�&�
�����
���
	�
�!�����
���!�

�!���&��
��������
	��!����
�U8&����



)�(����
��#&�!�>���

����EE+7

(!������ 
�����
All spectraLIGHT operators must be fully aware of how to shut down the
machine quickly, should the need arise.

There are three ways an emergency stop can be initiated on the spectraLIGHT
Machining Center:

� By pressing the emergency stop switch on the machining center,

� By pressing a key on the computer keyboard, and

� By activating one of the limit switches on the machining center.
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G00 Rapid traverse.

G01 Linear interpolation.

G02 Circular interpolation (clockwise).

G03 Circular interpolation (counterclockwise).

G90 Absolute coordinate programming:  All X, Y and Z axes coordinates are
relative to a (0,0) location on a mill.

G91 Incremental coordinate programming: Each command is relative to the
one before it in the program.

G70 Inch: Used to instruct the mill that inches are the unit of measure for the
part program. (Fanuc G20)

G71 Metric: Used to instruct the mill that millimeters are the unit of measure
for the part program. (Fanuc G21)

G04 Dwell (wait): Equals the value of the feed rate (F code) in seconds (used
primarily for robotic operations). G04 excludes motion commands with a
new feed rate on the same line (block).

G05 Pause: Used for operator intervention. The order of action for the pause
and dwell codes in one NC block is G05, G04 (pause, dwell).

G25 Wait for robot input to be high: Used in conjunction with H code,
which specifies input number. Used for robot synchronization (see
Section L).

G26 Wait for robot input to be low: Used in conjunction with H code, which
specifies input number. Used for robot synchronization (see Section L).

G31 Linear to specified coordinate.Stop short if specified input goes High (if
H is positive) or Low (if H is negative).
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G15 Polar programming cancel.

  G16 Begin polar programming.

G53 Rapid traverse to specified coordinates in Absolute programming mode.
(e.g. G53X0Y0Z0 rapids to machine reference point)

G54 Use coordinate system one.

G55 Use coordinate system two.

G56 Use coordinate system three.

G57 Use coordinate system four.

G58 Use coordinate system five.

G59 Use coordinate system six.

G80 Canned cycle cancel.

G81 Canned cycle drilling.

G82 Canned cycle straight drilling with dwell.

G83 Canned cycle peck drilling.

G84 Canned cycle tapping.

G85 Canned cycle boring.

G86 Canned cycle boring with spindle off (dwell optional).

G89 Canned cycle boring with dwell.

G27 Check reference point: This code moves the tool to its home position on
the Machining Center to perform automatic calibration of the axes.
Compares reported position against zero to see if position has been lost.

G28 Set reference point: Sets machine position to 0,0,0.

G29 Return to reference point: Moves the tool to a coordinate specified by
XYZ. Typically used after a G27 or G28 code.

G92 Set position: This code works like the Set Position function under the
Setup Menu (see Section E). The X, Y and Z coordinates following a
G92 code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle complete (Section G).

G99 Rapid move to point R (surface of material or other reference point) after
canned cycle complete (Section G).
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G17 Select the X,Y plane for circular interpolation. This is the default plane
for circular interpolation. Use this code to switch back to the X,Y plane
after circular moves on the X,Z or Y, Z planes. The arc center
coordinates are given by I for the X axis and J for the Y axis.

G18 Select the X,Z plane for circular interpolation. Use this code to perform
circular interpolation on the X,Z plane. The arc center coordinates are
given by I for the X axis and K for the Z axis.

G19 Select the Y,Z plane for circular interpolation. Use this code to perform
circular interpolation on the Y,Z plane. The arc center coordinates are
given by J for the Y axis and K for the Z axis.

G50 Cancel scaling.

G51 Invoke scaling. Use this code to scale axes by a single factor or by
independent factors around a fixed origin. The default scale factor is 1.

G68 Invoke rotation. Use this code to rotate geometry by an arbitrary angle
around a specified point. Rotation works on any plane, one plane at a
time.

G69 Cancel rotation.

G39 Corner offset in circular interpolation.

G40 Cancel cutter compensation.

G41 Invoke cutter compensation left.

G42 Invoke cutter compensation right.

D Specifies the offset number from the Offset Table.

G43 Shifts Z axis in a positive direction by a value specified by H.

G44 Shifts Z axis in a negative direction by a value specified by H.

G49 Cancel Tool Length Offsets.

H Specifies the offset number from the Offset Table.

G45 Increases the movement amount by the value of D.

G46 Decreases the movement amount by the value of D.

G47 Increases the movement amount by twice the value of D.

G48 Decreases the movement amount by twice the value of D.

D Specifies the offset number from the Offset Table.
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  M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.

  M01 Optional Stop: Allows you to place an optional stop in your code. Place an
M01 in the block of code where you would like to pause. With Optional
Stop on, the M01 works like a G05. With Optional Stop off, the M01
code is ignored, the other codes on the block are executed as usual.

  M02 End of Program: Takes effect after all motion has stopped; turns off drive
motors, spindle and accessory outlets.

  M30 Program stop: Same as M02.

  M03 Spindle Motor On: Activated concurrently with motion specified in the
program block; remains in effect until superseded by M05.

  M05 Spindle Motor Off: Activated after the motion specified in the program
block; remains in effect until superseded by M03.

  M06 Tool Change: Used in conjunction with a T code to perform multiple
tool operations. See Section H.

  M08 ACC1 On: Turns on accessory ACC1 outlet concurrently with the
motion specified in the program block; remains in effect until superseded
by M09.

  M09 ACC1 Off: Turns off accessory ACC1 outlet after the motion specified in
the program block; remains in effect until superseded by M08.

  M10 Clamp ACC2: Turns on ACC2. Closes air vise accessory concurrently
with the motion specified in the program block; remains in effect until
superseded by M11.

  M11 Unclamp ACC2: Turns off ACC2. Opens air vise accessory after the
motion specified in the program block; remains in effect until superseded
by M10.

  M25 Set robot output: Used for robot synchronization. Used in conjunction
with H code to specify output number.

  M26 Set robot output: Used for robot synchronization. Used in conjunction
with H code to specify output number.
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  M20 Chain to Next Program: This code appears at the end of a part program
and is followed on the next line by the file name of another program
which is executed when all motion stops. Here’s an example of a part
program chain to another program:

N37Z.2
N38M20
PROGRAM TWO

If the two programs you are chaining are not in the same directory, you
must specify the full pathname for each file. If the specified file is not
found, the Open dialog box appears so you can locate it.

  M22 Output to file: Outputs information to a file. The first time the Control
Program encounters an M22 code, it opens the specified file. You must
enclose the name of the file in parentheses for the Control Program to
recognize it.

The proper format for using this code is: M22([filename.ext [,A]]) [text
and macros]. Items in brackets [ ] are optional, except that a filename is
required for the first M22. If no text is specified to be output to the file,
the current axis positions are output. M22 automatically adds a tilde (~)
to the output text, so the next M22 starts on a new line in the file.

If you use more than one M22, only the first occurrence must have the
filename in the parentheses. The remaining M22's may have empty
parentheses, ( ). If you want to generate more than one file at a time you
must include the filename each time you specify M22. If a filename is not
specified, the first file opened is used.

Following is a list of special codes that can be used with M22 to generate
run-time reports.

@X Current X position (in current coordinate system)
@Y Current Y position (in current coordinate system)
@Z Current Z position (in current coordinate system)
~ (tilde) New line (starts a new line in the file)
@TD Time of day (12hour): “11:59:59AM”
@TC Time (elapsed) for cycle: “99:11:59” (0’s trimmed from left)
@TT Time total (of program run): “99:11:59”
@TA Time Average (per cycle): “99:11:59” (“??:??” if first part)
@TL Current tool number:  “5”
@C Cycle number (current pass): “3”
@D Date: “12/31/94”
@FN Current file (without path): “PART.NC”

(“UNTITLED.NC” if untitled)
\t Tab
\\ Outputs a single backslash character to the file

The M22 code supports multiple output files. The first occurrence of a
filename opens the file. In the name M22(FILE.OUT,A) TEXT... the
output is appended to the file (if it exists). Each unique filename opens a
separate file. For backward compatibility, empty parentheses M22( )
TEXT... cause the M22 output to go to the first file that was opened with
an M22.
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  M47 Rewind: Restarts the currently running program; takes effect after all
motion comes to a stop. Use the L code to repeat a finite number of
times. The L code defines the number of times to run. For example,
M47L2 rewinds once.

  M98 Call to subprogram

  M99 Return from subprogram: Returns you to the block following the initial
M98 command.

Go to: Used with P code. P code defines N code destination. Goes to first
occurrence of N code within the main program. The N code can not
follow any subprogram (O code).
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The spectraLIGHT Machining Center has a simple interface for interacting
with common robots, like those used for automatic part loading between
machining operations. The machining center and the robot communicate by
way of an interface connector (labeled I/0) located on the rear panel of the
machining center.

The method of communication between the machining center and robot is
very basic. They are both able to transmit and receive high or low signals.
Since communcation signals are typically 0 and 5 volts, a high signal is 5
volts (or 3.5 volts or greater); and a low signal is 0 volts (or 1.5 volts or less).
See the figure below.

There are NC codes that you can place in a part program to instruct the
machining center to transmit a high or low signal to the robot. There are also
codes that instruct the machining center to wait for a high or low signal from
the robot.



)�'�
�
�"�
����
��� �+0

Signals sent out are referred to as outputs, while signals coming in are called
inputs. Any signals that the machining center transmits to the robot are trans-
mitted through an output pin on the interface connector. Outputs can drive a
maximum load of 1mA. Any signals that the machining center receives from
the robot come in through an input pin on the interface connector.

Examples of input and output wiring are shown in the schematic below.
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The 9-pin I/O connector on the rear panel provides a number of ways for
the machining center to communicate with robots and other external
mechanisms, such as an additional limit switch. Most of the Controller
inputs and outputs are located on this connector.

Some of the inputs and outputs are not free for robotic interfacing, they
already have dedicated uses; inputs 7 and 8 for example. The inputs and
outputs on the machining center are designated as follows.

$�� )������� 	G-
��+��� *�!�

1 Input 1 +5V INP 1L

2 External Limit 0 or +5V ELim

3 Output 2 +1V to +3.5V OUTPUT 2

4 Output 1 +1V to +3.5V OUTPUT1

5 Common GND

6 Input 2 0 or +5V INPUT 2

7 Input 1H See Note INPUT 1H

8 Input 2H See Note INPUT 2H

9 Common GND

Other Input/Output Notes:

u All User outputs are disabled by an ESTOP condition.

u Never apply a negative voltage or an AC voltage to an input.

u Do not connect to pins 7 or 8. These are for special applications.

u Outputs are set to source current only. Max load on each output is 1mA.

u Do not operate relays, motors or other inductive loads with the
I/O outputs. This will damage the machine. You may however, run an
optical relay.
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The NC codes used in robotic communication are:

G25 - wait for High signal
G26 - wait for Low signal
M25 - transmit High signal
M26 - transmit Low signal
H# - specifies the input or output (default is H1)

The H code is used in conjunction with the wait codes and transmit codes.
For example, G25H3 tells the machining center to wait until the state at in-
put #3 goes high.

Assuming the robot’s initial output state is low, if you place this line of code
at the beginning of your program, the machining center waits until input #3
goes high, then executes the next line of code.

If the external device sends a low signal, nothing happens because the machining
center is waiting for a high signal. If there’s no change to a high signal, the
machining center does not execute the next line of NC code in the program.

When the robot sends a high signal, the machining center responds by con-
tinuing with the NC program. If the machining center does not respond to
the robot as you have programmed it to, check that you have correctly wired
the robot to the interface, and that the robot’s initial output state was not
changed to high during the connection of the robot.
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As previously explained, communication between the machining center and
robot is very simple. They only use and recognize high or low signals. Once
the machining center sends a signal to the robot, it goes into a wait state and
continues to wait until the robot sends the appropriate signal back. When
the signal is recognized, the machining center executes the next instruction in
the part program. After executing the instruction, it sends a signal to the rbot.
The robot, which has been in a wait state since its last transmission, receives
the signal, performs as it has been programmed, then again signals the ma-
chining center.

This reciprocal system of communication is made possible by the placement
of G and M codes in the part program. The G codes provide the wait in-
structions to the inputs, while the M codes provide the transmit instructions
to the outputs.

The following sequence is typical of communication between the machining
center and a robot. Since the robot’s initial output state is low, the mill’s in-
puts have already been pulled down to a low state. This sequence assumes the
machining center is equipped with an air vise.
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N0M11;OPEN VISE

N1M25H2;TRANSMIT HIGH SIGNAL THROUGH ACC2

N2G25H1;WAIT FOR HIGH SIGNAL THROUGH ACC2

N3M10;CLOSE VISE

N4M26H2;TRANSMIT LOW SIGNAL THROUGH ACC2

N5G26H1;WAIT FOR LOW SIGNAL THROUGH ACC2

N0;THIS FILE FOR SLM0200 MILL

N1;USE 3" X 2" MACHINABLE WAX

N2G05

N3S1500M03

N4G0Z0.0700

N5G0X1.0000Y0.3140

N6G0Z0.0050

N7G1Z-0.1000F4.0

N8G3X1.5830Y1.3330I-0.5990J1.0190F12.0

N9X0.4170I-0.5830J-1.0190

N10X1.0000Y0.3140I1.1820J0.0000

N11G0Z0.0700

N12S1500.00

N13G0X0.8000Y0.7330

N14G0Z0.0050

N15G1Z-0.1000F4.0

N16G3X0.9330Y0.6670I0.1330J0.1010F12.0

N17G1X1.0670

N18G3Y1.0010I0.0000J0.1670

N19G1X0.9330Y1.0000

N20G2Y1.3340I0.0000J0.1670

N21G1X1.0670Y1.3330

N22G2X1.1997Y1.2668I0.0000J-0.1660

N23G0Z0.0700

N24M02

N26M25H2;TRANSMIT HIGH SIGNAL THROUGH ACC2

N27G25H1;WAIT FOR HIGH SIGNAL THROUGH ACC2

N28M11;OPEN VISE

N29M26H2;TRANSMIT LOW SIGNAL THROUGH ACC2

N30G26H1;WAIT FOR LOW SIGNAL THROUGH ACC2

N31M47L3;CYCLE BACK TO N0

N32M2;END OF PROGRAM
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